gnome-shell-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236
  1. %define pkg_version 3.6.3
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.xz
  8. Source101: gnome-shell.gnome-3-6.ja.po
  9. # settings for Vine
  10. Patch101: gnome-shell-vine-settings.patch
  11. License: GPLv2+
  12. Group: User Interface/Desktops
  13. URL: http://live.gnome.org/GnomeShell
  14. Requires(post,postun): scrollkeeper >= 0.1.4
  15. Requires: mutter
  16. Requires: caribou
  17. Requires: ca-certificates
  18. Requires: at-spi2-atk
  19. BuildRequires: gnome-common
  20. BuildRequires: libtool
  21. BuildRequires: automake
  22. BuildRequires: autoconf
  23. BuildRequires: pkgconfig
  24. BuildRequires: gtk2-devel
  25. BuildRequires: clutter-devel
  26. BuildRequires: mutter-devel
  27. BuildRequires: gjs-devel
  28. BuildRequires: gnome-desktop3-devel
  29. BuildRequires: gnome-menus-devel
  30. BuildRequires: libSM-devel
  31. BuildRequires: libffi-devel
  32. BuildRequires: startup-notification-devel
  33. BuildRequires: gnome-doc-utils
  34. BuildRequires: desktop-file-utils
  35. BuildRequires: libcroco-devel
  36. BuildRequires: librsvg2-devel
  37. BuildRequires: gobject-introspection-devel
  38. BuildRequires: gcr-devel
  39. BuildRequires: gstreamer-devel
  40. BuildRequires: dbus-glib-devel
  41. BuildRequires: telepathy-logger-devel
  42. BuildRequires: polkit-devel
  43. BuildRequires: pulseaudio-libs-devel
  44. BuildRequires: evolution-data-server-devel
  45. BuildRequires: folks-devel
  46. BuildRequires: NetworkManager-glib-devel
  47. BuildRequires: libgudev1-devel
  48. BuildRequires: libcanberra-gtk3-devel
  49. BuildRequires: ca-certificates
  50. BuildRequires: intltool
  51. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. Packager: Takemikaduchi
  55. %description
  56. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  57. It provides core interface functions like switching to windows and launching
  58. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  59. hardware and introduces innovative user interface concepts to provide a delightful
  60. and easy to use experience.
  61. %prep
  62. %setup -q
  63. %patch101 -p1 -b .vine
  64. cp %{SOURCE101} po/ja.po
  65. %build
  66. libtoolize --copy --force
  67. autoreconf
  68. %configure \
  69. --disable-static
  70. %{__make} %{?_smp_mflags}
  71. %install
  72. %{__rm} -rf ${RPM_BUILD_ROOT}
  73. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  74. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  75. %find_lang %{name}
  76. %clean
  77. %{__rm} -rf ${RPM_BUILD_ROOT}
  78. %post
  79. /sbin/ldconfig
  80. touch --no-create %{_datadir}/icons/hicolor
  81. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  82. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  83. fi
  84. %postun
  85. /sbin/ldconfig
  86. touch --no-create %{_datadir}/icons/hicolor
  87. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  88. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  89. fi
  90. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  91. %posttrans
  92. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  93. %files -f %{name}.lang
  94. %defattr(-,root,root)
  95. %doc COPYING NEWS README
  96. %{_bindir}/gnome-shell
  97. %{_bindir}/gnome-shell-extension-tool
  98. %{_bindir}/gnome-shell-extension-prefs
  99. %{_bindir}/gnome-shell-perf-tool
  100. %{_libdir}/gnome-shell/*
  101. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  102. %{_libexecdir}/gnome-shell-calendar-server
  103. %{_libexecdir}/gnome-shell-hotplug-sniffer
  104. %{_libexecdir}/gnome-shell-perf-helper
  105. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  106. %{_datadir}/applications/gnome-shell.desktop
  107. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  108. %{_datadir}/applications/evolution-calendar.desktop
  109. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  110. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  111. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  112. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  113. %{_datadir}/gnome-shell/*
  114. %{_datadir}/gtk-doc/html/shell
  115. %{_datadir}/gtk-doc/html/st
  116. %{_datadir}/man/man1/*.1.gz
  117. %changelog
  118. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  119. - new upstream release
  120. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  121. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  122. - new upstream release
  123. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  124. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  125. - rebuild with telepathy-logger-0.6.0
  126. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  127. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  128. - new upstream release
  129. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  130. - new upstream release
  131. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  132. - update Patch101 (gnome-shell-vine-settings.patch)
  133. - change BuildRequires: ca-certificates instead of openssl
  134. - add BuildRequires: libcanberra-gtl3-devel
  135. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  136. - new upstream release
  137. - remove Patch103 (gnome-shell-ja.po-date.patch)
  138. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  139. - new upstream release
  140. - update Patch101,103
  141. - remove Patch0,102
  142. - add BuildRequires: gcr-devel
  143. - remove BuildRequires: GConf2-devel
  144. - add Requires: at-spi2-atk
  145. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  146. - new upstream release
  147. - remove Patch1
  148. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  149. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  150. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  151. - rename Patch103 (gnome-shell-ja.po-date.patch)
  152. - drop Patch102
  153. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  154. - new upstream release
  155. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  156. - new upstream release
  157. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  158. - new upstream release
  159. - update Patch101
  160. - update Patch102
  161. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  162. - add BuildRequires: libgudev1-devel, openssl
  163. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  164. - new upstream release
  165. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  166. - add Requires: caribou
  167. - remove Patch0
  168. - update Patch101
  169. - update Patch102
  170. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  171. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  172. - rebuild with gnome-menus-3.1.5
  173. - add Patch0 (gnome-shell-git20110821.patch)
  174. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  175. - new upstream release
  176. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  177. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  178. - remove BuildRequires: xulrunner-devel
  179. - add Patch101 (gnome-shell-vine-settings.patch)
  180. - add Patch102 (gnome-shell-vine-customize.patch)
  181. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  182. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  183. - add Requires: mutter
  184. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  185. - new upstream release
  186. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  187. - initial build for Vine Linux