PyQt4-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310
  1. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  2. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  3. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  4. %global sip_ver %(sip -V 2>/dev/null | cut -d' ' -f1 | cut -d- -f1)
  5. # Qt4 version auto-detection -- inagaki
  6. %define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.1)
  7. %define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
  8. Name: PyQt4
  9. Summary: Python bindings for Qt4
  10. Summary(ja): Qt4 の Python バインディング
  11. Version: 4.8.3
  12. Release: 2%{?_dist_release}
  13. # GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
  14. License: GPLv3 or GPLv2 with exceptions
  15. Group: Development/Languages
  16. URL: http://www.riverbankcomputing.com/software/pyqt/
  17. Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
  18. Patch1: PyQt-x11-gpl-4.8.3-64bit.patch
  19. # HACK! FIXME: ping upstream why this isn't working right. -- Rex
  20. Patch2: PyQt-x11-gpl-4.5.2-QT_SHARED.patch
  21. Patch4: PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
  22. # Vine Patch
  23. Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. #BuildRequires: chrpath
  26. BuildRequires: dbus-devel dbus-python-devel
  27. BuildRequires: findutils
  28. BuildRequires: phonon-devel
  29. # beware of PyQt4/qscintilla bootstap issues
  30. #BuildRequires: qscintilla
  31. BuildRequires: qt4-devel >= 4.5.0
  32. BuildRequires: python-devel
  33. BuildRequires: sip-devel >= 4.9
  34. BuildRequires: libXext-devel
  35. Requires: sip >= %{sip_ver}
  36. Requires: dbus-python
  37. Requires: qt4 >= %{qtver}
  38. %description
  39. These are Python bindings for Qt4.
  40. %package devel
  41. Summary: Files needed to build other bindings based on Qt4
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: qt4-devel >= %{qtver}
  45. Requires: sip-devel >= 4.9
  46. %description devel
  47. Files needed to build other bindings for C++ classes that inherit from any
  48. of the Qt4 classes (e.g. KDE or your own).
  49. %prep
  50. %setup -q -n PyQt-x11-gpl-%{version}
  51. %ifarch x86_64
  52. %patch1 -p1 -b .64bit
  53. %endif
  54. %patch2 -p1 -b .QT_SHARED
  55. #patch4 -p1
  56. %patch100 -p1 -b .phononpath_vine
  57. ## permissions
  58. # mark examples non-executable
  59. find examples/ -name "*.py" | xargs chmod a-x
  60. chmod a+rx pyuic/uic/pyuic.py
  61. %build
  62. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  63. CFLAGS="${CFLAGS:-%optflags}" \
  64. CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
  65. %{__python} configure.py \
  66. --confirm-license \
  67. --qmake=%{qt4qmake} \
  68. --no-qsci-api \
  69. --verbose
  70. make %{?_smp_mflags}
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
  74. # HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
  75. rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
  76. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
  77. $RPM_BUILD_ROOT%{_bindir}/pyuic4
  78. ln -s %{_bindir}/pyuic4 \
  79. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %files
  83. %defattr(-,root,root,-)
  84. %doc NEWS README
  85. %doc OPENSOURCE-NOTICE.TXT
  86. %doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
  87. %doc LICENSE.GPL3
  88. %{python_sitearch}/PyQt4/
  89. %exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
  90. # fixme? -> sitearch? -- Rex
  91. %{python_sitelib}/dbus/mainloop/qt.so
  92. %{_libdir}/qt-%{qtver}/plugins/designer/*
  93. %files devel
  94. %defattr(-,root,root,-)
  95. %doc doc/*
  96. %doc examples/
  97. %{_bindir}/pylupdate4
  98. %{_bindir}/pyrcc4
  99. %{_bindir}/pyuic4
  100. %{python_sitearch}/PyQt4/uic/pyuic.py*
  101. %{_datadir}/sip/PyQt4/
  102. #{_qt4_prefix}/qsci/api/python/PyQt4.api
  103. %changelog
  104. * Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
  105. - update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
  106. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
  107. - new upstream release
  108. - built with sip-4.12.1 and qt4-4.7.1
  109. * Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
  110. - rebuild with qt4-4.6.3
  111. - fix %qtver (from 4.6.1 to 4.6.3)
  112. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
  113. - new upstream release
  114. - rebuilt with sip-4.10.5 and qt4-4.6.3
  115. * Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
  116. - new upstream release
  117. - updated Patch100
  118. * Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
  119. - updated Patch100 to build phonon module
  120. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
  121. - new upstream release
  122. - rebuilt with python-2.6.4
  123. - dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
  124. * Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
  125. - now BuildRequires sip-devel >= 4.9 (was 4.8.2)
  126. * Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
  127. - new upstream release
  128. - added BR: libXext-devel
  129. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
  130. - added Patch100 for building phonon modules
  131. * Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
  132. - Initial build for Vine
  133. * Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
  134. - PyQt4-4.5.4
  135. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  137. * Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
  138. - PyQt4-4.5.2
  139. * Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
  140. - fix build with qt-4.5.2
  141. - PyQt4-devel multilib conflict (#509415)
  142. * Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
  143. - PyQt-4.5.1
  144. * Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
  145. - PyQt-4.5
  146. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
  147. - fix generation of sip_ver
  148. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
  149. - PyQt-4.5-snapshot-20090520
  150. * Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
  151. - rebuild for phonon bindings (#497680)
  152. * Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
  153. - move designer plugins to main/runtime (#487622)
  154. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  156. * Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
  157. - rebuild against qt-4.5rc1
  158. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
  159. - Rebuild for Python 2.6
  160. * Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
  161. - PyQt-4.4.4
  162. * Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
  163. - PyQt-4.4.3
  164. * Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
  165. - PyQt4 is built without QtWebKit support (#451490)
  166. * Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
  167. - PyQt-4.4.2
  168. * Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
  169. - PyQt-4.4
  170. - License: GPLv3 or GPLv2 with exceptions
  171. * Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
  172. - respin (gcc43)
  173. * Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
  174. - PyQt-4.3.3
  175. * Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
  176. - dbus support (#395741)
  177. * Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
  178. - PyQt-4.3.1
  179. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
  180. - drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
  181. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
  182. - fix QtDesigner plugin install
  183. * Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
  184. - 64bit QtDesigner patch
  185. * Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
  186. - -devel: Requires: qt4-devel
  187. * Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
  188. - use %%python_sitearch
  189. - License: GPLv2
  190. * Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
  191. - fix python_sitelib typo (wrt chrpath call)
  192. - move %%_bindir stuff to -devel
  193. - mark %%doc examples non-executable
  194. - add shebang to %%_bindir/pyuic4
  195. * Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
  196. - remove rpath from QtDesigner.so
  197. - BR: qt4-devel > 4.3.0-8
  198. * Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
  199. - PyQt4-4.2
  200. * Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
  201. - fix build against multilib'd qt4
  202. * Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
  203. - PyQt4-4.1.1
  204. - BR: sip-devel >= 4.5.1
  205. * Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
  206. - PyQt4-4.1
  207. * Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
  208. - don't own %%_datadir/sip (bug #206633)
  209. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
  210. - BR: qt4-devel < 4.2
  211. * Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
  212. - fix reference(s) to qmake(4)
  213. * Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
  214. - PyQt-4.0.1
  215. * Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
  216. - PyQt-4.0(final)
  217. - BR: sip-devel >= 4.4.4 (see bug #199430)
  218. * Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
  219. - drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
  220. - drop usage of (undefined) %%sip_min
  221. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
  222. - cleanup for Extras
  223. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
  224. - 4.0beta1
  225. * Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
  226. - respin for sip-4.4.3
  227. - use sip-abi, sip-abi-min
  228. * Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
  229. - 20060421 snapshot
  230. * Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
  231. - first try, using 20060417 snapshot