grub-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204
  1. %ifarch %{ix86}
  2. %define _host_cpu i386
  3. %else
  4. %define _host_cpu %{_arch}
  5. %endif
  6. %define defshell defaultmenu.sh
  7. Summary: grub - a Multiboot boot loader.
  8. Summary(ja): grub - マルチブートローダ
  9. Name: grub
  10. Version: 0.97
  11. Release: 3%{?_dist_release}
  12. License: GPL
  13. Group: System Environment/Base
  14. URL: http://www.gnu.org/software/grub/
  15. Source0: ftp://alpha.gnu.org/gnu/grub/%{name}-%{version}.tar.gz
  16. Source1: %{defshell}
  17. Patch10: grub-0.97-prototypes.patch
  18. Patch100: ext3_256byte_inode.diff
  19. Patch110: grub-0.97-ext4-support.patch
  20. Patch120: grub-0.97-build-id=none.patch
  21. Patch130: grub-0.97-tinfo.patch
  22. ExclusiveArch: %{ix86} x86_64
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. Requires(post): install-info, sed, grep, coreutils
  25. Requires(preun): install-info
  26. Requires: mktemp
  27. BuildRequires: ncurses-devel >= 5.6
  28. BuildRequires: glibc-static
  29. %ifarch x86_64
  30. BuildRequires: compat32-glibc-devel
  31. BuildRequires: compat32-glibc-static
  32. %endif
  33. %description
  34. GNU GRUB is a Multiboot boot loader.
  35. It was derived from GRUB, GRand Unified Bootloader, which was
  36. originally designed and implemented by Erich Stefan Boleyn.
  37. Briefly, bootloader is the first software program that runs when
  38. a computer starts. It is responsible for loading and transferring
  39. control to the operating system kernel software (such as the Hurd
  40. or the Linux). The kernel, in turn, initializes the rest of the
  41. operating system (usually GNU).
  42. %description -l ja
  43. GNU GRUB はマルチブートローダです。
  44. この名前は GRand Unified Bootloader (壮大な 統一されたブート
  45. ローダ) に由来し、元来は Erich Stefan Boleyn によって、設計・
  46. 実装されたものです。
  47. 手短に言えば、ブートローダとはコンピュータが起動する際に最初
  48. に実行されるプログラムで、(Hurd や Linux のような) オペレー
  49. ティングシステムのカーネルをディスクから読み込んで制御を渡す
  50. 作業を担当します。カーネルは、それを受けて、オペレーティング
  51. システムの他の部分 (通常は GNU) を初期化します。
  52. %prep
  53. %setup -q
  54. %patch10 -p1 -b .prototypes
  55. %patch100 -p1 -b .ext3_256byte_inode
  56. %patch110 -p1 -b .ext4
  57. %patch120 -p1 -b .build-id
  58. %patch130 -p1 -b .ncurses5
  59. aclocal
  60. autoconf
  61. %build
  62. GCCVERS=$(gcc --version | head -1 | cut -d\ -f3 | cut -d. -f1)
  63. CFLAGS="-Os"
  64. if [ "$GCCVERS" == "4" ]; then
  65. CFLAGS="$CFLAGS -Wno-pointer-sign"
  66. fi
  67. %ifarch x86_64
  68. CFLAGS="$CFLAGS -static"
  69. %endif
  70. export CFLAGS
  71. %configure --disable-auto-linux-mem-opt
  72. %__make
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. %makeinstall
  76. %{__install} -p -m 644 docs/menu.lst %{buildroot}%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}
  77. %{__install} -p -m 744 %{SOURCE1} %{buildroot}%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}
  78. %clean
  79. rm -rf $RPM_BUILD_ROOT
  80. %post
  81. /sbin/install-info %{_infodir}/grub.info.gz %{_infodir}/dir
  82. /sbin/install-info %{_infodir}/multiboot.info.gz %{_infodir}/dir
  83. %{_libdir}/grub/%{_host_cpu}-%{_target_vendor}/%{defshell}
  84. %preun
  85. if [ $1 = 0 ]; then
  86. /sbin/install-info --delete %{_infodir}/grub.info.gz %{_infodir}/dir
  87. /sbin/install-info --delete %{_infodir}/multiboot.info.gz %{_infodir}/dir
  88. fi
  89. %files
  90. %defattr(-,root,root)
  91. %doc COPYING INSTALL README AUTHORS BUGS ChangeLog NEWS THANKS TODO MAINTENANCE
  92. %{_bindir}/*
  93. %{_sbindir}/*
  94. %{_libdir}/grub
  95. %{_infodir}/*.info*
  96. %{_mandir}/man*/*
  97. %changelog
  98. * Wed Mar 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-3
  99. - add Patch110 to support ext4 filesystem
  100. - add Patch120 to build with current binutils
  101. - add Patch130 to build with ncurses-5.6
  102. - add R(post): install-info, grep, sed, coreutils
  103. - add R(preun): install-info
  104. - add BR: compat32-glibc-{devel,static} for x86_64
  105. - add BR: glibc-static
  106. * Wed Jan 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-2
  107. - add patch100 to support newer e2fsprogs
  108. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.97-1vl5
  109. - applied new versioning policy, spec in utf-8
  110. * Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl8
  111. - fix _host_cpu trick
  112. * Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl7
  113. - add x86_64 to ExclusiveArch:
  114. - add BuildRequires: compat32-glibc-devel for x86_64
  115. - add "-static" to CFLAGS for x86_64
  116. - use special CFLAGS
  117. - add Patch10 to run configure with new binutils
  118. * Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl6
  119. - add PreReq: grep, sed for defaultmenu.sh
  120. * Tue Sep 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl5
  121. - add initrd in menu.lst file created by defaultmenu.sh
  122. * Thu Jun 26 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl4
  123. - fix date of previous changelog entry
  124. - escape macro of past changelog entries
  125. - change Source1: menu.lst.vine to defautmenu.sh
  126. - invoke defaultmenu.sh on %%post scriptlet
  127. * Thu Jun 21 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl3
  128. - remove Requires: ncurses, gpm, bash
  129. * Thu May 12 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl2
  130. - upstream release
  131. - add MAINTENANCE to %%doc
  132. - drop Patch0 (merged in upstream source)
  133. * Sun Mar 20 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.96-0vl3
  134. - savedefault patch from upstream CVS: http://savannah.gnu.org/cgi-bin/viewcvs/grub/grub/stage2/stage2.c.diff?r1=1.45&r2=1.46&diff_format=u
  135. stage2/stage2.c (cmain): Initialize DEFAULT_FILE to an empty
  136. string. Reported by NATORI Shin <natori@adm.s.u-tokyo.ac.jp>.
  137. * Sun Feb 20 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.96-0vl2
  138. - upstream release
  139. - drop Patch0 (merged)
  140. - added sample file /usr/lib/grub/i386-pc/menu.lst.vine
  141. - change installation destination of menu.lst from %%datadir to %%libdir
  142. * Wed Jan 19 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.95-0vl3
  143. - applied Patch0 from upstream CVS:
  144. http://savannah.gnu.org/cgi-bin/viewcvs/grub/grub/util/grub-install.in.diff?r1=1.46&r2=1.47&diff_format=u
  145. util/grub-install.in (convert): Fix the sed statement for
  146. Linux. The expression was ambigious in some cases.
  147. * Wed Aug 18 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.95-0vl2
  148. - catch up to upstream release
  149. - delete %%_target_platform macro
  150. - delete gzip info files from %%install macro
  151. - add BuildRequires: ncurses-devel
  152. - add Requires: ncurses, gpm, mktemp, bash
  153. - add PreReq: install-info
  154. - %%configure with --disable-auto-linux-mem-opt option
  155. * Thu Jul 12 2001 <sagami@vinelinux.org>
  156. - 0.90-0vl1: %%configure with a trick for _host_cpu, %%makeinstall
  157. * Tue Apr 24 2001 <sagami@vinelinux.org>
  158. - 0.5.96-0vl1: use some macros
  159. * Wed Oct 11 2000 Yoshihiro Kajiki <kajiki@ylug.org> [0vl2]
  160. - build for Vine 2.1beta
  161. * Tue Oct 10 2000 Yoshihiro Kajiki <kajiki@ylug.org> [0vl1]
  162. - update to 0.5.95 and build for Vine 2.0
  163. - add Japanese summary and description
  164. - based on grub-0.5.94-2, Kondara Zoo
  165. * Sun Jun 4 2000 AYUHANA Tomonori <l@kondara.org>
  166. * /usr/doc/grub-*/menu.lst -> /usr/share/grub/i386-pc/menu.lst
  167. * Thu May 18 2000 AYUHANA Tomonori <l@kondara.org>
  168. - upgrade to 0.5.93.1 to 0.5.94