glib2-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library of handy utility functions.
  3. Name: glib2
  4. Version: 2.28.0
  5. Release: 1%{?_dist_release}
  6. License: LGPLv2+
  7. Group: System Environment/Libraries
  8. Source: http://ftp.gnome.org/pub/GNOME/sources/glib/2.28/glib-%{version}.tar.bz2
  9. Source2: glib2.sh
  10. Source3: glib2.csh
  11. BuildRoot: %{_tmppath}/glib-%{version}-root
  12. BuildRequires: pkgconfig >= 0.14
  13. BuildRequires: gamin-devel
  14. BuildRequires: gtk-doc
  15. BuildRequires: zlib-devel
  16. Obsoletes: glib-gtkbeta
  17. URL: http://www.gtk.org
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>, Takemikaduchi
  21. %description
  22. GLib is the low-level core library that forms the basis
  23. for projects such as GTK+ and GNOME. It provides data structure
  24. handling for C, portability wrappers, and interfaces for such runtime
  25. functionality as an event loop, threads, dynamic loading, and an
  26. object system.
  27. This package provides version 2.28 of GLib.
  28. %package devel
  29. Summary: Development files for the GLib library
  30. Group: Development/Libraries
  31. Obsoletes: glib-gtkbeta-devel
  32. Requires: pkgconfig >= 0.14
  33. Requires: %{name} = %{version}
  34. Conflicts: glib-devel <= 1.2.8
  35. %description devel
  36. The glib-devel package includes the header files for
  37. version 2.28 of the GLib library.
  38. ## to build compat32 for x86_64 architecture support
  39. %package -n compat32-%{name}
  40. Summary: A library of handy utility functions.
  41. Group: System Environment/Libraries
  42. %description -n compat32-%{name}
  43. GLib is the low-level core library that forms the basis
  44. for projects such as GTK+ and GNOME. It provides data structure
  45. handling for C, portability wrappers, and interfaces for such runtime
  46. functionality as an event loop, threads, dynamic loading, and an
  47. object system.
  48. This package provides version 2.28 of GLib.
  49. %package -n compat32-%{name}-devel
  50. Summary: Development files for the GLib library
  51. Group: Development/Libraries
  52. Requires: pkgconfig >= 0.14
  53. Requires: compat32-%{name} = %{version}
  54. Conflicts: glib-devel <= 1.2.8
  55. %description -n compat32-%{name}-devel
  56. The glib-devel package includes the header files for
  57. version 2.28 of the GLib library.
  58. %prep
  59. %setup -q -n glib-%{version}
  60. %build
  61. %configure --disable-selinux --enable-static
  62. make %{?_smp_mflags}
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  66. %makeinstall
  67. ## glib2.sh and glib2.csh
  68. ./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  69. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  70. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  71. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  72. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
  74. %find_lang glib20
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %post -p /sbin/ldconfig
  78. %postun -p /sbin/ldconfig
  79. %post -n compat32-%{name} -p /sbin/ldconfig
  80. %postun -n compat32-%{name} -p /sbin/ldconfig
  81. %files -f glib20.lang
  82. %defattr(-, root, root)
  83. %doc AUTHORS COPYING ChangeLog NEWS README
  84. %{_bindir}/gdbus
  85. %{_bindir}/gio-querymodules
  86. %{_bindir}/glib-compile-schemas
  87. %{_bindir}/gsettings
  88. %{_libdir}/libglib-2.0.so.*
  89. %{_libdir}/libgthread-2.0.so.*
  90. %{_libdir}/libgmodule-2.0.so.*
  91. %{_libdir}/libgobject-2.0.so.*
  92. %{_libdir}/libgio-2.0.so.*
  93. %{_libdir}/gio/modules/lib*.so
  94. %{_sysconfdir}/profile.d/*
  95. %{_sysconfdir}/bash_completion.d/*
  96. %files devel
  97. %defattr(-, root, root)
  98. %{_bindir}/glib-genmarshal
  99. %{_bindir}/glib-gettextize
  100. %{_bindir}/glib-mkenums
  101. %{_bindir}/gobject-query
  102. %{_bindir}/gtester
  103. %{_bindir}/gtester-report
  104. %{_libdir}/lib*.so
  105. %{_libdir}/lib*.a
  106. %{_libdir}/glib-2.0
  107. %{_includedir}/*
  108. %{_datadir}/aclocal/*
  109. %{_libdir}/pkgconfig/*
  110. %{_datadir}/glib-2.0
  111. %doc %{_datadir}/gtk-doc/html/*
  112. %doc %{_mandir}/man1/*
  113. %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
  114. %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
  115. %if %{build_compat32}
  116. %files -n compat32-%{name}
  117. %defattr(-, root, root)
  118. %{_libdir}/libglib-2.0.so.*
  119. %{_libdir}/libgthread-2.0.so.*
  120. %{_libdir}/libgmodule-2.0.so.*
  121. %{_libdir}/libgobject-2.0.so.*
  122. %{_libdir}/libgio-2.0.so.*
  123. %{_libdir}/gio/modules/lib*.so
  124. %files -n compat32-%{name}-devel
  125. %defattr(-, root, root)
  126. %{_libdir}/lib*.so
  127. %{_libdir}/lib*.a
  128. %{_libdir}/glib-2.0
  129. %{_libdir}/pkgconfig/*
  130. %endif
  131. %changelog
  132. * Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  133. - new upstream release
  134. * Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
  135. - move the following files from glib2-devel to glib2 package
  136. (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
  137. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
  138. - new upstream release
  139. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
  140. - new upstream release
  141. - fix Source (add URL)
  142. - fix %files to add /etc/bash_completion.d files
  143. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
  144. - build with rpm-4.8.1-1 for pkg-config file
  145. * Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
  146. - new upstream release
  147. * Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  148. - new upstream release
  149. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  150. - new upstream release
  151. - add BuildRequires: zlib-devel
  152. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
  153. - new upstream release
  154. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
  155. - new upstream release
  156. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
  157. - new upstream release
  158. * Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  159. - new upstream release
  160. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
  161. - new upstream release
  162. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
  163. - new upstream release
  164. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
  165. - new upstream release
  166. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
  167. - new upstream release
  168. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
  169. - new upstream release
  170. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
  171. - new upstream release
  172. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
  173. - new upstream release
  174. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
  175. - new upstream release
  176. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
  177. - new upstream release
  178. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
  179. - new upstream release
  180. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  181. - new upstream release
  182. * Mon Jul 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
  183. - new upstream release
  184. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
  185. - updated %%if %%{build_compat32} case related statements
  186. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
  187. - new upstream release
  188. - removed lib*.la files from devel package
  189. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
  190. - new upstream release
  191. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
  192. - added %%{?_dist_release}
  193. - BuildRequires: gamin-devel
  194. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
  195. - new upstream release
  196. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
  197. - new upstream release
  198. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
  199. - new upstream release
  200. * Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
  201. - new upstream release
  202. * Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  203. - new upstream release
  204. - removed BuildRequires: automake17
  205. * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
  206. - new upstream release
  207. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
  208. - new upstream release
  209. * Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
  210. - new upstream release
  211. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
  212. - rebuild with new environment
  213. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
  214. - new upstream release
  215. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
  216. - new upstream release
  217. * Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
  218. - new upstream release
  219. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  220. - new upstream release
  221. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
  222. - new upstream release
  223. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
  224. - new upstream release
  225. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  226. - new upstream release
  227. * Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
  228. - rebuild
  229. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
  230. - update glib2.{sh,csh}
  231. - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
  232. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
  233. - new upstream release
  234. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  235. - new upstream release
  236. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  237. - new upstream release
  238. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  239. - new upstream release
  240. * Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
  241. - added compat32-* packages for x86_64 architecture support
  242. - chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
  243. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
  244. - new upstream release
  245. * Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
  246. - new upstream release
  247. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
  248. - new upstream release
  249. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
  250. - new upstream release
  251. * Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
  252. - fixed typo in glib2.csh
  253. * Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  254. - update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
  255. G_BROKEN_FILENAMES.
  256. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  257. - new upstream release
  258. * Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  259. - new upstream release
  260. * Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
  261. - new upstream release
  262. * Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
  263. - new upstream release
  264. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
  265. - new upstream release
  266. * Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
  267. - new upstream release
  268. - add *.la to build arts (should be fixed in arts?)
  269. * Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  270. - new upstream release
  271. * Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  272. - new upstream release
  273. * Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  274. - new upstream release
  275. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  276. - new upstream release
  277. * Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
  278. - new upstream release
  279. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
  280. - rebuilt
  281. * Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
  282. - new upstream release
  283. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
  284. - new upstream release
  285. * Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
  286. - new upstream release
  287. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
  288. - new upstream release
  289. * Sat Jun 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  290. - new upstream release
  291. * Sat May 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  292. - new upstream release
  293. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  294. - new upstream release
  295. * Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
  296. - rebuild with new toolchain
  297. * Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  298. - new upstream release
  299. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  300. - new upstream release
  301. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  302. - new upstream release
  303. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  304. - new upstream release
  305. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  306. - new upstream release
  307. - build for Vine Linux
  308. * Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
  309. - install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
  310. - blow away unpackaged files in install
  311. * Thu Aug 8 2002 Owen Taylor <otaylor@redhat.com>
  312. - Version 2.0.6
  313. - Remove fixed-ltmain.sh; shouldn't be needed any more.
  314. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  315. - automated rebuild
  316. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  317. - 2.0.4
  318. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  319. - automated rebuild
  320. * Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
  321. - rebuild in different environment
  322. * Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
  323. - Fix missing .po files (#63336)
  324. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  325. - Update to version 2.0.1
  326. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  327. - Version 2.0.0
  328. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  329. - Update to 1.3.15
  330. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  331. - Bump for rebuild
  332. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  333. - Update to 1.3.14
  334. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  335. - add horrible buildrequires hack
  336. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  337. - 1.3.13.91 cvs snap
  338. * Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
  339. - rebuild from CVS snapshot
  340. - use setup -q
  341. * Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
  342. - rebuild
  343. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  344. - 1.3.13
  345. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  346. - attempting rebuild in rawhide
  347. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  348. - remove 64-bit patch now upstream, 1.3.12.90
  349. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  350. - add some missing files to file list, langify
  351. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  352. - add temporary patch to fix GTypeFundamentals on 64-bit
  353. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  354. - Version 1.3.11
  355. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  356. - Version 1.3.10
  357. * Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
  358. - Version 1.3.9
  359. * Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
  360. - Version 1.3.8
  361. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  362. - Make -devel package require main package (#45388)
  363. - Fix description and summary
  364. - Configure with --disable-gtk-doc
  365. * Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  366. - add some portability fixes needed at least on s390
  367. - copy config.{guess,sub} instead of calling libtoolize
  368. * Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
  369. - try a new glib tarball with Makefile changes to work around
  370. libtool linking to installed .la files
  371. - make -devel require pkgconfig
  372. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  373. - either libtool or the bad libtool hacks caused link
  374. against glib-gobject 1.3.2, rebuild
  375. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  376. - 1.3.6
  377. - bad libtool workarounds
  378. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  379. - 1.3.5, rename to glib2
  380. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  381. - Final 1.3.2
  382. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  383. - Version 1.3.2pre1
  384. - Remove pkgconfig
  385. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  386. - Call 1.3.1b instead of snap... the snap* naming doesn't
  387. order correctly.
  388. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  389. - new snapshot with fixed .pc files
  390. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  391. - include .pc files in file list
  392. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  393. - Include pkg-config
  394. - Upgrade to a glib CVS snapshot
  395. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  396. - rebuild to cope with glibc locale binary incompatibility
  397. * Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
  398. - Remove glib-config.1 manpage from build since
  399. it conflicts with glib-devel. When we go to
  400. glib glib1.2 setup, we should add it back
  401. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  402. - Version 1.3.1
  403. - Move back to standard %{prefix}
  404. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  405. - Rebuild in /opt/gtk-beta
  406. * Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
  407. - New version (adds gobject)
  408. * Wed Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  409. - Don't blow away /etc/ld.so.conf (sorry!)
  410. * Tue Apr 24 2000 Owen Taylor <otaylor@redhat.com>
  411. - Snapshot RPM for Pango testing
  412. * Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
  413. - Added fixes from stable branch of CVS
  414. * Thu Oct 7 1999 Owen Taylor <otaylor@redhat.com>
  415. - version 1.2.6
  416. * Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
  417. - version 1.2.5
  418. * Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
  419. - version 1.2.4
  420. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  421. - version 1.2.3
  422. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  423. - version 1.2.1
  424. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  425. - Version 1.2
  426. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  427. - version 1.2.0pre1
  428. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  429. - new description tags
  430. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  431. - removed libtoolize from %build
  432. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  433. - added libgthread to file list
  434. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  435. - version 1.1.15
  436. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  437. - version 1.1.14
  438. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  439. - version 1.1.13
  440. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  441. - version 1.1.12
  442. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  443. - updated in preparation for the GNOME freeze
  444. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  445. - Split out glib package