tracker-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318
  1. Summary: An object database, tag/metadata database, search tool and indexer
  2. Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
  3. Name: tracker
  4. Version: 0.10.25
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: Applications/System
  8. URL: http://www.gnome.org/projects/tracker/
  9. Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.10/tracker-%{version}.tar.xz
  10. Patch0: tracker-0.8.18-tracker_spawn.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: glib2-devel >= 2.24.0
  13. BuildRequires: gtk3-devel >= 3.0.0
  14. BuildRequires: gnome-panel-devel
  15. BuildRequires: gmime-devel >= 2.4
  16. BuildRequires: poppler-devel
  17. BuildRequires: gettext
  18. BuildRequires: file
  19. BuildRequires: gnome-desktop-devel, gamin-devel
  20. BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
  21. BuildRequires: gstreamer-devel
  22. BuildRequires: desktop-file-utils, intltool
  23. BuildRequires: raptor-devel >= 1.4.18
  24. BuildRequires: sqlite3-devel
  25. BuildRequires: dbus-devel >= 1.0
  26. BuildRequires: dbus-glib-devel >= 0.78
  27. BuildRequires: libgnome-devel >= 2.13.2
  28. BuildRequires: libgnomeui-devel >= 2.13.7
  29. BuildRequires: libSM-devel
  30. BuildRequires: libnotify-devel >= 0.4.3
  31. BuildRequires: libuuid-devel
  32. BuildRequires: vala-devel
  33. BuildRequires: libgee-devel
  34. BuildRequires: upower-devel
  35. BuildRequires: gnome-applets
  36. BuildRequires: libgee-devel >= 0.3
  37. BuildRequires: nautilus-devel
  38. BuildRequires: libicu-devel
  39. ## BuildRequires: autoconf, automake
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. %description
  43. Tracker is a powerful desktop-neutral first class object database,
  44. tag/metadata database, search tool and indexer.
  45. It consists of a common object database that allows entities to have an
  46. almost infinte number of properties, metadata (both embedded/harvested as
  47. well as user definable), a comprehensive database of keywords/tags and
  48. links to other entities.
  49. It provides additional features for file based objects including context
  50. linking and audit trails for a file object.
  51. It has the ability to index, store, harvest metadata. retrieve and search
  52. all types of files and other first class objects
  53. %package devel
  54. Summary: Headers for developing programs that will use %{name}
  55. Group: Development/Libraries
  56. Requires: %{name} = %{version}-%{release}
  57. Requires: pkgconfig
  58. Requires: dbus-glib-devel
  59. %description devel
  60. This package contains the static libraries and header files needed for
  61. developing with tracker
  62. %package search-tool
  63. Summary: Tracker search tool(s)
  64. Group: User Interface/Desktops
  65. Requires: %{name} = %{version}-%{release}
  66. %description search-tool
  67. Graphical frontend to tracker search facilities. This has dependencies on
  68. GNOME libraries
  69. %prep
  70. %setup -q
  71. # %patch0 -p1 -b .spawn
  72. # remove shebangs from the python files as none should be executable scripts
  73. ## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
  74. sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
  75. %build
  76. ## libtoolize --force --copy
  77. ## intltoolize --copy --force
  78. ## autoreconf -i -f
  79. %configure --disable-static \
  80. --enable-video-extractor=external \
  81. --enable-tracker-search-tool=yes \
  82. --enable-tracker-search-bar=yes
  83. make %{?_smp_mflags}
  84. %install
  85. rm -rf %{buildroot}
  86. make DESTDIR=%{buildroot} install
  87. mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
  88. echo "%{_libdir}/tracker-0.10" \
  89. > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
  90. desktop-file-install --delete-original \
  91. --vendor="" \
  92. --dir=%{buildroot}%{_datadir}/applications \
  93. %{buildroot}%{_datadir}/applications/%{name}-needle.desktop
  94. rm -rf %{buildroot}%{_libdir}/*.{a,la}
  95. rm -f %{buildroot}%{_libdir}/nautilus/extensions-*/*.la
  96. rm -rf %{buildroot}%{_datadir}/tracker-tests
  97. %find_lang %{name}
  98. %clean
  99. rm -rf %{buildroot}
  100. %post
  101. /sbin/ldconfig
  102. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  103. %posttrans
  104. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  105. %postun
  106. /sbin/ldconfig
  107. if [ $1 -eq 0 ] ; then
  108. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  109. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  110. fi
  111. %files -f %{name}.lang
  112. %defattr(-, root, root, -)
  113. %doc AUTHORS ChangeLog COPYING NEWS README
  114. ### %doc %{_datadir}/gtk-doc/html/libtracker-common/
  115. ### %doc %{_datadir}/gtk-doc/html/libtracker-module/
  116. %{_bindir}/tracker*
  117. %exclude %{_bindir}/tracker-needle
  118. %exclude %{_bindir}/tracker-preferences
  119. ### %exclude %{_bindir}/tracker-applet
  120. %{_libexecdir}/tracker*
  121. %{_libdir}/*.so.*
  122. %{_libdir}/girepository-1.0/*.typelib
  123. %{_libdir}/tracker-0.10/
  124. %{_datadir}/tracker/
  125. %{_datadir}/dbus-1/services/org.freedesktop.Tracker*
  126. %{_datadir}/dbus-1/services/org.gnome.panel.applet.SearchBarFactory.service
  127. %{_datadir}/gnome-panel/4.0/applets/org.gnome.panel.SearchBar.panel-applet
  128. %{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
  129. %{_sysconfdir}/xdg/autostart/tracker*.desktop
  130. %{_mandir}/*/tracker*.gz
  131. %exclude %{_mandir}/man1/tracker-search-bar.1.gz
  132. %exclude %{_mandir}/man1/tracker-preferences.1.gz
  133. %exclude %{_mandir}/man1/tracker-needle.1.gz
  134. %files devel
  135. %defattr(-, root, root, -)
  136. %{_includedir}/tracker-0.10/
  137. ### %{_includedir}/libtracker-gtk/*
  138. %{_libdir}/*.so
  139. %{_libdir}/pkgconfig/*.pc
  140. %{_datadir}/vala/vapi/tracker*.vapi
  141. %{_datadir}/vala/vapi/tracker*.deps
  142. %{_datadir}/gir-1.0/*.gir
  143. %files search-tool
  144. %defattr(-, root, root, -)
  145. %{_bindir}/tracker-needle
  146. %{_bindir}/tracker-preferences
  147. %{_libdir}/nautilus/extensions-3.0/*.so
  148. %{_datadir}/icons/*/*/apps/tracker.*
  149. %{_datadir}/applications/*.desktop
  150. %{_mandir}/man1/tracker-search-bar.1.gz
  151. %{_mandir}/man1/tracker-preferences.1.gz
  152. %{_mandir}/man1/tracker-needle.1.gz
  153. %changelog
  154. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.25-1
  155. - new upstream release
  156. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-1
  157. - new upstream release
  158. * Wed Jul 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.22-1
  159. - new upstream release
  160. - add BuildRequires: libicu-devel
  161. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.18-1
  162. - new upstream release
  163. - add Patch0 (tracker-0.8.18-tracker_spawn.patch)
  164. - delete Patch1
  165. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
  166. - rebuilt with poppler-0.16.3
  167. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
  168. - rebuild with poppler-0.14.2
  169. * Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
  170. - new upstream release
  171. - add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
  172. - add configure option (--enable-tracker-search-bar)
  173. * Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
  174. - new upstream release
  175. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
  176. - new upstream release
  177. - fix URL of Source0
  178. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
  179. - new upstream release
  180. * Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
  181. - new upstream release
  182. * Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
  183. - new upstream release
  184. - fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
  185. * Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  186. - new upstream release
  187. * Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
  188. - new upstream release
  189. - add BuildRequires: upower-devel, gnome-applets
  190. - change BuildRequires: dbus-glib -> dbus-glib-devel
  191. * Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  192. - new upstream release
  193. - add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
  194. - fix BuildRequires: gmime-devel >= 2.4
  195. - add configure option (--enable-tracker-search-tool)
  196. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
  197. - new upstream release
  198. * Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
  199. - rebuild with poppler-0.10.2
  200. - spec in UTF-8
  201. * Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
  202. - new upstream release
  203. - update Patch1
  204. - drop Patch10 (no more necessary)
  205. - add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
  206. - remove --enable-external-sqlite option (no more bundled sqlite exist)
  207. - apply new versioning policy
  208. * Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  209. - new upstream release
  210. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
  211. - add Patch10 to fix selecting video-extractor
  212. - use external video extractor(totem) instead of gstreamer/xine
  213. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
  214. - initial build for Vine Linux
  215. * Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
  216. - Ship both autostart desktop files in the main package (BZ #233323)
  217. * Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
  218. - Package the deskbar plugin properly (BZ #228308)
  219. * Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
  220. - Split out tracker-search-tool sub-packages, for the GUI facility
  221. - Add proper requires for the -devel subpackage
  222. - Deal with the rpmlint complaints on rpath
  223. * Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
  224. - Update to 0.5.4
  225. * Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
  226. - Update to 0.5.3
  227. * Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
  228. - Apply patch on Makefile.am instead of Makefile.in
  229. - Add libtool to BR
  230. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
  231. - Update to 0.5.2
  232. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
  233. - Update to new version
  234. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
  235. - Have the devel subpackage require pkgconfig
  236. - Make the description field not have more than 76 characters on a line
  237. - Fix up the RPM group
  238. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
  239. - Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
  240. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
  241. - Remove unneeded BRs (gnome-utils-devel and openssl-devel)
  242. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
  243. - Add autostart desktop file.
  244. - Edit the package description as suggested in review
  245. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
  246. - More cleaups to the spec file.
  247. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
  248. - Add needed BRs
  249. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
  250. - Initial packaging for Fedora Extras