epiphany-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381
  1. # gecko backend was removed 2.27.0
  2. %define with_gecko 0
  3. %define with_webkit 1
  4. %define gecko_version 1.9.1
  5. %define webkit_version 1.4.2
  6. ExclusiveArch: %ix86 ppc x86_64 alpha
  7. Summary: GNOME web browser based on Gecko/WebKit
  8. Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
  9. Name: epiphany
  10. Version: 3.1.90
  11. Release: 1%{?_dist_release}
  12. License: GPL
  13. Group: Applications/Internet
  14. URL: http://www.gnome.org/projects/epiphany/
  15. Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/3.1/%{name}-%{version}.tar.xz
  16. Patch1: epiphany-2.26.2-gecko191.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: gnome-icon-theme >= 2.30.0
  19. %if %{with_gecko}
  20. Requires: gecko-libs
  21. %endif
  22. Requires(post,pre,preun): GConf2
  23. Requires(post,postun): scrollkeeper, shared-mime-info
  24. %if %{with_gecko}
  25. BuildRequires: gecko-devel-unstable >= %{gecko_version}
  26. %endif
  27. %if %{with_webkit}
  28. BuildRequires: WebKit3-gtk-devel >= %{webkit_version}
  29. %endif
  30. BuildRequires: glib2-devel >= 2.24.0
  31. BuildRequires: gtk3-devel >= 3.0.0
  32. BuildRequires: libxml2-devel >= 2.6.12
  33. BuildRequires: libxslt-devel >= 1.1.7
  34. BuildRequires: libnotify-devel >= 0.4.0
  35. BuildRequires: dbus-glib-devel >= 0.35
  36. BuildRequires: libsoup-devel >= 2.30.0
  37. BuildRequires: gnome-desktop-devel >= 2.30.0
  38. BuildRequires: GConf2-devel
  39. BuildRequires: nss-devel
  40. BuildRequires: avahi-gobject-devel >= 0.6.22
  41. BuildRequires: NetworkManager-devel
  42. BuildRequires: iso-codes
  43. BuildRequires: intltool >= 0.40
  44. BuildRequires: libICE-devel
  45. BuildRequires: libSM-devel
  46. BuildRequires: libgnome-keyring-devel
  47. BuildRequires: gobject-introspection-devel
  48. BuildRequires: gnome-doc-utils
  49. BuildRequires: seed-devel
  50. BuildRequires: gsettings-desktop-schemas
  51. Vendor: Project Vine
  52. Distribution: Vine Linux
  53. %description
  54. epiphany is a simple GNOME web browser based on the Mozilla rendering
  55. engine
  56. %description -l ja
  57. epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
  58. ウェブブラウザです。
  59. %package devel
  60. Summary: Epipany development environment
  61. Summary(ja): Epipany の開発環境
  62. Group: Development/Libraries
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: pkgconfig
  65. %description devel
  66. Header files and libraries for building a extension library for the
  67. epipany.
  68. %prep
  69. %setup -q
  70. #patch1 -p1
  71. %build
  72. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
  73. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  74. %configure \
  75. %if %{with_gecko}
  76. --with-gecko=libxul-embedding \
  77. %endif
  78. %if %{with_webkit}
  79. --with-engine=webkit \
  80. %endif
  81. --enable-zeroconf \
  82. --enable-network-manager \
  83. --disable-scrollkeeper \
  84. --without-ca-file \
  85. --enable-introspection=yes \
  86. --enable-seed
  87. %__make %{?_smp_mflags}
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  91. make install DESTDIR=$RPM_BUILD_ROOT
  92. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  93. %find_lang %{name} --with-gnome
  94. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
  96. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  97. %post
  98. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  99. %postun
  100. if [ $1 -eq 0 ] ; then
  101. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  102. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  103. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  104. scrollkeeper-update >& /dev/null ||:
  105. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  106. fi
  107. %posttrans
  108. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  109. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  110. scrollkeeper-update >& /dev/null ||:
  111. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  112. %clean
  113. rm -rf $RPM_BUILD_ROOT
  114. %files -f %{name}.lang
  115. %defattr(-,root,root,-)
  116. %doc AUTHORS ChangeLog* COPYING* NEWS README
  117. %{_bindir}/epiphany
  118. %{_bindir}/ephy-profile-migrator
  119. %{_libdir}/girepository-1.0/*.typelib
  120. %if %{with_gecko}
  121. %{_libdir}/epiphany
  122. %endif
  123. #{_datadir}/pygtk/*/defs/*
  124. %{_datadir}/GConf/gsettings/*.convert
  125. %{_datadir}/applications/*.desktop
  126. %{_datadir}/epiphany
  127. %{_datadir}/glib-2.0/schemas/*.xml
  128. %{_datadir}/icons/*
  129. %{_datadir}/dbus-1/services/*
  130. %{_mandir}/man1/epiphany.1*
  131. %files devel
  132. %defattr(-,root,root,-)
  133. %{_includedir}/%{name}
  134. %{_libdir}/pkgconfig/*.pc
  135. %{_datadir}/aclocal/*
  136. %{_datadir}/gir-1.0/*.gir
  137. %{_datadir}/gtk-doc/html/*
  138. %changelog
  139. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
  140. - new upstream release
  141. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
  142. - new upstream release
  143. - add BuildRequires: gsettings-desktop-schemas
  144. - create -devel sub package
  145. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.6-1
  146. - new upstream release
  147. - remove BuildRequires: gir-repository-devel
  148. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.2-2
  149. - rebuilt with rpm-4.8.1 for pkg-config
  150. * Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  151. - new upstream release
  152. - add BuildRequires: gobject-introspection-devel, seed-devel
  153. - add configure option (--enable-introspection=yes, --enable-seed)
  154. * Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  155. - new upstream release
  156. - add BuildRequires: gobject-introspection-devel, gir-repository-devel
  157. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  158. - add configure option (--without-ca-file)
  159. - remove unrecognized configure option (--with-engine)
  160. * Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  161. - new upstream release
  162. - added BR: libICE-devel, libSM-devel and gnome-keyring-devel
  163. * Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  164. - new upstream release
  165. * Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  166. - run gtk-update-icon-cache in %%post/postun script.
  167. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  168. - new upstream release
  169. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  170. - rebuild with gecko-1.9.1
  171. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  172. - new upstream release
  173. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  174. - new upstream release
  175. - build with xulrunner-1.9.0.7
  176. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  177. - new upstream release
  178. * Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
  179. - build with gecko-1.9.0.3 instead of WebKit.
  180. - WebKit port is unstable yet.
  181. - enable zeroconf, NetworkManager support
  182. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
  183. - new upstream release
  184. * Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
  185. - build with WebKit instead of gecko.
  186. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
  187. - new upstream release
  188. - added %%pre and %%preun section
  189. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  190. - new upstream release
  191. - rebuilt with firefox-2.0.0.6-0vl3
  192. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
  193. - add BuildRequires: gnome-python
  194. * Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  195. - new upstream release
  196. - rebuilt with new toolchain and firefox-2.0.0.4-0vl6
  197. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  198. - new upstream release
  199. * Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
  200. - source update
  201. - add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
  202. - add BuildRequires: pygtk2-devel
  203. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
  204. - new upstream release
  205. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  206. - rebuild with firefox-1.5.0.2-0vl4
  207. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  208. - new upstream release
  209. - build with firefox-1.5.0.2
  210. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  211. - new upstream release
  212. * Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
  213. - new upstream release
  214. - build with firefox-1.5.0.1
  215. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  216. - new upstream release
  217. - build with mozilla-1.7.12
  218. * Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
  219. - rebuild with mozilla-1.7.8
  220. * Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
  221. - new upstream release
  222. * Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
  223. - new upstream release
  224. - build with mozilla-1.7.7
  225. * Fri Apr 1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
  226. - rebuild with mozilla-1.7.6
  227. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  228. - new upstream release
  229. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
  230. - new upstream release
  231. - build with mozilla-1.7.5
  232. * Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  233. - new upstream release
  234. * Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
  235. - new upstream release
  236. * Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
  237. - rebuild with mozilla-1.7.3
  238. * Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
  239. - new upstream release
  240. - build with mozilla-1.7.2
  241. - add Patch10 to build with gnome-2.4
  242. * Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
  243. - new upstream version
  244. -- dropped patch10
  245. - changed URL
  246. * Fri Jan 9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
  247. - add alpha into ExclusiveArch
  248. * Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
  249. - rebuild with mozilla-1.5.1
  250. * Sat Dec 6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
  251. - new upstream release
  252. * Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
  253. - new upstream release
  254. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
  255. - fixed missing locale files
  256. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  257. - new upstream release
  258. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
  259. - new upstream release
  260. * Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
  261. - new upstream release
  262. * Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
  263. - new upstream release
  264. - build with mozilla 1.4
  265. * Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
  266. - new upstream release
  267. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
  268. - build for Vine Linux
  269. * Mon Jun 2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
  270. - Rebuild to fix broken mozilla dep, patch for mozilla 1.4
  271. * Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
  272. - 0.6.1
  273. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
  274. - add patch to fix gint/gpointer conversion bugs for 64bit arches
  275. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
  276. - only build on arches mozilla is built on
  277. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
  278. - rebuild against new mozilla, make mozilla requires dynamic
  279. * Sun May 4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
  280. - update to 0.6.0
  281. - fix tyop in %%postun
  282. * Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
  283. - make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
  284. * Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
  285. - add some buildrequires, prereq GConf2
  286. - disable building nautilus view
  287. * Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
  288. - Initial build.