self-build-vlc-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329
  1. %define pkgname vlc
  2. %define name self-build-%{pkgname}
  3. %define version 1.1.4
  4. %define release 1%{?_dist_release}
  5. %if %{?_dist_release} == "vl4"
  6. ## dummy echo
  7. echo This package cannot build on Vine Linux 4.2.
  8. exit 1
  9. %endif
  10. %define with_mozilla 0
  11. %define with_dc1394 0
  12. %define with_directfb 1
  13. %define with_samba 0
  14. %define sourceurl0 http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.bz2
  15. Summary: Package to automatically build %{pkgname} rpm package
  16. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  17. Name: %{name}
  18. Version: %{version}
  19. Release: %{release}
  20. Obsoletes: vlc < 1.1.0
  21. Obsoletes: vlc-devel < 1.1.0
  22. Source0: %{pkgname}-vl.spec
  23. Source10: vlc-handlers.schemas
  24. Source100: vlc-1.1.0-vlc-cache-gen_noerror.patch
  25. License: GPLv2+
  26. Group: Restricted Software
  27. Requires(post): self-build-setup >= 0.9.9
  28. Requires(post): desktop-file-utils
  29. Requires(post): gettext
  30. Requires(post): gettext-devel
  31. Requires(post): libtool
  32. Requires(post): aalib-devel
  33. Requires(post): alsa-lib-devel
  34. Requires(post): avahi-devel
  35. Requires(post): cdparanoia-devel
  36. Requires(post): dbus-devel
  37. %{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
  38. %if %with_directfb
  39. Requires(post): libdirectfb-devel
  40. %endif
  41. Requires(post): flac-devel
  42. Requires(post): fribidi-devel
  43. Requires(post): gnome-vfs2-devel
  44. Requires(post): gnutls-devel >= 1.0.17
  45. Requires(post): gsm-devel
  46. Requires(post): hal-devel
  47. Requires(post): jack-audio-connection-kit-devel
  48. Requires(post): libavc1394-devel
  49. Requires(post): libcdio-devel >= 0.77-3
  50. Requires(post): libdv-devel
  51. Requires(post): libdvdread-devel
  52. Requires(post): libebml-devel
  53. Requires(post): libid3tag-devel
  54. %{?_with_kate: Requires(post): libkate-devel}
  55. Requires(post): libmatroska-devel >= 0.7.6
  56. Requires(post): libmpcdec-devel
  57. Requires(post): libmtp-devel
  58. Requires(post): libnotify-devel
  59. Requires(post): librsvg2-devel >= 2.5.0
  60. Requires(post): libshout-devel
  61. Requires(post): libsmbclient-devel
  62. Requires(post): libtheora-devel
  63. Requires(post): libtiff-devel
  64. Requires(post): libupnp-devel
  65. Requires(post): libv4l-devel
  66. Requires(post): libvorbis-devel
  67. Requires(post): libxml2-devel
  68. Requires(post): lirc
  69. Requires(post): kernel-headers >= 2.6.20
  70. Requires(post): libmusicbrainz-devel
  71. Requires(post): lua-devel
  72. Requires(post): ncurses-devel
  73. Requires(post): openslp-devel
  74. Requires(post): qt4-devel
  75. Requires(post): SDL_image-devel
  76. Requires(post): speex-devel >= 1.1.5
  77. %ifarch %{ix86} x86_64
  78. Requires(post): svgalib-devel
  79. %endif
  80. Requires(post): taglib-devel
  81. Requires(post): twolame-devel
  82. Requires(post): xosd-devel
  83. Requires(post): zlib-devel
  84. # X-libs
  85. Requires(post): libXt-devel
  86. Requires(post): libXv-devel
  87. Requires(post): libXxf86vm-devel
  88. Requires(post): libX11-devel
  89. Requires(post): libXext-devel
  90. Requires(post): libXpm-devel
  91. %ifarch %{ix86} x86_64
  92. Requires(post): libXvMC-devel
  93. %endif
  94. Requires(post): xorg-x11-proto-devel
  95. %if %with_samba
  96. Requires(post): samba-libsmbclient-devel
  97. %endif
  98. Requires(post): pulseaudio-libs-devel >= 0.9.8
  99. %if %with_mozilla
  100. Requires(post): gecko-devel
  101. Requires(post): nspr-devel
  102. %endif
  103. Requires(post): libraw1394-devel
  104. Requires: TrueType-dejavu
  105. ## vine
  106. %if %{?_dist_release} == "vl6"
  107. Requires(post): libva-devel
  108. %endif
  109. Requires(post): libgcrypt-devel
  110. Requires(post): wx-gtk2-devel
  111. Requires: mesa-libGL
  112. Requires(post): xorg-x11-devel
  113. Requires(post): mesa-libGL-devel
  114. Requires(post): self-build-libmpeg2
  115. Requires(post): self-build-a52dec
  116. Requires(post): self-build-faac
  117. Requires(post): self-build-faad2
  118. Requires(post): self-build-ffmpeg >= 0.4.9
  119. Requires(post): self-build-libdca
  120. Requires(post): self-build-libdvbpsi
  121. Requires(post): self-build-libdvdnav
  122. Requires(post): self-build-libmad
  123. Requires(post): self-build-libmp4v2
  124. Requires(post): self-build-x264 >= 0.0.0-9.20090522
  125. Requires(post): self-build-xvidcore
  126. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  127. Packager: munepi
  128. %description
  129. VLC (initially VideoLAN Client) is a highly portable multimedia player
  130. for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
  131. mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
  132. It can also be used as a server to stream in unicast or multicast in
  133. IPv4 or IPv6 on a high-bandwidth network.
  134. [Note]
  135. This package requires many other packages to compile
  136. targetsoftware. So it consume more disk space than usual.
  137. Also installation takes logner time because of compilation.
  138. (This will take a few minutes to quarter or half of an hour,
  139. depends on building environment)
  140. [About self-build package]
  141. For some kind of software, distributing of binary package
  142. may viorate the patent or law. Therefore we chose self-build
  143. packge, create binary package on your machine, for such kind
  144. of softwares instead of distributing binary package.
  145. Please obey the national law when you use the created binary
  146. packages. And if you want to use the softwares using patented
  147. thechnology, it may be required to get a permission, make an
  148. agreement or purchas a license. Please consider it with your
  149. purpose or way of use and take appropriate action.
  150. %description -l ja
  151. VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
  152. 様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
  153. mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
  154. 対応しています.
  155. また,高帯域幅上の IPv4 や IPv6 で,
  156. ユニキャストやマルチキャストのストリームに,
  157. サーバーとして使用することもできます.
  158. このパッケージをインストールすると、自動的にソースコードを
  159. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  160. の rpm パッケージを作成します。
  161. また apt-get コマンドや synaptic パッケージマネージャから実行
  162. した場合は、作成された rpm パッケージのインストールも自動的に
  163. 行います。
  164. [注意]
  165. コンパイルに必要な多くの関連パッケージを要求するので通常より
  166. ディスクの領域を多く消費します。
  167. またインストール時にコンパイルを行うため、通常より時間がかか
  168. る場合があります。(環境にもよりますが数分から数十分程度)
  169. [self-build パッケージについて]
  170. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  171. 違反する可能性があるものがあります。その為、このような問題が
  172. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  173. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  174. ジという方法を採っています。
  175. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  176. アのライセンス、および利用する国の各種法令に従ってください。
  177. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  178. センスの購入などが必要となる場合がありますので、利用する目的
  179. や形態に応じて各自で判断し適切な対応を取ってください。
  180. %prep
  181. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  182. %install
  183. %{__rm} -rf ${RPM_BUILD_ROOT}
  184. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  185. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  186. %{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  187. %{__install} -m 644 \
  188. %{SOURCE100} \
  189. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  190. %clean
  191. %{__rm} -rf ${RPM_BUILD_ROOT}
  192. %posttrans
  193. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 1195000
  194. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  195. %{pkgname}-devel-%{version}-%{release}
  196. %files
  197. %defattr(-,root,root)
  198. %{_datadir}/%{name}
  199. %changelog
  200. * Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
  201. - new upstream release
  202. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
  203. - new upstream release
  204. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
  205. - for only vl6, supported libva
  206. - set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
  207. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
  208. - new upstream release
  209. - added Requires(post): libva-devel
  210. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
  211. - renamed %%{Source0} to vlc-vl.spec
  212. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
  213. - added Requires(post): libsmbclient-devel
  214. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
  215. - new upstream release
  216. * Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
  217. - built with libdvbpsi-devel
  218. - dropped 0002-Default-aout-for-pulse.patch
  219. * Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
  220. - new upstream release
  221. - updated 0002-Default-aout-for-pulse.patch
  222. * Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
  223. - added Requires(post): libmtp-devel
  224. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
  225. - new upstream release
  226. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
  227. - rebuilt to add signature
  228. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
  229. - new upstream release
  230. - applied vlc-1.0.2-compiler.patch from RPM Fusion
  231. - added Requires(post): lua-devel
  232. * Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
  233. - new upstream release
  234. * Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
  235. - added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
  236. * Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
  237. - new upstream release
  238. - clean-up some old patches and merged some patches from RPM Fusion package
  239. - added vlc-trunk-default_font-vine.patch
  240. - added vlc-handlers.schemas
  241. - Gonf2 url-handler support
  242. - added shine.c, enc_base.h
  243. - missing sources
  244. - check version between original spec and self-build spec in %%prep
  245. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
  246. - dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
  247. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
  248. - rebuild with x264 >= 0.0.0-9.20090522
  249. - avoided to execute self-build-rpm.sh on RPM transaction
  250. - moved %%post actions to %%posttrans
  251. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
  252. - new upstream release
  253. - added BuildArch: noarch
  254. - s/TrueType-DejaVu/TrueType-dejavu/
  255. * Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
  256. - corrected release number in vlc.spec
  257. - dropped ExclusiveArch
  258. * Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
  259. - add ppc to ExclusiveArch
  260. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
  261. - changed to PreReq: self-build-faad2 from faad2-devel
  262. - changed to PreReq: self-build-libmad from libmad-devel
  263. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
  264. - initial build
  265. ### end of file