compiz-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799
  1. # build with kde4
  2. %bcond_with kde
  3. %define dialogversion 0.7.18
  4. %define kde_dialogversion 0.0.5
  5. %define core_plugins blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
  6. %define gnome_plugins annotate gconf glib svg gnomecompat
  7. # List of plugins passed to ./configure. The order is important
  8. %define plugins core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
  9. Summary: OpenGL window and compositing manager
  10. Summary(ja): OpenGL ウィンドウ・コンポジットマネージャ
  11. Name: compiz
  12. URL: http://www.go-compiz.org
  13. License: X11/MIT/GPL
  14. Group: User Interface/Desktops
  15. Version: 0.8.6
  16. Release: 4%{?_dist_release}
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. # libdrm is not available on these arches
  19. ExcludeArch: s390 s390x ppc64
  20. Requires: xorg-x11-server-Xorg
  21. Requires: mesa-libGL
  22. Requires(post): desktop-file-utils
  23. BuildRequires: libX11-devel, libdrm-devel, libwnck-devel
  24. BuildRequires: libXfixes-devel, libXrandr-devel, libXrender-devel
  25. BuildRequires: libXcomposite-devel, libXdamage-devel, libXext-devel
  26. BuildRequires: libXt-devel, libXmu-devel, libICE-devel, libSM-devel
  27. BuildRequires: control-center-devel, GConf2-devel
  28. BuildRequires: gnome-desktop-devel >= 2.30.0
  29. BuildRequires: metacity-devel
  30. BuildRequires: desktop-file-utils
  31. BuildRequires: intltool >= 0.35
  32. BuildRequires: gettext
  33. BuildRequires: dbus-devel
  34. BuildRequires: librsvg2-devel
  35. BuildRequires: mesa-libGLU-devel
  36. BuildRequires: fuse-devel
  37. %if %{with kde}
  38. BuildRequires: kdebase-workspace-devel
  39. BUildRequires: dbus-qt-devel
  40. %endif
  41. Conflicts: control-center < 2.32.1-2
  42. Source0: http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
  43. Source1: desktop-effects-%{dialogversion}.tar.bz2
  44. Source2: kde-desktop-effects-%{kde_dialogversion}.tar.bz2
  45. # Make sure that former beryl users still have bling
  46. Obsoletes: beryl-core
  47. # Patches from fedora
  48. Patch102: desktop-effects-0.7.17-wall-plugin.patch
  49. Patch103: composite-cube-logo.patch
  50. Patch111: gconf-core-plugin-loopfix.patch
  51. # Make sure configuration plugins never get unloaded
  52. Patch123: compiz-0.7.8-pin-initial-plugins.patch
  53. # Patches from ubuntu
  54. Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
  55. Patch1150: 015_optional-fbo.patch
  56. Patch1160: 016_call_glxwaitx_before_drawing.patch
  57. Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
  58. Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
  59. Patch1490: 049-damage-report-non-empty.patch
  60. Patch1600: 060_move_checks_to_compiz.patch
  61. # Patches from upstream
  62. Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
  63. Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
  64. %description
  65. Compiz is one of the first OpenGL-accelerated compositing window
  66. managers for the X Window System. The integration allows it to perform
  67. compositing effects in window management, such as a minimization
  68. effect and a cube workspace. Compiz is an OpenGL compositing manager
  69. that use Compiz use EXT_texture_from_pixmap OpenGL extension for
  70. binding redirected top-level windows to texture objects.
  71. %package devel
  72. Summary: Development packages for compiz
  73. Summary(ja): compiz の開発パッケージ
  74. Group: Development/Libraries
  75. Requires: compiz = %{version}-%{release}
  76. Requires: pkgconfig
  77. Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
  78. Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
  79. Requires: libxslt-devel startup-notification-devel
  80. %description devel
  81. The compiz-devel package includes the header files,
  82. and developer docs for the compiz package.
  83. Install compiz-devel if you want to develop plugins for the compiz
  84. windows and compositing manager.
  85. %package gnome
  86. Summary: Compiz gnome integration bits
  87. Summary(ja): Compiz gnome integration bits
  88. Group: User Interface/Desktops
  89. Requires: gnome-session
  90. Requires: metacity
  91. Requires: libwnck
  92. Requires: glx-utils
  93. Requires: %{name} = %{version}
  94. Requires(pre): GConf2
  95. Requires(post): GConf2
  96. Requires(preun): GConf2
  97. Obsoletes: compiz < 0.5.2-8
  98. Obsoletes: beryl-gnome
  99. %description gnome
  100. The compiz-gnome package contains gtk-window-decorator,
  101. and other gnome integration related stuff.
  102. %if %{with kde}
  103. %package kde
  104. Summary: Compiz kde integration bits
  105. Summary(ja): Compiz kde integration bits
  106. Group: User Interface/Desktops
  107. Requires: %{name} = %{version}
  108. Requires: compiz-manager
  109. Obsoletes: beryl-kde
  110. %description kde
  111. The compiz-kde package contains kde-window-decorator,
  112. and other kde integration related stuff.
  113. %endif
  114. %prep
  115. %setup -q -T -b1 -n desktop-effects-%{dialogversion}
  116. #%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
  117. %setup -q
  118. pushd ../desktop-effects-%{dialogversion}
  119. %patch102 -p1 -b .wall-plugin
  120. popd
  121. %patch103 -p1 -b .composite-cube-logo
  122. %patch111 -p1 -b .gconf-core-loop
  123. ## %patch123 -p1 -b .initial-plugins
  124. # ubuntu patch
  125. %patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
  126. %patch1150 -p1 -b .disable-fbo
  127. %patch1160 -p1 -b .call_glxwaitx_before_drawing
  128. %patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
  129. %patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
  130. %patch1490 -p1 -b .damage-report-non-empty
  131. %patch1600 -p1 -b .move-check-to-compiz
  132. # upstream patch
  133. %patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
  134. %patch2010 -p1 -b .fix-pixmap-size-calculation
  135. %build
  136. rm -rf $RPM_BUILD_ROOT
  137. CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
  138. export CPPFLAGS
  139. #needed to find kde4 libs
  140. #LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
  141. #export LDFLAGS
  142. libtoolize
  143. autoreconf
  144. %configure \
  145. %{?with_kde: --enable-kde4 } \
  146. %{!?with_kde: --disable-kde4 } \
  147. --disable-kde \
  148. --enable-gconf \
  149. --enable-dbus \
  150. --enable-place \
  151. --enable-librsvg \
  152. --enable-gtk \
  153. --enable-metacity \
  154. --enable-gnome \
  155. --with-default-plugins=%{plugins} \
  156. --enable-gnome-keybindings
  157. make %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
  158. # desktop-effects
  159. cd ../desktop-effects-%{dialogversion}
  160. %configure
  161. %install
  162. rm -rf $RPM_BUILD_ROOT
  163. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  164. make DESTDIR=$RPM_BUILD_ROOT install || exit 1
  165. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  166. echo INSTALLING DESKTOP EFFECTS
  167. pushd ../desktop-effects-%{dialogversion}
  168. make DESTDIR=$RPM_BUILD_ROOT install || exit 1
  169. #desktop-file-install --vendor vine --delete-original \
  170. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  171. # $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  172. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  173. popd
  174. %if %{with kde}
  175. # kde-desktop-effects
  176. echo INSTALLING KDE DESKTOP EFFECTS
  177. pushd ../kde-desktop-effects-%{kde_dialogversion}
  178. cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
  179. mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  180. cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  181. iconlist="16 24 32 36 48 96"
  182. for i in $iconlist; do
  183. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
  184. cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
  185. done
  186. desktop-file-install --vendor="" \
  187. --dir=%{buildroot}%{_datadir}/applications/kde \
  188. kde-desktop-effects.desktop
  189. popd
  190. %endif
  191. %if !%{with kde}
  192. rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
  193. %endif
  194. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  195. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
  196. %find_lang compiz
  197. %find_lang desktop-effects
  198. cat compiz.lang > core-files.txt
  199. cat desktop-effects.lang > gnome-files.txt
  200. for f in %{core_plugins}; do
  201. echo %{_libdir}/compiz/lib$f.so
  202. echo %{_datadir}/compiz/$f.xml
  203. done >> core-files.txt
  204. for f in %{gnome_plugins}; do
  205. echo %{_libdir}/compiz/lib$f.so
  206. echo %{_datadir}/compiz/$f.xml
  207. done >> gnome-files.txt
  208. %post -p /sbin/ldconfig
  209. %postun -p /sbin/ldconfig
  210. %post gnome
  211. update-desktop-database -q %{_datadir}/applications
  212. export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
  213. for f in %{core_plugins} %{gnome_plugins} core; do
  214. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  215. | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
  216. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  217. touch --no-create %{_datadir}/icons/hicolor
  218. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  219. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  220. fi
  221. %pre gnome
  222. if [ "$1" -gt 1 ]; then
  223. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  224. for f in %{core_plugins} %{gnome_plugins} core; do
  225. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  226. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
  227. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  228. fi
  229. %preun gnome
  230. if [ "$1" -eq 0 ]; then
  231. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  232. for f in %{core_plugins} %{gnome_plugins} core; do
  233. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  234. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
  235. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  236. fi
  237. %postun gnome
  238. touch --no-create %{_datadir}/icons/hicolor
  239. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  240. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  241. fi
  242. %if %{with kde}
  243. %post kde
  244. update-desktop-database -q %{_datadir}/applications/kde
  245. touch --no-create %{_datadir}/icons/hicolor
  246. %postun kde
  247. touch --no-create %{_datadir}/icons/hicolor
  248. %endif
  249. %clean
  250. rm -rf $RPM_BUILD_ROOT
  251. %files -f core-files.txt
  252. %defattr(-, root, root)
  253. %doc AUTHORS ChangeLog COPYING* README TODO
  254. %{_bindir}/compiz
  255. %{_libdir}/libdecoration.so.*
  256. %dir %{_libdir}/compiz
  257. %dir %{_datadir}/compiz
  258. %{_datadir}/compiz/*.png
  259. %{_datadir}/compiz/core.xml
  260. %files gnome -f gnome-files.txt
  261. %defattr(-, root, root)
  262. %{_bindir}/gtk-window-decorator
  263. %{_bindir}/desktop-effects
  264. %{_libdir}/window-manager-settings/libcompiz.so
  265. %{_datadir}/gnome/wm-properties/compiz-wm.desktop
  266. %{_datadir}/applications/compiz.desktop
  267. %{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
  268. %{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
  269. %{_datadir}/compiz/desktop-effects.glade
  270. %{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
  271. %{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
  272. %{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
  273. %{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
  274. %{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
  275. %{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
  276. %{_sysconfdir}/gconf/schemas/*.schemas
  277. %if %{with kde}
  278. %files kde
  279. %defattr(-, root, root)
  280. %{_bindir}/kde4-window-decorator
  281. %{_docdir}/compiz-kde-%{version}
  282. %{_bindir}/kde-desktop-effects.sh
  283. %{_datadir}/applications/kde/kde-desktop-effects.desktop
  284. %{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
  285. %{_datadir}/compiz/kconfig.xml
  286. %endif
  287. %files devel
  288. %defattr(-, root, root)
  289. %{_libdir}/pkgconfig/compiz.pc
  290. %{_libdir}/pkgconfig/libdecoration.pc
  291. %{_libdir}/pkgconfig/compiz-cube.pc
  292. %{_libdir}/pkgconfig/compiz-gconf.pc
  293. %{_libdir}/pkgconfig/compiz-scale.pc
  294. %{_datadir}/compiz/schemas.xslt
  295. %{_includedir}/compiz
  296. %{_libdir}/libdecoration.so
  297. %changelog
  298. * Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
  299. - drop compiz-gtk
  300. - add Conflicts: control-center < 2.32.1-2
  301. * Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
  302. - rebuild with mesa-7.10.1
  303. - add cherry picked ubuntu patch
  304. - Patch1150: add --no-fbo option
  305. - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
  306. - Patch1160: call glxwaitx before drawing
  307. - Patch1170: always unredirect screensaver on nvidia
  308. - Patch1490: damage report non empty
  309. - Patch1600: move check to compiz
  310. - add upstream patch
  311. - Patch2000: replace gdk_draw_drawable with cairo equivalents
  312. - Patch2010: fix pixmap size calculation
  313. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
  314. - rebuild with rpm-4.8.1 for pkg-config file
  315. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  316. - new upstream release (build on GNOME-2.30)
  317. - drop Patch123, Patch300
  318. * Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
  319. - rebuild with mesa-7.6
  320. - add Patch300 to build with gconf-2.28
  321. * Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
  322. - disable glib plugin in compiz-gtk
  323. - use direct rendering on virtualbox video adaptor.
  324. * Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
  325. - add Requires: glx-utils to compiz-gnome
  326. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  327. - new upstream release
  328. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
  329. - re-enable metacity decoration on gtk-window-decorator
  330. - BR: metacity-devel instead of metacity
  331. * Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
  332. - fix pre/post scripts for speeding up gconf schema installation
  333. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
  334. - add ccp compiz option to compiz-gtk
  335. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
  336. - remove desktop-effect.desktop
  337. - we use gnome-appearance-properties integrated version.
  338. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
  339. - add Patch121,122 from upstream fix.
  340. - add Patch123: make sure configuration plugins never get unloaded
  341. - add Patch124: memleak fix from upstream
  342. - add Patch125: make the terminal keybind work
  343. - add Patch120,126,127 for kde42
  344. - add Patch128: gwd fix from upstream
  345. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
  346. - rebuild with gnome-desktop-2.26.0
  347. * Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
  348. - add compiz-gtk scripts and desktop file from fedora
  349. * Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
  350. - new upstream release
  351. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
  352. - rebuild with gnome-desktop-2.24.0
  353. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
  354. - new upstream release
  355. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
  356. - new upstream release
  357. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
  358. - initial build for Vine Linux
  359. * Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
  360. - Fix gconf plugin loop RH #438794, patch based on
  361. older one from Guillaume Seguin
  362. - Add core to default plugin list
  363. * Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
  364. - Reword kde-desktop-effects messages to mention Compiz by name (#438883)
  365. * Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
  366. - Update to 0.7.2
  367. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
  368. - Autorebuild for GCC 4.3
  369. * Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
  370. - Update to desktop-effects version 0.7.17 which include more
  371. translations and move desktop-effects translations to compiz-gnome.
  372. - Fix spelling in beryl-core obsoletes.
  373. * Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
  374. - Update buildrequires (kwd uses the kde3 api)
  375. * Tue Nov 6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
  376. - Fix a typo in description of the main package.
  377. - All descriptions should end with a dot (unlike the summary line)
  378. * Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
  379. - Include kde-desktop-effects in kde subpackage
  380. * Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
  381. - Obsolete berly-core
  382. * Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
  383. - 0.6.2
  384. * Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
  385. - Disable scale corner initiate and install a GNOME key config entry.
  386. * Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
  387. - 0.6.0 final
  388. - always-restack-windows-on-map
  389. * Tue Oct 9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
  390. - Make compiz behave with gnome-terminal (#304051)
  391. * Fri Oct 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
  392. - Also install gwd.schemas (#319621)
  393. * Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
  394. - Update to more recent 0.6 branch snapshot (fixes #253575).
  395. * Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
  396. - compiz-gnome: install core schema so it actually works
  397. - remove unnecessary gconf stuff from %%install
  398. * Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
  399. - Make compiz-gnome Obsolete the older compiz package so yum/anaconda
  400. will pull it in (thans to Adel Gadllah).
  401. * Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
  402. - Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
  403. up dialog.
  404. - Fix broken gconf install and uninstall rules.
  405. - Pick up shadowman logo for RHEL builds (#232398).
  406. * Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
  407. - Add more-sm-junk.patch so we set SM restart style to
  408. SmRestartIfRunning on exit (#247163, #245971).
  409. - Add Requires to compiz-devel (#253407).
  410. - Update to desktop-effects 0.7.6, which terminates decorator when
  411. switching to metacity or on compiz failure (#215247, #215032).
  412. * Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
  413. - Split into gnome and kde subpackages
  414. - Minor cleanups
  415. * Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
  416. - Reorder plugin list to avoid 'place' getting removed on startup.
  417. - Add run-command-key.patch to put the run command key in the GNOME
  418. keyboard shortcut dialog (#213576).
  419. - Drop a bunch of obsolete patches.
  420. - Bump mesa-libGL and X server requires to fix TFP bugs for
  421. power-of-two textures (#251935).
  422. - Rebase fedora-logo and composite-cube-logo patch.
  423. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
  424. - Build with desktop-effects so we don't pick up metacity work spaces.
  425. Fixes #250568.
  426. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
  427. - Build git snapshot from fedora branch at
  428. git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
  429. branch.
  430. - Fixes #237486.
  431. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
  432. - Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
  433. 'glib' on the command line too.
  434. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
  435. - Move xml meta data files to main package.
  436. * Thu Aug 9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
  437. - Update to 0.5.2.
  438. - Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
  439. with LIBGL_ALWAYS_INDIRECT set.
  440. * Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
  441. - Update to 0.5.0
  442. * Tue Jun 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
  443. - Update to 0.4.0
  444. * Mon Jun 4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
  445. - Rebuild against new libwnck
  446. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
  447. - Don't install INSTALL
  448. * Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
  449. - Update metacity build requires to metacity-devel.
  450. * Wed Apr 4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
  451. - Fix typo in ./configure option.
  452. * Wed Apr 4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
  453. - Add place and clone plugins to default plugin list.
  454. * Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
  455. - Update URL (#208214).
  456. - Require at least metacity 2.18 (#232831).
  457. - Add close-session.patch to deregister from SM when replaced (#229113).
  458. * Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
  459. - Explicitly disable KDE parts (#234128).
  460. * Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
  461. - Fix some directory ownership issues (#233825)
  462. - Small spec cleanups
  463. * Tue Feb 6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
  464. - Require gnome-session > 2.16 so it starts gtk-window-decorator.
  465. - Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
  466. * Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
  467. - Update to 0.3.6, update patches.
  468. - Drop autotool build requires.
  469. - Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
  470. - Add libdecoration.so
  471. - Update to desktop-effects-0.7.0, which spawns the right decorator
  472. and plays nicely with unknown plugins.
  473. * Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
  474. - Update the fedora logo patch (#217224)
  475. * Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  476. - Update to 0.3.4
  477. * Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
  478. - Use cow by default, bug 208044
  479. * Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  480. - Update to 0.3.2
  481. - Drop upstreamed patches
  482. - Work with new metacity theme api
  483. * Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
  484. - Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
  485. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  486. - Add buildrequires on intltool
  487. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  488. - Build
  489. * Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
  490. - Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
  491. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
  492. - Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
  493. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
  494. - Change default plugin list to not include the plane plugin. (Bug 208448).
  495. - Change default keybinding for shrink to be Pause (Bug 206187).
  496. * Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
  497. - Add patch to show a menu when the window icon is clicked. (Bug 201629).
  498. * Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
  499. - Add restart.patch to make compiz ask the session manager to restart it
  500. if it crashes (bug 200280).
  501. * Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
  502. - Change plane.patch to not do cyclical window movement in dimensions
  503. where the desktop has size 1 (bug 207263).
  504. * Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
  505. - Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
  506. * Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
  507. - Change .plane patch to
  508. (a) not set the background color to pink in the plane plugin.
  509. (b) allow workspaces with horizontal sizes less then 4.
  510. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
  511. - Change plane patch to correctly initialize the screen size to the
  512. defaults (bug 206088).
  513. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  514. - Run update-desktop-database and gtk-update-icon-cache in post. Add icons
  515. to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
  516. directories before attempting to install to them).
  517. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  518. - Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
  519. that the new version has icons.
  520. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  521. - Add patch to fix mispositioning of window decorator event windows (bug 201624)
  522. * Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
  523. - Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
  524. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  525. - Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
  526. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  527. - Add patch to fix thumbnail sorting (bug 201605)
  528. * Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
  529. - Add patch to fix double clicking (bug 201783).
  530. * Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
  531. - Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
  532. * Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
  533. - Fix plane.patch to draw correctly when no timeout is running. (206088).
  534. * Wed Sep 6 2006 Kristian H淡gsberg <krh@redhat.com>
  535. - Update fbconfig-depth-fix.patch to also skip fbconfigs without
  536. corresponding visuals.
  537. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
  538. - Make number of vertical size configurable
  539. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
  540. - Fix vertical viewport support in the plane patch.
  541. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
  542. - Upgrade to 0.6.61 of the dialog
  543. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  544. - Add libtool to BuildRequires
  545. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  546. - Add automake and autoconf to BuildRequires
  547. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  548. - Add a patch to put viewports on a plane.
  549. * Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
  550. - Drop gl-include-inferiors.patch now that compiz uses COW and the X
  551. server evicts offscreen pixmaps automatically on
  552. GLX_EXT_texture_from_pixmap usage.
  553. * Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
  554. - Add cow.patch to make compiz use the composite overlay window.
  555. * Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
  556. - Rebase to desktop-effects 0.6.41
  557. * Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
  558. - Rebase to desktop-effects 0.6.19 and drop
  559. desktop-effects-0.6.1-delete-session.patch
  560. * Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
  561. - Add patch from upstream to also use sync protocol for override
  562. redirect windows (sync-override-redirect-windows.patch).
  563. * Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
  564. - Rebase to latest upstream changes which has the rest of the bindings
  565. rewrite. Add resize-move-keybindings.patch to make move and resize
  566. bindings work like metacity.
  567. - Add back scale plugin.
  568. * Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
  569. - Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
  570. - unlink session file on changing wms (bug 201473)
  571. * Thu Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
  572. - Add Requires: gnome-session 2.15.4-3
  573. * Wed Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  574. - New version of dialog box. Macro the version number.
  575. * Wed Aug 2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  576. - Add 'desktop effects' dialog box.
  577. * Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
  578. - Add libwnck requires.
  579. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
  580. - Bump and build for fc5 AIGLX repo.
  581. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
  582. - Fix gconf hooks.
  583. * Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
  584. - Require system-logos instead.
  585. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
  586. - Bump version to work around tagging weirdness.
  587. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
  588. - Add devel package and require redhat-logos instead of fedora-logos (#199757).
  589. * Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
  590. - Add workaround for AIGLX throttling problem.
  591. * Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
  592. - Drop scale plugin from snapshot.
  593. * Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
  594. - Don't build on s390
  595. * Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
  596. - Do some changes forced upon us by package review
  597. * Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
  598. - Use sane numbering scheme.
  599. * Fri Jul 7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
  600. - Drop the fullscreen hardcode patch and require X server that has
  601. GLX_MESA_copy_sub_buffer.
  602. * Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
  603. - Unbreak --replace.
  604. * Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
  605. - Add Requires, fix start-compiz.sh.
  606. * Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
  607. - Spec file for compiz, borrowing bits and pieces from Alphonse Van
  608. Assches spec file (#192432).