evolution-data-server-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811
  1. %define use_nss 1
  2. %define ldap_support 1
  3. %define static_ldap 1
  4. %define krb5_support 1
  5. %define nntp_support 1
  6. %define glib2_version 2.34.0
  7. %define gtk3_version 3.6.0
  8. %define gtk_doc_version 1.18
  9. %define intltool_version 0.35.5
  10. %define orbit2_version 2.14.19
  11. %define soup_version 2.36.0
  12. %define libgweather_version 3.2.0
  13. %define libical_version 0.44
  14. %define libgdata_version 0.10.1
  15. %define eds_base_version 3.10
  16. %define eds_api_version 1.2
  17. %define use_gnome_keyring 1
  18. %define support_imap4_provider 0
  19. %define camel_provider_dir %{_libdir}/evolution-data-server/camel-providers
  20. %define ebook_backends_dir %{_libdir}/evolution-data-server/addressbook-backends
  21. %define ecal_backends_dir %{_libdir}/evolution-data-server/calendar-backends
  22. %define registry_modules_dir %{_libdir}/evolution-data-server/registry-modules
  23. ### Abstract ###
  24. Summary: Backend data server for evolution
  25. Summary(ja): Evolution バックエンドデータサーバ
  26. Name: evolution-data-server
  27. Version: 3.10.1
  28. Release: 1%{?_dist_release}
  29. License: LGPL
  30. Group: System Environment/Libraries
  31. URL: http://www.gnome.org/projects/evolution/
  32. Source0: http://ftp.gnome.org/pub/GNOME/sources/evolution-data-server/3.10/%{name}-%{version}.tar.xz
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. ### Patches ###
  35. # RH bug #243296
  36. Patch12: evolution-data-server-1.11.5-fix-64bit-acinclude.patch
  37. ### Dependencies ###
  38. #Requires: ORBit2 >= %{orbit2_version}
  39. Requires: libsoup >= %{soup_version}
  40. ### Build Dependencies ###
  41. #BuildRequires: ORBit2-devel >= %{orbit2_version}
  42. BuildRequires: bison
  43. BuildRequires: db4-devel
  44. BuildRequires: flex
  45. BuildRequires: gettext
  46. BuildRequires: glib2-devel
  47. BuildRequires: gtk3-devel
  48. BuildRequires: dbus-glib-devel
  49. BuildRequires: gnutls-devel
  50. BuildRequires: intltool >= %{intltool_version}
  51. BuildRequires: libsoup-devel >= %{soup_version}
  52. BuildRequires: libtool
  53. BuildRequires: libgnome-keyring-devel
  54. BuildRequires: gtk-doc >= 1.14
  55. BuildRequires: sqlite3-devel
  56. BuildRequires: libgweather-devel >= %{libgweather_version}
  57. BuildRequires: libical-devel >= %{libical_version}
  58. BuildRequires: gperf
  59. BuildRequires: krb5-devel
  60. BuildRequires: libgdata-devel >= %{libgdata_version}
  61. BuildRequires: gnome-online-accounts-devel
  62. BuildRequires: liboauth-devel
  63. BuildRequires: libsecret-devel
  64. BuildRequires: gnome-common
  65. BuildRequires: vala
  66. BuildRequires: vala-tools
  67. %if %{use_nss}
  68. BuildRequires: nspr-devel
  69. BuildRequires: nss-devel
  70. %else
  71. BuildRequires: openssl-devel
  72. %endif
  73. %if %{ldap_support}
  74. %if %{static_ldap}
  75. BuildRequires: openldap-evolution-devel
  76. BuildRequires: openssl-devel
  77. %else
  78. BuildRequires: openldap-devel >= 2.0.11
  79. %endif
  80. %endif
  81. %if %{krb5_support}
  82. BuildRequires: krb5-devel
  83. # tweak for krb5 1.2 vs 1.3
  84. %define krb5dir /usr/kerberos
  85. #define krb5dir `pwd`/krb5-fakeprefix
  86. %endif
  87. Vendor: Project Vine
  88. Distribution: Vine Linux
  89. %description
  90. The evolution-data-server package provides a unified backend for
  91. programs that work with contacts, tasks, and calendar information.
  92. It was originally developed for Evolution (hence the name), but
  93. is now used by other packages.
  94. %package devel
  95. Summary: Development files for building against evolution-data-server
  96. Group: Development/Libraries
  97. Requires: %{name} = %{version}-%{release}
  98. Requires: pkgconfig
  99. Requires: sqlite3-devel
  100. Requires: libgnome-keyring-devel
  101. %description devel
  102. Development files needed for building things which link against
  103. evolution-data-server.
  104. %package doc
  105. Summary: Documentation for %{name}
  106. Summary(ja): %{name} 用のドキュメント
  107. Group: Documentation
  108. Requires: %{name} = %{version}-%{release}
  109. BuildArch: noarch
  110. %description doc
  111. This package contains documentation for %{name}.
  112. %package vala
  113. Summary: Vala bindings for %{name}
  114. Summary(ja): %{name} の Vala バインディング
  115. Group: Development/Libraries
  116. Requires: %{name} = %{version}-%{release}
  117. Requires: vala
  118. %description vala
  119. Vala bindings for %{name}.
  120. %prep
  121. %setup -q
  122. %patch12 -p1 -b .fix-64bit-acinclude
  123. mkdir -p krb5-fakeprefix/include
  124. mkdir -p krb5-fakeprefix/lib
  125. mkdir -p krb5-fakeprefix/%{_lib}
  126. %build
  127. %if %{ldap_support}
  128. %if %{static_ldap}
  129. %define ldap_flags --with-openldap=%{_libdir}/evolution-openldap --with-static-ldap
  130. # Set LIBS so that configure will be able to link with static LDAP libraries,
  131. # which depend on Cyrus SASL and OpenSSL. XXX Is the "else" clause necessary?
  132. if pkg-config libssl ; then
  133. export LIBS="-lsasl2 `pkg-config --libs libssl`"
  134. else
  135. export LIBS="-lsasl2 -lssl -lcrypto"
  136. fi
  137. %else
  138. %define ldap_flags --with-openldap=yes
  139. %endif
  140. %else
  141. %define ldap_flags --without-openldap
  142. %endif
  143. %if %{krb5_support}
  144. %define krb5_flags --with-krb5=%{krb5dir} --with-krb5-libs=%{_libdir} --with-krb5-includes=%{_includedir}
  145. %else
  146. %define krb5_flags --without-krb5
  147. %endif
  148. %if %{nntp_support}
  149. %define nntp_flags --enable-nntp=yes
  150. %else
  151. %define nntp_flags --enable-nntp=no
  152. %endif
  153. %if %{use_nss}
  154. %define ssl_flags --enable-nss=yes --enable-smime=yes
  155. %else
  156. %define ssl_flags --enable-openssl=yes
  157. %endif
  158. %if %{use_nss}
  159. if ! pkg-config --exists nss; then
  160. echo "Unable to find suitable version of nss to use!"
  161. exit 1
  162. fi
  163. %endif
  164. %if %{use_gnome_keyring}
  165. %define keyring_flags --enable-gnome-keyring
  166. %else
  167. %define keyring flags --disable-gnome-keyring
  168. %endif
  169. %if %{support_imap4_provider}
  170. %define imap4_flags --enable-imap4=yes
  171. %else
  172. %define imap4_flags --enable-imap4=no
  173. %endif
  174. export CPPFLAGS="-I%{_includedir}/et"
  175. export CFLAGS="$RPM_OPT_FLAGS -DLDAP_DEPRECATED -fPIC -I%{_includedir}/et"
  176. # Regenerate configure to pick up configure.in and acinclude.m4 changes.
  177. autoreconf -if
  178. # See Ross Burton's blog entry for why we want --with-libdb.
  179. # http://www.burtonini.com/blog//computers/eds-libdb-2006-07-18-10-40
  180. %configure \
  181. --with-libdb=/usr \
  182. --disable-uoa \
  183. --enable-file-locking=fcntl \
  184. --enable-dot-locking=no \
  185. --enable-gtk-doc \
  186. --enable-introspection=yes \
  187. --enable-vala-bindings \
  188. %ldap_flags %krb5_flags %nntp_flags %ssl_flags %imap4_flags \
  189. %keyring_flags
  190. export tagname=CC
  191. #make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
  192. make LIBTOOL=/usr/bin/libtool
  193. %install
  194. rm -rf $RPM_BUILD_ROOT
  195. export tagname=CC
  196. make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
  197. # remove libtool archives for importers and the like
  198. find $RPM_BUILD_ROOT/%{_libdir} -name '*.la' -exec rm {} \;
  199. find $RPM_BUILD_ROOT/%{_libdir} -name '*.a' -exec rm {} \;
  200. # give the libraries some executable bits
  201. find $RPM_BUILD_ROOT -name '*.so.*' -exec chmod +x {} \;
  202. %find_lang %{name}-%{eds_base_version}
  203. %clean
  204. rm -rf $RPM_BUILD_ROOT
  205. %post -p /sbin/ldconfig
  206. %postun
  207. /sbin/ldconfig
  208. if [ $1 -eq 0 ]; then
  209. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  210. fi
  211. %posttrans
  212. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  213. %files -f %{name}-%{eds_base_version}.lang
  214. %defattr(-,root,root,-)
  215. %doc README COPYING ChangeLog NEWS AUTHORS
  216. %{_libdir}/*.so.*
  217. %{_libdir}/girepository-1.0/*.typelib
  218. %{_libexecdir}/evolution-addressbook-factory
  219. %{_libexecdir}/evolution-calendar-factory
  220. %{_libexecdir}/evolution-source-registry
  221. %{_libexecdir}/evolution-user-prompter
  222. %{_libexecdir}/camel-index-control-%{eds_api_version}
  223. %{_libexecdir}/camel-lock-helper-%{eds_api_version}
  224. %{_datadir}/GConf/gsettings/evolution-data-server.convert
  225. %{_datadir}/GConf/gsettings/libedataserver.convert
  226. %{_datadir}/dbus-1/services/*
  227. %{_datadir}/%{name}/evolutionperson.schema
  228. %{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
  229. %{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
  230. %{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
  231. %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
  232. %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
  233. %{_datadir}/pixmaps/evolution-data-server
  234. %dir %{_libdir}/evolution-data-server
  235. %dir %{camel_provider_dir}
  236. %dir %{ebook_backends_dir}
  237. %dir %{ecal_backends_dir}
  238. %dir %{registry_modules_dir}
  239. %{camel_provider_dir}/libcamelimapx.so
  240. %{camel_provider_dir}/libcamelimapx.urls
  241. %{camel_provider_dir}/libcamellocal.so
  242. %{camel_provider_dir}/libcamellocal.urls
  243. %{camel_provider_dir}/libcamelnntp.so
  244. %{camel_provider_dir}/libcamelnntp.urls
  245. %{camel_provider_dir}/libcamelpop3.so
  246. %{camel_provider_dir}/libcamelpop3.urls
  247. %{camel_provider_dir}/libcamelsendmail.so
  248. %{camel_provider_dir}/libcamelsendmail.urls
  249. %{camel_provider_dir}/libcamelsmtp.so
  250. %{camel_provider_dir}/libcamelsmtp.urls
  251. # e-d-s extensions:
  252. %{ebook_backends_dir}/libebookbackendfile.so
  253. %{ebook_backends_dir}/libebookbackendgoogle.so
  254. %{ebook_backends_dir}/libebookbackendldap.so
  255. %{ebook_backends_dir}/libebookbackendwebdav.so
  256. %{ecal_backends_dir}/libecalbackendcaldav.so
  257. %{ecal_backends_dir}/libecalbackendcontacts.so
  258. %{ecal_backends_dir}/libecalbackendfile.so
  259. %{ecal_backends_dir}/libecalbackendhttp.so
  260. %{ecal_backends_dir}/libecalbackendweather.so
  261. %{registry_modules_dir}/module-cache-reaper.so
  262. %{registry_modules_dir}/module-google-backend.so
  263. %{registry_modules_dir}/module-gnome-online-accounts.so
  264. %{registry_modules_dir}/module-outlook-backend.so
  265. %{registry_modules_dir}/module-owncloud-backend.so
  266. %{registry_modules_dir}/module-trust-prompt.so
  267. %{registry_modules_dir}/module-yahoo-backend.so
  268. %files devel
  269. %defattr(-,root,root,-)
  270. %{_includedir}/%{name}
  271. %{_libdir}/*.so
  272. %{_libdir}/pkgconfig/*.pc
  273. %{_datadir}/gir-1.0/*.gir
  274. %files doc
  275. %defattr(-,root,root,-)
  276. %{_datadir}/gtk-doc/html/camel
  277. %{_datadir}/gtk-doc/html/libebackend
  278. %{_datadir}/gtk-doc/html/libebook
  279. %{_datadir}/gtk-doc/html/libebook-contacts
  280. %{_datadir}/gtk-doc/html/libecal
  281. %{_datadir}/gtk-doc/html/libedata-book
  282. %{_datadir}/gtk-doc/html/libedata-cal
  283. %{_datadir}/gtk-doc/html/libedataserver
  284. %files vala
  285. %defattr(-,root,root,-)
  286. %{_datadir}/vala/vapi/libebook-1.2.deps
  287. %{_datadir}/vala/vapi/libebook-1.2.vapi
  288. %{_datadir}/vala/vapi/libebook-contacts-1.2.deps
  289. %{_datadir}/vala/vapi/libebook-contacts-1.2.vapi
  290. %{_datadir}/vala/vapi/libedataserver-1.2.deps
  291. %{_datadir}/vala/vapi/libedataserver-1.2.vapi
  292. %changelog
  293. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  294. - new upstream release
  295. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.5-1
  296. - new upstream release
  297. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  298. - new upstream release
  299. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  300. - new upstream release
  301. * Sat Apr 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  302. - new upstream release
  303. - add configure option (--disable-uoa)
  304. - add BuildRequires: libsecret-devel, gnome-common, vala, vala-tools
  305. - create %%{name}-vala subpackage
  306. * Sun Mar 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.4-1
  307. - new upstream release
  308. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  309. - new upstream release
  310. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  311. - new upstream release
  312. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  313. - new upstream release
  314. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  315. - new upstream release
  316. * Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
  317. - new upstream release
  318. * Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
  319. - new upstream release
  320. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  321. - new upstream release
  322. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  323. - new upstream release
  324. - add BuildRequires: dbus-glib-devel
  325. * Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
  326. - new upstream release
  327. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  328. - new upstream release
  329. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  330. - new upstream release
  331. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  332. - new upstream release
  333. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  334. - new upstream release
  335. - remove Patch101
  336. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
  337. - new upstream release
  338. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  339. - new upstream release
  340. - change BuildRequires: gtk3-devel instead of gtk2-devel
  341. - BuildRequires: gnome-online-accounts-devel
  342. - add Patch101 (evolution-data-server-3.1.3-build-with-glib-2.29.14.patch)
  343. - fix %%files
  344. * Tue Feb 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  345. - new upstream release
  346. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-2
  347. - rebuild with openssl-1.0.0c
  348. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  349. - new upstream release
  350. - remove Requires: gnome-vfs2, libglade2, libgnomeui
  351. - remove BuildRequires: gnome-vfs2-devel, libglade2-devel, libgnomeui-devel
  352. - add BuildRequires: libgdata
  353. - add Requires: nspr-devel, nss-devel (devel package)
  354. - drop Patch11
  355. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
  356. - rebuild with rpm-4.8.1 for pkg-config file
  357. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  358. - new upstream release
  359. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  360. - new upstream release
  361. * Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  362. - new upstream release
  363. - remove BuildRequires: libbonobo-devel
  364. - remove Requires: libbonobo
  365. - drop Patch10
  366. - add configure option (--with-krb5-libs, --with-krb5-includes)
  367. * Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.28.1-2
  368. - rebuilt with db4-4.8
  369. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  370. - new upstream release
  371. * Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  372. - new upstream release
  373. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  374. - new upstream release
  375. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1.1-1
  376. - new upstream release
  377. * Sat Apr 4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
  378. - added Requires: libical-devel >= 0.43 to devel package
  379. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  380. - new upstream release
  381. - add BR: libgweather-devel >= 2.26.0
  382. - add BR: libical-devel >= 0.43
  383. * Sat Mar 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.5-1
  384. - new upstream release
  385. - added BuildRequires: sqlite3-devel
  386. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-2
  387. - enabled krb5 support
  388. * Sun Dec 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
  389. - new upstream release
  390. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  391. - new upstream release
  392. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  393. - new upstream release
  394. * Mon Jun 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1
  395. - new upstream release
  396. * Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-2
  397. - rebuilt with db4-4.6.21
  398. * Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1
  399. - new upstream release
  400. * Sun May 4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
  401. - new upstream release
  402. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  403. - new upstream release
  404. * Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  405. - new upstream release based on Fedora package 2.20.0-3.fc9
  406. * Mon Mar 24 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-3.fc9
  407. - Add patch for GNOME bug #523023 (EFolder leak in evo-ex-storage).
  408. * Tue Mar 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2.fc9
  409. - Add patch for RH bug #296671 (GC servers may not support NTLM).
  410. * Thu Feb 14 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-3.fc9
  411. - Try removing the ancient "ldap-x86_64-hack" patch.
  412. * Mon Feb 11 2008 Matthew Barnes <mbarnes@redhat.com> - 2.21.91-1.fc9
  413. - Add patch for GNOME bug #516074 (latest glibc breaks Camel).
  414. - split doc subpackage
  415. * Sat Jul 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl2
  416. - fixed dependancy
  417. * Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.10.1-1vl1
  418. - updated to 1.10.3.1 based on Fedora package 1.10.1-1.fc7
  419. * Wed Apr 04 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-6.fc7
  420. - Revise patch for GNOME bug #417999 (another ESourceComboBox goof).
  421. * Mon Apr 02 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-5.fc7
  422. - Make the new ESourceComboBox widget work properly (RH bug #234760).
  423. * Tue Mar 27 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-4.fc7
  424. - Link to static evolution-openldap library (RH bug #210126).
  425. - Require openssl-devel when statically linking against openldap.
  426. - Add -Wdeclaration-after-statement to strict build settings.
  427. * Wed Mar 14 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-2.fc7
  428. - Modify patch for GNOME bug #376991 to fix RH bug #231994.
  429. - Add patch for GNOME bug #417999 (avoid deprecated GTK+ symbols).
  430. * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 1.10.0-1.fc7
  431. - Update to 1.10.0
  432. * Fri Mar 09 2007 Matthew Barnes <mbarnes@redhat.com> - 1.9.92-4.fc7
  433. - Add patch for GNOME bug #415922 (support MS ISA Server 2004).
  434. - Patch by Kenny Root.
  435. - rebuilt with nss-devel and nspr-devel
  436. * Fri May 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.2-0vl2
  437. - rebuilt with new toolchain and db4-4.3.x
  438. * Sun Nov 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.2-0vl1
  439. - new upstream release
  440. * Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-0vl1
  441. - new upstream release
  442. - dropped Patch16, 17, 19, 20 and 21 (merged into upstream)
  443. * Sat Oct 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-11vl1
  444. - new upstream release
  445. - rebuilt with openssl instead of mozilla-nss
  446. * Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl2
  447. - rebuilt with openldap-2.3.24-0vl4
  448. * Thu Dec 1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2.1-0vl1
  449. - new upstream release
  450. - build with libsoap-2.2.7
  451. * Tue Nov 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1.1-0vl1
  452. - new upstream release
  453. * Sun Sep 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.0-2vl1
  454. - new upstream release
  455. - added/removed Patches based on Fedora packages
  456. * Tue Aug 23 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.8-3
  457. - Updated patch 102 to fix further implicit function declarations
  458. * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-2
  459. - Added patch to use nspr rather than mozilla-nspr when doing pkg-config
  460. tests (Patch5: evolution-data-server-1.3.5-nspr_fix.patch)
  461. * Mon Jul 25 2005 David Malcolm <dmalcolm@redhat.com> - 1.3.5-1
  462. - Removed upstreamed patch:
  463. evolution-data-server-1.2.0-cope-with-a-macro-called-read.patch
  464. * Mon Apr 11 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.2-2
  465. - added patch to calendar/libecal/e-cal.c to fix missing declaration
  466. of open_calendar
  467. - rebuilt with mozilla-1.7.12
  468. * Wed May 04 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.1-0vl2
  469. - rebuilt with mozilla-1.7.7
  470. * Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
  471. - initial build for Vine Linux based on FC package
  472. - disable krb5 support
  473. * Thu Mar 17 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.1-1
  474. - 1.2.1
  475. * Thu Mar 10 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-3
  476. - Removed explicit run-time spec-file requirement on mozilla.
  477. The Mozilla NSS API/ABI stabilised by version 1.7.3
  478. The libraries are always located in the libdir
  479. However, the headers are in /usr/include/mozilla-%{mozilla_build_version}
  480. and so they move each time the mozilla version changes.
  481. So we no longer have an explicit mozilla run-time requirement in the specfile;
  482. a requirement on the appropriate NSS and NSPR .so files is automagically generated on build.
  483. We have an explicit, exact build-time version, so that we can find the headers (without
  484. invoking an RPM query from the spec file; to do so is considered bad practice)
  485. - Introduced mozilla_build_version, to replace mozilla_version
  486. - Set mozilla_build_version to 1.7.6 to reflect current state of tree
  487. * Tue Mar 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-2
  488. - Added a patch to deal with glibc defining a macro called "read"
  489. * Tue Mar 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.2.0-1
  490. - 1.2.0
  491. - Removed patch for GCC 4 as this is now in upstream tarball
  492. * Wed Mar 2 2005 Jeremy Katz <katzj@redhat.com> - 1.1.6-6
  493. - rebuild to fix library linking silliness
  494. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-5
  495. - disabling gtk-doc on ia64 and s390x
  496. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-4
  497. - added macro use_gtk_doc; added missing BuildRequires on gtk-doc; enabled gtk-doc generation on all platforms (had been disabled on ia64)
  498. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-3
  499. - extended patch to deal with camel-groupwise-store-summary.c
  500. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-2
  501. - added patch to fix badly-scoped declaration of "namespace_clear" in camel-imap-store-summary.c
  502. * Tue Mar 1 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.6-1
  503. - 1.1.6
  504. * Tue Feb 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-3
  505. - rebuild
  506. * Tue Feb 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-2
  507. - forgot to fix sources
  508. * Tue Feb 8 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.5-1
  509. - 1.1.5
  510. * Thu Jan 27 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.2-1
  511. - Update from unstable 1.1.4.1 to unstable 1.1.1.4.2
  512. * Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-3
  513. - disable gtk-doc generation on ia64 for now
  514. * Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-2
  515. - Exclude ppc64 due to missing mozilla dependency
  516. * Wed Jan 26 2005 David Malcolm <dmalcolm@redhat.com> - 1.1.4.1-1
  517. - Update from 1.0.3 to 1.1.4.1
  518. - Updated eds_major from 1.0 to 1.2; fixed translation search path.
  519. - Removed 64-bit patch for calendar backend hash table; upstream now stores pointers to ECalBackendFactory, rather than GType
  520. - Removed calendar optimisation patch for part of part of bug #141283 as this is now in the upstream tarball
  521. - Added /usr/lib/evolution-data-server-%{eds_major} to cover the extensions, plus the camel code now in e-d-s, rather than evolution
  522. - Added /usr/share/pixmaps/evolution-data-server-%{eds_major} to cover the category pixmaps
  523. - Camel code from evolution is now in evolution-data-server:
  524. - Added camel-index-control and camel-lock-helper to packaged files
  525. - Added mozilla dependency code from the evolution package
  526. - Ditto for LDAP
  527. - Ditto for krb5
  528. - Ditto for NNTP support handling
  529. - Ditto for --enable-file-locking and --enable-dot-locking
  530. - Added requirements on libbonobo, libgnomeui, gnome-vfs2, GConf2, libglade2
  531. - Updated libsoup requirement from 2.2.1 to 2.2.2
  532. - Enabled gtk-doc
  533. * Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-2
  534. - fixed packaging of translation files to reflect upstream change to GETTEXT_PACKAGE being evolution-data-server-1.0 rather than -1.5
  535. * Wed Dec 15 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.3-1
  536. - update from upstream 1.0.2 to 1.0.3:
  537. * Address Book
  538. - prevent e_book_commit_contact from crashing on multiple calls (Diego Gonzalez)
  539. - prevent file backend from crashing if uid of vcard is NULL (Diego Gonzalez)
  540. * Calendar
  541. #XB59904 - Speed up calendar queries (Rodrigo)
  542. #XB69624 - make changes in evo corresponding to soap schema changes (Siva)
  543. - fix libical build for automake 1.9 (Rodney)
  544. - fix putenv usage for portability (Julio M. Merino Vidal)
  545. * Updated Translations:
  546. - sv (Christian Rose)
  547. - Removed patches to fix build on x86_64 and calendar optimisation for XB59004 as these are in the upstream tarball
  548. * Tue Dec 7 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-6
  549. - Amortize writes to a local cache of a webcal calendar, fixing further aspect of #141283 (upstream bugzilla #70267), as posted to mailing list here:
  550. http://lists.ximian.com/archives/public/evolution-patches/2004-December/008338.html
  551. (The groupwise part of that patch did not cleanly apply, so I removed it).
  552. * Thu Dec 2 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-5
  553. - Added fix for #141283 (upstream bugzilla XB 59904), a backported calendar
  554. optimisation patch posted to upstream development mailing list here:
  555. http://lists.ximian.com/archives/public/evolution-patches/2004-November/008139.html
  556. * Wed Nov 3 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-4
  557. - Added patch to fix usage of GINT_TO_POINTER/GPOINTER_TO_INT for calendar backend GType hash table, breaking on ia64 (#136914)
  558. * Wed Oct 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-3
  559. - added workaround for a backend leak that causes the "contacts" calendar
  560. backend to hold open an EBook for the local contacts (filed upstream at:
  561. http://bugzilla.ximian.com/show_bug.cgi?id=68533 ); this was causing e-d-s to
  562. never lose its last addressbook, and hence never quit. We workaround this by
  563. detecting this condition and exiting when it occurs, fixing bug #134851 and #134849.
  564. * Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-2
  565. - added patch to fix build on x86_64 (had multiple definitions of mutex code in libdb/dbinc.mutex.h)
  566. * Tue Oct 12 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.2-1
  567. - update from 1.0.1 to 1.0.2
  568. - increased libsoup requirement to 2.2.1 to match configuration script
  569. * Tue Sep 28 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.1-1
  570. - update from 1.0.0 to 1.0.1
  571. - removed patch that fixed warnings in calendar code (now in upstream tarball)
  572. * Mon Sep 20 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-2
  573. - fixed various warnings in the calendar code
  574. (filed upstream here: http://bugzilla.ximian.com/show_bug.cgi?id=66383)
  575. * Tue Sep 14 2004 David Malcolm <dmalcolm@redhat.com> - 1.0.0-1
  576. - update from 0.0.99 to 1.0.0
  577. - changed path in FTP source location from 0.0 to 1.0
  578. * Tue Aug 31 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.99-1
  579. - update from 0.0.98 to 0.0.99
  580. - increased libsoup requirement to 2.2.0 to match configuration script
  581. * Mon Aug 16 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.98-1
  582. - updated tarball from 0.0.97 to 0.0.98; updated required libsoup version to 2.1.13
  583. * Thu Aug 5 2004 Warren Togami <wtogami@redhat.com> - 0.0.97-2
  584. - pkgconfig -devel Requires libbonobo-devel, libgnome-devel
  585. * Wed Aug 4 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.97-1
  586. - upgraded to 0.0.97; rewrote the package's description
  587. * Mon Jul 26 2004 David Malcolm <dmalcolm@redhat.com>
  588. - rebuilt
  589. * Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-2
  590. - added version numbers to the BuildRequires test for libsoup-devel and ORBit2-devel
  591. * Tue Jul 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.96-1
  592. - 0.0.96; libsoup required is now 2.1.12
  593. * Thu Jul 8 2004 David Malcolm <dmalcolm@redhat.com>
  594. - rebuilt
  595. * Wed Jul 7 2004 David Malcolm <dmalcolm@redhat.com>
  596. - rebuilt
  597. * Tue Jul 6 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.95-1
  598. - 0.0.95
  599. * Thu Jun 17 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94.1-1
  600. - 0.0.94.1
  601. * Mon Jun 7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-2
  602. - rebuilt
  603. * Mon Jun 7 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.94-1
  604. - 0.0.94
  605. * Wed May 26 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-4
  606. - added ORBit2 requirement
  607. * Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-3
  608. - rebuild again
  609. * Fri May 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-2
  610. - rebuilt
  611. * Thu May 20 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.93-1
  612. - 0.0.93; libsoup required is now 2.1.10
  613. * Wed Apr 21 2004 David Malcolm <dmalcolm@redhat.com> - 0.0.92-1
  614. - Update to 0.0.92; added a define and a requirement on the libsoup version
  615. * Wed Mar 10 2004 Jeremy Katz <katzj@redhat.com> - 0.0.90-1
  616. - 0.0.90
  617. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  618. - rebuilt
  619. * Mon Jan 26 2004 Jeremy Katz <katzj@redhat.com> - 0.0.6-1
  620. - 0.0.6
  621. * Wed Jan 21 2004 Jeremy Katz <katzj@redhat.com> - 0.0.5-2
  622. - better fix by using system libtool
  623. * Mon Jan 19 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-1
  624. - add some libdb linkage to make the build on x86_64 happy
  625. * Wed Jan 14 2004 Jeremy Katz <katzj@redhat.com> 0.0.5-0
  626. - update to 0.0.5
  627. * Sat Jan 3 2004 Jeremy Katz <katzj@redhat.com> 0.0.4-0
  628. - Initial build.