123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142 |
- %{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
- %define pkg_version 3.8.2
- %define pkg_release 2%{?_dist_release}
- Summary: An interactive Python accessibility explorer for the GNOME desktop.
- Summary(ja): GNOME デスクトップ用 Python アクセシビリティエクスプローラ
- Name: accerciser
- Version: %{pkg_version}
- Release: %{pkg_release}
- Source0: http://ftp.gnome.org/pub/GNOME/sources/accerciser/3.8/%{name}-%{version}.tar.xz
- License: BSD
- Group: Desktop/Accessibility
- URL: http://live.gnome.org/Accerciser
- Requires: python3 >= 3.2
- Requires: python3-pygobject >= 2.90.3
- Requires: python3-pyatspi >= 2.5.2
- Requires: at-spi2-core
- Requires(post): desktop-file-utils
- Requires(postun): desktop-file-utils
- BuildRequires: python3-devel >= 3.2
- BuildRequires: python3-pygobject-devel
- BuildRequires: gtk3-devel
- BuildRequires: at-spi2-core-devel
- BuildRequires: python3-pyatspi
- BuildRequires: glib2-devel >= 2.26.0
- BuildRequires: docbook-dtds
- BuildRequires: yelp-tools
- BuildRequires: autoconf
- BuildRequires: gnome-common
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: Takemikaduchi
- %description
- Accerciser is an interactive Python accessibility explorer for the GNOME
- desktop. It uses AT-SPI to inspect and control widgets, allowing you to check
- if an application is providing correct information to assistive technologies
- and automated test frameworks. Accerciser has a simple plugin framework which
- you can use to create custom views of accessibility information.
- %prep
- %setup -q
- %build
- %configure --disable-static
- %{__make} %{?_smp_mflags}
- %install
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %{__make} install DESTDIR=${RPM_BUILD_ROOT}
- %find_lang %{name} --with-gnome --all-name
- %clean
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %post
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
- update-desktop-database & > /dev/null || :
- %postun
- if [ $1 -eq 0 ]; then
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
- update-desktop-database & > /dev/null || :
- glib-compile-schemas %{_datadir}/glib-2.0/schemas
- fi
- %posttrans
- glib-compile-schemas %{_datadir}/glib-2.0/schemas
- %files -f %{name}.lang
- %defattr(-,root,root)
- %doc AUTHORS COPYING ChangeLog NEWS README
- %{_bindir}/accerciser
- %{python3_sitelib}/accerciser
- %{_datadir}/applications/accerciser.desktop
- %{_datadir}/accerciser/*
- %{_datadir}/glib-2.0/schemas/*.xml
- %{_datadir}/icons/hicolor/*/apps/*
- %{_datadir}/icons/HighContrast/*/apps/*
- %{_mandir}/man1/accerciser.1.gz
- %changelog
- * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
- - change BuildRequires: python3-pygobject-devel instead of pygobject3
- - change BuildRequires: python3-pyatspi instead of pyatspi
- * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
- - new upstream release
- * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
- - new upstream release
- - add BuildRequires: autoconf, gnome-common
- * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
- - new upstream release
- * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
- - new upstream release
- - change BuildRequires: yelp-tools instead of gome-doc-utils
- * Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
- - new upstream release
- - remove BuildRequires: GConf2-devel
- * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
- - new upstream release
- * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
- - new upstream release
- * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
- - new upstream release
- - add BuildRequires: gtk3-devel, pygobject3-devel
- - change BuildRequires: at-spi2-core-devel instead of at-spi-devel
- * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
- - new upstream release
- * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
- - new upstream release
- * Mon May 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
- - new upstream release
- * Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
- - initial build for Vine Linux
|