corosync-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432
  1. Name: corosync
  2. Summary: The Corosync Cluster Engine and Application Programming Interfaces
  3. Summary(ja): Corosyncクラスタエンジンおよびアプリケーションプログラミングインタフェース
  4. Version: 1.4.3
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Base
  8. URL: http://ftp.corosync.org
  9. Source0: ftp://ftp:downloads@ftp.corosync.org/downloads/%{name}-%{version}/%{name}-%{version}.tar.gz
  10. # Runtime bits
  11. Requires: corosynclib = %{version}-%{release}
  12. Requires(pre): shadow-utils
  13. Requires(post): chkconfig
  14. Requires(preun): chkconfig
  15. # Build bits
  16. %define buildtrunk 0
  17. %{?_with_buildtrunk: %define buildtrunk 1}
  18. %define enablerdma 0
  19. %{?_with_rdma: %define enablerdma 1}
  20. %if %{buildtrunk}
  21. BuildRequires: autoconf automake
  22. %endif
  23. BuildRequires: nss-devel
  24. %if %{enablerdma}
  25. BuildRequires: libibverbs-devel librdmacm-devel
  26. %endif
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. %prep
  29. %setup -q -n %{name}-%{version}
  30. %build
  31. %if %{buildtrunk}
  32. ./autogen.sh
  33. %endif
  34. %if %{enablerdma}
  35. export ibverbs_CFLAGS=-I/usr/include/infiniband \
  36. export ibverbs_LIBS=-libverbs \
  37. export rdmacm_CFLAGS=-I/usr/include/rdma \
  38. export rdmacm_LIBS=-lrdmacm \
  39. %endif
  40. %{configure} \
  41. --enable-nss \
  42. %if %{enablerdma}
  43. --enable-rdma \
  44. %endif
  45. --with-initddir=%{_initrddir}
  46. make %{_smp_mflags}
  47. %install
  48. rm -rf %{buildroot}
  49. make install DESTDIR=%{buildroot}
  50. ## tree fixup
  51. # drop static libs
  52. rm -f %{buildroot}%{_libdir}/*.a
  53. # drop docs and html docs for now
  54. rm -rf %{buildroot}%{_docdir}/*
  55. %clean
  56. rm -rf %{buildroot}
  57. %description
  58. This package contains the Corosync Cluster Engine Executive, several default
  59. APIs and libraries, default configuration files, and an init script.
  60. %post
  61. if [ $1 -eq 1 ]; then
  62. /sbin/chkconfig --add corosync || :
  63. fi
  64. %preun
  65. if [ $1 -eq 0 ]; then
  66. /sbin/service corosync stop &>/dev/null || :
  67. /sbin/chkconfig --del corosync || :
  68. fi
  69. %files
  70. %defattr(-,root,root,-)
  71. %doc LICENSE SECURITY
  72. %{_bindir}/corosync-blackbox
  73. %{_sbindir}/corosync
  74. %{_sbindir}/corosync-keygen
  75. %{_sbindir}/corosync-objctl
  76. %{_sbindir}/corosync-cfgtool
  77. %{_sbindir}/corosync-fplay
  78. %{_sbindir}/corosync-pload
  79. %{_sbindir}/corosync-cpgtool
  80. %{_sbindir}/corosync-quorumtool
  81. %{_sbindir}/corosync-notifyd
  82. %dir %{_sysconfdir}/corosync
  83. %dir %{_sysconfdir}/corosync/service.d
  84. %dir %{_sysconfdir}/corosync/uidgid.d
  85. %config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example
  86. %config(noreplace) %{_sysconfdir}/corosync/corosync.conf.example.udpu
  87. %{_initrddir}/corosync
  88. %{_initrddir}/corosync-notifyd
  89. %dir %{_libexecdir}/lcrso
  90. %{_libexecdir}/lcrso/coroparse.lcrso
  91. %{_libexecdir}/lcrso/objdb.lcrso
  92. %{_libexecdir}/lcrso/service_cfg.lcrso
  93. %{_libexecdir}/lcrso/service_cpg.lcrso
  94. %{_libexecdir}/lcrso/service_evs.lcrso
  95. %{_libexecdir}/lcrso/service_confdb.lcrso
  96. %{_libexecdir}/lcrso/service_pload.lcrso
  97. %{_libexecdir}/lcrso/quorum_votequorum.lcrso
  98. %{_libexecdir}/lcrso/quorum_testquorum.lcrso
  99. %{_libexecdir}/lcrso/vsf_quorum.lcrso
  100. %{_libexecdir}/lcrso/vsf_ykd.lcrso
  101. %dir %{_localstatedir}/lib/corosync
  102. %dir %{_localstatedir}/log/cluster
  103. %{_mandir}/man8/corosync_overview.8*
  104. %{_mandir}/man8/corosync.8*
  105. %{_mandir}/man8/corosync-blackbox.8*
  106. %{_mandir}/man8/corosync-objctl.8*
  107. %{_mandir}/man8/corosync-keygen.8*
  108. %{_mandir}/man8/corosync-cfgtool.8*
  109. %{_mandir}/man8/corosync-cpgtool.8*
  110. %{_mandir}/man8/corosync-fplay.8*
  111. %{_mandir}/man8/corosync-pload.8*
  112. %{_mandir}/man8/corosync-quorumtool.8*
  113. %{_mandir}/man8/corosync-notifyd.8*
  114. %{_mandir}/man5/corosync.conf.5*
  115. %package -n corosynclib
  116. Summary: The Corosync Cluster Engine Libraries
  117. Summary(ja): The Corosync Cluster Engine Libraries
  118. Group: System Environment/Libraries
  119. Requires: %{name} = %{version}-%{release}
  120. %description -n corosynclib
  121. This package contains corosync libraries.
  122. %files -n corosynclib
  123. %defattr(-,root,root,-)
  124. %doc LICENSE
  125. %{_libdir}/libcfg.so.*
  126. %{_libdir}/libcpg.so.*
  127. %{_libdir}/libconfdb.so.*
  128. %{_libdir}/libevs.so.*
  129. %{_libdir}/libtotem_pg.so.*
  130. %{_libdir}/liblogsys.so.*
  131. %{_libdir}/libcoroipcc.so.*
  132. %{_libdir}/libcoroipcs.so.*
  133. %{_libdir}/libquorum.so.*
  134. %{_libdir}/libvotequorum.so.*
  135. %{_libdir}/libpload.so.*
  136. %{_libdir}/libsam.so.*
  137. %post -n corosynclib -p /sbin/ldconfig
  138. %postun -n corosynclib -p /sbin/ldconfig
  139. %package -n corosynclib-devel
  140. Summary: The Corosync Cluster Engine Development Kit
  141. Summary(ja): The Corosync Cluster Engine Development Kit
  142. Group: Development/Libraries
  143. Requires: corosynclib = %{version}-%{release}
  144. Requires: pkgconfig
  145. Provides: corosync-devel = %{version}
  146. Obsoletes: corosync-devel < 0.92-7
  147. %description -n corosynclib-devel
  148. This package contains include files and man pages used to develop using
  149. The Corosync Cluster Engine APIs.
  150. %files -n corosynclib-devel
  151. %defattr(-,root,root,-)
  152. %doc LICENSE README.devmap
  153. %dir %{_includedir}/corosync/
  154. %{_includedir}/corosync/cs_config.h
  155. %{_includedir}/corosync/corodefs.h
  156. %{_includedir}/corosync/coroipc_types.h
  157. %{_includedir}/corosync/coroipcs.h
  158. %{_includedir}/corosync/coroipcc.h
  159. %{_includedir}/corosync/cfg.h
  160. %{_includedir}/corosync/confdb.h
  161. %{_includedir}/corosync/corotypes.h
  162. %{_includedir}/corosync/cpg.h
  163. %{_includedir}/corosync/evs.h
  164. %{_includedir}/corosync/hdb.h
  165. %{_includedir}/corosync/list.h
  166. %{_includedir}/corosync/mar_gen.h
  167. %{_includedir}/corosync/sam.h
  168. %{_includedir}/corosync/swab.h
  169. %{_includedir}/corosync/quorum.h
  170. %{_includedir}/corosync/votequorum.h
  171. %dir %{_includedir}/corosync/totem/
  172. %{_includedir}/corosync/totem/coropoll.h
  173. %{_includedir}/corosync/totem/totem.h
  174. %{_includedir}/corosync/totem/totemip.h
  175. %{_includedir}/corosync/totem/totempg.h
  176. %dir %{_includedir}/corosync/lcr/
  177. %{_includedir}/corosync/lcr/lcr_ckpt.h
  178. %{_includedir}/corosync/lcr/lcr_comp.h
  179. %{_includedir}/corosync/lcr/lcr_ifact.h
  180. %dir %{_includedir}/corosync/engine
  181. %{_includedir}/corosync/engine/config.h
  182. %{_includedir}/corosync/engine/coroapi.h
  183. %{_includedir}/corosync/engine/logsys.h
  184. %{_includedir}/corosync/engine/objdb.h
  185. %{_includedir}/corosync/engine/quorum.h
  186. %{_libdir}/libcfg.so
  187. %{_libdir}/libcpg.so
  188. %{_libdir}/libconfdb.so
  189. %{_libdir}/libevs.so
  190. %{_libdir}/libtotem_pg.so
  191. %{_libdir}/liblogsys.so
  192. %{_libdir}/libcoroipcc.so
  193. %{_libdir}/libcoroipcs.so
  194. %{_libdir}/libquorum.so
  195. %{_libdir}/libvotequorum.so
  196. %{_libdir}/libpload.so
  197. %{_libdir}/libsam.so
  198. %{_libdir}/pkgconfig/*.pc
  199. %{_mandir}/man3/cpg_*3*
  200. %{_mandir}/man3/evs_*3*
  201. %{_mandir}/man3/confdb_*3*
  202. %{_mandir}/man3/votequorum_*3*
  203. %{_mandir}/man3/sam_*3*
  204. %{_mandir}/man8/cpg_overview.8*
  205. %{_mandir}/man8/evs_overview.8*
  206. %{_mandir}/man8/confdb_overview.8*
  207. %{_mandir}/man8/logsys_overview.8*
  208. %{_mandir}/man8/votequorum_overview.8*
  209. %{_mandir}/man8/coroipc_overview.8*
  210. %{_mandir}/man8/sam_overview.8*
  211. %changelog
  212. * Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
  213. - new upstream release
  214. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-1
  215. - initial build for Vine Linux
  216. * Mon Jul 5 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.6-1
  217. - New upstream release
  218. - Resync spec file with upstream changes
  219. * Tue May 25 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.3-1
  220. - New upstream release
  221. - Rediff revision 2770 patch
  222. * Mon May 17 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.2-1
  223. - New upstream release
  224. - Add upstream trunk revision 2770 to add cpg_model_initialize api.
  225. - Fix URL and Source0 entries.
  226. - Add workaround to broken 1.2.2 Makefile with make -j.
  227. * Wed Mar 24 2010 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.1-1
  228. - New upstream release
  229. * Tue Dec 8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.2.0-1
  230. - New upstream release
  231. - Use global instead of define
  232. - Update Source0 url
  233. - Use more %name macro around
  234. - Cleanup install section. Init script is now installed by upstream
  235. - Cleanup whitespace
  236. - Don't deadlock between package upgrade and corosync condrestart
  237. - Ship service.d config directory
  238. - Fix Conflicts vs Requires
  239. - Ship new sam library and man pages
  240. * Fri Oct 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.2-1
  241. - New upstream release fixes major regression on specific loads
  242. * Wed Oct 21 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.1-1
  243. - New upstream release
  244. * Fri Sep 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.1.0-1
  245. - New upstream release
  246. - spec file updates:
  247. * enable IB support
  248. * explicitly define built-in features at configure time
  249. * Tue Sep 22 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.1-1
  250. - New upstream release
  251. - spec file updates:
  252. * use proper configure macro
  253. * Tue Jul 28 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-3
  254. - spec file updates:
  255. * more consistent use of macros across the board
  256. * fix directory ownership
  257. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  258. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  259. * Wed Jul 8 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.0-1
  260. - New upstream release
  261. * Thu Jul 2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.100-1
  262. - New upstream release
  263. * Sat Jun 20 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.98-1
  264. - New upstream release
  265. - spec file updates:
  266. * Drop corosync-trunk patch and alpha tag.
  267. * Fix alphatag vs buildtrunk handling.
  268. * Drop requirement on ais user/group and stop creating them.
  269. * New config file locations from upstream: /etc/corosync/corosync.conf.
  270. * Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2233
  271. - spec file updates:
  272. * Update to svn version 2233 to include library linking fixes
  273. * Wed Jun 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.97-1.svn2232
  274. - New upstream release
  275. - spec file updates:
  276. * Drop pkgconfig fix that's now upstream
  277. * Update to svn version 2232
  278. * Define buildtrunk if we are using svn snapshots
  279. * BuildRequires: nss-devel to enable nss crypto for network communication
  280. * Force autogen invokation if buildtrunk is defined
  281. * Whitespace cleanup
  282. * Stop shipping corosync.conf in favour of a generic example
  283. * Update file list
  284. * Mon Mar 30 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-2
  285. - Backport svn commit 1913 to fix pkgconfig files generation
  286. and unbreak lvm2 build.
  287. * Tue Mar 24 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.95-1
  288. - New upstream release
  289. - spec file updates:
  290. * Drop alpha tag
  291. * Drop local patches (no longer required)
  292. * Allow to build from svn trunk by supporting rpmbuild --with buildtrunk
  293. * BuildRequires autoconf automake if building from trunk
  294. * Execute autogen.sh if building from trunk and if no configure is available
  295. * Switch to use rpm configure macro and set standard install paths
  296. * Build invokation now supports _smp_mflags
  297. * Remove install section for docs and use proper doc macro instead
  298. * Add tree fixup bits to drop static libs and html docs (only for now)
  299. * Add LICENSE file to all subpackages
  300. * libraries have moved to libdir. Drop ld.so.conf.d corosync file
  301. * Update BuildRoot usage to preferred versions/names
  302. * Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-5.svn1797
  303. - Update the corosync-trunk patch for real this time.
  304. * Tue Mar 10 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-4.svn1797
  305. - Import fixes from upstream:
  306. * Cleanup logsys format init around to use default settings (1795)
  307. * logsys_format_set should use its own internal copy of format_buffer (1796)
  308. * Add logsys_format_get to logsys API (1797)
  309. - Cherry pick svn1807 to unbreak CPG.
  310. * Mon Mar 9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-3.svn1794
  311. - Import fixes from upstream:
  312. * Add reserve/release feature to totem message queue space (1793)
  313. * Fix CG shutdown (1794)
  314. * Fri Mar 6 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-2.svn1792
  315. - Import fixes from upstream:
  316. * Fix uninitialized memory. Spotted by valgrind (1788)
  317. * Fix logsys_set_format by updating the right bits (1789)
  318. * logsys: re-add support for timestamp (1790)
  319. * Fix cpg crash (1791)
  320. * Allow logsys_format_set to reset to default (1792)
  321. * Tue Mar 3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.94-1
  322. - New upstream release.
  323. - Drop obsolete patches.
  324. - Add soname bump patch that was missing from upstream.
  325. * Wed Feb 25 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-4
  326. - Add Makefile fix to install all corosync tools (commit r1780)
  327. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
  328. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  329. * Mon Feb 23 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-2
  330. - Rename gcc-4.4 patch to match svn commit (r1767).
  331. - Backport patch from trunk (commit r1774) to fix quorum engine.
  332. * Thu Feb 19 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.93-1
  333. - New upstream release.
  334. - Drop alphatag from spec file.
  335. - Drop trunk patch.
  336. - Update Provides for corosynclib-devel.
  337. - Backport gcc-4.4 build fix from trunk.
  338. * Mon Feb 2 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-7.svn1756
  339. - Update to svn trunk at revision 1756 from upstream.
  340. - Add support pkgconfig to devel package.
  341. - Tidy up spec files by re-organazing sections according to packages.
  342. - Split libraries from corosync to corosynclib.
  343. - Rename corosync-devel to corosynclib-devel.
  344. - Comply with multiarch requirements (libraries).
  345. * Tue Jan 27 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-6.svn1750
  346. - Update to svn trunk at revision 1750 from upstream.
  347. - Include new quorum service in the packaging.
  348. * Mon Dec 15 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-5.svn1709
  349. - Update to svn trunk at revision 1709 from upstream.
  350. - Update spec file to include new include files.
  351. * Wed Dec 10 2008 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.92-4.svn1707
  352. - Update to svn trunk at revision 1707 from upstream.
  353. - Update spec file to include new lcrso services and include file.
  354. * Mon Oct 13 2008 Dennis Gilmore <dennis@ausil.us> - 0.92-3
  355. - remove ExclusiveArch line
  356. * Fri Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-2
  357. - Add conflicts for openais and openais-devel packages older then 0.90.
  358. * Wed Sep 24 2008 Steven Dake <sdake@redhat.com> - 0.92-1
  359. - New upstream release corosync-0.92.
  360. * Sun Aug 24 2008 Steven Dake <sdake@redhat.com> - 0.91-3
  361. - move logsys_overview.8.* to devel package.
  362. - move shared libs to main package.
  363. * Wed Aug 20 2008 Steven Dake <sdake@redhat.com> - 0.91-2
  364. - use /sbin/service instead of calling init script directly.
  365. - put corosync-objctl man page in the main package.
  366. - change all initrddir to initddir for fedora 10 guidelines.
  367. * Thu Aug 14 2008 Steven Dake <sdake@redhat.com> - 0.91-1
  368. - First upstream packaged version of corosync for rawhide review.