ccid-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166
  1. %define dropdir %(pkg-config libpcsclite --variable usbdropdir 2>/dev/null)
  2. %define libusb1_ver 1.0.9
  3. %define pcsc_lite_ver 1.8.3
  4. Name: ccid
  5. Version: 1.4.7
  6. Release: 1%{?_dist_release}
  7. Summary: Generic USB CCID smart card reader driver
  8. Summary(ja): Generic USB CCID smart card reader driver
  9. Group: System Environment/Libraries
  10. License: LGPLv2+
  11. URL: http://pcsclite.alioth.debian.org/ccid.html
  12. Source0: http://alioth.debian.org/download.php/1563/%{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: libusb1-devel >= %{libusb1_ver}
  15. BuildRequires: pcsc-lite-devel >= %{pcsc_lite_ver}
  16. Requires(post): initscripts
  17. Requires(postun): initscripts
  18. Requires: libusb1
  19. Requires: pcsc-lite
  20. Provides: pcsc-ifd-handler
  21. # 390 does not have libusb or smartCards
  22. ExcludeArch: s390 s390x
  23. %description
  24. Generic USB CCID (Chip/Smart Card Interface Devices) driver.
  25. %prep
  26. %setup -q
  27. for f in ChangeLog README ; do
  28. iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
  29. done
  30. %build
  31. %configure --disable-dependency-tracking --disable-static --enable-twinserial
  32. make %{?_smp_mflags}
  33. %install
  34. rm -rf $RPM_BUILD_ROOT
  35. make install DESTDIR=$RPM_BUILD_ROOT
  36. %{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d
  37. %{__install} -m 644 src/92_pcscd_ccid.rules $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d/92-pcscd_ccid.rules
  38. %clean
  39. rm -rf $RPM_BUILD_ROOT
  40. %post
  41. [ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H > /dev/null 2>&1
  42. exit 0
  43. %postun
  44. [ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H > /dev/null 2>&1
  45. exit 0
  46. %files
  47. %defattr(-,root,root,-)
  48. %doc AUTHORS ChangeLog COPYING NEWS README SCARDGETATTRIB.txt
  49. %{dropdir}/ifd-ccid.bundle/
  50. %{dropdir}/serial/
  51. %config(noreplace) %{_sysconfdir}/reader.conf.d/libccidtwin
  52. %config %{_sysconfdir}/udev/rules.d/92-pcscd_ccid.rules
  53. %changelog
  54. * Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
  55. - new upstream release
  56. - change BuildRequires: libusb1-devel instead of libusb-devel
  57. * Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.8-1
  58. - initial build for Vine Linux
  59. * Tue Aug 26 2008 Bob Relyea <rrelyea@redhat.com> - 1.3.8-1
  60. - update to ccid 1.3.8
  61. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.1-4
  62. - Autorebuild for GCC 4.3
  63. * Fri Aug 20 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-3
  64. - Update License description to the new Fedora standard
  65. * Mon Apr 30 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-2
  66. - Fix the missed use of the version macro
  67. * Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-1
  68. - Pick up ccid 1.2.1
  69. - use pcscd 'hotplug' feature instead of restarting the daemon
  70. - add enable_udev
  71. * Mon Nov 06 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-2
  72. - Fix version macro to remove '-'
  73. * Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-1
  74. - Pickup ccid 1.1.0
  75. * Sun Jul 20 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-5
  76. - require initscripts for post/postun
  77. * Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-4
  78. - fix excludearch line
  79. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
  80. - rebuild
  81. * Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-3
  82. - remove s390 from the build
  83. * Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-2
  84. - Move to Fedora Core, removed %%{_dist}.
  85. * Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.1-1
  86. - 1.0.1.
  87. * Mon Mar 6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.0-1
  88. - 1.0.0, license changed to LGPL.
  89. * Wed Feb 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-7
  90. - Rebuild.
  91. * Thu Nov 3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-6
  92. - Clean up build dependencies.
  93. - Convert docs to UTF-8.
  94. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.4.1-5
  95. - rebuilt
  96. * Fri Feb 25 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-4
  97. - Drop Epoch: 0.
  98. - Improve summary.
  99. - Build with dependency tracking disabled.
  100. * Thu Jul 1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.3
  101. - Restart pcscd in post(un)install phase if it's available and running.
  102. * Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.2
  103. - Provide pcsc-ifd-handler (idea from Debian).
  104. * Sat Feb 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.1
  105. - Update to 0.4.1.
  106. * Fri Feb 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.0-0.fdr.1
  107. - Update to 0.4.0.
  108. * Wed Nov 5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.2-0.fdr.1
  109. - Update to 0.3.2.
  110. - Update URL.
  111. * Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.1-0.fdr.1
  112. - Update to 0.3.1.
  113. * Wed Sep 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.0-0.fdr.1
  114. - Update to 0.3.0.
  115. * Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.2.0-0.fdr.1
  116. - Update to 0.2.0.
  117. * Tue Aug 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.1.0-0.fdr.1
  118. - First build.