flac-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264
  1. # set 1 if you want to build input plugin for xmms
  2. %define build_xmms_plugin 0
  3. %define xmmsinputdir %{_libdir}/xmms/Input
  4. #%%define extraver beta
  5. Summary: FLAC - Free Lossless Audio Codec
  6. Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
  7. Name: flac
  8. Version: 1.2.1
  9. Release: 1%{?_dist_release}
  10. License: GPL/LGPL
  11. Group: Applications/Multimedia
  12. Source: http://prdownloads.sourceforge.net/flac/%{name}-%{version}%{?extraver:-%extraver}.tar.gz
  13. Patch0: flac-xmms-euc-jp-ms.patch
  14. URL: http://flac.sourceforge.net/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. Requires: libogg
  17. BuildRequires: libogg-devel
  18. %ifarch %ix86
  19. BuildRequires: nasm
  20. %endif
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
  25. similar to MP3, but lossless.
  26. The FLAC project consists of:
  27. * the stream format
  28. * libFLAC - reference encoders and decoders in library form
  29. * flac - a command-line program to encode and decode FLAC files
  30. * metaflac - a command-line metadata editor for FLAC files
  31. # * input plugins for various music players (the xmms plugin is in a xmms-
  32. # flac package)
  33. %description -l ja
  34. FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
  35. MP3 に似ていますが、音質が劣化しません。
  36. FLAC プロジェクトは以下により構成されています。
  37. * ストリーム形式
  38. * libFLAC - リファレンスエンコーダ/デコーダを実装するライブラリ
  39. * flac - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
  40. プログラム。
  41. * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
  42. # * 各種音楽再生プログラム用入力プラグイン (XMMS プラグインは xmms-flac パッ
  43. # ケージに含まれます)
  44. %package devel
  45. Summary: Development libraries and header files from FLAC
  46. Summary(ja): FLAC アプリケーション開発用ライブラリ及びヘッダファイル
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}
  49. Requires: pkgconfig
  50. %description devel
  51. This package contains all the files needed to develop applications that
  52. will use the Free Lossless Audio Codec (FLAC).
  53. %description -l ja devel
  54. このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
  55. 開発するために必要なライブラリ及びヘッダファイルが含まれています。
  56. %if %{build_xmms_plugin}
  57. %package -n xmms-flac
  58. Summary: X MultiMedia System plugin to play FLAC files
  59. Summary(ja): FLAC ファイルを再生するための XMMS プラグイン
  60. Group: Applications/Multimedia
  61. Requires: xmms, %{name} = %{version}
  62. BuildRequires: xmms-devel >= 0.9.5.1, gtk+-devel
  63. %description -n xmms-flac
  64. An input plugin that enables playback of FLAC files in xmms.
  65. %description -l ja -n xmms-flac
  66. XMMS で FLAC ファイル (*.flac) を再生するための入力プラグインです。
  67. %endif
  68. %prep
  69. %define srcver %{version}%{?extraver:-%extraver}
  70. %setup -q -n %{name}-%{srcver}
  71. %if %{build_xmms_plugin}
  72. %patch0 -p1 -b .euc-jp-ms
  73. %endif
  74. %build
  75. %ifarch ppc
  76. %configure --disable-static --disable-asm-optimizations
  77. %else
  78. %configure --disable-static
  79. %endif
  80. %__make %{?_smp_mflags}
  81. %install
  82. %__rm -rf %{buildroot}
  83. %makeinstall \
  84. xmmsinputplugindir=%{buildroot}%{xmmsinputdir}
  85. # remove unneeded files
  86. %{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
  87. %clean
  88. %__rm -rf %{buildroot}
  89. %post -p %{_syssbindir}/ldconfig
  90. %postun -p %{_syssbindir}/ldconfig
  91. %files
  92. %defattr(-,root,root)
  93. %doc AUTHORS COPYING.* README
  94. %{_bindir}/*
  95. %{_libdir}/*.so.*
  96. %{_mandir}/*/*
  97. %files devel
  98. %defattr(-,root,root)
  99. %doc doc/html COPYING.*
  100. %{_includedir}/*
  101. %{_libdir}/*.so
  102. %{_libdir}/pkgconfig/*.pc
  103. %{_datadir}/aclocal/*.m4
  104. %if %{build_xmms_plugin}
  105. %files -n xmms-flac
  106. %defattr(-,root,root)
  107. %{xmmsinputdir}/*.so
  108. %endif
  109. %changelog
  110. * Sun Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  111. - applied new versioning policy
  112. - spec in UTF-8
  113. * Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
  114. - new upstream release
  115. - drop bmp-plugin.patch (patch1)
  116. - disable xmms plugin
  117. * Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  118. - new upsteram release
  119. - dropped Patch2 (merged into upstream)
  120. - do not build beepmp plugin
  121. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
  122. - rebuilt with new toolchain
  123. * Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
  124. - add '--disable-static' option to %%configure
  125. - remove *.la
  126. * Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
  127. - rebuild
  128. * Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
  129. - --disable-asm-optimizations on ppc
  130. * Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
  131. - rebuild
  132. * Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
  133. - initialize flac_cfg.stream with NULL to avoid crashing (patch2)
  134. * Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
  135. - upstream release
  136. - update bmp-plugin.patch
  137. * Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
  138. - upstream release
  139. - update bmp-plugin.patch
  140. * Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
  141. - fix typo
  142. * Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
  143. - move html docs to devel package
  144. * Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
  145. - add input plugin for beepmp based on for xmms (patch1)
  146. - BuildRequires: beepmp-devel >= 0.9.7
  147. - define build_*_plugin macros to build input plugin sub-packages
  148. - update description
  149. * Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
  150. - drop BuildRequires: zlib-devel (was required to build with id3lib)
  151. * Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
  152. - upstream release
  153. - drop (Build)Requires: id3lib(-devel)
  154. * Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
  155. - 1.1.1-beta1
  156. - add BuildRequires: gtk+-devel, zlib-devel
  157. * Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
  158. - xmms-flac
  159. - enable to convert charset from/to EUC-JP-MS (Patch0)
  160. - Requires: glibc >= 2.3.3
  161. * Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
  162. - fix docs
  163. * Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
  164. - first build for Vine Linux
  165. * Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  166. - Rebuilt for Red Hat Linux 9.
  167. - Exclude .la files.
  168. - Updated description.
  169. * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  170. - Fix nasm dep to be only for ix86.
  171. * Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  172. - Update to 1.1.0.
  173. * Sun Jan 5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  174. - Rebuilt against the latest id3lib for the xmms plugin.
  175. * Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  176. - Fixed location of include files, doh!
  177. * Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  178. - Rebuilt for Red Hat Linux 8.0.
  179. * Thu Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  180. - Update to 1.0.4.
  181. - Removed obsolete build patch, the xmms plugin builds cleanly at last!
  182. * Thu Jul 4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  183. - Update to 1.0.3.
  184. * Tue Apr 23 2002 Daniel Resare <noa@resare.com>
  185. - Fixed plugin build when flac is not already installed
  186. * Mon Apr 8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  187. - Replaced the hard-coded xmms input path with an expansion.
  188. - Fixed spec (License tag and redundant Group for devel package).
  189. - Fixed defattr for the xmms plugin.
  190. * Sat Apr 6 2002 Daniel Resare <noa@resare.com>
  191. - Update to 1.0.2.
  192. - Splitted out xmms plugin to a separate subpackage.
  193. * Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  194. - Update to 1.0.1.
  195. * Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  196. - Rebuilt for Red Hat 7.2 and added xmms dependency.
  197. * Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  198. - Initial RPM release.
  199. - You cannot rebuild this SRPM easily if you want the xmms plugin.