epiphany-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345
  1. # gecko backend was removed 2.27.0
  2. %define with_gecko 0
  3. %define with_webkit 1
  4. %define gecko_version 1.9.1
  5. %define webkit_version 1.1.15
  6. ExclusiveArch: i386 ppc x86_64 alpha
  7. Summary: GNOME web browser based on Gecko/WebKit
  8. Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
  9. Name: epiphany
  10. Version: 2.28.2
  11. Release: 1%{?_dist_release}
  12. License: GPL
  13. Group: Applications/Internet
  14. URL: http://www.gnome.org/projects/epiphany/
  15. Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/2.28/%{name}-%{version}.tar.bz2
  16. Patch1: epiphany-2.26.2-gecko191.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: gnome-icon-theme >= 2.24.0
  19. %if %{with_gecko}
  20. Requires: gecko-libs
  21. %endif
  22. Requires(post,pre,preun): GConf2
  23. Requires(post,postun): scrollkeeper, shared-mime-info
  24. %if %{with_gecko}
  25. BuildRequires: gecko-devel-unstable >= %{gecko_version}
  26. %endif
  27. %if %{with_webkit}
  28. BuildRequires: WebKit-gtk-devel >= %{webkit_version}
  29. %endif
  30. BuildRequires: glib2-devel >= 2.20.0
  31. BuildRequires: gtk2-devel >= 2.16.0
  32. BuildRequires: libxml2-devel >= 2.6.12
  33. BuildRequires: libxslt-devel >= 1.1.7
  34. BuildRequires: libnotify-devel >= 0.4.0
  35. BuildRequires: dbus-glib-devel >= 0.35
  36. BuildRequires: libsoup-devel >= 2.28.0
  37. BuildRequires: gnome-desktop-devel >= 2.26.0
  38. BuildRequires: GConf2-devel
  39. BuildRequires: nss-devel
  40. BuildRequires: avahi-gobject-devel >= 0.6.22
  41. BuildRequires: NetworkManager-devel
  42. BuildRequires: iso-codes
  43. BuildRequires: intltool >= 0.40
  44. BuildRequires: libICE-devel
  45. BuildRequires: libSM-devel
  46. BuildRequires: gnome-keyring-devel
  47. %description
  48. epiphany is a simple GNOME web browser based on the Mozilla rendering
  49. engine
  50. %description -l ja
  51. epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
  52. ウェブブラウザです。
  53. %prep
  54. %setup -q
  55. #patch1 -p1
  56. %build
  57. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
  58. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  59. %configure \
  60. %if %{with_gecko}
  61. --with-engine=mozilla \
  62. --with-gecko=libxul-embedding \
  63. %endif
  64. %if %{with_webkit}
  65. --with-engine=webkit \
  66. %endif
  67. --enable-zeroconf \
  68. --enable-network-manager \
  69. --disable-scrollkeeper
  70. %__make %{?_smp_mflags}
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  74. make install DESTDIR=$RPM_BUILD_ROOT
  75. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  76. %find_lang %{name} --with-gnome
  77. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
  79. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  80. %pre
  81. if [ "$1" -gt 1 ]; then
  82. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  83. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  84. for S in $SCHEMAS; do
  85. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  86. done
  87. fi
  88. %post
  89. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  90. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  91. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  92. for S in $SCHEMAS; do
  93. gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
  94. done
  95. %preun
  96. if [ "$1" -eq 0 ]; then
  97. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  98. SCHEMAS="epiphany.schemas epiphany-lockdown.schemas"
  99. for S in $SCHEMAS; do
  100. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$S > /dev/null
  101. done
  102. fi
  103. %postun
  104. if [ $1 -eq 0 ] ; then
  105. touch --no-create %{_datadir}/icons/hicolor >& /dev/null ||:
  106. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  107. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  108. scrollkeeper-update >& /dev/null ||:
  109. fi
  110. %posttrans
  111. gtk-update-icon-cache -q %{_datadir}/icons/hicolor >& /dev/null ||:
  112. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  113. scrollkeeper-update >& /dev/null ||:
  114. %clean
  115. rm -rf $RPM_BUILD_ROOT
  116. %files -f %{name}.lang
  117. %defattr(-,root,root,-)
  118. %doc AUTHORS ChangeLog* COPYING* NEWS README
  119. %{_sysconfdir}/gconf/schemas/epiphany*.schemas
  120. %{_bindir}/epiphany
  121. %{_includedir}/epiphany/*
  122. %{_libdir}/pkgconfig/epiphany*.pc
  123. %if %{with_gecko}
  124. %{_libdir}/epiphany
  125. %endif
  126. #{_datadir}/pygtk/*/defs/*
  127. %{_datadir}/applications/*.desktop
  128. %{_datadir}/epiphany
  129. %{_datadir}/gtk-doc/html/*
  130. %{_datadir}/icons/*
  131. %{_datadir}/aclocal/*
  132. %{_datadir}/dbus-1/services/*
  133. %{_mandir}/man1/epiphany.1*
  134. %changelog
  135. * Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  136. - new upstream release
  137. - added BR: libICE-devel, libSM-devel and gnome-keyring-devel
  138. * Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  139. - new upstream release
  140. * Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  141. - run gtk-update-icon-cache in %%post/postun script.
  142. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  143. - new upstream release
  144. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  145. - rebuild with gecko-1.9.1
  146. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  147. - new upstream release
  148. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  149. - new upstream release
  150. - build with xulrunner-1.9.0.7
  151. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  152. - new upstream release
  153. * Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
  154. - build with gecko-1.9.0.3 instead of WebKit.
  155. - WebKit port is unstable yet.
  156. - enable zeroconf, NetworkManager support
  157. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
  158. - new upstream release
  159. * Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
  160. - build with WebKit instead of gecko.
  161. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
  162. - new upstream release
  163. - added %%pre and %%preun section
  164. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  165. - new upstream release
  166. - rebuilt with firefox-2.0.0.6-0vl3
  167. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
  168. - add BuildRequires: gnome-python
  169. * Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  170. - new upstream release
  171. - rebuilt with new toolchain and firefox-2.0.0.4-0vl6
  172. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  173. - new upstream release
  174. * Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
  175. - source update
  176. - add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
  177. - add BuildRequires: pygtk2-devel
  178. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
  179. - new upstream release
  180. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  181. - rebuild with firefox-1.5.0.2-0vl4
  182. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  183. - new upstream release
  184. - build with firefox-1.5.0.2
  185. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  186. - new upstream release
  187. * Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
  188. - new upstream release
  189. - build with firefox-1.5.0.1
  190. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  191. - new upstream release
  192. - build with mozilla-1.7.12
  193. * Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
  194. - rebuild with mozilla-1.7.8
  195. * Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
  196. - new upstream release
  197. * Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
  198. - new upstream release
  199. - build with mozilla-1.7.7
  200. * Fri Apr 1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
  201. - rebuild with mozilla-1.7.6
  202. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  203. - new upstream release
  204. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
  205. - new upstream release
  206. - build with mozilla-1.7.5
  207. * Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  208. - new upstream release
  209. * Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
  210. - new upstream release
  211. * Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
  212. - rebuild with mozilla-1.7.3
  213. * Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
  214. - new upstream release
  215. - build with mozilla-1.7.2
  216. - add Patch10 to build with gnome-2.4
  217. * Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
  218. - new upstream version
  219. -- dropped patch10
  220. - changed URL
  221. * Fri Jan 9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
  222. - add alpha into ExclusiveArch
  223. * Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
  224. - rebuild with mozilla-1.5.1
  225. * Sat Dec 6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
  226. - new upstream release
  227. * Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
  228. - new upstream release
  229. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
  230. - fixed missing locale files
  231. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  232. - new upstream release
  233. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
  234. - new upstream release
  235. * Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
  236. - new upstream release
  237. * Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
  238. - new upstream release
  239. - build with mozilla 1.4
  240. * Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
  241. - new upstream release
  242. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
  243. - build for Vine Linux
  244. * Mon Jun 2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
  245. - Rebuild to fix broken mozilla dep, patch for mozilla 1.4
  246. * Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
  247. - 0.6.1
  248. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
  249. - add patch to fix gint/gpointer conversion bugs for 64bit arches
  250. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
  251. - only build on arches mozilla is built on
  252. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
  253. - rebuild against new mozilla, make mozilla requires dynamic
  254. * Sun May 4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
  255. - update to 0.6.0
  256. - fix tyop in %%postun
  257. * Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
  258. - make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
  259. * Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
  260. - add some buildrequires, prereq GConf2
  261. - disable building nautilus view
  262. * Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
  263. - Initial build.