bash-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591
  1. %define bashversion 5.0
  2. %define patchlevel 11
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Shells
  9. License: GPLv3+
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. Source0: http://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-001
  17. Patch2: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-002
  18. Patch3: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-003
  19. Patch4: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-004
  20. Patch5: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-005
  21. Patch6: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-006
  22. Patch7: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-007
  23. Patch8: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-008
  24. Patch9: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-009
  25. Patch10: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-010
  26. Patch11: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-011
  27. # Other patches
  28. #Patch101: bash-2.02-security.patch
  29. Patch102: bash-2.03-paths.patch
  30. Patch103: bash-2.03-profile.patch
  31. Patch104: bash-2.05a-interpreter.patch
  32. Patch105: bash-2.05b-debuginfo.patch
  33. #Patch106: bash-2.05b-manso.patch
  34. Patch107: bash-2.05b-pgrp_sync.patch
  35. #Patch108: bash-2.05b-readline-oom.patch
  36. #Patch109: bash-2.05b-xcc.patch
  37. Patch110: bash-3.2-audit.patch
  38. Patch111: bash-3.2-ssh_source_bash.patch
  39. #Patch112: bash-bashbug.patch
  40. Patch113: bash-infotags.patch
  41. Patch114: bash-requires.patch
  42. Patch115: bash-setlocale.patch
  43. Patch116: bash-tty-tests.patch
  44. # 484809, check if interp section is NOBITS
  45. Patch117: bash-4.0-nobits.patch
  46. # Do the same CFLAGS in generated Makefile in examples
  47. Patch118: bash-4.1-examples.patch
  48. # Builtins like echo and printf won't report errors
  49. # when output does not succeed due to EPIPE
  50. Patch119: bash-4.1-broken_pipe.patch
  51. # Enable system-wide .bash_logout for login shells
  52. Patch120: bash-4.2-rc2-logout.patch
  53. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  54. Patch121: bash-4.2-coverity.patch
  55. # Don't call malloc in signal handler
  56. #Patch122: bash-4.1-defer-sigchld-trap.patch
  57. # 799958, updated info about trap
  58. Patch123: bash-4.2-manpage_trap.patch
  59. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  60. Patch125: bash-4.2-size_type.patch
  61. # 1112710 - mention ulimit -c and -f POSIX block size
  62. Patch128: bash-4.3-man-ulimit.patch
  63. # A series of patches emitted by upstream since 4.3-18
  64. #Patch134: bash-4.3-pathexp-globignore-delim.patch
  65. # 1102815 - fix double echoes in vi visual mode
  66. Patch135: bash-4.3-noecho.patch
  67. # 1182278 - bash crashes on `select' if REPLY is readonly
  68. #Patch137: bash-4.3-select-readonly.patch
  69. #1241533,1224855 - bash leaks memory when LC_ALL set
  70. Patch138: bash-4.3-memleak-lc_all.patch
  71. #1245233 - old memleak reappeared, taken from upstream
  72. #Patch139: bash-4.3-old-memleak.patch
  73. # bash-4.4 builds loadable builtin examples by default
  74. # this patch disables it
  75. Patch140: bash-4.4-no-loadable-builtins.patch
  76. Buildroot: %{_tmppath}/%{name}-%{version}-root
  77. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  78. Obsoletes: bash <= 1.14.7
  79. Obsoletes: bash2
  80. %description
  81. Bash is a GNU project sh-compatible shell or command language
  82. interpreter. Bash (Bourne Again shell) incorporates useful features
  83. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  84. can be run by bash without modification.
  85. Bash offers several improvements over sh, including command line
  86. editing, unlimited size command history, job control, shell
  87. functions and aliases, indexed arrays of unlimited size and
  88. integer arithmetic in any base from two to 64. Bash is ultimately
  89. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  90. Tools standard.
  91. %package doc
  92. Summary: Documentation for the GNU Bourne Again shell (bash).
  93. Summary(ja): GNU Bourne Again シェル向けドキュメント
  94. Group: Applications/Documentation
  95. Requires: %{name} = %{version}-%{release}
  96. Obsoletes: bash2-doc
  97. %description doc
  98. This is a separate documentation package for the GNU Bourne
  99. Again shell.
  100. %prep
  101. %setup -q -n %{name}-%{bashversion}
  102. # Official upstream patches
  103. %patch1 -p0 -b .001
  104. %patch2 -p0 -b .002
  105. %patch3 -p0 -b .003
  106. %patch4 -p0 -b .004
  107. %patch5 -p0 -b .005
  108. %patch6 -p0 -b .006
  109. %patch7 -p0 -b .007
  110. %patch8 -p0 -b .008
  111. %patch9 -p0 -b .009
  112. %patch10 -p0 -b .010
  113. %patch11 -p0 -b .011
  114. # Other patches
  115. %patch102 -p1 -b .paths
  116. %patch103 -p1 -b .profile
  117. %patch104 -p1 -b .interpreter
  118. %patch105 -p1 -b .debuginfo
  119. %patch107 -p1 -b .pgrp_sync
  120. %patch110 -p1 -b .audit
  121. %patch111 -p1 -b .ssh_source_bash
  122. %patch113 -p1 -b .infotags
  123. %patch114 -p1 -b .requires
  124. %patch115 -p1 -b .setlocale
  125. %patch116 -p1 -b .tty_tests
  126. %patch117 -p1 -b .nobits
  127. %patch118 -p1 -b .examples
  128. %patch119 -p1 -b .broken_pipe
  129. %patch120 -p1 -b .logout
  130. %patch121 -p1 -b .coverity
  131. %patch123 -p1
  132. %patch125 -p1 -b .size_type
  133. %patch128 -p1 -b .ulimit
  134. %patch135 -p1 -b .noecho
  135. %patch138 -p1 -b .lc_all
  136. %patch140 -p1 -b .no_loadable_builtin
  137. echo %{version} > _distribution
  138. echo %{release} |sed 's/vl.*//' > _patchlevel
  139. %build
  140. %configure --with-bash-malloc=no
  141. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  142. %install
  143. rm -rf %{buildroot}
  144. # Fix bug #83776
  145. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  146. make DESTDIR=$RPM_BUILD_ROOT install
  147. pushd $RPM_BUILD_ROOT
  148. mkdir ./bin
  149. mv ./usr/bin/bash ./bin/bash
  150. ln -s bash ./bin/sh
  151. rm -f .%{_infodir}/dir
  152. popd
  153. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  154. # make manpages for bash builtins as per suggestion in DOC/README
  155. pushd doc
  156. sed -e '
  157. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  158. /^\.SH NAME/d
  159. s/^bash, //
  160. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  161. s/,//g
  162. b
  163. }
  164. d
  165. ' builtins.1 > man.pages
  166. for i in echo pwd test kill; do
  167. perl -pi -e "s,$i,,g" man.pages
  168. perl -pi -e "s, , ,g" man.pages
  169. done
  170. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  171. for i in `cat man.pages` ; do
  172. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  173. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  174. done
  175. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  176. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  177. # Not for printf, false and true (conflict with coreutils)
  178. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  179. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  180. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  181. popd
  182. %find_lang %{name}
  183. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  184. %clean
  185. rm -rf %{buildroot}
  186. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  187. # to prevent prereq loops
  188. # post is in lua so that we can run it without any external deps. Helps
  189. # for bootstrapping a new install.
  190. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  191. %post -p <lua>
  192. bashfound = false;
  193. shfound = false;
  194. f = io.open("/etc/shells", "r");
  195. if f == nil
  196. then
  197. f = io.open("/etc/shells", "w");
  198. else
  199. repeat
  200. t = f:read();
  201. if t == "/bin/bash"
  202. then
  203. bashfound = true;
  204. end
  205. if t == "/bin/sh"
  206. then
  207. shfound = true;
  208. end
  209. until t == nil;
  210. end
  211. f:close()
  212. f = io.open("/etc/shells", "a");
  213. if not bashfound
  214. then
  215. f:write("/bin/bash\n")
  216. end
  217. if not shfound
  218. then
  219. f:write("/bin/sh\n")
  220. end
  221. f:close()
  222. %files -f %{name}.lang
  223. %defattr(-,root,root)
  224. %license COPYING
  225. %doc CHANGES
  226. %doc examples
  227. %config(noreplace) /etc/bashrc
  228. /bin/bash
  229. /bin/sh
  230. %{_infodir}/bash.info*
  231. %{_mandir}/*/*
  232. %{_mandir}/*/..1*
  233. %{_bindir}/bashbug
  234. %files doc
  235. %defattr(-,root,root)
  236. %doc COMPAT NEWS NOTES POSIX RBASH
  237. %doc examples/functions/ examples/misc/
  238. %doc examples/scripts*/
  239. %doc examples/startup-files/ examples/complete/ examples/loadables/
  240. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  241. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  242. %changelog
  243. * Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
  244. - updated to 5.0 patch level 11.
  245. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  246. - updated to 5.0 patch level 9.
  247. - dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
  248. - imported Patch140 from rawhide.
  249. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
  250. - updated to 4.3 patch level 46.
  251. * Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
  252. - updated to 4.3 patch level 42.
  253. - imported patch 128-139 from RawHide.
  254. * Fri Oct 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
  255. - updated to 4.3 patch level 29.
  256. - removed patch1000 (included in 4.3.26).
  257. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
  258. - added patch1000 to fix CVE-2014-7169.
  259. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
  260. - updated to 4.3 patch level 25.
  261. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  262. - update to 4.3 patch level 18
  263. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  264. - update to 4.3 patch level 11
  265. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  266. - update to 4.2 patch level 45
  267. - import some patch from fedora package (122-127)
  268. - patch122: Don't call malloc in signal handler
  269. - patch123: #799958, updated info about trap
  270. - patch124: #695656, block the signal and unblock it after the
  271. new handler is installed
  272. - patch125: Use unsigned type for size
  273. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  274. - patch126: #903833, Fix missing close(), fixes fd leaks
  275. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  276. - remove postun lua script because bash will be never uninstalled
  277. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  278. - update to 4.2 patch level 37
  279. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  280. - update to 4.2 patch level 20
  281. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  282. - update to 4.2 patch level 8
  283. - use lua script in post/postun
  284. - update patches from fedora
  285. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  286. - update to 4.1 patch level 7
  287. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  288. - check if /bin/grep exists on %%post script
  289. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  290. - rebuilt with gcc-4.4.3-3 on ppc
  291. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  292. - rebuilt with new toolchain
  293. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  294. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  295. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  296. - add Requires(post): grep
  297. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  298. - remove obsolete /bin/bash2 entry from /etc/shells
  299. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  300. - add Requires(post): ncurses (should be added by find-requires..)
  301. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  302. - add upstream patch (from 040 to 048)
  303. - build against ncurses-devel (libtinfo)
  304. - spec in utf-8
  305. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  306. - added upstream patch (from 026 to 039)
  307. - added Japanese summary
  308. - applied new versioning policy
  309. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  310. - rebuilt with libtermcap-devel
  311. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  312. - new upstream release
  313. - add upstream patch (from 001 to 025)
  314. - remove Provides: bash2
  315. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  316. - rebuilt with new toolchain
  317. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  318. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  319. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  320. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  321. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  322. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  323. - update to 2.05b
  324. - rebuild with new toolchains
  325. - add make check
  326. - add %postun script based on Fedora development
  327. - README file moved doc package
  328. - update Patch5 and Patch8 from Fedora development
  329. - change Patch6
  330. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  331. - add Patch11--39 from Fedora development 2.05b-36
  332. * Tim Waugh <twaugh@redhat.com>
  333. - Fix parameter expansion in multibyte locales (bug #112657).
  334. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  335. bug #110777).
  336. - Apply upstream patches (bug #109269 among others).
  337. - Fix bash.info (bug #83776).
  338. - Add bash205b-007 patch to fix bug #106876.
  339. - Avoid crashing on multibyte input when locale is set incorrectly
  340. (bug #74266).
  341. - LFS support (bug #103627).
  342. - Fix completion display when multibyte or control characters are to be
  343. shown (bug #90201).
  344. - Fix a warning message (bug #79629).
  345. - Don't build with AFS support (bug #86514).
  346. - Don't explicitly strip binaries (bug #85995).
  347. - Really fix bug #83331 for good.
  348. - Fix builtins.1.
  349. - Actually apply the patch (bug #83331).
  350. - Fix history/UTF-8 bug (bug #83331).
  351. - More tab-completion fixing (bug #72512).
  352. - Force pgrp synchronization (bug #81653).
  353. - Prevent prompt overwriting output (bug #74383).
  354. - Fix '-rbash' (bug #78455).
  355. - Add readline-init patch (bug #74925).
  356. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  357. - Ship '.' man page, which doesn't get picked up by glob.
  358. - Locale shell variables fix (bug #74701).
  359. * Elliot Lee <sopwith@redhat.com>
  360. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  361. cross compiles.
  362. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  363. - update to 2.05
  364. - add README.jpatch to %doc
  365. - remove patch4 (bash2): revert command name in man pages to "bash"
  366. - fix perl command to remove man pages conflict with sh-utils
  367. - remove section of config.h.in from patch0 to prevent remake of configure
  368. - change patch9: define in config-top.h to avoid conflict with patch100
  369. - remove patches 7, 10 & 101
  370. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  371. - made a link for man sh
  372. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  373. - added missing %%post and %%triggerpostun section
  374. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  375. - 2.04-1vl12
  376. - now bash2 is finally bash
  377. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  378. - build for Playstation2
  379. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  380. - 2.04-1vl10
  381. - Provides: bash = %%{version}
  382. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  383. - added Provides: bash
  384. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  385. - Obsoletes: bash
  386. - changed Copyright to License
  387. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  388. - 2.04-1vl7
  389. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  390. - corrected: bashrc-vine -> bashrc
  391. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  392. - combined bash-1.x and bash-2.x packages
  393. - added some patches from bash-2.04-13mdk
  394. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  395. - fix spec macros
  396. - added tests
  397. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  398. - build with gcc-2.95.3
  399. - partially used rpmmacros
  400. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  401. - minor bug fix in spec file
  402. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  403. - 2.04-1vl3
  404. - modified %install and %files section to handle compressed man page(s)
  405. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  406. - added pcomplete patch to fix complete if the candidate list is NULL.
  407. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  408. - updated to 2.04
  409. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  410. - Remove annoying ^H's from documentation
  411. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  412. - patch to detect what executables are required by a script.
  413. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  414. - auto rebuild in the new build environment (release 4)
  415. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  416. - strip binaries.
  417. - include bash-doc correctly.
  418. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  419. - fixed post/postun /etc/shells work.
  420. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  421. - updated again text in the spec file
  422. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  423. - updated text in spec file.
  424. - update to 2.03.
  425. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  426. - build it as bash2 instead of bash
  427. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  428. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  429. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  430. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  431. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  432. - patch for the arm
  433. - use $RPM_ARCH-redhat-linux as the build target
  434. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  435. - rewrite %pre, axe %postun (to avoid prereq loops)
  436. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  437. - resurrect for RH 6.0.
  438. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  439. - update to 2.02.1
  440. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  441. - Package for 5.2.
  442. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  443. - added POSIX.NOTES doc file
  444. - some extraneous doc files removed
  445. - minor .spec file changes
  446. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  447. - upgraded to version 2.02
  448. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  449. - glibc & signal patches no longer required
  450. - added documentation subpackage (doc)
  451. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  452. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  453. is based on a change made in bash 2.0. Should fix some early exit
  454. problems with suspends and fg.
  455. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  456. - added %clean
  457. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  458. - added comment explaining why install-info isn't used
  459. - added mips patch
  460. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  461. - added BuildRoot
  462. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  463. - built against glibc