elfutils-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %global nocheck false
  3. Summary: A collection of utilities and DSOs to handle compiled objects
  4. Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
  5. Name: elfutils
  6. Version: 0.189
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+ and (GPLv2+ or LGPLv3+) and GFDL
  12. URL: https://sourceware.org/elfutils/
  13. Source: https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
  14. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  15. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: bison >= 1.875
  18. BuildRequires: flex >= 2.5.4a
  19. BuildRequires: gcc >= 9.0.0
  20. BuildRequires: gettext
  21. BuildRequires: m4
  22. BuildRequires: bzip2-devel
  23. BuildRequires: libzstd-devel
  24. BuildRequires: xz-devel
  25. BuildRequires: zlib-devel
  26. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  27. BuildRequires: glibc-headers >= 2.3.4-11
  28. BuildRequires: bzip2
  29. BuildRequires: zstd
  30. %define _gnu %{nil}
  31. %define _program_prefix eu-
  32. %description
  33. Elfutils is a collection of utilities, including ld (a linker),
  34. nm (for listing symbols from object files), size (for listing the
  35. section sizes of an object or archive file), strip (for discarding
  36. symbols), readelf (to see the raw ELF file structures), and elflint
  37. (to check for well-formed ELF files).
  38. %package libs
  39. Summary: Libraries to handle compiled objects
  40. Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
  41. License: GPLv2+ or LGPLv3+
  42. Group: system
  43. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  44. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  45. Conflicts: elfutils < %{version}-%{release}
  46. Conflicts: elfutils > %{version}-%{release}
  47. Conflicts: elfutils-devel < %{version}-%{release}
  48. Conflicts: elfutils-devel > %{version}-%{release}
  49. %description libs
  50. The elfutils-libs package contains libraries which implement DWARF, ELF,
  51. and machine-specific ELF handling. These libraries are used by the programs
  52. in the elfutils package. The elfutils-devel package enables building
  53. other programs using these libraries.
  54. %package devel
  55. Summary: Development libraries to handle compiled objects
  56. Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
  57. License: GPLv2+ or LGPLv3+
  58. Group: programming
  59. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  60. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  61. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  62. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  63. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  64. %description devel
  65. The elfutils-devel package contains the libraries to create
  66. applications for handling compiled objects. libebl provides some
  67. higher-level ELF access functionality. libdw provides access to
  68. the DWARF debugging information. libasm provides a programmable
  69. assembler interface.
  70. %package devel-static
  71. Summary: Static archives to handle compiled objects
  72. Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
  73. License: GPLv2+ or LGPLv3+
  74. Group: programming
  75. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  76. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  77. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  78. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  79. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  80. %description devel-static
  81. The elfutils-devel-static package contains the static archives
  82. with the code to handle compiled objects.
  83. %package libelf
  84. Summary: Library to read and write ELF files
  85. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  86. License: GPLv2+ or LGPLv3+
  87. Group: system
  88. Provides: libelf = %{version}-%{release}
  89. Obsoletes: libelf <= 0.8.2-2
  90. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  91. Conflicts: elfutils < %{version}-%{release}
  92. Conflicts: elfutils > %{version}-%{release}
  93. Conflicts: elfutils-libs < %{version}-%{release}
  94. Conflicts: elfutils-libs > %{version}-%{release}
  95. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  96. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  97. %description libelf
  98. The elfutils-libelf package provides a DSO which allows reading and
  99. writing ELF files on a high level. Third party programs depend on
  100. this package to read internals of ELF files. The programs of the
  101. elfutils package use it also to generate new ELF files.
  102. %package libelf-devel
  103. Summary: Development support for libelf
  104. Summary(ja): libelf の開発用ライブラリ
  105. License: GPLv2+ or LGPLv3+
  106. Group: programming
  107. Provides: libelf-devel = %{version}-%{release}
  108. Obsoletes: libelf-devel <= 0.8.2-2
  109. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  110. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  111. Conflicts: libelf-devel < %{version}-%{release}
  112. %description libelf-devel
  113. The elfutils-libelf-devel package contains the libraries to create
  114. applications for handling compiled objects. libelf allows you to
  115. access the internals of the ELF object file format, so you can see the
  116. different sections of an ELF file.
  117. %package libelf-devel-static
  118. Summary: Static archive of libelf
  119. Summary(ja): libelf の静的ライブラリ
  120. License: GPLv2+ or LGPLv3+
  121. Group: programming
  122. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  123. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  124. %description libelf-devel-static
  125. The elfutils-libelf-static package contains the static archive
  126. for libelf.
  127. # compat32
  128. %package -n compat32-%{name}-libelf
  129. Summary: Library to read and write ELF files
  130. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  131. License: GPLv2+ or LGPLv3+
  132. Group: system,legacy
  133. Provides: compat32-libelf = %{version}-%{release}
  134. %description -n compat32-%{name}-libelf
  135. The elfutils-libelf package provides a DSO which allows reading and
  136. writing ELF files on a high level. Third party programs depend on
  137. this package to read internals of ELF files. The programs of the
  138. elfutils package use it also to generate new ELF files.
  139. %debug_package
  140. %prep
  141. %setup -q
  142. autoreconf -f -v -i
  143. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  144. # disable some tests
  145. sed -i -e 's/check_native.*$/exit 0/' \
  146. tests/run-backtrace-native.sh \
  147. tests/run-backtrace-native-biarch.sh \
  148. tests/run-backtrace-native-core.sh \
  149. tests/run-backtrace-native-core-biarch.sh \
  150. %{nil}
  151. %build
  152. # This package uses top level ASM constructs which are incompatible with LTO.
  153. # Top level ASMs are often used to implement symbol versioning. gcc-10
  154. # introduces a new mechanism for symbol versioning which works with LTO.
  155. # Converting packages to use that mechanism instead of toplevel ASMs is
  156. # recommended.
  157. # Disable LTO
  158. %define _lto_cflags %{nil}
  159. # Remove -Wall from default flags. The makefiles enable enough warnings
  160. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  161. # the makefiles disable some specific warnings for specific code.
  162. # But add -Wformat explicitly for use with -Werror=format-security which
  163. # doesn't work without -Wformat (enabled by -Wall).
  164. RPM_OPT_FLAGS="${RPM_OPT_FLAGS/-Wall/}"
  165. RPM_OPT_FLAGS="${RPM_OPT_FLAGS} -Wformat"
  166. %configure \
  167. CFLAGS="$RPM_OPT_FLAGS -fexceptions" \
  168. --disable-debuginfod \
  169. --disable-libdebuginfod
  170. make -s %{?_smp_mflags}
  171. %install
  172. rm -rf ${RPM_BUILD_ROOT}
  173. make -s install DESTDIR=${RPM_BUILD_ROOT}
  174. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  175. %find_lang %{name}
  176. # XXX Nuke unpackaged files
  177. { cd ${RPM_BUILD_ROOT}
  178. rm -f .%{_bindir}/eu-ld
  179. }
  180. # failed on i686 container hosted by x86_64
  181. %ifarch x86_64
  182. %check
  183. %make_build -s check || (cat tests/test-suite.log; %{nocheck})
  184. %endif
  185. %clean
  186. rm -rf ${RPM_BUILD_ROOT}
  187. %files -f %{name}.lang
  188. %defattr(-,root,root)
  189. %license COPYING COPYING-GPLV2 COPYING-LGPLV3 doc/COPYING-GFDL
  190. %doc README TODO CONTRIBUTING
  191. %{_bindir}/eu-addr2line
  192. %{_bindir}/eu-ar
  193. %{_bindir}/eu-elfclassify
  194. %{_bindir}/eu-elfcmp
  195. %{_bindir}/eu-elflint
  196. %{_bindir}/eu-findtextrel
  197. %{_bindir}/eu-nm
  198. %{_bindir}/eu-objdump
  199. %{_bindir}/eu-ranlib
  200. %{_bindir}/eu-readelf
  201. %{_bindir}/eu-size
  202. %{_bindir}/eu-stack
  203. %{_bindir}/eu-strings
  204. %{_bindir}/eu-strip
  205. #%{_bindir}/eu-ld
  206. %{_bindir}/eu-unstrip
  207. %{_bindir}/eu-make-debug-archive
  208. %{_bindir}/eu-elfcompress
  209. %{_mandir}/man1/eu-*
  210. %files libs
  211. %defattr(-,root,root)
  212. %license COPYING-GPLV2 COPYING-LGPLV3
  213. %{_libdir}/libasm-%{version}.so
  214. %{_libdir}/libasm.so.*
  215. %{_libdir}/libdw-%{version}.so
  216. %{_libdir}/libdw.so.*
  217. %files devel
  218. %defattr(-,root,root)
  219. %{_includedir}/dwarf.h
  220. %dir %{_includedir}/elfutils
  221. %{_includedir}/elfutils/elf-knowledge.h
  222. %{_includedir}/elfutils/known-dwarf.h
  223. %{_includedir}/elfutils/libasm.h
  224. %{_includedir}/elfutils/libdw.h
  225. %{_includedir}/elfutils/libdwelf.h
  226. %{_includedir}/elfutils/libdwfl.h
  227. %{_includedir}/elfutils/version.h
  228. %{_libdir}/libasm.so
  229. %{_libdir}/libdw.so
  230. %{_libdir}/pkgconfig/libdw.pc
  231. %files devel-static
  232. %defattr(-,root,root)
  233. %{_libdir}/libasm.a
  234. %{_libdir}/libdw.a
  235. %files libelf
  236. %defattr(-,root,root)
  237. %{_libdir}/libelf-%{version}.so
  238. %{_libdir}/libelf.so.*
  239. %files libelf-devel
  240. %defattr(-,root,root)
  241. %{_includedir}/libelf.h
  242. %{_includedir}/gelf.h
  243. %{_includedir}/nlist.h
  244. %{_libdir}/libelf.so
  245. %{_libdir}/pkgconfig/libelf.pc
  246. %{_mandir}/man3/elf_*
  247. %files libelf-devel-static
  248. %defattr(-,root,root)
  249. %{_libdir}/libelf.a
  250. %if %{build_compat32}
  251. %files -n compat32-%{name}-libelf
  252. %defattr(-,root,root)
  253. %{_libdir}/libelf-%{version}.so
  254. %{_libdir}/libelf.so.*
  255. %endif
  256. %changelog
  257. * Fri Sep 22 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.189-1
  258. - new upstream release.
  259. * Sat Sep 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.187-1
  260. - new upstream release.
  261. * Thu Aug 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.185-1
  262. - new upstream release.
  263. * Sat Apr 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-2
  264. - rebuilt with current environment.
  265. * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.183-1
  266. - new upstream release.
  267. * Fri Oct 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.177-1
  268. - new upstream release.
  269. * Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.170-3
  270. - rebuilt
  271. - 2vl7 was skipped (used for vl6)
  272. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.170-1
  273. - updated to 0.170.
  274. - dropped all patches.
  275. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-3
  276. - rebuild with gcc-5.4.0
  277. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
  278. - create compat32-elfutils-libelf subpackage
  279. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
  280. - update to 0.161
  281. - added Japanese summary
  282. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  283. - update to 0.157
  284. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  285. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  286. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  287. - update to 0.152
  288. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  289. - elfutils-libs: changed Group to System Environment/Libraries
  290. - elfutils-libelf: changed Group to System Environment/Libraries
  291. - elfutils-devel: changed Group to Development/Libraries
  292. - elfutils-devel-static: changed Group to Development/Libraries
  293. - elfutils-libelf-devel: changed Group to Development/Libraries
  294. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  295. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  296. - merged with Fedora 9 0.135-1
  297. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  298. - applied new versioning policy
  299. - added elfutils-0.131-readelf_c.patch
  300. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  301. - new upstream release
  302. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  303. - remove Obsoletes: libelf, libelf-devel from elfutils
  304. - add Obsoletes: libelf to elfutils-libelf
  305. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  306. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  307. - Update to 0.135
  308. - libdwfl: bug fixes
  309. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  310. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  311. - Update to 0.134
  312. - elflint: backend improvements for sparc, alpha (#204170)
  313. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  314. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  315. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  316. - Update to 0.133
  317. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  318. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  319. - libdwfl: bug fixes and optimization in relocation handling
  320. - elfcmp: bug fix for non-allocated section handling
  321. - ld: implement newer features of binutils linker.
  322. - Install eu-objdump and libasm, now has limited disassembler support.
  323. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  324. - Update to 0.132
  325. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  326. - eu-readelf: Fix handling of ET_REL files in archives.
  327. - libcpu: Implement x86 and x86-64 disassembler.
  328. - libasm: Add interface for disassembler.
  329. - all programs: add debugging of branch prediction.
  330. - libelf: new function elf_scnshndx.
  331. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  332. - Update to 0.131
  333. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  334. bug fixes for oddly-formatted DWARF
  335. - libdwfl: bug fixes in offline archive support, symbol table handling;
  336. apply partial relocations for dwfl_module_address_section on ET_REL
  337. - libebl: powerpc backend support for Altivec registers
  338. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  339. - Fix ET_REL support.
  340. - Fix odd indentation in eu-readelf -x output.
  341. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  342. - Update to 0.130
  343. - eu-readelf -p option can take an argument like -x for one section
  344. - eu-readelf --archive-index (or -c)
  345. - eu-readelf -n improved output for core dumps
  346. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  347. - eu-elflint: ditto
  348. - eu-elflint: stricter checks on debug sections
  349. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  350. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  351. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  352. - libebl: backend improvements (#324031)
  353. - libdwfl: build_id support, new functions for it
  354. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  355. - libdwfl offline archive support, new script eu-make-debug-archive
  356. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  357. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  358. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  359. - Update to 0.129
  360. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  361. - addr2line: new option --symbols (or -S)
  362. - libdw: dwarf_getscopes fixes (#230235)
  363. - libdwfl: dwfl_module_addrsym fixes (#249490)
  364. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  365. - Update to 0.128
  366. - new program: unstrip
  367. - elfcmp: new option --hash-inexact
  368. - Replace Conflicts: with Provides/Requires using -arch
  369. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  370. - Update to 0.127
  371. - libdw: new function dwarf_getsrcdirs
  372. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  373. dwfl_module_address_section
  374. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  375. - Update to 0.126
  376. - New program eu-ar.
  377. - libdw: fix missing dwarf_getelf (#227206)
  378. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  379. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  380. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  381. - Fix overeager warn_unused_result build failures.
  382. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  383. - Update to 0.125
  384. - elflint: Compare DT_GNU_HASH tests.
  385. - move archives into -static RPMs
  386. - libelf, elflint: better support for core file handling
  387. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  388. - Resolves: RHBZ #220817, RHBZ #213792
  389. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  390. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  391. - Update to 0.124
  392. - libebl: fix ia64 reloc support (#206981)
  393. - libebl: sparc backend support for return value location
  394. - libebl, libdwfl: backend register name support extended with more info
  395. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  396. - readelf, elflint: trivial bugs fixed
  397. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  398. - Update to 0.123
  399. - libebl: Backend build fixes, thanks to Stepan Kasal.
  400. - libebl: ia64 backend support for register names, return value location
  401. - libdwfl: Handle truncated linux kernel module section names.
  402. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  403. - elflint: Fix checks to permit --hash-style=gnu format.
  404. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  405. - Fix warnings in elflint compilation.
  406. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  407. - Update to 0.122
  408. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  409. - libebl: add function to test for relative relocation
  410. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  411. - elflint, readelf: add support for DT_GNU_HASH
  412. - libelf: add elf_gnu_hash
  413. - elflint, readelf: add support for 64-bit SysV-style hash tables
  414. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  415. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  416. - Update to 0.121
  417. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  418. - make all installed headers usable in C++ code (#193153).
  419. - eu-readelf: better output format.
  420. - eu-elflint: fix tests of dynamic section content.
  421. - libdw, libdwfl: handle files without aranges info.
  422. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  423. - rebuild to pick up -devel deps
  424. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  425. - Update to 0.120
  426. - License changed to GPL, with some exceptions for using
  427. the libelf, libebl, libdw, and libdwfl library interfaces.
  428. Red Hat elfutils is an included package of the Open Invention Network.
  429. - dwarf.h updated for DWARF 3.0 final specification.
  430. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  431. - libdwfl: New function dwfl_version; fixes for offline.
  432. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  433. - bump again for double-long bug on ppc(64)
  434. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  435. - rebuilt for new gcc4.1 snapshot and glibc changes
  436. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  437. - update to 0.119
  438. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  439. - rebuilt
  440. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  441. - update to 0.118
  442. - elflint: more tests.
  443. - libdwfl: New function dwfl_module_register_names.
  444. - libebl: New backend hook for register names.
  445. - Make sure -fexceptions is always in CFLAGS.
  446. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  447. - update to 0.117
  448. - libdwfl: New function dwfl_module_return_value_location (#166118)
  449. - libebl: Backend improvements for several CPUs
  450. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  451. - update to 0.116
  452. - libdw fixes, API changes and additions
  453. - libdwfl fixes (#169672)
  454. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  455. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  456. - Update requires/conflicts for better biarch update behavior.
  457. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  458. - update to 0.115
  459. - New program eu-strings.
  460. - libdw: New function dwarf_getscopes_die.
  461. - libelf: speed-ups of non-mmap reading.
  462. - Implement --enable-gcov option for configure.
  463. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  464. - update to 0.114
  465. - new program eu-ranlib
  466. - libdw: new calls for inlines
  467. - libdwfl: new calls for offline modules
  468. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  469. - update to 0.113
  470. - elflint: relax a bit. Allow version definitions for defined symbols
  471. against DSO versions also for symbols in nobits sections.
  472. Allow .rodata section to have STRINGS and MERGE flag set.
  473. - strip: add some more compatibility with binutils.
  474. - libdwfl: bug fixes.
  475. - Separate libdw et al into elfutils-libs subpackage.
  476. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  477. - update to 0.112
  478. - elfcmp: some more relaxation.
  479. - elflint: many more tests, especially regarding to symbol versioning.
  480. - libelf: Add elfXX_offscn and gelf_offscn.
  481. - libasm: asm_begin interface changes.
  482. - libebl: Add three new interfaces to directly access machine, class,
  483. and data encoding information.
  484. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  485. - update portability patch
  486. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  487. - update to 0.111
  488. - libdwfl library now merged into libdw
  489. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  490. - update to 0.110
  491. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  492. - update to 0.109
  493. - verify that libebl modules are from the same build
  494. - new eu-elflint checks on copy relocations
  495. - new program eu-elfcmp
  496. - new experimental libdwfl library
  497. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  498. - robustification of eu-strip and eu-readelf
  499. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  500. - more robustification
  501. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  502. - robustification
  503. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  504. - update to 0.108
  505. - merge strip fixes
  506. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  507. - update elf.h from glibc
  508. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  509. - fix strip -f byte-swapping bug
  510. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  511. - update to 0.107
  512. - readelf: improve DWARF output format
  513. - elflint: -d option to support checking separate debuginfo files
  514. - strip: fix ET_REL debuginfo files (#156341)
  515. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  516. - fix some bugs in new code, reenable make check
  517. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  518. - disable make check for most arches, for now
  519. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  520. - update to 0.106
  521. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  522. - update to 0.104
  523. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  524. - update to 0.103
  525. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  526. - update to 0.101.
  527. - use %%configure macro to get CFLAGS etc. right
  528. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  529. - upgrade to 0.99.
  530. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  531. - upgrade to 0.97.
  532. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  533. - upgrade to 0.96.
  534. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  535. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  536. warning
  537. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  538. - rebuilt
  539. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  540. - upgrade to 0.95.
  541. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  542. - rebuilt
  543. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  544. - rebuilt
  545. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  546. - upgrade to 0.94
  547. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  548. - upgrade to 0.93
  549. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  550. - full version
  551. - macroized spec file for GPL or OSL builds
  552. - include only libelf under GPL plus wrapper scripts
  553. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  554. - macroized spec file for GPL or OSL builds
  555. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  556. - split elfutils-devel into two packages.
  557. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  558. - include only libelf under GPL plus wrapper scripts
  559. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  560. - readelf, not readline, in %%description (#111214).
  561. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  562. - update to 0.89 (fix eu-strip)
  563. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  564. - update to 0.86 (fix eu-strip on s390x/alpha)
  565. - libebl is an archive now; remove references to DSO
  566. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  567. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  568. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  569. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  570. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  571. - upgrade to 0.82 (strip tests fixed on big-endian).
  572. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  573. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  574. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  575. - upgrade to 0.80 (debugedit changes for kernel in progress).
  576. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  577. - rebuilt
  578. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  579. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  580. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  581. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  582. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  583. - debuginfo rebuild
  584. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  585. - use the correct way of identifying the section via the sh_info link.
  586. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  587. - update to 0.75 (eu-strip -g fix)
  588. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  589. - update to 0.74 (fix for writing with some non-dirty sections)
  590. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  591. - another -0.73 update (with sparc fixes).
  592. - do "make check" in %%check, not %%install, section.
  593. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  594. - update to 0.73 (with s390 fixes).
  595. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  596. - rebuilt
  597. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  598. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  599. - fix other warnings
  600. - reenable checks on s390x
  601. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  602. - temporarily disable checks on s390x, until someone has
  603. time to look at it
  604. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  605. - update to 0.72
  606. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  607. - update to 0.71
  608. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  609. - update to 0.69.
  610. - add "make check" and segfault avoidance patch.
  611. - elfutils-libelf needs to run ldconfig.
  612. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  613. - update to 0.68.
  614. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  615. - update to 0.67.
  616. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  617. - update to 0.65.
  618. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  619. - update to 0.64.
  620. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  621. - split packages further into elfutils-libelf
  622. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  623. - update to 0.63.
  624. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  625. - Adjust for dropping libtool
  626. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  627. - update to 0.59
  628. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  629. - update to 0.56
  630. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  631. - update to 0.54
  632. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  633. - update to 0.53
  634. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  635. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  636. - get beehive to punch a rhpkg generated package.
  637. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  638. - build in 8.0.1.
  639. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  640. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  641. - Add libelf-devel to conflicts for elfutils-devel
  642. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  643. - Split into runtime and devel package
  644. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  645. - integrate into official sources
  646. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  647. - Swaddle.