123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199 |
- %bcond_with java
- Name: libwebp
- Summary: Library and tools for the WebP graphics format
- Summary(ja): WebP 画像フォーマットのためのライブラリとツール
- Version: 1.3.2
- Release: 1%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: iwaim
- # Additional IPR is licensed as well. See PATENTS file for details
- License: BSD
- URL: https://developers.google.com/speed/webp
- Source0: https://github.com/webmproject/libwebp/archive/v%{version}.tar.gz#/libwebp-%{version}.tar.gz
- Source1: libwebp_jni_example.java
- # Fix build with freeglut
- Patch0: libwebp-freeglut.patch
- # Fix cmake module install location
- Patch2: libwebp-cmakedir.patch
- # Kill rpath
- Patch3: libwebp-rpath.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: cmake
- BuildRequires: libjpeg-devel
- BuildRequires: libpng-devel
- BuildRequires: libtool
- BuildRequires: freeglut-devel
- %if %{with java}
- BuildRequires: swig
- BuildRequires: java-1.8.0-openjdk-devel
- BuildRequires: jpackage-utils
- %endif
- %description
- WebP is an image format that does lossy compression of digital
- photographic images. WebP consists of a codec based on VP8, and a
- container based on RIFF. Webmasters, web developers and browser
- developers can use WebP to compress, archive and distribute digital
- images more efficiently.
- %package tools
- Summary: The WebP command line tools
- Summary(ja): WebP コマンドラインツール
- Group: graphics
- %description tools
- WebP is an image format that does lossy compression of digital
- photographic images. WebP consists of a codec based on VP8, and a
- container based on RIFF. Webmasters, web developers and browser
- developers can use WebP to compress, archive and distribute digital
- images more efficiently.
- %package devel
- Summary: Development files for libwebp, a library for the WebP format
- Summary(ja): WebP フォーマットのためのライブラリ libwebp の開発ファイル
- Group: programming
- Requires: %{name} = %{version}-%{release}
- %description devel
- WebP is an image format that does lossy compression of digital
- photographic images. WebP consists of a codec based on VP8, and a
- container based on RIFF. Webmasters, web developers and browser
- developers can use WebP to compress, archive and distribute digital
- images more efficiently.
- %if %{with java}
- %package java
- Summary: Java bindings for libwebp, a library for the WebP format
- Summary(ja): WebP フォーマットのためのライブラリ libwebp の Java バインディング
- Group: programming
- Requires: %{name} = %{version}-%{release}
- Requires: java
- Requires: jpackage-utils
- %description java
- Java bindings for libwebp.
- %endif
- %debug_package
- %prep
- %autosetup -p1
- %build
- %global optflags %{optflags} -fPIC
- %cmake
- %cmake_build
- %if %{with java}
- # swig generated Java bindings
- cp %{SOURCE1} .
- cd swig
- rm -rf libwebp.jar libwebp_java_wrap.c
- mkdir -p java/com/google/webp
- swig -ignoremissing -I../src -java \
- -package com.google.webp \
- -outdir java/com/google/webp \
- -o libwebp_java_wrap.c libwebp.swig
- gcc %{optflags} -shared \
- -I/usr/lib/jvm/java/include \
- -I/usr/lib/jvm/java/include/linux \
- -I../src \
- -L../src/.libs -lwebp libwebp_java_wrap.c \
- -o libwebp_jni.so
- cd java
- javac com/google/webp/libwebp.java
- jar cvf ../libwebp.jar com/google/webp/*.class
- %endif
- %install
- %cmake_install
- %if %{with java}
- # swig generated Java bindings
- mkdir -p %{buildroot}/%{_libdir}/%{name}-java
- cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
- %endif
- %files tools
- %{_bindir}/*
- %{_mandir}/man*/*
- %files -n %{name}
- %license COPYING PATENTS
- %doc README* NEWS AUTHORS
- %{_libdir}/%{name}*.so.*
- %{_libdir}/libsharpyuv.so.*
- %files devel
- %{_libdir}/%{name}*.so
- %{_libdir}/libsharpyuv.so
- %{_includedir}/*
- %{_libdir}/pkgconfig/*
- %{_libdir}/cmake/*
- %if %{with java}
- %files java
- %doc libwebp_jni_example.java
- %{_libdir}/%{name}-java/
- %endif
- %changelog
- * Thu Sep 28 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
- - new upstream release.
- * Wed Jul 05 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
- - new upstream release.
- * Fri Sep 23 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-1
- - new upstream release.
- * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.0-1
- - new upstream release.
- * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1-1
- - new upstream release.
- * Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.3.1-3
- - moved libwebp to System Environment/Libraries Group
- * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.1-2
- - rebuild with libpng-1.6.12
- * Sat Oct 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.3.1-1
- - new upstream release
- * Sat Jan 12 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
- - initial build for Vine Linux
- * Thu Dec 27 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.2.1-1
- - new upstream release 0.2.1
- * Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.1.3-3
- - rebuild against new libjpeg
- * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Thu Feb 02 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.3-1
- - Several spec improvements by Scott Tsai <scottt.tw@gmail.com>
- * Wed May 25 2011 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.2-1
- - Initial spec. Based on openSUSE one
|