gnucash-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %global guile_sitedir %{_datadir}/guile/site/2.2
  2. Name: gnucash
  3. Summary: GnuCash is an application to keep track of your finances.
  4. Summary(ja): 個人用財務管理アプリケーション
  5. Version: 4.4
  6. Release: 1%{?_dist_release}
  7. Group: office
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: kenta, inagaki
  11. License: GPL/LGPL/GFDL
  12. URL: https://www.gnucash.org/
  13. Source: https://github.com/Gnucash/gnucash/releases/download/%{version}/%{name}-%{version}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libappstream-glib-devel
  16. BuildRequires: aqbanking-devel >= 3.7.2
  17. BuildRequires: bzip2-devel
  18. BuildRequires: cmake
  19. BuildRequires: desktop-file-utils
  20. BuildRequires: expat-devel
  21. BuildRequires: gwenhywfar-devel
  22. BuildRequires: gettext
  23. BuildRequires: gmock-devel
  24. BuildRequires: gtest-devel
  25. BuildRequires: gtk3-devel
  26. BuildRequires: guile-devel
  27. BuildRequires: libappstream-glib
  28. BuildRequires: libboost-date-time
  29. BuildRequires: libboost-devel
  30. BuildRequires: libboost-locale
  31. BuildRequires: libboost-regex
  32. BuildRequires: libboost-filesystem
  33. BuildRequires: libboost-program-options
  34. BuildRequires: libicu-devel
  35. BuildRequires: libofx-devel
  36. BuildRequires: libdbi-devel
  37. BuildRequires: libjpeg-devel
  38. BuildRequires: libsecret-devel
  39. BuildRequires: libtool-ltdl-devel
  40. BuildRequires: libxslt-devel
  41. BuildRequires: pcre-devel
  42. BuildRequires: popt-devel
  43. BuildRequires: python3-devel
  44. BuildRequires: swig
  45. BuildRequires: webkitgtk4-devel
  46. #BuildRequires: slib
  47. BuildRequires: libdbi-dbd-pgsql
  48. BuildRequires: libdbi-dbd-mysql
  49. BuildRequires: libdbi-dbd-sqlite
  50. Requires: aqbanking
  51. Requires: perl-DateManip
  52. Requires: yelp
  53. Requires(post,postun): gtk3
  54. Requires(postun,posttrans): glib2
  55. Obsoletes: gnucash-backend-postgres
  56. %description
  57. GnuCash is a personal finance manager. A check-book like
  58. register GUI allows you to enter and track bank accounts,
  59. stocks, income and even currency trades. The interface is
  60. designed to be simple and easy to use, but is backed with
  61. double-entry accounting principles to ensure balanced books.
  62. %description -l ja
  63. GnuCashは 個人用財務管理をするアプリケーションです.
  64. 預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
  65. グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
  66. 使用できるようにデザインされています.
  67. %debug_package
  68. %prep
  69. %setup -q
  70. %build
  71. %global optflags %{optflags} -Wno-parentheses
  72. %cmake . \
  73. -DCMAKE_INSTALL_DOCDIR=%{_datadir}/doc/gnucash-%{version} \
  74. -DWITH_SQL=OFF
  75. %make_build
  76. %install
  77. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  78. %make_install
  79. %find_lang %name
  80. rm -rf $RPM_BUILD_ROOT%{_infodir} \
  81. $RPM_BUILD_ROOT%{_includedir} \
  82. $RPM_BUILD_ROOT%{_datadir}/aclocal \
  83. $RPM_BUILD_ROOT%{_libdir}/lib*.a \
  84. $RPM_BUILD_ROOT%{_libdir}/gnucash/lib*.a \
  85. $RPM_BUILD_ROOT%{_bindir}/gnc-test-env \
  86. $RPM_BUILD_ROOT%{_bindir}/gnc-fq-update
  87. find $RPM_BUILD_ROOT%{_libdir} -name *.la -exec rm -f {} \;
  88. %clean
  89. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  90. %post
  91. /sbin/ldconfig
  92. touch --no-create %{_datadir}/icons/hicolor || :
  93. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  94. %postun
  95. if [ $1 -eq 0 ] ; then
  96. /sbin/ldconfig
  97. touch --no-create %{_datadir}/icons/hicolor || :
  98. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  99. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  100. fi
  101. %posttrans
  102. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  103. %files -f %{name}.lang
  104. %defattr(-,root,root,755)
  105. %doc %{_docdir}/gnucash-%{version}/*
  106. %license LICENSE
  107. %dir %{_sysconfdir}/%{name}
  108. %{_bindir}/*
  109. %{_libdir}/*
  110. %{_datadir}/glib-2.0/schemas/*
  111. %{_datadir}/%{name}
  112. %{_datadir}/metainfo/*
  113. %{_datadir}/applications/*
  114. %{_datadir}/icons/hicolor/*/apps/*
  115. %{guile_sitedir}/%{name}
  116. %{_mandir}/man*/*
  117. %config %{_sysconfdir}/%{name}/*
  118. %changelog
  119. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.4-1
  120. - new upstream release.
  121. - built with boost-1.75.0.
  122. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10-1
  123. - new upstream release.
  124. - built with icu-67 and boost-1.72.0.
  125. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8b-1
  126. - new upstream release.
  127. - built with icu-66.
  128. * Sun Oct 13 2019 Toshiaki Ara <ara_t@384.jp> 3.7-2
  129. - rebuild with libicu-65
  130. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7-1
  131. - new upstream release.
  132. * Thu Mar 31 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.12-1
  133. - new upstream release
  134. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-1
  135. - new upstream release
  136. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-2
  137. - remove *.la files
  138. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-1
  139. - new upstream release
  140. - add BuildRequires: libtool-ltdl-devel
  141. * Mon Mar 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.5-2
  142. - rebuilt with libofx 0.9.10
  143. - added Vendor and Distribution tag
  144. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  145. - update to 2.6.5
  146. - remove old patches
  147. - add BuildRequires: libdbi-devel
  148. - change BuildRequires: goffice08-devel instead of goffice-devel
  149. * Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
  150. - rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
  151. - added Patch1 for building with aqbanking-4.2.4
  152. - added Patch2 for building with goffice-0.8.10
  153. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
  154. - added slib to BuildRequires: and Requires:
  155. * Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
  156. - new upstream release
  157. * Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
  158. - new upstream release
  159. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
  160. - rebuild with guile-1.8.6
  161. - add BuildRequires: gwenhywfar-devel
  162. * Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
  163. - new upstream release
  164. - applied new versioning policy
  165. - built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
  166. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
  167. - new upstream release
  168. - rebuilt with goffice-0.6.0
  169. * Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
  170. - new upstream release
  171. * Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
  172. - new upstream release
  173. - enable HBCI (Home Banking Computer Interface)
  174. * Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
  175. - rebuild with libofx-0.8.3 (libofx.so.3)
  176. * Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
  177. - new upstream release
  178. - disable postgresql backend, as it is unmaintained upstream
  179. - added Patch0: gnucash-2.2.0-quiet.patch
  180. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
  181. - new upstream release
  182. - remove BuildRequiers: autoconf213
  183. - update ja.po
  184. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  185. - new upstream release
  186. - added BuildPrereq: libtool-ltdl-devel
  187. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  188. - rebuild with new toolchains
  189. - update ja.po
  190. * Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
  191. - new upstream release
  192. * Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
  193. - merged gnucash-docs-1.8.3
  194. - added patch from Redhat Rawhide 1.8.7-1
  195. - changed Group, License
  196. * Mon Oct 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
  197. - updated to 1.8.7
  198. - updated print.patch
  199. - overwrite prefs.scm
  200. - s/Copyright/License/
  201. * Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
  202. - updated to 1.8.3
  203. - added datelength.patch
  204. - separated devel packages
  205. (and ofx, hbci, backend-postgres. But default is off)
  206. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
  207. - Build against with new gal.
  208. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
  209. - Fixed printing issue.
  210. * Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
  211. - New upstream release.
  212. * Thu Jul 26 2001 <sagami@vinelinux.org>
  213. - 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
  214. * Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  215. - %%make line is now commented out (bash2 complains it)
  216. (BTW, what the hell is the macro %%make anyway? I don't even know...)
  217. * Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  218. - update to 1.6.0 (stable release version)
  219. * Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
  220. - update to 1.5.96 ( pre beta for 1.6.0 )
  221. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
  222. - added japanese patch for reporting and printing (thanx tagoh-san)
  223. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
  224. - updated to 1.5.6
  225. * Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
  226. - added translation messages to ja.po
  227. - enable guppi
  228. * Mon Apr 2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
  229. - upstream update
  230. - fixed broken ja.po
  231. * Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
  232. - fixed registor window cursor position problem(gnucash-cursor_pos.patch)
  233. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
  234. - initial relese package