ModemManager-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227
  1. %define snapshot .git20100502
  2. %define ppp_version 2.4.4
  3. Summary: Mobile broadband modem management service
  4. Summary(ja): Mobile broadband modem management service
  5. Name: ModemManager
  6. Version: 0.3
  7. Release: 1%{?snapshot}%{?_dist_release}
  8. License: GPLv2+
  9. Group: System Environment/Base
  10. URL: http://www.gnome.org/projects/NetworkManager/
  11. #
  12. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  13. # tarball built with:
  14. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  15. # make distcheck
  16. #
  17. Source: %{name}-%{version}%{?snapshot}.tar.bz2
  18. Patch1: %{name}-0.3-jp-modems.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. Requires: dbus-glib
  21. Requires: glib2
  22. BuildRequires: glib2-devel >= 2.18
  23. BuildRequires: dbus-glib-devel >= 0.82
  24. BuildRequires: libgudev-devel >= 143
  25. BuildRequires: ppp = %{ppp_version}
  26. BuildRequires: ppp-devel = %{ppp_version}
  27. BuildRequires: polkit-devel
  28. BuildRequires: automake autoconf intltool libtool
  29. # for xsltproc
  30. BuildRequires: libxslt
  31. %description
  32. The ModemManager service provides a consistent API to operate many different
  33. modems, including mobile broadband (3G) devices.
  34. %prep
  35. %setup -q
  36. %patch1 -p1 -b .jp-modems
  37. %build
  38. pppddir=`ls -1d %{_libdir}/pppd/2*`
  39. %configure \
  40. --enable-more-warnings=yes \
  41. --with-udev-base-dir=/lib/udev \
  42. --with-tests=yes \
  43. --with-docs=yes \
  44. --disable-static \
  45. --with-pppd-plugin-dir=$pppddir \
  46. --with-polkit=no
  47. make %{?_smp_mflags}
  48. %check
  49. make check
  50. %install
  51. make install DESTDIR=$RPM_BUILD_ROOT
  52. rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
  53. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
  54. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  55. %post
  56. /sbin/ldconfig
  57. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  58. %postun
  59. /sbin/ldconfig
  60. if [ $1 -eq 0 ]; then
  61. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  62. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  63. fi
  64. %posttrans
  65. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  66. %files
  67. %defattr(0644, root, root, 0755)
  68. %doc COPYING README
  69. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager.conf
  70. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
  71. %attr(0755,root,root) %{_sbindir}/modem-manager
  72. %dir %{_libdir}/%{name}
  73. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  74. /lib/udev/rules.d/*
  75. %{_datadir}/polkit-1/actions/*.policy
  76. %{_datadir}/icons/hicolor/22x22/apps/modem-manager.png
  77. %changelog
  78. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  79. - initial build for Vine Linux
  80. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  81. - core: ignore some failures on disconnect (rh #578280)
  82. - core: add support for platform serial devices
  83. - gsm: better Blackberry DUN support
  84. - gsm: periodically poll access technology
  85. - cdma: prevent crash on modem removal (rh #571921)
  86. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  87. - novatel: better signal strength reporting on CDMA cards
  88. - novatel: add access technology and mode preference support on GSM cards
  89. - zte: fix mode preference retrieval
  90. - longcheer: add support for Zoom modems (4595, 4596, etc)
  91. - longcheer: add access technology and mode preference support
  92. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  93. - Silence %%post
  94. - Update scripts
  95. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  96. - gsm: fix parsing Blackberry supported character sets response
  97. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  98. - mbm: fix retrieval of current allowed mode
  99. - gsm: fix initialization issues with some devices (like Blackberries)
  100. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  101. - core: fix detection of some generic devices (rh #579247)
  102. - core: fix detection regression of some Huawei devices in 0.3-5
  103. - cdma: periodically poll registration state and signal quality
  104. - cdma: really fix registration detection on various devices (rh #569067)
  105. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  106. - core: fix PPC/SPARC/etc builds
  107. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  108. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  109. - cdma: handle signal quality requests while connected for more devices
  110. - cdma: handle serving system requests while connected for more devices
  111. - gsm: determine current access technology earlier
  112. - huawei: work around automatic registration issues on some devices
  113. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  114. - core: ensure enabled modems are disabled when MM stops
  115. - core: better capability detection for Blackberry devices (rh #573510)
  116. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  117. - gsm: don't block modem when it requires PIN2
  118. - option: fix access technology updates
  119. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  120. - mbm: add device IDs for C3607w
  121. - mbm: fail earlier during connection failures
  122. - mbm: fix username/password authentication when checked by the network
  123. - hso: implement asynchronous signal quality updates
  124. - option: implement asynchronous signal quality updates
  125. - novatel: correctly handle CDMA signal quality
  126. - core: basic PolicyKit support
  127. - core: fix direct GSM registration information requests
  128. - core: general GSM PIN/PUK unlock fixes
  129. - core: poll GSM registration state internally for quicker status updates
  130. - core: implement GSM 2G/3G preference
  131. - core: implement GSM roaming allowed/disallowed preference
  132. - core: emit signals on access technology changes
  133. - core: better handling of disconnections
  134. - core: fix simple CDMA status requests
  135. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  136. - core: startup speed improvements
  137. - core: GSM PIN checking improvements
  138. - huawei: fix EVDO-only connections on various devices (rh #553199)
  139. - longcheer: add support for more devices
  140. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  141. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  142. - core: fix crashes when devices are unplugged during operation (rh #553953)
  143. - cdma: prefer primary port for status/registration queries
  144. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  145. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  146. - gsm: fix Nokia N80 network scan parsing
  147. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  148. - core: fix apparent hangs by limiting retried serial writes
  149. - gsm: ensure modem state is reset when disabled
  150. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  151. - sierra: fix CDMA registration detection in some cases (rh #547513)
  152. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  153. - sierra: ensure CDMA device is powered up when trying to use it
  154. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  155. - zte: handle unsolicited messages better during probing
  156. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  157. - cdma: fix signal strength reporting on some devices
  158. - cdma: better registration state detection when dialing (ex Sierra 5275)
  159. - option: always use the correct tty for dialing commands
  160. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  161. - core: fix reconnect after manual disconnect (rh #541314)
  162. - core: fix various segfaults during registration
  163. - core: fix probing of various modems on big-endian architectures (ie PPC)
  164. - core: implement modem states to avoid duplicate operations
  165. - hso: fix authentication for Icera-based devices like iCON 505
  166. - zte: use correct port for new devices
  167. - nozomi: fix detection
  168. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  169. - Update to latest git
  170. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  171. - cdma: wait for network registration before trying to connect
  172. - gsm: add cell access technology reporting
  173. - gsm: allow longer-running network scans
  174. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  175. - nokia: don't power down phones on disconnect
  176. - hso: fix disconnection/disable
  177. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  178. - Fixes for Motorola and Ericsson devices
  179. - Fixes for CDMA "serving-system" command parsing
  180. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  181. - Fix a typo in one of the udev rules files
  182. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  184. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  185. - Fix source repo location
  186. - Fix directory ownership
  187. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  188. - Initial version