kdevelop-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496
  1. Name: kdevelop
  2. Summary: Integrated Development Environment for C++/C
  3. Summary(ja): C++/C 向け統合開発環境
  4. Version: 4.2.0
  5. Release: 2%{?_dist_release}
  6. License: GPLv2
  7. URL: http://www.kdevelop.org/
  8. Group: Applications/Development
  9. Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.tar.bz2
  10. Source1: ftp://ftp.kde.org/pub/kde/stable/kdevelop/%{version}/src/kdevelop-%{version}.md5sum
  11. # fixing https://bugs.kde.org/show_bug.cgi?id=236315
  12. Patch100: kdevelop-4.0.0-qmake_qt4.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: desktop-file-utils
  15. BuildRequires: gettext
  16. BuildRequires: kdebase-workspace-devel
  17. BuildRequires: kdevplatform-devel >= 1.2.0
  18. BuildRequires: kdelibs4-devel
  19. BuildRequires: kdesdk-devel
  20. BuildRequires: soprano-devel
  21. BuildRequires: valgrind
  22. Requires: %{name}-libs = %{version}-%{release}
  23. Requires: kdevplatform >= 1.2.0
  24. #Conflicts: kdevelop
  25. %description
  26. The KDevelop Integrated Development Environment provides many features
  27. that developers need as well as providing a unified interface to programs
  28. like gdb, the C/C++ compiler, and make. KDevelop manages or provides:
  29. All development tools needed for C++ programming like Compiler,
  30. Linker, automake and autoconf; KAppWizard, which generates complete,
  31. ready-to-go sample applications; Classgenerator, for creating new
  32. classes and integrating them into the current project; File management
  33. for sources, headers, documentation etc. to be included in the
  34. project; The creation of User-Handbooks written with SGML and the
  35. automatic generation of HTML-output with the KDE look and feel;
  36. Automatic HTML-based API-documentation for your project's classes with
  37. cross-references to the used libraries; Internationalization support
  38. for your application, allowing translators to easily add their target
  39. language to a project;
  40. KDevelop also includes WYSIWYG (What you see is what you get)-creation
  41. of user interfaces with a built-in dialog editor; Debugging your
  42. application by integrating KDbg; Editing of project-specific pixmaps
  43. with KIconEdit; The inclusion of any other program you need for
  44. development by adding it to the "Tools"-menu according to your
  45. individual needs.
  46. %package libs
  47. Summary: %{name} runtime libraries
  48. Summary(ja): %{name} のランタイムライブラリ
  49. Group: System Environment/Libraries
  50. #Requires: %{name} = %{version}-%{release}
  51. Requires: kdelibs4
  52. %description libs
  53. %{summary}.
  54. %package devel
  55. Summary: Development files for %{name}
  56. Summary(ja): %{name} の開発用ファイル
  57. Group: Development/Libraries
  58. Requires: %{name}-libs = %{version}-%{release}
  59. %description devel
  60. %{summary}.
  61. %prep
  62. %setup -q -n kdevelop-%{version}
  63. #patch100 -p1 -b .qmake_qt4
  64. %build
  65. mkdir -p %{_target_platform}
  66. pushd %{_target_platform}
  67. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  68. %cmake \
  69. -DCMAKE_BUILD_TYPE=release \
  70. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  71. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  72. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  73. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  74. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  75. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  76. ..
  77. popd
  78. make %{?_smp_mflags} -C %{_target_platform}
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  82. %find_lang %{name} --all-name --with-kde
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %post
  86. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  87. %postun
  88. if [ $1 -eq 0 ] ; then
  89. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  90. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  91. update-desktop-database -q &> /dev/null
  92. update-mime-database %{_datadir}/mime &> /dev/null
  93. fi
  94. %posttrans
  95. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  96. update-desktop-database -q &> /dev/null
  97. update-mime-database %{_datadir}/mime &> /dev/null
  98. %post libs -p /sbin/ldconfig
  99. %postun libs -p /sbin/ldconfig
  100. %files -f %{name}.lang
  101. %defattr(-,root,root)
  102. %{_bindir}/*
  103. %config %{_datadir}/config/kdeveloprc
  104. %{_datadir}/applications/kde4/*.desktop
  105. %{_datadir}/kde4/apps/kdev*/
  106. %{_datadir}/kde4/services/*.desktop
  107. %{_datadir}/icons/hicolor/*/*/*
  108. %{_datadir}/mime/packages/kdevelop.xml
  109. #{_datadir}/servicetypes/*
  110. #doc %{_datadir}/doc/HTML/en/*
  111. %files libs
  112. %defattr(-,root,root,-)
  113. %{_libdir}/lib*.so
  114. %{_libdir}/kde4/*.so
  115. %files devel
  116. %defattr(-,root,root,-)
  117. %{_datadir}/kde4/apps/cmake/modules/FindKDevelop.cmake
  118. %{_includedir}/kde4/kdevelop/
  119. %changelog
  120. * Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-2
  121. - add BuildRequires: kdesdk-devel, soprano-devel
  122. * Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.0-1
  123. - new upstream release
  124. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.2-1
  125. - new upstream release
  126. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.0-1
  127. - new upstream release
  128. - split shared libraries and header files
  129. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.4-1
  130. - new upstream release
  131. - applied new versioning policy, spec in UTF-8
  132. - changed Group to Applications/Development
  133. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl2
  134. - rebuild for VineSeed
  135. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.5-0vl1
  136. - new upstream release
  137. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl2
  138. - rebuild for VineSeed
  139. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.4-0vl1
  140. - new upstream release
  141. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl2
  142. - rebuild for VineSeed
  143. * Fri Jun 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.3-0vl1
  144. - new upstream release
  145. - use ap?-config for Vine3.x and use ap?-1-config for VineSeed
  146. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  147. - rebuild for VineSeed
  148. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  149. - new upstream release
  150. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  151. - rebuild for VineSeed
  152. * Mon Feb 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  153. - new upstream release
  154. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl2
  155. - rebuild for VineSeed
  156. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl1
  157. - new upstream release
  158. - add BuildPrereq: apache2-devel subversion-devel
  159. * Tue Nov 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.0-0vl0.rc1
  160. - new upstream release
  161. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.92-0vl1
  162. - new upstream release
  163. - delete Patch0
  164. * Thu Sep 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.91-0vl1
  165. - new upstream release
  166. - add Patch0
  167. - update %%files
  168. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl2
  169. - rebuild for VineSeed
  170. * Mon Jul 25 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  171. - new upstream release
  172. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl2
  173. - rebuild for VineSeed
  174. * Tue Jul 5 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  175. - new upstream release
  176. - add --disable-rpath to configure option
  177. - remove BuildPrereq: qt-static
  178. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl2
  179. - rebuild for VineSeed
  180. * Sun Mar 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-0vl1
  181. - new upstream release
  182. - update %%files
  183. - add +w to %%{_prefix}/kdevbdb/*
  184. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl2
  185. - rebuild for VineSeed
  186. * Sun Jan 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  187. - new upstream release
  188. - update %%files
  189. * Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  190. - source upgrade
  191. - add BuildPrereq: qt-static
  192. * Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  193. - rebuild with qt32
  194. * Wed Jun 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  195. - source upgrade
  196. - remove lines about vine26
  197. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  198. - source upgrade
  199. - add Requires: ctags
  200. * Tue Mar 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-0vl1
  201. - source upgrade
  202. - remove all patches
  203. - remove c references
  204. - add Requires: htdig
  205. * Fri Feb 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl0
  206. - change spec to build both VineSeed and Vine2.5/2.6
  207. - change configure options
  208. - add %%clean section
  209. - add Requires: kdbg kdoc kdegraphics kdeutils kdesdk
  210. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.5-0vl1
  211. - source upgrade
  212. - change spec to build both VineSeed and Vine2.5/2.6
  213. - change configure option (add -enable--final, remove -enable--debug)
  214. - update %%files section
  215. * Thu Oct 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.3-0vl1
  216. - source upgrade
  217. - remove patch1 (rejected)
  218. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.2-0vl2
  219. - BuildPrereq: autoconf253 objprelink2 instead of autoconf252 objprelink
  220. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.2-0vl1
  221. - source upgrade
  222. - revised Source1
  223. - remove Patch1 and Patch4
  224. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.1.1-3vl1
  225. - merged with rawhide 2.1.1-3
  226. - clean up spec
  227. - add BuildPrereq: objprelink (i386 only)
  228. - remove Obsoletes: kdevelop-c_c++_ref
  229. - add BuildPrereq: autoconf252 automake15
  230. - There is Vine's previous changes, hacked for Vine
  231. -- Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0.2-2vl1
  232. - build for VineSeed
  233. - delete Epoch
  234. - update Patch1 and delete Patch2
  235. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  236. - automated rebuild
  237. * Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
  238. - don't forcibly strip binaries
  239. * Sun Jun 2 2002 Than Ngo <than@redhat.com> 2.1.1-1
  240. - 2.1.1
  241. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  242. - automated rebuild
  243. * Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
  244. - Use automake15
  245. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
  246. - Change sonames
  247. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
  248. - final
  249. * Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
  250. - update
  251. * Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
  252. - update to 2.1rc3
  253. * Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
  254. - update to 2.1rc2
  255. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
  256. - rebuild against new kdelibs
  257. * Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
  258. - fixed Strange characters appear in the output window (bug #59217)
  259. - fixed return-line feed sign in Kdevelop setup tool (bug #55032)
  260. * Wed Mar 8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
  261. - update to 2.1beta2
  262. * Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
  263. - rebuild against new kdelibs
  264. * Wed Jan 9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
  265. - update to 2.1 beta1
  266. - fix build against gcc 3
  267. - fix some typo bugs
  268. - get rid of libkfile
  269. - update c_cpp_reference to 2.0.1
  270. * Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
  271. - add patch to show non lattin1 font in build-in editor correct (bug #54457)
  272. * Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
  273. - fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
  274. - backport some major bugfixes from 2.0.1
  275. * Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
  276. - Don't crash on startup
  277. * Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
  278. - Fix file list
  279. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
  280. - Update
  281. * Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  282. - Yet another respin - printing was broken.
  283. * Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  284. - Update the C/C++ reference guide docs. The older version had a
  285. couple of examples that won't work with gcc 2.96-*
  286. * Thu Feb 22 2001 Than Ngo <than@redhat.com>
  287. - fix version number
  288. * Wed Feb 21 2001 Than Ngo <than@redhat.com>
  289. - 1.4-respin
  290. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  291. - 1.4
  292. * Wed Feb 14 2001 Than Ngo <than@redhat.com>
  293. - update (only bugfixes)
  294. - fix up kdelibs documentation path
  295. - fix a dependency problem with kde-i18n package (Bug #27675)
  296. - add qt-designer into requires
  297. * Sun Feb 11 2001 Than Ngo <than@redhat.com>
  298. - fixed to build on s390
  299. * Tue Feb 06 2001 Than Ngo <than@redhat.com>
  300. - update, only bugfixes
  301. * Wed Jan 24 2001 Than Ngo <than@redhat.com>
  302. - hacked for building of KDE references
  303. * Tue Jan 23 2001 Than Ngo <than@redhat.com>
  304. - work-around to build on alpha
  305. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  306. - Update
  307. * Wed Jan 10 2001 Than Ngo <than@redhat.com>
  308. - update new snapshot, only require KDE2/Qt2
  309. * Fri Dec 22 2000 Than Ngo <than@redhat.com>
  310. - fixed dependency problem with kde-i18n
  311. * Thu Dec 21 2000 Than Ngo <than@redhat.com>
  312. - updated to 1.4beta1 with KDE2 support
  313. - fixed to build on s390
  314. - fixed some broken codes
  315. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  316. - fixed for building on ia64
  317. * Wed Nov 15 2000 Than Ngo <than@redhat.com>
  318. - build snapshot 20001112, it works now with KDE2 and kde1-compat
  319. - fix libtool to build on sparc and alpha
  320. - don't use make -j
  321. * Sun Aug 13 2000 Than Ngo <than@redhat.com>
  322. - fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
  323. * Tue Aug 01 2000 Than Ngo <than@redhat.de>
  324. - add missing ldconfig in %post and %postun section (Bug #14924)
  325. - add missing C references stuff to kdevelop
  326. * Sun Jul 30 2000 Than Ngo <than@redhat.de>
  327. - rebuilt against compat-egcs-c++, put KDE1 under /usr
  328. - cleanup specfile
  329. * Tue Jul 25 2000 Than Ngo <than@redhat.de>
  330. - fix dependency problem
  331. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  332. - rebuilt against compat-libstdc++
  333. * Mon Jul 17 2000 Than Ngo <than@redhat.de>
  334. - install under /usr/share instead /usr/lib/kde1-compat/share,
  335. fix dependency problem
  336. * Sat Jul 15 2000 Than Ngo <than@redhat.de>
  337. - rebuilt with egcs-c++-1.1.2
  338. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  339. - automatic rebuild
  340. * Mon Jul 03 2000 Than Ngo <than@redhat.de>
  341. - fix docdir
  342. - add requires kdebase
  343. * Sun Jul 02 2000 Than Ngo <than@redhat.de>
  344. - rebuilt with kde1-compat
  345. * Sun Jun 18 2000 Than Ngo <than@redhat.de>
  346. - rebuilt in the new build environment, fix docdir
  347. - FHS packaging
  348. * Thu Jun 08 2000 Than Ngo <than@redhat.de>
  349. - update to 1.2
  350. - move from powertools to main CD
  351. - use %%configure
  352. * Mon Apr 3 2000 Ngo Than <than@redhat.de>
  353. - fix up reference (Bug #10368)
  354. * Tue Feb 15 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  355. - Fix up documentation path (Bug #7291)
  356. - Update to current stable branch - this should fix up the debugger problem
  357. - clean up spec file
  358. * Fri Jan 6 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  359. - Update to current stable branch
  360. - Adapt to 6.2 Qt libraries
  361. - Use BuildPrereq
  362. * Wed Jan 05 2000 Ngo Than <than@redhat.de>
  363. - added patch for alpha
  364. * Tue Dec 21 1999 Ngo Than <than@redhat.de>
  365. - updated kdevelop-1.0 release
  366. * Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
  367. - kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
  368. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  369. - initial packaging for 6.1.