gstreamer1-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266
  1. # keep in sync with the VERSION. gstreamer can append a .0.1 to CVS snapshots.
  2. %define major 1.0
  3. %define po_package gstreamer-%{major}
  4. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  5. Name: gstreamer1
  6. Summary: GStreamer streaming media framework runtime.
  7. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  8. Version: 1.22.6
  9. Release: 1%{?_dist_release}
  10. Group: multimedia,system
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: LGPL
  14. URL: https://gstreamer.freedesktop.org/
  15. Source: https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: meson
  18. BuildRequires: glib2-devel
  19. BuildRequires: gobject-introspection-devel
  20. BuildRequires: libxml2-devel
  21. BuildRequires: bison
  22. BuildRequires: flex
  23. BuildRequires: gettext
  24. BuildRequires: libunwind-devel
  25. BuildRequires: elfutils-devel
  26. BuildRequires: bash-completion
  27. %description
  28. GStreamer is a streaming-media framework, based on graphs of filters which
  29. operate on media data. Applications using this library can do anything
  30. from real-time sound processing to playing videos, and just about anything
  31. else media-related. Its plugin-based architecture means that new data
  32. types or processing capabilities can be added simply by installing new
  33. plugins.
  34. %package devel
  35. Summary: Libraries/header files for GStreamer streaming media framework.
  36. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  37. Group: programming
  38. Requires: %{name} = %{version}-%{release}
  39. Requires: glib2-devel%{?_isa}
  40. Requires: libxml2-devel%{?_isa}
  41. %description devel
  42. GStreamer is a streaming-media framework, based on graphs of filters which
  43. operate on media data. Applications using this library can do anything
  44. from real-time sound processing to playing videos, and just about anything
  45. else media-related. Its plugin-based architecture means that new data
  46. types or processing capabilities can be added simply by installing new
  47. plugins.
  48. This package contains the libraries and includes files necessary to develop
  49. applications and plugins for GStreamer.
  50. # compat32
  51. %package -n compat32-%{name}
  52. Summary: GStreamer streaming media framework runtime.
  53. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  54. Group: system,multimedia,legacy
  55. %description -n compat32-%{name}
  56. GStreamer is a streaming-media framework, based on graphs of filters which
  57. operate on media data. Applications using this library can do anything
  58. from real-time sound processing to playing videos, and just about anything
  59. else media-related. Its plugin-based architecture means that new data
  60. types or processing capabilities can be added simply by installing new
  61. plugins.
  62. %package -n compat32-%{name}-devel
  63. Summary: Libraries/header files for GStreamer streaming media framework.
  64. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  65. Group: programming,legacy
  66. Requires: compat32-%{name} = %{version}-%{release}
  67. Requires: %{name}-devel = %{version}-%{release}
  68. %description -n compat32-%{name}-devel
  69. GStreamer is a streaming-media framework, based on graphs of filters which
  70. operate on media data. Applications using this library can do anything
  71. from real-time sound processing to playing videos, and just about anything
  72. else media-related. Its plugin-based architecture means that new data
  73. types or processing capabilities can be added simply by installing new
  74. plugins.
  75. This package contains the libraries and includes files necessary to develop
  76. applications and plugins for GStreamer.
  77. %debug_package
  78. %prep
  79. %setup -q -n gstreamer-%{version}
  80. %build
  81. %meson \
  82. -Dpackage-name='Vine Linux gstreamer package' \
  83. -Dpackage-origin='https://vinelinux.org/' \
  84. -Dtests=disabled \
  85. -Dexamples=disabled \
  86. -Dcheck=disabled \
  87. -Ddbghelp=disabled \
  88. -Ddoc=disabled
  89. %meson_build
  90. %install
  91. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  92. %meson_install
  93. %find_lang %{po_package}
  94. %clean
  95. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  96. %files -f %{po_package}.lang
  97. %defattr(-, root, root)
  98. %license COPYING
  99. %doc AUTHORS ChangeLog README NEWS RELEASE
  100. %{_bindir}/*
  101. %dir %{_libdir}/gstreamer-%{major}
  102. %{_libdir}/gstreamer-%{major}/*.so*
  103. %{_libdir}/*.so.*
  104. %{_libdir}/girepository-1.0/*.typelib
  105. %dir %{_libexecdir}/gstreamer-%{major}
  106. %{_libexecdir}/gstreamer-%{major}/*
  107. %dir %{_datadir}/bash-completion
  108. %dir %{_datadir}/bash-completion/completions
  109. %{_datadir}/bash-completion/completions/gst-inspect-1.0
  110. %{_datadir}/bash-completion/completions/gst-launch-1.0
  111. %{_datadir}/bash-completion/helpers/gst
  112. %doc %{_mandir}/man1/*
  113. %files devel
  114. %defattr(-, root, root)
  115. %dir %{_includedir}/gstreamer-%{major}
  116. %{_includedir}/gstreamer-%{major}/*
  117. %{_libdir}/*.so
  118. %{_libdir}/pkgconfig/gstreamer*.pc
  119. %{_datadir}/aclocal/*.m4
  120. %{_datadir}/gir-1.0/*.gir
  121. %dir %{_datadir}/gdb
  122. %dir %{_datadir}/gdb/auto-load
  123. %dir %{_datadir}/gdb/auto-load/usr
  124. %dir %{_datadir}/gdb/auto-load/usr/%{_lib}
  125. %{_datadir}/gdb/auto-load/usr/%{_lib}/libgstreamer-%{major}.so.*-gdb.py
  126. %dir %{_datadir}/gstreamer-%{major}
  127. %dir %{_datadir}/gstreamer-%{major}/gdb
  128. %{_datadir}/gstreamer-%{major}/gdb/glib_gobject_helper.py
  129. %{_datadir}/gstreamer-%{major}/gdb/gst_gdb.py
  130. # compat32
  131. %if %{build_compat32}
  132. %files -n compat32-%{name}
  133. %defattr(-, root, root)
  134. %dir %{_libdir}/gstreamer-%{major}
  135. %{_libdir}/gstreamer-%{major}/*.so*
  136. %{_libdir}/*.so.*
  137. %files -n compat32-%{name}-devel
  138. %defattr(-, root, root)
  139. %{_libdir}/*.so
  140. %endif
  141. %changelog
  142. * Mon Oct 02 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.6-1
  143. - new upstream release.
  144. * Fri Jul 29 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.20.3-1
  145. - new upstream release.
  146. * Thu Apr 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18.2-1
  147. - new upstream release.
  148. - dropped ldconfig scriptlets.
  149. * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.2-1
  150. - new upstream release.
  151. * Sat Jun 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  152. - new upstream release.
  153. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.4-1
  154. - new upstream release.
  155. * Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.4-1
  156. - new upstream release.
  157. * Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  158. - new upstream release
  159. * Wed May 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  160. - new upstream release
  161. * Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.3-1
  162. - new upstream release
  163. * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
  164. - new upstream release
  165. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  166. - new upstream release
  167. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.5-1
  168. - new upstream release
  169. * Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
  170. - new upstream release
  171. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
  172. - new upstream release
  173. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  174. - new upstream release
  175. * Sun Mar 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
  176. - new upstream release
  177. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
  178. - new upstream release
  179. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  180. - new upstream release
  181. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  182. - new upstream release
  183. * Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  184. - new upstream release
  185. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
  186. - new upstream release
  187. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  188. - new upstream release
  189. * Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  190. - new upstream release
  191. * Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
  192. - new upstream release
  193. * Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  194. - new upstream release
  195. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  196. - new upstream release
  197. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
  198. - new upstream release
  199. * Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
  200. - new upstream release
  201. * Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  202. - initial build