webkitgtk4-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360
  1. %bcond_with clang
  2. ## NOTE: Lots of files in various subdirectories have the same name (such as
  3. ## "LICENSE") so this short macro allows us to distinguish them by using their
  4. ## directory names (from the source tree) as prefixes for the files.
  5. %global add_to_license_files() \
  6. mkdir -p _license_files ; \
  7. cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
  8. Summary: GTK+ Web content engine library
  9. Name: webkitgtk4
  10. Version: 2.28.4
  11. Release: 1%{?_dist_release}
  12. Group: system
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. License: LGPLv2
  16. URL: http://www.webkitgtk.org/
  17. Source0: https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
  18. %if %{with clang}
  19. BuildRequires: clang
  20. BuildRequires: lld
  21. %endif
  22. BuildRequires: at-spi2-core-devel
  23. BuildRequires: bison
  24. BuildRequires: bubblewrap
  25. BuildRequires: cairo-devel
  26. BuildRequires: cmake
  27. BuildRequires: enchant2-devel
  28. BuildRequires: flex
  29. BuildRequires: fontconfig-devel
  30. BuildRequires: freetype-devel
  31. BuildRequires: geoclue2-devel
  32. BuildRequires: gettext
  33. BuildRequires: glib2-devel
  34. BuildRequires: gobject-introspection-devel
  35. BuildRequires: gperf
  36. BuildRequires: gstreamer1-devel
  37. BuildRequires: gstreamer1-plugins-base-devel
  38. BuildRequires: gtk2-devel
  39. BuildRequires: gtk3-devel
  40. BuildRequires: harfbuzz-icu-devel
  41. BuildRequires: libicu-devel
  42. BuildRequires: libjpeg-turbo-devel
  43. BuildRequires: libpng-devel
  44. BuildRequires: libseccomp-devel
  45. BuildRequires: libsecret-devel
  46. BuildRequires: libsoup-devel
  47. BuildRequires: libwebp-devel
  48. BuildRequires: libxslt-devel
  49. BuildRequires: libXt-devel
  50. BuildRequires: ninja
  51. BuildRequires: mesa-libGL-devel
  52. BuildRequires: pcre-devel
  53. BuildRequires: python3-devel
  54. BuildRequires: ruby
  55. BuildRequires: sqlite3-devel
  56. BuildRequires: libnotify-devel
  57. BuildRequires: hyphen-devel
  58. BuildRequires: woff2-devel
  59. BuildRequires: xdg-dbus-proxy
  60. Requires: geoclue2
  61. # for sandbox
  62. Requires: bubblewrap
  63. Requires: xdg-dbus-proxy
  64. # Require the jsc subpackage
  65. Requires: %{name}-jsc = %{version}-%{release}
  66. # Obsolete libwebkit2gtk from the webkitgtk3 package
  67. Obsoletes: libwebkit2gtk < 2.4.5-3
  68. Provides: libwebkit2gtk = %{version}-%{release}
  69. # Filter out provides for private libraries
  70. %global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
  71. %description
  72. WebKitGTK+ is the port of the portable web rendering engine WebKit to the
  73. GTK+ platform.
  74. This package contains WebKitGTK+ for GTK+ 3.
  75. %package devel
  76. Summary: Development files for %{name}
  77. Group: programming
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: %{name}-jsc-devel = %{version}-%{release}
  80. %description devel
  81. The %{name}-devel package contains libraries, build data, and header
  82. files for developing applications that use %{name}.
  83. %package jsc
  84. Summary: JavaScript engine from %{name}
  85. Group: system
  86. %description jsc
  87. This package contains JavaScript engine from %{name}.
  88. %package jsc-devel
  89. Summary: Development files for JavaScript engine from %{name}
  90. Group: programming
  91. Requires: %{name}-jsc = %{version}-%{release}
  92. %description jsc-devel
  93. The %{name}-jsc-devel package contains libraries, build data, and header
  94. files for developing applications that use JavaScript engine from %{name}.
  95. %debug_package
  96. %prep
  97. %setup -q -n webkitgtk-%{version}
  98. # Remove bundled libraries
  99. rm -rf Source/ThirdParty/leveldb/
  100. rm -rf Source/ThirdParty/gtest/
  101. rm -rf Source/ThirdParty/qunit/
  102. %build
  103. # binutils-2.23 doesn't support "reduce-memory-overheads"
  104. # Use linker flags to reduce memory consumption
  105. # global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
  106. %if %{with clang}
  107. %ifnarch x86_64
  108. %define cflags_add --rtlib=compiler-rt
  109. %endif
  110. %global optflags %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
  111. %else
  112. %global optflags %{optflags} -DENABLE_YARR_JIT=0
  113. %endif
  114. mkdir -p %{_target_platform}
  115. pushd %{_target_platform}
  116. %if %{with clang}
  117. export CC=clang
  118. export CXX=clang++
  119. export LD=ld.lld
  120. %endif
  121. %cmake \
  122. -GNinja \
  123. %if %{with clang}
  124. -DCOMPILER_IS_CLANG=ON \
  125. -DCMAKE_CXX_COMPILER=clang++ \
  126. %endif
  127. -DPORT=GTK \
  128. -DCMAKE_BUILD_TYPE=Release \
  129. -DENABLE_JIT=OFF \
  130. -DENABLE_LLINT_C_LOOP=ON \
  131. -DUSE_GSTREAMER_GL=OFF \
  132. -DUSE_OPENJPEG=OFF \
  133. -DENABLE_GTKDOC=OFF \
  134. ..
  135. popd
  136. ninja -C %{_target_platform}
  137. %install
  138. DESTDIR=%{buildroot} ninja -C %{_target_platform} install
  139. %find_lang WebKit2GTK-4.0
  140. # Finally, copy over and rename various files for %%license inclusion
  141. %add_to_license_files Source/JavaScriptCore/COPYING.LIB
  142. %add_to_license_files Source/JavaScriptCore/icu/LICENSE
  143. %add_to_license_files Source/ThirdParty/ANGLE/LICENSE
  144. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
  145. %add_to_license_files Source/WebCore/icu/LICENSE
  146. %add_to_license_files Source/WebCore/LICENSE-APPLE
  147. %add_to_license_files Source/WebCore/LICENSE-LGPL-2
  148. %add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
  149. %add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
  150. %add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
  151. %add_to_license_files Source/WTF/icu/LICENSE
  152. %add_to_license_files Source/WTF/wtf/dtoa/COPYING
  153. %add_to_license_files Source/WTF/wtf/dtoa/LICENSE
  154. %post -p /sbin/ldconfig
  155. %postun -p /sbin/ldconfig
  156. %post jsc -p /sbin/ldconfig
  157. %postun jsc -p /sbin/ldconfig
  158. %files -f WebKit2GTK-4.0.lang
  159. %license _license_files/*
  160. %{_libdir}/libwebkit2gtk-4.0.so.*
  161. %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
  162. %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
  163. %{_libdir}/webkit2gtk-4.0/
  164. %{_libexecdir}/webkit2gtk-4.0/*
  165. %exclude %{_libexecdir}/webkit2gtk-4.0/jsc
  166. %{_bindir}/WebKitWebDriver
  167. %files jsc
  168. %license _license_files/*JavaScriptCore*
  169. %dir %{_libexecdir}/webkit2gtk-4.0/
  170. %{_libexecdir}/webkit2gtk-4.0/jsc
  171. %{_libdir}/libjavascriptcoregtk-4.0.so.*
  172. %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
  173. %files devel
  174. %{_includedir}/webkitgtk-4.0/*
  175. %exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  176. %{_libdir}/libwebkit2gtk-4.0.so
  177. %{_libdir}/pkgconfig/webkit2gtk-4.0.pc
  178. %{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
  179. %{_datadir}/gir-1.0/WebKit2-4.0.gir
  180. %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
  181. %files jsc-devel
  182. %dir %{_includedir}/webkitgtk-4.0
  183. %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  184. %{_libdir}/libjavascriptcoregtk-4.0.so
  185. %{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
  186. %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
  187. %changelog
  188. * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.4-1
  189. - new upstream release.
  190. * Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.3-1
  191. - new upstream release.
  192. * Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.2-1
  193. - new upstream release.
  194. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
  195. - new upstream release.
  196. - rebuilt with libicu67.
  197. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
  198. - rebuilt with libicu66.
  199. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
  200. - new upstream release.
  201. - dropped Patch1: fixed in upstream.
  202. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
  203. - new upstream release.
  204. - built with icu-65.
  205. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
  206. - new upstream release.
  207. - switched build-system to ninja.
  208. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
  209. - new upstream release.
  210. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
  211. - new upstream release.
  212. * Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
  213. - new upstream release.
  214. - added subpackages webkitgtk4-jsc{,-devel}.
  215. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
  216. - new upstream release.
  217. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
  218. - rebuilt with new toolchain.
  219. * Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
  220. - new upstream release
  221. (including security fix for CVE-2016-1856,1857)
  222. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
  223. - new upstream release
  224. - remove Patch0
  225. - add BuildRequires: libnotify-devel, hyphen-devel
  226. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
  227. - rebuild with gnutls-3.4.7
  228. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
  229. - rebuild with icu-56.1
  230. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
  231. - new upstream release
  232. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
  233. - new upstream release
  234. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
  235. - new upstream release
  236. * Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
  237. - new upstream release
  238. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
  239. - new upstream release
  240. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  241. - new upstream release
  242. - update Patch0
  243. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  244. - new upstream release
  245. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
  246. - add Group tag
  247. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
  248. - new upstream release
  249. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  250. - new upstream release
  251. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  252. - initial build for Vine Linux
  253. * Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
  254. - Add the wrongly removed CLoop patch and remove the one that was upstreamed
  255. * Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
  256. - Update to 2.6.0
  257. * Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
  258. - Update to 2.5.90
  259. * Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
  260. - Obsolete libwebkit2gtk from the webkitgtk3 package
  261. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
  262. - rebuild for ICU 53.1
  263. * Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
  264. - Add support for secondary arches
  265. * Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
  266. - Add webkitgtk-2.5.3-toggle-buttons.patch
  267. * Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
  268. - More package review fixes (#1131284)
  269. - Correct the license tag to read LGPLv2
  270. - Filter out provides for private libraries
  271. * Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
  272. - Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
  273. * Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
  274. - Update to 2.5.3
  275. * Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
  276. - Initial Fedora packaging, based on the webkitgtk3 package