gnutls-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %global guile_shortver %(guile-config --version 2>&1 | sed -e 's/^guile-config.*version //' -e ' s/\.[0-9]*$//')
  3. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  4. Summary: GNU TLS Library
  5. Summary(ja): GNU TLS ライブラリ
  6. Name: gnutls
  7. Version: 3.6.15
  8. Release: 1%{?_dist_release}
  9. Group: system
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. # The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
  13. License: GPLv3+ and LGPLv2+
  14. URL: https://www.gnutls.org/
  15. %global shortver %(echo "%{version}" | sed -e 's/\.[0-9]*$//')
  16. Source0: https://www.gnupg.org/ftp/gcrypt/gnutls/v%{shortver}/%{name}-%{version}.tar.xz
  17. Source1: libgnutls-config
  18. #patches from fedora development
  19. Patch1: gnutls-3.2.7-rpath.patch
  20. Patch2: gnutls-3.6.7-no-now-guile.patch
  21. # Vine Patches
  22. # Nothing...
  23. # Security fixes
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: libtasn1-devel >= 4.13
  26. Requires: libtasn1 >= 4.13
  27. BuildRequires: libunistring-devel
  28. BuildRequires: datefudge >= 1.22
  29. BuildRequires: gmp-devel
  30. BuildRequires: gettext readline-devel libtool
  31. BuildRequires: guile-devel >= 1.8.6
  32. BuildRequires: p11-kit-devel >= 0.21.3
  33. BuildRequires: nettle-devel >= 3.6
  34. Requires: nettle >= 3.6
  35. BuildRequires: texinfo, autogen
  36. BuildRequires: unbound-devel unbound-libs
  37. BuildRequires: zlib-devel
  38. Requires: zlib
  39. # for tests
  40. BuildRequires: net-tools
  41. Requires(post): ldconfig
  42. Requires(postun): ldconfig
  43. %description
  44. GnuTLS is a project that aims to develop a library which provides a secure
  45. layer, over a reliable transport layer. Currently the GnuTLS library implements
  46. the proposed standards by the IETF's TLS working group.
  47. #'
  48. %package devel
  49. Summary: Development files for the GnuTLS package.
  50. Summary(ja): GnuTLS の開発用ファイル
  51. Group: programming
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: libgcrypt-devel, zlib-devel, pkgconfig
  54. Requires: libtasn1-devel, nettle-devel
  55. Provides: pkgconfig(gnutls) = %{version}
  56. Provides: pkgconfig(gnutls-dane) = %{version}
  57. Requires(post,preun): /sbin/install-info
  58. %description devel
  59. GnuTLS is a project that aims to develop a library which provides a secure
  60. layer, over a reliable transport layer. Currently the GnuTLS library implements
  61. the proposed standards by the IETF's TLS working group.
  62. This package contains files needed for developing applications with the GnuTLS
  63. library.
  64. #'
  65. %package utils
  66. Summary: Command line tools for TLS protocol.
  67. Summary(ja): GnuTLS のコマンドラインツール
  68. Group: system
  69. Requires: %{name} = %{version}-%{release}
  70. %description utils
  71. GnuTLS is a project that aims to develop a library which provides a secure
  72. layer, over a reliable transport layer. Currently the GnuTLS library implements
  73. the proposed standards by the IETF's TLS working group.
  74. This package contains command line TLS client and server and certificate
  75. manipulation tools.
  76. #'
  77. %package guile
  78. Summary: Guile bindings for the GNUTLS library
  79. Group: programming
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: guile
  82. %description guile
  83. GnuTLS is a project that aims to develop a library which provides a secure
  84. layer, over a reliable transport layer. Currently the GnuTLS library implements
  85. the proposed standards by the IETF's TLS working group.
  86. This package contains Guile bindings for the library.
  87. #'
  88. %package c++
  89. Summary: The C++ interface to GnuTLS
  90. Group: system
  91. Requires: %{name} = %{version}-%{release}
  92. %description c++
  93. GnuTLS is a project that aims to develop a library which provides a secure
  94. layer, over a reliable transport layer. Currently the GnuTLS library implements
  95. the proposed standards by the IETF's TLS working group.
  96. This package contains the C++ interface for the GnuTLS library.
  97. #'
  98. %package -n compat32-%{name}
  99. Summary: GNU TLS Library
  100. Summary(ja): GNU TLS ライブラリ
  101. Group: system
  102. Requires: %{name} = %{version}-%{release}
  103. %description -n compat32-%{name}
  104. GnuTLS is a project that aims to develop a library which provides a secure
  105. layer, over a reliable transport layer. Currently the GnuTLS library implements
  106. the proposed standards by the IETF's TLS working group.
  107. #'
  108. %package -n compat32-%{name}-devel
  109. Summary: Development files for the GnuTLS package.
  110. Summary(ja): GnuTLS の開発用ファイル
  111. Group: programming
  112. Requires: compat32-%{name} = %{version}-%{release}
  113. Requires: %{name}-devel = %{version}-%{release}
  114. Requires: compat32-libgcrypt-devel, compat32-zlib-devel
  115. Requires(post,preun): /sbin/install-info
  116. %description -n compat32-%{name}-devel
  117. GnuTLS is a project that aims to develop a library which provides a secure
  118. layer, over a reliable transport layer. Currently the GnuTLS library implements
  119. the proposed standards by the IETF's TLS working group.
  120. This package contains files needed for developing applications with the GnuTLS
  121. library.
  122. #'
  123. %package -n compat32-%{name}-guile
  124. Summary: Guile bindings for the GNUTLS library
  125. Group: system
  126. Requires: compat32-%{name} = %{version}-%{release}
  127. Requires: %{name}-guile = %{version}-%{release}
  128. %description -n compat32-%{name}-guile
  129. GnuTLS is a project that aims to develop a library which provides a secure
  130. layer, over a reliable transport layer. Currently the GnuTLS library implements
  131. the proposed standards by the IETF's TLS working group.
  132. This package contains Guile bindings for the library.
  133. #'
  134. %debug_package
  135. %prep
  136. %autosetup -p1
  137. sed -i -e 's|sys_lib_dlsearch_path_spec="/lib /usr/lib|sys_lib_dlsearch_path_spec="/lib /usr/lib %{_libdir}|g' configure
  138. rm -f lib/minitasn1/*.c lib/minitasn1/*.h
  139. rm -f src/libopts/*.c src/libopts/*.h src/libopts/compat/*.c src/libopts/compat/*.h
  140. echo "SYSTEM=NORMAL" >> tests/system.prio
  141. %build
  142. export LDFLAGS="-Wl,--no-add-needed"
  143. # autoreconf -fi
  144. %configure \
  145. --enable-sha1-support \
  146. --disable-static \
  147. --disable-openssl-compatibility \
  148. --disable-non-suiteb-curves \
  149. --enable-guile \
  150. --with-unbound-root-key-file=/var/lib/unbound/root.key \
  151. --enable-dane \
  152. --disable-rpath \
  153. %{nil}
  154. # --with-libgcrypt
  155. # --with-lzo \
  156. # --with-included-libcfg \
  157. # --with-libtasn1-prefix=%{_prefix} \
  158. # --with-included-libtasn1 \
  159. # --with-included-opencdk \
  160. # --with-included-lzo \
  161. make %{?_smp_mflags}
  162. # cp lib/COPYING COPYING.LIB
  163. %install
  164. %__rm -rf %{buildroot}
  165. # makeinstall macro causes build error, why?
  166. make install DESTDIR=%{buildroot}
  167. rm -f %{buildroot}%{_infodir}/dir
  168. rm -f %{buildroot}%{_libdir}/*.la
  169. rm -f %{buildroot}%{_libdir}/libguile*.a
  170. rm -f %{buildroot}%{_libdir}/guile/%{guile_shortver}/*.la
  171. rm -f %{buildroot}%{_libdir}/guile/%{guile_shortver}/extensions/*.la
  172. rm -f %{buildroot}%{_libdir}/gnutls/libpkcs11mock1.*
  173. rm -rf %{buildroot}%{_docdir}/gnutls
  174. %find_lang gnutls
  175. %check
  176. make check %{?_smp_mflags}
  177. %clean
  178. rm -rf %{buildroot}
  179. %post -p /sbin/ldconfig
  180. %postun -p /sbin/ldconfig
  181. %post devel
  182. if [ -f %{_infodir}/gnutls.info.gz ]; then
  183. /sbin/install-info %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
  184. fi
  185. %preun devel
  186. if [ $1 = 0 -a -f %{_infodir}/gnutls.info.gz ]; then
  187. /sbin/install-info --delete %{_infodir}/gnutls.info.gz %{_infodir}/dir || :
  188. fi
  189. %post guile -p /sbin/ldconfig
  190. %postun guile -p /sbin/ldconfig
  191. %post -n compat32-%{name} -p /sbin/ldconfig
  192. %postun -n compat32-%{name} -p /sbin/ldconfig
  193. %post -n compat32-%{name}-guile -p /sbin/ldconfig
  194. %postun -n compat32-%{name}-guile -p /sbin/ldconfig
  195. %files -f gnutls.lang
  196. %defattr(-,root,root,-)
  197. %{_libdir}/libgnutls.so.30*
  198. %{_libdir}/libgnutls-dane.so.*
  199. # %{_libdir}/libgnutls-xssl.so.0*
  200. %doc README* AUTHORS NEWS THANKS
  201. %files devel
  202. %defattr(-,root,root,-)
  203. %{_includedir}/*
  204. %{_libdir}/libgnutls*.so
  205. %{_libdir}/pkgconfig/*.pc
  206. %{_mandir}/man3/*
  207. %{_infodir}/gnutls*
  208. %{_infodir}/pkcs11-vision.png.gz
  209. %files utils
  210. %defattr(-,root,root,-)
  211. %{_bindir}/certtool
  212. %{_bindir}/danetool
  213. %{_bindir}/psktool
  214. %{_bindir}/p11tool
  215. %{_bindir}/ocsptool
  216. %{_bindir}/srptool
  217. %{_bindir}/gnutls*
  218. %{_mandir}/man1/*
  219. %doc doc/certtool.cfg
  220. %files guile
  221. %defattr(-,root,root,-)
  222. %{_libdir}/guile/%{guile_shortver}/extensions/guile*.so*
  223. %{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls.go
  224. %{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls/extra.go
  225. %{_datadir}/guile/site/%{guile_shortver}/gnutls
  226. %{_datadir}/guile/site/%{guile_shortver}/gnutls.scm
  227. %files c++
  228. %{_libdir}/libgnutlsxx.so.*
  229. %if %{build_compat32}
  230. %files -n compat32-%{name}
  231. %defattr(-,root,root,-)
  232. %{_libdir}/libgnutls.so.30*
  233. %{_libdir}/libgnutls-dane.so.*
  234. # %{_libdir}/libgnutls-xssl.so.0*
  235. %files -n compat32-%{name}-devel
  236. %defattr(-,root,root,-)
  237. #%{_libdir}/libgnutls*.a
  238. %{_libdir}/libgnutls*.so
  239. %files -n compat32-%{name}-guile
  240. %defattr(-,root,root,-)
  241. %{_libdir}/guile/%{guile_shortver}/extensions/guile*.so*
  242. %{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls.go
  243. %{_libdir}/guile/%{guile_shortver}/site-ccache/gnutls/extra.go
  244. %endif
  245. %changelog
  246. * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.15-1
  247. - new upstream release.
  248. * Thu Jun 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.14-1
  249. - new upstream release.
  250. * Tue Apr 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.13-1
  251. - new upstream release.
  252. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.9-1
  253. - new upstream release.
  254. * Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.7-1
  255. - new upstream release.
  256. - updated Patch2.
  257. - dropped Patch3.
  258. * Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6.4-1
  259. - new upstream release.
  260. - dropped Patch2-3,1001 and 2001.
  261. - imported Patch2-3 from rawhide.
  262. - enabled DANE support.
  263. * Sat Jan 28 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.4.14-3
  264. - fix CVE-2017-5337, CVE-2017-5334, CVE-2017-5336, CVE-2017-5335
  265. - add Patch3001 from Fedora 24 gnutls-3.4.17-2.fc24
  266. * Thu Jan 12 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.4.14-2
  267. - fix CVE-2016-7444; OCSP validation issue
  268. - add Patch2001
  269. - add BR: net-tools; for test
  270. * Thu Jul 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.14-1
  271. - new upstream release 3.4.14.
  272. - dropped Patch100.
  273. - added BR: datefudge.
  274. * Mon Jul 4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.13-1
  275. - new upstream release 3.4.13.
  276. - added Patch100: workaround of failing cert-test (The certificate was expired).
  277. * Sun Feb 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.9-1
  278. - new upstream release 3.4.9
  279. * Fri Jan 1 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-2
  280. - rebuilt to marge changelog
  281. * Tue Dec 29 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.4.7-1
  282. - new upstream release 3.4.7
  283. * Tue Dec 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.17-3
  284. - rebuild with nettls-3.1.1
  285. * Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-2
  286. - BR: libtasn1-devel >= 3.9
  287. * Fri Aug 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-1
  288. - built for release
  289. * Tue Aug 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.2
  290. - rm libgnutls-xssl.so.0* in files list
  291. * Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.3.17-0.1
  292. - for test
  293. * Mon Aug 17 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-3
  294. - add patch1000 for fix SA-2015-3
  295. * Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2.20-2
  296. - rebuilt with guile 2.0.11
  297. * Tue Nov 18 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.20-1
  298. - new upstream release with security fix
  299. * Thu Jun 5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.15-1
  300. - new upstream release with security fix
  301. * Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.12.1-1
  302. - new upstream release with security fix
  303. * Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.11-1
  304. - new upstream release with security fix
  305. * Sun Feb 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-3
  306. - fix R: in compat32
  307. * Wed Feb 5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-2
  308. - fix BR:, R: (drop unneeded dependency)
  309. * Mon Feb 3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.2.10-1
  310. - new upstream release 3.2.10
  311. - update patches / drop old patches
  312. - add BR: nettle
  313. * Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
  314. - added Patch100 from upstream to fix CVE-2013-2116
  315. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
  316. - new upstream release
  317. - fixed a day of the week in %%changelog
  318. * Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
  319. - new upstream release
  320. * Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
  321. - new upstream release
  322. * Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
  323. - new upstream release
  324. * Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
  325. - new upstream release
  326. * Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
  327. - new upstream release
  328. - changed BuildRequires: p11-kit-devel >= 0.11
  329. * Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
  330. - new upstream release
  331. * Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
  332. - new upstream release
  333. * Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
  334. - added BuildRequires: p11-kit-devel
  335. * Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
  336. - deleted BuildRequires: nettle-devel
  337. - mistake.. fixed.
  338. * Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
  339. - new upstream release
  340. - synced Fedora development package
  341. - add new sub-package: c++
  342. * Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
  343. - add Requires: libtasn1-devel for devel subpackage
  344. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
  345. - new upstream release
  346. * Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
  347. - new upstream release
  348. * Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
  349. - new upstream release
  350. - dropt patch1
  351. * Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
  352. - new upstream release
  353. - added patch1,2,3,4 from Fedora development
  354. - added BuildRequires: gettext readline-devel libtool
  355. - added configure option
  356. --disable-static,--disable-srp-authentication
  357. - dropt *.a files from -devel package again
  358. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
  359. - build with rpm-4.8.1-1 for pkg-config file
  360. * Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
  361. - new upstream release
  362. - applied new naming policy to spec
  363. * Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
  364. - new upstream release
  365. * Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
  366. - new upstream release
  367. * Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
  368. - new upstream release
  369. * Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
  370. - new upstream release with security fix (handling X.509 CN or SAN fields)
  371. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
  372. - added compat32 package for x86_64 arch support
  373. * Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
  374. - new upstream release
  375. - added autoreconf
  376. - deleted libguile*.a
  377. - dropt Patch3
  378. - added %post guile, %postun guile
  379. * Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
  380. - drop *.a files from -devel package
  381. - build with system lzo
  382. * Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
  383. - new upstream release with security fixes (CVE-2009-1415,1416,1417)
  384. * Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
  385. - update to 2.6.5
  386. * Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
  387. - spec in UTF-8
  388. * Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
  389. - update to 2.6.4
  390. - modifeid Source0
  391. * Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
  392. - add BuildRequires: guile-devel >= 1.8.6
  393. * Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
  394. - update to 2.6.3
  395. - import from fedora developing's 2.6.3
  396. - License tag fixed
  397. - dropped patch0, patch1, patch2
  398. - added patch3
  399. - added BuildRequires: gmp-devel
  400. - add new sub-package: guile
  401. - added %package guile, %description guile, %files guile
  402. * Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
  403. - used %%{?_dist_release} macro
  404. * Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
  405. - update to 1.6.3 (use no-SRP source)
  406. - import from fedora core's 1.6.3-2
  407. - nosrc.tar.bz2 (source0)
  408. - license tag fix
  409. - build with system libtasn1
  410. * Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  411. - update to 1.4.5 (use no-SRP source)
  412. - import from fedora core's 1.4.5-1
  413. - nosrc.tar.bz2 (source0)
  414. - drop obsolete cve-2006-4790.patch (patch3)
  415. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
  416. - [SECURITY] update to 1.4.1 (use no-SRP source)
  417. - import from fedora core's 1.4.1-2
  418. - nosrp.tar.bz2 (source0)
  419. - libgnutls-config (source1)
  420. - nosrc.patch (patch0)
  421. - enable-psk.patch (patch1)
  422. - cve-2006-4790.patch (patch3)
  423. - update required version of libgcrypt (>= 1.2.2)
  424. - add Requires: pkgconfig to -devel package
  425. - add %%check section
  426. - update %%files
  427. - add new sub-package: utils
  428. * Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
  429. - [SECURITY FIX] upstream release
  430. - record packet parsing denial of service (CAN-2005-1431)
  431. * Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
  432. - initial build for Vine Linux
  433. - upstream release
  434. * Wed Mar 2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
  435. - gcc4 rebuild
  436. * Tue Jan 4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
  437. - add gnutls Requires zlib-devel (#144069)
  438. * Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
  439. - Make gnutls-devel Require libgcrypt-devel
  440. * Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
  441. - rebuild with release++, otherwise unchanged.
  442. * Tue Sep 7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
  443. - patent tainted SRP code removed.
  444. * Sun Sep 5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
  445. - update to 1.0.20.
  446. - add --with-included-opencdk --with-included-libtasn1
  447. - add --with-included-libcfg --with-included-lzo
  448. - add --disable-srp-authentication.
  449. - do "make check" after build.
  450. * Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
  451. - upgrade to 0.9.2
  452. * Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
  453. - update to 0.4.4.
  454. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  455. - automated rebuild
  456. * Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
  457. - update to 0.4.3.
  458. * Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
  459. - update to 0.4.2.
  460. - change license to LGPL.
  461. - include splint annotations patch.
  462. * Tue Apr 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
  463. - update to 0.4.0
  464. * Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
  465. - update to 0.3.2
  466. * Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
  467. - add a URL
  468. * Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
  469. - initial package