network-manager-applet-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264
  1. %define _unpackaged_files_terminate_build 1
  2. %define dbus_version 1.4.20
  3. %define dbus_glib_version 0.96
  4. %define gtk3_version 3.10.0
  5. %define wireless_tools_version 29
  6. %define libnl3_version 3.4.0
  7. %define ppp_version 2.4.7
  8. #define snapshot .git20090414
  9. #define applet_snapshot %{nil}
  10. Name: network-manager-applet
  11. Summary: GNOME applications for use with NetworkManager
  12. Summary(ja): NetworkManager 用 GNOME アプリケーション
  13. Version: 1.8.10
  14. Release: 1%{?snapshot}%{?_dist_release}
  15. Group: Applications/Internet
  16. License: GPLv2+
  17. URL: http://www.gnome.org/projects/NetworkManager/
  18. Source: %{name}-%{version}.tar.gz
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: NetworkManager-glib-devel >= %{version}
  21. BuildRequires: ModemManager-glib-devel
  22. BuildRequires: dbus-devel >= %{dbus_version}
  23. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  24. BuildRequires: gtk3-devel
  25. BuildRequires: GConf2-devel
  26. BuildRequires: libgnome-keyring-devel
  27. #BuildRequires: gettext
  28. BuildRequires: libnotify-devel >= 0.7
  29. BuildRequires: libgudev1-devel
  30. BuildRequires: libsecret-devel
  31. BuildRequires: pkgconfig(jansson)
  32. BuildRequires: pygobject3
  33. BuildRequires: iso-codes
  34. Requires(post): chkconfig
  35. Requires(preun): chkconfig
  36. Requires: libnm-gtk = %{version}-%{release}
  37. Requires: NetworkManager >= %{version}
  38. Requires: dbus
  39. Requires: dbus-glib
  40. Requires: libnotify
  41. Requires: gnome-keyring
  42. Requires: nss
  43. Requires: gnome-icon-theme
  44. Obsoletes: NetworkManager-gnome < 0.9.7.0
  45. Provides: NetworkManager-gnome = 0.9.7.0
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. %description
  49. This package contains GNOME utilities and applications for use with
  50. NetworkManager, including a panel applet for wireless networks.
  51. %package -n libnm-gtk
  52. Summary: Private libraries for NetworkManager GUI support
  53. Group: System Environment/Libraries
  54. Requires: gtk3 >= %{gtk3_version}
  55. Obsoletes: NetworkManager-gtk < 0.9.7.0
  56. Provides: NetworkManager-gtk = 0.9.7.0
  57. %description -n libnm-gtk
  58. This package contains private libraries to be used only by nm-applet and
  59. the GNOME Control Center.
  60. %package -n libnm-gtk-devel
  61. Summary: Private header files for NetworkManager GUI support
  62. Group: Development/Libraries
  63. Requires: libnm-gtk = %{version}-%{release}
  64. Requires: gtk3-devel
  65. Requires: dbus-glib-devel
  66. Requires: pkgconfig
  67. Obsoletes: NetworkManager-gtk-devel < 0.9.7.0
  68. Provides: NetworkManager-gtk-devel = 0.9.7.0
  69. %description -n libnm-gtk-devel
  70. This package contains private header and pkg-config files to be used only by
  71. nm-applet and the GNOME control center.
  72. %package -n libnma
  73. Summary: Private libraries for NetworkManager GUI support
  74. Group: System Environment/Libraries
  75. %description -n libnma
  76. This package contains private libraries to be used only by nm-applet,
  77. nm-connection editor, and the GNOME Control Center.
  78. %package -n libnma-devel
  79. Summary: Private header files for NetworkManager GUI support
  80. Group: Development/Libraries
  81. Requires: pkgconfig
  82. Requires: pkgconfig(libnm)
  83. Requires: libnma = %{version}-%{release}
  84. Requires: NetworkManager-devel
  85. Requires: NetworkManager-libnm-devel
  86. %description -n libnma-devel
  87. This package contains private header and pkg-config files to be used only by
  88. nm-applet, nm-connection-editor, and the GNOME control center.
  89. %prep
  90. %setup -q
  91. %build
  92. export CFLAGS="$CFLAGS -Wno-error=deprecated-declarations"
  93. NOCONFIGURE=1 ./autogen.sh
  94. %configure --disable-static --without-selinux
  95. make
  96. %install
  97. %{__rm} -rf $RPM_BUILD_ROOT
  98. # install the applet
  99. make install DESTDIR=$RPM_BUILD_ROOT
  100. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  101. mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-vpn-properties
  102. %find_lang nm-applet
  103. %clean
  104. rm -rf $RPM_BUILD_ROOT
  105. %post
  106. touch --no-create %{_datadir}/icons/hicolor
  107. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  108. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  109. fi
  110. %postun
  111. touch --no-create %{_datadir}/icons/hicolor
  112. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  113. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  114. fi
  115. if [ $1 -eq 0 ]; then
  116. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  117. fi
  118. %posttrans
  119. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  120. %post -n libnm-gtk -p /sbin/ldconfig
  121. %postun -n libnm-gtk -p /sbin/ldconfig
  122. %files -f nm-applet.lang
  123. %defattr(-,root,root,0755)
  124. %{_bindir}/nm-applet
  125. %{_bindir}/nm-connection-editor
  126. #{_libexecdir}/nm-applet-migration-tool
  127. %{_datadir}/appdata/nm-connection-editor.appdata.xml
  128. %{_datadir}/applications/*.desktop
  129. #{_datadir}/nm-applet/
  130. %{_datadir}/GConf/gsettings/nm-applet.convert
  131. %{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
  132. %{_datadir}/icons/hicolor/16x16/apps/*.png
  133. %{_datadir}/icons/hicolor/22x22/apps/*.png
  134. %{_datadir}/icons/hicolor/32x32/apps/*.png
  135. %{_datadir}/icons/hicolor/48x48/apps/*.png
  136. %{_datadir}/icons/hicolor/scalable/apps/*.svg
  137. %{_sysconfdir}/xdg/autostart/nm-applet.desktop
  138. %dir %{_datadir}/gnome-vpn-properties
  139. ##%{_libdir}/gnome-bluetooth/plugins/libnma.so
  140. %{_mandir}/man1/nm-applet.1.gz
  141. %{_mandir}/man1/nm-connection-editor.1.gz
  142. %files -n libnm-gtk
  143. %defattr(-,root,root,-)
  144. %{_libdir}/libnm-gtk.so.*
  145. %{_libdir}/girepository-1.0/NMGtk-1.0.typelib
  146. #dir %{_datadir}/libnm-gtk
  147. #{_datadir}/libnm-gtk/*.ui
  148. %files -n libnm-gtk-devel
  149. %defattr(-,root,root,-)
  150. %{_includedir}/libnm-gtk
  151. %{_libdir}/pkgconfig/libnm-gtk.pc
  152. %{_libdir}/libnm-gtk.so
  153. %{_datadir}/gir-1.0/NMGtk-1.0.gir
  154. %files -n libnma
  155. %{_libdir}/girepository-1.0/NMA-1.0.typelib
  156. %{_libdir}/libnma.so.*
  157. %files -n libnma-devel
  158. %dir %{_includedir}/libnma
  159. %{_includedir}/libnma/*
  160. %{_libdir}/libnma.so
  161. %{_libdir}/pkgconfig/libnma.pc
  162. %{_datadir}/gir-1.0/NMA-1.0.gir
  163. %changelog
  164. * Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.10-1
  165. - new upstream release.
  166. - added subpackages libnma{,-devel}.
  167. * Sun Dec 27 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  168. - new upstream release
  169. * Wed Nov 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  170. - new upstream release
  171. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
  172. - new upstream release
  173. * Mon Jul 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  174. - new upstream release
  175. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
  176. - new upstream release
  177. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.10.2-1
  178. - new upstream release
  179. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.10.0-1
  180. - new upstream release
  181. * Tue Oct 14 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.8.10-2
  182. - moved libnm-gtk to System Environment/Libraries Group
  183. * Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.10-1
  184. - new upstream release
  185. * Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.9-1
  186. - new upstream release
  187. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.8-1
  188. - new upstream release
  189. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.4-1
  190. - new upstream release
  191. - remove Patch0 (network-manager-applet--0.9.8.2-git20130801.patch)
  192. - add BuildRequires: ModemManager-glib-devel
  193. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.2-2
  194. - add Patch0 (network-manager-applet--0.9.8.2-git20130801.patch)
  195. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.2-1
  196. - update to 0.9.8.2
  197. - add BuildRequires: libsecret-devel
  198. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8.0-1
  199. - initial package split from NetworkManager