123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466 |
- %define aprver 1
- # Arches on which the multilib apr.h hack is needed:
- %define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
- Summary: Apache Portable Runtime library
- Summary(ja): Apache ポータブルランタイムライブラリ
- Name: apr
- Version: 1.7.0
- Release: 3%{?_dist_release}
- Group: system
- Vendor: Project Vine
- Distribution: Vine Linux
- License: Apache Software License
- URL: https://apr.apache.org/
- Source0: %{name}-%{version}.tar.bz2
- Source1: apr-wrapper.h
- Patch1: apr-1.2.2-libdir.patch
- Patch2: apr-1.3.3-pkgconf.patch
- Patch3: apr-1.7.0-deepbind.patch
- Patch4: apr-1.7.0-autoconf.patch
- Patch5: apr-1.7.0-r1891269+.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: autoconf, libtool, python, doxygen
- BuildRequires: libuuid-devel
- # To enable SCTP support
- BuildRequires: lksctp-tools-devel
- Conflicts: subversion < 0.20.1-2
- Obsoletes: apache2-apr
- %description
- The mission of the Apache Portable Runtime (APR) is to provide a
- free library of C data structures and routines, forming a system
- portability layer to as many operating systems as possible,
- including Unices, MS Win32, BeOS and OS/2.
- %package devel
- Summary: APR library development kit
- Summary(ja): APR ライブラリ開発キット
- Group: programming
- Requires: %{name} = %{version}-%{release}
- Conflicts: subversion-devel < 0.20.1-2
- Obsoletes: apache2-apr-devel
- %description devel
- This package provides the support files which can be used to
- build applications using the APR library. The mission of the
- Apache Portable Runtime (APR) is to provide a free library of
- C data structures and routines.
- %debug_package
- %prep
- %setup -q
- %patch1 -p1 -b .libdir
- %patch2 -p1 -b .pkgconf
- %patch3 -p1 -b .deepbind
- %patch4 -p1 -b .autoconf-2-71
- %patch5 -p1 -b .r1891269+
- %build
- # regenerate configure script etc.
- ./buildconf
- # Forcibly prevent detection of shm_open (which then picks up but
- # does not use -lrt).
- export ac_cv_search_shm_open=no
- %configure \
- --includedir=%{_includedir}/apr-%{aprver} \
- --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
- --with-devrandom=/dev/urandom \
- --disable-static \
- CC=gcc CXX=g++
- make %{?_smp_mflags} && make dox
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- # Move docs to more convenient location
- rm -rf html
- mkdir -p html
- cp -pr docs/dox/html/* html/
- # mv docs/dox/html html
- # Trim exported dependecies
- sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
- $RPM_BUILD_ROOT%{_libdir}/libapr*.la
- sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/ */ /g}' \
- $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
- %ifarch %{multilib_arches}
- # Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
- # packages:
- mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
- $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
- install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
- %endif
- # Unpackaged files:
- rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
- rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
- %check
- # Fail if LFS support isn't present in a 32-bit build, since this
- # breaks ABI and the soname doesn't change: see #254241
- if grep 'define SIZEOF_VOIDP 4' include/apr.h \
- && ! grep off64_t include/apr.h; then
- cat config.log
- : LFS support not present in 32-bit build
- exit 1
- fi
- pushd test
- make %{?_smp_mflags}
- ./testall -v -q
- popd
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root,-)
- %license LICENSE
- %doc CHANGES NOTICE
- %{_libdir}/libapr-%{aprver}.so.*
- %files devel
- %defattr(-,root,root,-)
- %doc docs/APRDesign.html docs/canonical_filenames.html
- %doc docs/incomplete_types docs/non_apr_programs
- %{_bindir}/apr-%{aprver}-config
- #{_libdir}/libapr-%{aprver}.a
- %{_libdir}/libapr-%{aprver}.so
- %{_libdir}/pkgconfig/*.pc
- %dir %{_libdir}/apr-%{aprver}
- %dir %{_libdir}/apr-%{aprver}/build
- %{_libdir}/apr-%{aprver}/build/*
- %dir %{_includedir}/apr-%{aprver}
- %{_includedir}/apr-%{aprver}/*.h
- %changelog
- * Fri Nov 11 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-3
- - dropped ldconfig scriptlets.
- * Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-2
- - rebuilt with current environment.
- * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-1
- - updated to 1.7.0.
- - dropped Patch1 and 3: fixed in upstream.
- * Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.5-1
- - updated to 1.6.5.
- - dropped Patch2.
- - imported Patch1 from rawhide.
- * Mon May 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
- - updated to 1.5.2.
- * Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-1
- - update to 1.5.1
- * Sat Oct 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
- - new upstream release
- * Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
- - new upstream release
- - built with rpm-4.8.1
- - removed static libraries from devel package
- * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
- - rebuilt with new toolchain
- * Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
- - new upstream release
- * Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
- - new upstream release with security fix (CVE-2009-2412)
- * Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
- - new upstream release
- * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
- - new upstream release
- - updated Patch5
- * Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
- - new upstream release
- - removed Patch1 and 6
- * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
- - removed *.la files from devel package
- * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
- - new upstream release
- - added Patch2 and 6 from Fedora
- * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
- - add fix for use of %%pI with psprintf
- * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
- - use RTLD_DEEPBIND in apr_dso_open by default
- * Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
- - new upstream release
- * Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
- - new upstream release
- * Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
- - remove Requires: gcc = %%(gcc -dumpversion)
- * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
- - rebuilt with new toolchain
- * Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
- - new upstream release
- * Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
- - initial build for Vine Linux based on FC package
- * Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
- - fix another multilib conflict (#192659)
- * Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
- - BR e2fsprogs-devel for libuuid
- * Mon May 8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
- - use multilib parallel-installation wrapper hack for apr.h
- * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
- - fix installbuilddir in apr-1-config
- * Tue May 2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
- - update to 1.2.7
- - use pkg-config in apr-1-config to make it libdir-agnostic
- * Thu Apr 6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
- - update to 1.2.6
- * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
- - bump again for double-long bug on ppc(64)
- * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
- - rebuilt for new gcc4.1 snapshot and glibc changes
- * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
- - fix namespace pollution (r354824, r355464)
- * Wed Jan 4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
- - fix build with recent glibc (#176911)
- * Tue Jan 3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
- - rebuilt again
- * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- - rebuilt
- * Fri Dec 9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
- - rebuild for new gcc
- * Thu Dec 8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
- - add apr_file_seek() fixes from upstream (r326593, r326597)
- * Wed Dec 7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
- - apr-1-config: strip more exports (#175124)
- * Tue Dec 6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
- - avoid linking against -lrt
- - don't print -L${libdir} in --libs output
- - don't export -lcrypt/-luuid in .la file
- * Fri Dec 2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
- - update to 1.2.2
- * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
- - use RTLD_DEEPBIND in apr_dso_open by default
- * Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
- - update to 0.9.7
- * Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
- - rebuild for new gcc
- * Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
- - don't override CFLAGS at build time
- - allow setting TCP_NODELAY and TCP_CORK concurrently
- - use _exit() not exit() in child if exec*() fails (upstream #30913)
- * Fri Sep 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
- - add from 0.9.x branch:
- * fix for apr_{uid,gid}_* error handling (r239592)
- * fix for apr_file_ write flushing (r267192)
- - add backport for use of readdir64_r (r265032, r265681, r265684)
- * Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
- - rebuild
- * Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
- - fix apr_procattr_child_*_set error handling
- * Tue Mar 1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
- - have apr-devel depend on specific version of gcc
- - add NOTICE to docdir
- * Wed Feb 9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
- - update to 0.9.6
- * Wed Feb 2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
- - don't disable sendfile on s390 (IBM LTC, #146891)
- * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
- - really fix apr-config --srcdir
- * Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
- - fix apr-config --srcdir again
- * Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
- - update to 0.9.5
- * Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
- - rebuild
- * Wed Sep 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
- - have -devel require apr of same V-R
- * Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
- - backport fixes from HEAD:
- * correct implementation of nested mutexes
- * support for POSIX semaphores on LP64 platforms
- * Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
- - rebuild for another attempt at using sem_open
- * Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
- - move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
- * Thu Jul 1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
- - rebuild
- * Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
- - rebuild now /dev/shm is mounted
- * Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
- - add fix for cleanup structure reuse (part of upstream #23567)
- * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
- - add support for setuid/setgid/sticky bits (Andr辿 Malo)
- - add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
- * Mon Jun 7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
- - enable posixsem and process-shared pthread mutex support, but
- ensure that sysvsem remains the default mechanism
- * Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
- - entirely remove 2Gb file size limit from apr_file_copy();
- fixes "svnadmin hotcopy" on repos with >2Gb strings table
- - work around getnameinfo bugs with v4-mapped addresses
- - fix apr_time_exp_get() for dates in 2038 (Philip Martin)
- * Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
- - use APR_LARGEFILE in apr_file_{copy,append}
- * Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
- - add APR_LARGEFILE flag
- * Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
- - fix configure check for mmap of /dev/zero
- - just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
- * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
- - rebuilt
- * Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
- - undocument apr_dir_read() ordering constraint and fix tests
- * Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
- - rebuilt without -Wall -Werror
- * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
- - rebuilt
- * Tue Feb 3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
- - define apr_off_t as int/long/... to prevent it changing
- with _FILE_OFFSET_BITS on 32-bit platforms
- * Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
- - add apr_temp_dir_get fixes from HEAD
- * Thu Jan 8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
- - ensure that libapr is linked against libpthread
- - don't link libapr against -lnsl
- * Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
- - -devel package no longer requires libtool
- * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
- - disable tests on x86_64 (#97611)
- * Fri Oct 3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
- - update to 0.9.4, enable tests
- - ensure that libresolv is not used
- * Sun Sep 7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
- - use /dev/urandom (#103049)
- * Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
- - add back CC=gcc, CXX=g++
- * Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
- - rebuild
- * Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
- - work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
- * Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
- - support --cc and --cpp arguments in apr-config
- * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
- - force libtool to use CC=gcc, CXX=g++
- * Thu Jul 3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
- - fix libtool location in apr_rules.mk
- * Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
- - use AI_ADDRCONFIG in getaddrinfo() support (#73350)
- - include a working libtool script rather than relying on
- /usr/bin/libtool (#97695)
- * Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
- - don't use /usr/bin/libtool
- * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
- - add fix for psprintf memory corruption (CAN-2003-0245)
- - remove executable bit from apr_poll.h
- * Thu May 1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
- - link libapr against libpthread
- - make apr-devel conflict with old subversion-devel
- - fix License
- * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
- - run ldconfig in post/postun
- * Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
- - patch test suite to not care if IPv6 is disabled
- * Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
- - initial build
|