kdemultimedia-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598
  1. Name: kdemultimedia
  2. Summary: KDE multimedia applications
  3. Summary(ja): KDE マルチメディアアプリケーション集
  4. Version: 4.6.0
  5. Release: 1%{?_dist_release}
  6. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdemultimedia-%{version}.tar.bz2
  7. # Vine Patches
  8. # build with taglib < 1.6
  9. Patch700: kdemultimedia-4.4.5-juk_taglib.patch
  10. # not build with ffmpeg
  11. Patch701: kdemultimedia-4.6.0-noffmpeg.patch
  12. URL: http://www.kde.org/
  13. Group: Applications/Multimedia
  14. License: GPLv2+
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. # This one is normal, FLAC_OGG_LIBRARY is not actually used anyway:
  17. # FLAC_OGG_LIBRARY:FILEPATH=FLAC_OGG_LIBRARY-NOTFOUND
  18. BuildRequires: alsa-lib-devel
  19. BuildRequires: cdparanoia-devel
  20. BuildRequires: flac-devel
  21. BuildRequires: glib2-devel
  22. BuildRequires: kdebase-workspace-devel >= %{version}
  23. BuildRequires: kdelibs4-devel
  24. BuildRequires: libtheora-devel
  25. ## needed to build Kscd, keep for now -- Kevin
  26. #BuildRequires: libtunepimp-devel
  27. BuildRequires: libmusicbrainz3-devel
  28. BuildRequires: libvorbis-devel
  29. # KMix PulseAudio integration is not anywhere near shippable.
  30. # Almost everything is commented out, it basically does nothing.
  31. BuildRequires: pulseaudio-libs-devel
  32. BuildRequires: taglib-devel
  33. BuildRequires: xine-lib-devel libxcb-devel
  34. Requires: %{name}-libs = %{version}-%{release}
  35. Requires: kdelibs4 >= %{version}
  36. Requires: kdebase-workspace >= %{version}
  37. Provides: dragonplayer = 2.0.2-0.1
  38. Obsoletes: dragonplayer < 2.0.2-0.1
  39. Obsoletes: %{name}-extras < %{version}-%{release}
  40. Obsoletes: kmidi koncd
  41. Provides: kdemultimedia4 = %{version}-%{release}
  42. Obsoletes: kdemultimedia4 < %{version}-%{release}
  43. %description
  44. Multimedia applications for the K Desktop Environment.
  45. What it is
  46. ----------
  47. * dragonplayer (a simple video player)
  48. * juk (a music manager and player)
  49. * kmix (an audio mixer)
  50. * kscd (an Audio-CD player)
  51. %package libs
  52. Summary: Runtime libraries for %{name}
  53. Summary(ja): %{name} のランタイムライブラリ
  54. Group: System Environment/Libraries
  55. License: LGPLv2+ and GPLv2+
  56. Obsoletes: %{name}-extras-libs < %{version}-%{release}
  57. Conflicts: dragonplayer < 2.0.2-0.1
  58. %description libs
  59. %{summary}.
  60. %package devel
  61. Summary: Developer files for %{name}
  62. Summary(ja): %{name} の開発用ファイル
  63. Group: Development/Libraries
  64. Requires: %{name}-libs = %{version}-%{release}
  65. Requires: kdelibs4-devel
  66. Provides: kdemultimedia4-devel = %{version}-%{release}
  67. Obsoletes: kdemultimedia4-devel < %{version}-%{release}
  68. %description devel
  69. %{summary}.
  70. %prep
  71. %setup -q -n kdemultimedia-%{version}
  72. %if %{?_dist_release} == "vl5"
  73. %patch700 -p1 -b .taglib
  74. %endif
  75. %patch701 -p1 -b .ffmpeg
  76. %build
  77. mkdir -p %{_target_platform}
  78. pushd %{_target_platform}
  79. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  80. %cmake \
  81. -DCMAKE_BUILD_TYPE=release \
  82. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  83. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  84. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  85. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  86. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  87. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  88. ..
  89. popd
  90. make %{?_smp_mflags} -C %{_target_platform}
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %post
  97. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  98. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  99. %posttrans
  100. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  101. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  102. update-desktop-database -q &> /dev/null ||:
  103. %postun
  104. if [ $1 -eq 0 ] ; then
  105. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  106. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  107. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  108. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  109. update-desktop-database -q &> /dev/null ||:
  110. fi
  111. %post libs -p /sbin/ldconfig
  112. %postun libs -p /sbin/ldconfig
  113. %files
  114. %defattr(-,root,root)
  115. %{_bindir}/*
  116. %{_datadir}/kde4/apps/dragonplayer
  117. %{_datadir}/kde4/apps/juk
  118. %{_datadir}/kde4/apps/kmix
  119. %{_datadir}/kde4/apps/kconf_update/*
  120. %{_datadir}/kde4/apps/konqsidebartng
  121. %{_datadir}/kde4/apps/kscd
  122. %{_datadir}/kde4/apps/solid/actions/dragonplayer-opendvd.desktop
  123. %{_datadir}/kde4/apps/solid/actions/kscd-play-audiocd.desktop
  124. %{_datadir}/kde4/apps/solid/actions/solid_audiocd.desktop
  125. %{_datadir}/kde4/apps/videothumbnail/
  126. %{_datadir}/config/dragonplayerrc
  127. %{_datadir}/applications/kde4/*
  128. %{_datadir}/autostart/*
  129. %{_datadir}/kde4/services/*
  130. %{_datadir}/config.kcfg/*
  131. %{_datadir}/dbus-1/interfaces/*
  132. %{_docdir}/HTML/en/dragonplayer/
  133. %{_docdir}/HTML/en/juk/
  134. %{_docdir}/HTML/en/kcontrol/
  135. %{_docdir}/HTML/en/kioslave/
  136. %{_docdir}/HTML/en/kmix/
  137. %{_datadir}/icons/hicolor/*/*/*
  138. %{_datadir}/icons/oxygen/*/actions/player-volume-muted.*
  139. %{_datadir}/icons/oxygen/*/actions/kscd-dock.*
  140. %{_libdir}/libkdeinit*.so
  141. %files libs
  142. %defattr(-,root,root,-)
  143. %{_libdir}/lib*.so.*
  144. %{_libdir}/kde4/*
  145. %files devel
  146. %defattr(-,root,root)
  147. %{_includedir}/kde4/audiocdencoder.h
  148. %{_includedir}/kde4/libkcddb
  149. %{_includedir}/kde4/libkcompactdisc
  150. %{_libdir}/lib*.so
  151. %exclude %{_libdir}/libkdeinit*.so
  152. %changelog
  153. * Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
  154. - new upstream release
  155. - updated Patch701
  156. * Tue Aug 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
  157. - added Provides: kdemultimedia4
  158. - added Provides: kdemultimedia4-devel to devel package
  159. * Sat Aug 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  160. - new upstream release
  161. - added Patch701 to avoid link with ffmpeg
  162. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  163. - new upstream release
  164. - added Conflicts: kdemultimedia3
  165. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  166. - new upstream release
  167. * Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  168. - new upstream release
  169. * Sun Mar 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  170. - new upstream release
  171. * Sat Mar 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  172. - new upstream release
  173. - built with new toolchain
  174. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  175. - new upstream release
  176. * Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
  177. - new upstream release
  178. * Mon Sep 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  179. - new upstream release
  180. - used %%cmake macro
  181. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  182. - new upstream release
  183. - split libs sub-package
  184. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-3
  185. - added Japanese summary, spec in UTF-8
  186. - updated BR
  187. * Sat Mar 2 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 3.5.8-2vl4
  188. - Change BuildPrereq: (Use BuildRequires)
  189. - Change BuildRequires: self-build-libmad
  190. - applied vine versioning policy
  191. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  192. - rebuild for VineSeed
  193. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  194. - new upstream release
  195. * Thu Sep 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl4
  196. - rebuild without acl
  197. * Tue Aug 21 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl3
  198. - rebuild with flac-1.2.0
  199. * Tue Jul 3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  200. - rebuild for VineSeed
  201. - add BuildPrereq: cdparanoia-devel
  202. - delete our own copy of cdparanoia and BuildConflicts: cdparanoia-devel
  203. * Tue May 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  204. - new upstream release
  205. - enable-cdparanoia
  206. * Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  207. - new upstream release
  208. * Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  209. - added --with-qt-libraries and --enable-libsuffix option
  210. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  211. - rebuild for VineSeed
  212. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  213. - new upstream release
  214. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  215. - rebuild for VineSeed
  216. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  217. - new upstream release
  218. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  219. - rebuild for VineSeed
  220. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  221. - new upstream release
  222. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  223. - rebuild for VineSeed
  224. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  225. - new upstream release
  226. - remove BuildPrereq: gstreamer-plugins-devel
  227. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  228. - rebuild for VineSeed
  229. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  230. - new upstream release
  231. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  232. - rebuild for VineSeed
  233. * Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  234. - new upstream release
  235. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  236. - new upstream release
  237. - add --includedir=%%{_includedir}/kde to configure option
  238. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  239. - new upstream release
  240. * Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  241. - new upstream release
  242. * Thu Aug 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl4
  243. - rebuild for VineSeed
  244. * Thu Aug 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl3
  245. - rebuild with kdelibs-3.4.2
  246. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  247. - build for VineSeed
  248. - add --disable-rpath to configure option
  249. - add alsa support for VineSeed
  250. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  251. - new upstream release
  252. - use %%{?_smp_mflags} for make option
  253. * Sat Mar 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  254. - rebuild for VineSeed
  255. * Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  256. - new upstream release
  257. - change configure option
  258. - add BuildPrereq: gstreamer-plugins-devel libmad-devel
  259. * Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl3
  260. - rebuild with flac-1.1.2 (VineSeed)
  261. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  262. - rebuild for VineSeed
  263. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  264. - new upstream release
  265. - move all files under %%{_libdir} to main package
  266. - add --sysconfdir=/etc to configure option
  267. - add /etc/xdg/menus/applications-merged/kde-multimedia-music.menu to %%files
  268. * Sat Oct 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl2
  269. - rebuild with flac-1.1.1 (VineSeed)
  270. * Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  271. - source upgrade
  272. - add patch0 again
  273. - update %%files
  274. * Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  275. - rebuild with qt32
  276. * Mon Jun 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  277. - source upgrade
  278. - remove lines about vine26
  279. - add URL: http://www.kde.org/
  280. - remove patch0 and patch1
  281. - add BuildPrereq: audiofile-devel flac-devel taglib-devel gstreamer-devel
  282. - add BuildConflicts: cdparanoia-devel
  283. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  284. - source upgrade
  285. - kernel-2.4.26 does not need patch0
  286. * Sun Mar 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  287. - source upgrade
  288. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  289. - rebuild for VineSeedPlus
  290. * Mon Jan 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  291. - source upgrade
  292. - build for VinePlus/2.6
  293. - (VinePlus/2.6) BuildPrereq: autoconf258
  294. - build without cdparanoia
  295. * Thu Jan 8 2004 Tomoya TAKA <taka@vinelinux.org> 3.1.4-0vl2
  296. - add Patch1 to resolve conflicting typedef on alpha
  297. - remove ExcludeArch: alpha
  298. * Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  299. - source upgrade
  300. - change spec to build with gcc3
  301. - add Patch0 to build kaudiocreator
  302. (patch to /usr/include/asm/byteorder.h)
  303. - include our own copy of cdparanoia, nuke FixupTOC() from it
  304. - build without cdparanoia-devel
  305. - revised description
  306. - change spec to make monolithic package only
  307. - add Obsoletes: kmidi koncd
  308. - remove KOnCD configuration
  309. - rename timidity to avoid conflict with timidy++
  310. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  311. - source upgrade
  312. - change spec to build with gcc295
  313. - change make option for SMP and add script
  314. * Sat Jun 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  315. - source upgrade
  316. - change spec to build both VineSeed and Vine2.5/2.6
  317. - remove all patches
  318. - add BuildPrereq: cdparanoia-devel cdrtools-devel
  319. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  320. - change spec to build with g++-2.95.3
  321. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  322. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  323. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  324. - source upgrade
  325. - BuildPrereq: autoconf253 objprelink2
  326. * Mon Aug 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  327. - source upgrade
  328. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-1vl2
  329. - rebuild with libvorbis-1.0-0vl1
  330. * Tue Jul 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-1vl1
  331. - build for Vine Linux 2.5 / VineSeed
  332. - delete Epoch
  333. - objprelink (i386 only)
  334. - add %%define monolithic 1
  335. - add BuildPrereq: autoconf252 automake15 libogg-devel libvorbis-devel
  336. - delete BuildPrereq: desktop-file-utils and use default .desktop files
  337. - koncd: delete Requires: mkisofs and add Requires: cdrdao
  338. - kmidi: change Requires: timidity++ -> TiMidity++
  339. delete Obsoletes: kdemultimedia
  340. - devel: Requires: kdemultimedia = %%{version}-%%{rel}
  341. * Wed Jul 10 2002 Than Ngo <than@redhat.com> 3.0.2-1
  342. - 3.0.2
  343. - use desktop-file-install
  344. * Thu Jun 06 2002 Than Ngo <than@redhat.com> 3.0.1-3
  345. - rebuild
  346. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  347. - automated rebuild
  348. * Fri May 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.1-1
  349. - 3.0.1
  350. * Wed Apr 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
  351. - Make sure we link to the just built libraries instead of libs in the
  352. build environment from older releases
  353. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
  354. - Update ABI
  355. - Add cdrecord/mkisofs requirements for KOnCD (#63606)
  356. - Tell koncd where to find cdrecord and mkisofs (#63604)
  357. * Wed Mar 27 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-1
  358. - 3.0.0 final
  359. * Thu Mar 21 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020321.1
  360. - Adapt spec file to recent changes in base
  361. * Thu Mar 7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020307.1
  362. - Update
  363. - Rename subpackages
  364. * Fri Feb 1 2002 Tim Powers <timp@redhat.com>
  365. - kdemultimedia-devel shouldn't obsolete itself
  366. - temporarily ExcludeArch ia64
  367. * Mon Aug 6 2001 Than Ngo <than@redhat.com> 2.2-1
  368. - update to 2.2 release
  369. * Fri Aug 3 2001 Than Ngo <than@redhat.com> 2.2-0.cvs20010803.1
  370. - update
  371. - fix bug #24132
  372. - get rid of aktion
  373. * Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
  374. - Update
  375. - move devel files to a separate package
  376. - Add BuildPrereqs (#44914)
  377. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  378. - 2.1-respin
  379. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  380. - 2.1
  381. * Tue Feb 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  382. - Remove copyrighted midi files (#26431)
  383. - Use a real file list rather than find/sed (#26565)
  384. - Fix build with current glibc
  385. * Thu Feb 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  386. - Replace absolute symlinks with relative ones (#24794)
  387. - Don't use more than 2 CPUs at build time to shut up asok
  388. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  389. - Update
  390. * Mon Jan 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  391. - Update
  392. - Don't optimize on sparc, compiler breakage
  393. * Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  394. - Update to CVS
  395. - re-exclude ia64, the compiler can't handle this package
  396. * Sun Oct 22 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  397. - 2.0 final
  398. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  399. - 2.0
  400. * Thu Aug 24 2000 Than Ngo <than@redhat.com>
  401. - update kdemultimedia-1.93
  402. - fix to rebuilt with gcc-2.96
  403. * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  404. - new version
  405. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  406. - fix to build against gcc-2.96-40 on sparc, alpha
  407. - disable motif
  408. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  409. - SMPify
  410. - don't hardcode QTDIR
  411. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  412. - use gcc 2.96
  413. - new snapshot
  414. * Sun Jul 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  415. - use kernelcc
  416. - new snapshot
  417. * Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  418. - Obsoletes: aktion (it's included now)
  419. * Wed Jun 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  420. - new snapshot
  421. - ExcludeArch ia64 for now
  422. * Sat Apr 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  423. - 2.0 snapshot
  424. * Tue Feb 29 2000 Preston Brown <pbrown@redhat.com>
  425. - fix localkscd patch, broken since 6.1 (#9404).
  426. * Fri Feb 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  427. - Remove (world!) write permissions to %%{prefix}/share/apps/kscd/cddb/*
  428. - fix description
  429. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  430. - Change the kmix error message (Bug #9065)
  431. - Fix kmidi behavior when trying to play an empty playlist (Bug #8843)
  432. - Fix compilation with kernel 2.3.x headers
  433. * Sat Jan 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  434. - current version from KDE_1_1_BRANCH
  435. - work around make install-strip breakage
  436. - Rebuild for 6.2
  437. * Sat Sep 25 1999 Preston Brown <pbrown@redhat.com>
  438. - patched kscd to use local user directory for cddb entries
  439. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  440. - mark doc files as such
  441. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  442. - 1.1.2 release.
  443. * Mon Jun 14 1999 Preston Brown <pbrown@redhat.com>
  444. - snapshot, includes kde 1.1.1 + fixes
  445. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  446. - last snapshot before release
  447. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  448. - snapshot from today fixed kmid freeze issues
  449. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  450. - latest stable snapshot
  451. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  452. - Injected new description and group.
  453. * Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
  454. - upgraded to KDE 1.1 final.
  455. * Sat Feb 06 1999 Preston Brown <pbrown@redhat.com>
  456. - complies w/new RPM, newer libstdc++
  457. * Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
  458. - re-merged in updates from Duncan Haldane