perl-GD-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100
  1. %define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
  2. Summary: A perl5 interface to Thomas Boutell's gd library
  3. Summary(ja): GD ライブラリの Perl 用インターフェイス
  4. Name: perl-GD
  5. Version: 2.35
  6. Release: 2%{?_dist_release}
  7. License: distributable
  8. Group: Development/Libraries
  9. Source0: http://search.cpan.org/CPAN/authors/id/L/LD/LDS/GD-%{version}.tar.gz
  10. Url: http://search.cpan.org/dist/GD/
  11. BuildRoot: %{_tmppath}/perl-GD-buildroot/
  12. BuildRequires: perl >= 5.6.0, gd-devel >= 2.0.20, libjpeg-devel
  13. BuildRequires: freetype2-devel, libpng-devel, zlib-devel
  14. BuildRequires: libX11-devel
  15. BuildRequires: libXpm-devel
  16. Requires: perl >= 5.6.0, gd >= 2.0.12, libjpeg, freetype2
  17. Requires: libpng, zlib
  18. %description
  19. This is a autoloadable interface module for libgd, a popular library
  20. for creating and manipulating PNG files. With this library you can
  21. create PNG images on the fly or modify existing files. Features
  22. include:
  23. a. lines, polygons, rectangles and arcs, both filled and unfilled
  24. b. flood fills
  25. c. the use of arbitrary images as brushes and as tiled fill patterns
  26. d. line styling (dashed lines and the like)
  27. e. horizontal and vertical text rendering
  28. f. support for transparency and interlacing
  29. For full information on usage, see the accompanying man and html
  30. documentation.
  31. # Provide perl-specific find-{provides,requires}.
  32. %define __find_provides /usr/lib/rpm/find-provides.perl
  33. %define __find_requires /usr/lib/rpm/find-requires.perl
  34. %prep
  35. %setup -q -n GD-%{version}
  36. %build
  37. CFLAGS="$RPM_OPT_FLAGS" \
  38. perl Makefile.PL --lib_gd_path=%{_libdir} INSTALLDIRS="vendor" << _OPT_
  39. y
  40. _OPT_
  41. make
  42. make test
  43. %clean
  44. rm -rf %{buildroot}
  45. %install
  46. rm -rf %{buildroot}
  47. make DESTDIR=%{buildroot} install
  48. [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
  49. find %{buildroot}%{_prefix} -type f -print |
  50. sed "s@^%{buildroot}@@g" |
  51. grep -v perllocal.pod |
  52. grep -v "\.packlist" > %{name}-filelist
  53. if [ "$(cat %{name}-filelist)X" = "X" ] ; then
  54. echo "ERROR: EMPTY FILE LIST"
  55. exit -1
  56. fi
  57. find demos -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!/usr/bin/perl|g"
  58. find bdf_scripts -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!/usr/bin/perl|g"
  59. %files -f %{name}-filelist
  60. %defattr(-,root,root)
  61. %doc ChangeLog README* demos bdf_scripts
  62. %dir %{perl_vendorarch}/GD
  63. %dir %{perl_vendorarch}/auto/GD
  64. %changelog
  65. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35-2
  66. - rebuild with perl-5.12.3
  67. - add BuildRequires: libX11-devel, libXpm-devel
  68. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.35-1vl5
  69. - applied new versioning policy, spec in utf-8
  70. - built with perl-5.10.0
  71. * Sun Sep 3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.35-0vl1
  72. - new upstream release
  73. - changed Group to Development/Libraries
  74. * Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28-0vl1
  75. - new upstream release
  76. - added Japanese summary
  77. * Sun Jan 2 2005 IWAI, Masaharu <iwai@alib.jp> 2.19-0vl1
  78. - new upstream release
  79. - update {Build,}Requires
  80. * Tue Nov 11 2003 IWAI, Masaharu <iwai@alib.jp> 2.11-0vl1
  81. - initial build