clearsilver-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153
  1. %bcond_with ruby
  2. %define name clearsilver
  3. %define version 0.10.5
  4. %define release 11%{_dist_release}
  5. Summary: A fast, powerful, and language-neutral HTML template system.
  6. Summary(ja): 高速、パワフルで言語中立なHTMLテンプレートシステム
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. License: Neotonic ClearSilver Software License
  11. Group: Applications/Text
  12. URL: http://clearsilver.net/
  13. Source0: http://clearsilver.net/downloads/%{name}-%{version}.tar.gz
  14. Patch0: clearsilver-0.10.5-conf.patch
  15. Patch1: clearsilver-0.10.5-regression.patch
  16. Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
  17. Patch3: clearsilver-ruby-1.9.patch
  18. Patch4: clearsilver-ruby-2.2.patch
  19. # GCC 5 compatibility, bug #1190760
  20. Patch5: clearsilver-0.10.5-gcc5.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. BuildRequires: perl
  23. BuildRequires: python-devel
  24. %if %{with ruby}
  25. BuildRequires: ruby
  26. BuildRequires: ruby-devel >= 1.9.3
  27. %endif
  28. BuildRequires: zlib-devel
  29. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  30. Provides: ruby(clearsilver)
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. %description
  34. ClearSilver is a fast, powerful, and language-neutral template system.
  35. It is designed to make it easy to create template driven static or
  36. dynamic websites.
  37. %description -l ja
  38. Clearsilver は高速、強力で言語中立なテンプレートシステムです。
  39. テンプレート駆動の静的あるいは動的な Web サイトの構築を
  40. 容易にすることを目指して設計されています。
  41. %prep
  42. %setup -q
  43. %patch0 -p1 -b .conf
  44. %patch1 -p1
  45. %patch2 -p1
  46. %if %{with ruby}
  47. %patch3 -p1
  48. %patch4 -p1
  49. %endif
  50. %patch5 -p2
  51. touch configure
  52. perl -pi -e 's/python_versions="2\.5/python_versions="2.7 2.6 2.5/' configure
  53. sed -i 's|/neo/opt/bin/python|%{__python}|' python/examples/*/*.py
  54. sed -i 's|PYTHON_SITE = @PYTHON_SITE@|PYTHON_SITE = %{python_sitearch}|' rules.mk.in
  55. sed -i -r 's|(\$\(RUBY\) install.rb config) (--.*)|\1 --rb-dir="$(DESTDIR)%{ruby_vendorlibdir}" --so-dir="$(DESTDIR)%{ruby_vendorarchdir}" \2|' ruby/Makefile
  56. find python/examples -type f | xargs chmod -x
  57. %build
  58. %configure \
  59. %if ! %{with ruby}
  60. --disable-ruby \
  61. %endif
  62. --disable-csharp
  63. %ifarch x86_64
  64. perl -pi -e 's/^(TARGETS =.+) test/$1/' cs/Makefile
  65. %endif
  66. %__make %{_smp_mflags}
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. make DESTDIR=${RPM_BUILD_ROOT} install
  70. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  71. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  72. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  73. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  74. chmod -R u+w $RPM_BUILD_ROOT/*
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %files
  78. %defattr(-,root,root)
  79. %doc CS_LICENSE INSTALL LICENSE README README.python
  80. %{_bindir}/*
  81. %{_includedir}/ClearSilver/
  82. %{perl_sitearch}/*.pm
  83. %{perl_sitearch}/auto/ClearSilver/
  84. %{python_sitearch}/*.so
  85. %if %{with ruby}
  86. %{ruby_vendorarchdir}/*.so
  87. %{ruby_vendorlibdir}/*.rb
  88. %endif
  89. %{_libdir}/*.a
  90. %{_mandir}/man*/*.gz
  91. %changelog
  92. * Tue Dec 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-11
  93. - added Patch5 for gcc5.
  94. - disabled ruby stuff.
  95. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.5-10
  96. - rebuild with ruby-2.2.3
  97. - add Patch4 (clearsilver-ruby-2.2.patch) from fedora
  98. * Wed Dec 17 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.10.5-9
  99. - rebuilt with perl 5.16.3 and ruby 2.1.5
  100. * Sun Dec 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-8
  101. - rebuilt with ruby-2.0.0.353.
  102. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.5-7
  103. - rebuild with ruby-1.9.3
  104. - add patch3 to build with ruby-1.9
  105. - add patch2 for CVE-2011-4357
  106. * Sat Feb 25 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-6
  107. - rebuilt with python-2.7.
  108. * Sun May 15 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.10.5-5
  109. - rebuilt with perl-5.12.3 and python-2.6.
  110. * Mon Jun 22 2009 Shu KONNO <owa@bg.wakwak.com> 0.10.5-4
  111. - applied new versioning policy, spec in utf-8
  112. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.10.5-3
  113. - rebuilt with python-2.5.2
  114. - added clearsilver-0.10.5-conf.patch
  115. * Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-2
  116. - rebuilt with perl-5.10.0.
  117. * Mon Apr 28 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.10.5-1
  118. - x86_64: make to skip testing.
  119. * Fri Nov 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.5-0vl4
  120. - add --disable-csharp for configure script
  121. * Tue Aug 28 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.10.5-0vl2
  122. - initial build for Vine Linux