procps-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481
  1. %bcond_with systemd
  2. %bcond_with ja_po
  3. %define origname procps-ng
  4. Summary: System and process monitoring utilities.
  5. Summary(ja): システムやプロセスのモニタリングユーティリティ
  6. Name: procps
  7. Version: 3.3.17
  8. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  9. Group: system
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. License: GPL
  14. Url: https://gitlab.com/procps-ng/procps
  15. # alternative: http://sourceforge.net/projects/procps-ng/
  16. Source: https://downloads.sourceforge.net/project/procps-ng/Production/%{origname}-%{version}.tar.xz
  17. Patch1: pwait-to-pidwait.patch
  18. # Vine source/patches
  19. Source10: procps-ng-3.3.10-ja.po
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: ncurses-devel
  22. %if %{with systemd}
  23. BuildRequires: systemd-devel
  24. %else
  25. BuildRequires: elogind-devel
  26. %endif
  27. Requires(post): /bin/rm
  28. %description
  29. The procps package contains a set of system utilities that provide
  30. system information. Procps includes ps, free, skill, snice, tload,
  31. top, uptime, vmstat, w, and watch. The ps command displays a snapshot
  32. of running processes. The top command provides a repetitive update of
  33. the statuses of running processes. The free command displays the
  34. amounts of free and used memory on your system. The skill command
  35. sends a terminate command (or another specified signal) to a specified
  36. set of processes. The snice command is used to change the scheduling
  37. priority of specified processes. The tload command prints a graph of
  38. the current system load average to a specified tty. The uptime command
  39. displays the current time, how long the system has been running, how
  40. many users are logged on, and system load averages for the past one,
  41. five, and fifteen minutes. The w command displays a list of the users
  42. who are currently logged on and what they are running. The watch
  43. program watches a running program. The vmstat command displays virtual
  44. memory statistics about processes, memory, paging, block I/O, traps,
  45. and CPU activity.
  46. %description -l ja
  47. システムの状態を知るためのユーティリティ集です. 実行中のプロセス, 使用
  48. 可能なメモリ容量, 現在ログインしているユーザの情報等を得ることができます.
  49. %package devel
  50. Summary: System and process monitoring utilities
  51. Summary(ja): procpsを利用した開発に必要なファイル
  52. Group: programming
  53. Requires: %{name} = %{version}-%{release}
  54. %description devel
  55. System and process monitoring utilities development headers
  56. %description devel -l ja
  57.  このパッケージにはprocpsを利用した開発に必要なヘッダ・ライブラリファイル
  58. が収録されています。
  59. %debug_package
  60. %prep
  61. %setup -q
  62. %autopatch -p1
  63. # vine
  64. %if %{with ja_po}
  65. cp -f %{SOURCE10} po/ja.po
  66. #echo "ja" > po/LINGUAS
  67. %endif
  68. %build
  69. autoreconf --verbose --force --install
  70. %configure \
  71. --exec-prefix=/ \
  72. --sbindir=%{_syssbindir} \
  73. --docdir=/unwanted \
  74. --disable-static \
  75. --disable-w-from \
  76. --disable-kill \
  77. --enable-watch8bit \
  78. --enable-skill \
  79. --enable-sigwinch \
  80. --disable-libselinux \
  81. --enable-pidwait \
  82. %if %{with systemd}
  83. --with-systemd
  84. %else
  85. --without-systemd \
  86. --with-elogind
  87. %endif
  88. make CFLAGS="%{optflags}"
  89. #sed -i -e 's|/procps-ng-.*-dirty/|/|' po/Makefile
  90. #sed -i -e 's|^procps-ng-.*-dirty/||' po/POTFILES.in
  91. %if %{with ja_po}
  92. make -C po update-po
  93. make -C po ja.gmo
  94. %endif
  95. %install
  96. make DESTDIR=%{buildroot} install
  97. make DESTDIR=%{buildroot} -C po install
  98. mkdir -p %{buildroot}%{_sysconfdir}/sysctl.d
  99. # for compatibility
  100. mkdir -p %{buildroot}%{_sysbindir}
  101. ln -sf ..%{_bindir}/ps %{buildroot}%{_sysbindir}/ps
  102. mkdir -p %{buildroot}%{_syssbindir}
  103. ln -sf ..%{_bindir}/pidof %{buildroot}%{_syssbindir}/pidof
  104. rm -f %{buildroot}/%{_libdir}/libprocps.la
  105. rm -rf %{buildroot}/unwanted
  106. # these are created by make, yet empty. This causes rpmbuild errors.
  107. rm -rf %{buildroot}%{_mandir}/{pl,pt_BR,sv}/man5
  108. %find_lang procps-ng --all-name --with-man
  109. %clean
  110. rm -rf %{buildroot}
  111. %pre
  112. if [ -L %{_bindir}/ps ]; then
  113. rm -f %{_bindir}/ps
  114. fi
  115. if [ -L %{_bindir}/pidof ]; then
  116. rm -f %{_bindir}/pidof
  117. fi
  118. if [ -f /sbin/pidof ]; then
  119. rm -f /sbin/pidof
  120. fi
  121. %files -f procps-ng.lang
  122. %defattr(-,root,root,-)
  123. %license COPYING COPYING.LIB
  124. %doc AUTHORS NEWS
  125. %{_libdir}/libprocps.so.*
  126. %{_bindir}/*
  127. %{_sysbindir}/*
  128. %{_syssbindir}/*
  129. %{_sysconfdir}/sysctl.d
  130. %{_mandir}/man1/*
  131. %{_mandir}/man3/*
  132. %{_mandir}/man8/*
  133. %{_mandir}/man5/*
  134. %files devel
  135. %defattr(-,root,root,-)
  136. %license COPYING COPYING.LIB
  137. %{_libdir}/libprocps.so
  138. %{_libdir}/pkgconfig/libprocps.pc
  139. %{_includedir}/proc
  140. %changelog
  141. * Fri Oct 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.17-1
  142. - new upstream release.
  143. - dropped ldconfig scriptlets.
  144. - enabled pidof
  145. - imported Patch1 from rawhide.
  146. - enabled pwait as pidwait.
  147. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.16-1
  148. - new upstream release.
  149. - added systemd support (disabled as default).
  150. * Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.15-1
  151. - new upstream release.
  152. - enabled elogind.
  153. - added japanese summary.
  154. * Sun Jun 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-2
  155. - fixed Source10.
  156. * Sat Jun 20 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-1
  157. - new upstream release.
  158. - updated Source10 and Patch10.
  159. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.9-1
  160. - update to forked version of procps 3.3.9
  161. - add minimum ja.po
  162. * Sat Sep 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
  163. - update to 3.2.8
  164. - add patch30 to fix top highlight bug
  165. (thanks to <BTS:916>)
  166. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-2
  167. - spec in utf-8
  168. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-1
  169. - new upstream release
  170. * Wed Sep 20 2006 IWAI, Masaharu <iwai@alib.jp> 3.2.6-0vl3
  171. - [BTS:205] update ja.po ( in Patch20 )
  172. * Tue Feb 14 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl2
  173. - add Obsoletes: pgrep
  174. * Sun Feb 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl1
  175. - upstream release
  176. - update Patch20
  177. - fix encode of spec file (SJIS -> EUC-JP)
  178. - add pwdx command (new from 3.2.4)
  179. * Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl3
  180. - update gettext patch
  181. * Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl2
  182. - add gettext patch (Patch20)
  183. still needs more work ( only for "free" and "uptime" )
  184. * Sun Feb 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl1
  185. - new upstream release
  186. * Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2.0-1vl1
  187. - modified for Vine
  188. - add obsoletes -X11 package
  189. * Tue Feb 24 2004 Dan Walsh <dwalsh@redhat.com> 3.2.0-1
  190. - New version from upstream
  191. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  192. - rebuilt
  193. * Thu Jan 22 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-3
  194. - Match -Z to --context
  195. * Wed Jan 21 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-2
  196. - Add back in -Z support
  197. * Wed Jan 21 2004 Alexander Larsson <alexl@redhat.com> 3.1.15-1
  198. - upgrade to procps3
  199. - Some regressions, see bug #114012
  200. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 2.0.17-7
  201. - Remove LIBCURSES from skill and sysctl
  202. * Wed Dec 10 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-6
  203. - Turn on SELinux
  204. * Mon Dec 8 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-5
  205. - Fix top total percentages (#109484)
  206. * Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-4
  207. - Turn off selinux
  208. * Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-3.sel
  209. - Fix help message
  210. * Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-2.sel
  211. - Turn on selinux
  212. * Fri Oct 3 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-1
  213. - Update to 2.0.17, drop upstream patches, forward port remaining patches
  214. * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-11
  215. - Turn off selinux
  216. * Thu Aug 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-10.sel
  217. - Add -Z switch for SELinux
  218. * Sun Aug 17 2003 Doug Ledford <dledford@redhat.com> 2.0.13-9E
  219. - Add patch to recognize irq and softirq time accounting in kernels that
  220. support this feature
  221. * Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-8
  222. - rebuild
  223. * Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-7E
  224. - Add swapped patch from rik van riel
  225. * Wed Aug 6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-6
  226. - rebuild
  227. * Wed Aug 6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-5E
  228. - Update iowait patch (#101657)
  229. - Add wchan 64bit patch from Mark DeWandel
  230. * Mon Jul 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-4E
  231. - Add SELinux patch
  232. * Wed Jul 16 2003 Matt Wilson <msw@redhat.com> 2.0.13-3E
  233. - display iowait with procps-2.0.13-iowait.patch (#99061)
  234. * Fri Jul 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-2E
  235. - Disable linuxthreads thread hack
  236. * Mon Jul 7 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1E
  237. - rebuild
  238. * Fri Jul 4 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1
  239. - update to 2.0.13
  240. - Re-merged ntpl patch
  241. - Add hertz fix from Ernie Petrides <petrides@redhat.com>
  242. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  243. - rebuilt
  244. * Fri May 23 2003 Alexander Larsson <alexl@redhat.com> 2.0.12-1
  245. - Update to 2.0.12
  246. - Add patch to fix segfault on ps axl (#91453)
  247. * Fri Mar 14 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-7
  248. - Add patch that fixes negative priorities in top.
  249. * Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-6
  250. - New NPTL patch:
  251. - Added skipthreads optimization to top
  252. - Don't read threads in 'w'
  253. * Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-5
  254. - Update the NPTL patch since the kernel /proc was fixed
  255. - For kernels >= 2.4.20-2.50
  256. * Mon Feb 17 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-4
  257. - Update nptl patch to new /proc layout.
  258. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.11-3
  259. - rebuilt
  260. * Wed Jan 22 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-2
  261. - Created nptl patch after discussion with ingo and arjan
  262. * Tue Jan 21 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-1
  263. - Update to 2.0.11
  264. * Mon Dec 16 2002 Elliot Lee <sopwith@redhat.com> 2.0.10-4
  265. - Fix %%install in changelog
  266. * Tue Nov 19 2002 Jakub Jelinek <jakub@redhat.com> 2.0.10-3
  267. - Fix for Hammer
  268. * Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-2
  269. - Remove uninstalled files in %%install. Add pmap to %%files
  270. * Tue Oct 8 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-1
  271. - Update to 2.0.10
  272. - Removed applied patches.
  273. * Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-25
  274. - Add patch to protect against idle ticks going backwards. Fixes #71237
  275. * Thu Aug 8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-24
  276. - Fix saving of sort, fixes #32757
  277. - Fix printing size, fixes #48224
  278. - Fix float decimal point input #58163
  279. * Thu Aug 8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-23
  280. - Fix unsigned/signed bug. Closes #60998.
  281. - Update threadbadhack to correctly propagate process time to the main thread.
  282. * Wed Aug 7 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-22
  283. - Don't strip binaries
  284. * Fri Jul 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-21
  285. - Remove the X11 subpackage
  286. * Mon Jul 1 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-19
  287. - Added patch that fixes #35174
  288. * Wed Jun 26 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-18
  289. - New thread badhack patch. Fixes a segfault.
  290. * Mon Jun 24 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-16
  291. - New thread badhack. Now enabled by default.
  292. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  293. - automated rebuild
  294. * Thu Jun 20 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-14
  295. - Added badhack to support hiding threads
  296. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  297. - automated rebuild
  298. * Mon Apr 15 2002 Bill Nottingham <notting@redhat.com> 2.0.7-12
  299. - add ldconfig in %postun
  300. * Mon Aug 27 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 2.0.7-11
  301. - Add ncurses-devel as a build dependency (#49562)
  302. * Sat Jul 21 2001 Tim Powers <timp@redhat.com>
  303. - removed applnk entry, one of the things that's cluttering our menus
  304. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  305. - Bump release + rebuild.
  306. * Thu Apr 5 2001 Jakub Jelinek <jakub@redhat.com>
  307. - fix AIX style user defined formats (#34833)
  308. * Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
  309. - add a '-e' to sysctl to ignore errors (#31852)
  310. * Mon Mar 5 2001 Preston Brown <pbrown@redhat.com>
  311. - bigger buffer for reading /proc/stat fixes segfault (#27840)
  312. * Thu Feb 1 2001 Preston Brown <pbrown@redhat.com>
  313. - make sysctl return a value when errors occur (#18820).
  314. - support big UIDs (#22683)
  315. * Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
  316. - work-around for negative CPU output (Bug #18380)
  317. * Thu Aug 17 2000 Than Ngo <than@redhat.com>
  318. - fix failing in RPM post script (Bug #16226)
  319. * Wed Jul 26 2000 Michael K. Johnson <johnsonm@redhat.com>
  320. - Added Jakub's locale patch
  321. * Fri Jul 14 2000 Michael K. Johnson <johnsonm@redhat.com>
  322. - procps-2.0.7
  323. - integrated all patches except for signames patch, which is broken
  324. and unnecessary
  325. - See NEWS for changes between 2.0.6 and 2.0.7
  326. - Added patch to correctly install desktop file. Oops.
  327. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  328. - automatic rebuild
  329. * Mon Jul 03 2000 Preston Brown <pbrown@redhat.com>
  330. - larger buffers for reading /proc/stat
  331. * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
  332. - FHS paths
  333. * Tue May 30 2000 Preston Brown <pbrown@redhat.com>
  334. - add smp, signal name patches from VA Linux. Thanks guys.
  335. * Mon May 22 2000 Harald Hoyer <harald@redhat.com>
  336. - added sysctl.conf (5) man page
  337. * Wed May 10 2000 Bill Nottingham <notting@redhat.com>
  338. - fix PAGE_SIZE mismatch on ia64
  339. * Sun May 7 2000 Bill Nottingham <notting@redhat.com>
  340. - rebuild with different optimizations for ia64
  341. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  342. - rebuild with current ncurses
  343. * Tue Mar 7 2000 Bill Nottingham <notting@redhat.com>
  344. - fix end-of-file behavior in sysctl
  345. * Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
  346. - wmconfig -> desktop
  347. * Mon Feb 7 2000 Jakub Jelinek <jakub@redhat.com>
  348. - don't try to load System.map (and spit error messages if it does not
  349. exist) if ps or top are not going to use it, both to speed things up
  350. and remove the ugly messages when they don't make sense.
  351. - in top, print the possible error messages using standard top SHOWMESSAGE
  352. (because it will be now printed out when already in terminal mode).
  353. * Thu Feb 3 2000 Matt Wilson <msw@redhat.com>
  354. - added patch to prevent divide by zero on UltraSparc
  355. - gzip man pages