glib-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # overwrite configure macro (remove --target option)
  3. %define configure CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; ./configure --host=%{_host} --build=%{_build} --program-prefix=%{?_program_prefix} --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
  4. Summary: A library of handy utility functions.
  5. Summary(ja): 便利なユーティリティ関数ライブラリ
  6. Name: glib
  7. Version: 1.2.10
  8. Release: 5%{?_dist_release}
  9. License: LGPL
  10. Group: System Environment/Libraries
  11. URL: http://www.gtk.org
  12. Source: ftp://ftp.gimp.org/pub/gtk/v1.2/%{name}-%{version}.tar.gz
  13. Patch1: glib-1.2.10-isowarning.patch
  14. Patch2: glib-1.2.10-gcc34.patch
  15. Patch3: glib-1.2.10-config.sub-x86_64.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. %description
  18. Glib is a handy library of utility functions. This C
  19. library is designed to solve some portability problems
  20. and provide other useful functionality which most
  21. programs require.
  22. Glib is used by GDK, GTK+ and many applications.
  23. You should install Glib because many of your applications
  24. will depend on this library.
  25. This package rebuilds binaries with debug option.
  26. %description -l ja
  27. Glib は便利なユーティリティ関数ライブラリです。この C
  28. ライブラリはいくつかのよく遭遇する問題を解決し、多くの
  29. プログラムで必要な有用な機能を提供するために作られました。
  30. このパッケージでは debug option 付きで binary を 作成します。
  31. %package devel
  32. Summary: Libraries and header files for glib development
  33. Group: Development/Libraries
  34. Requires(post,preun): /sbin/install-info
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. Static libraries and header files for the support library for the GIMP's X
  38. libraries, which are available as public libraries. GLIB includes generally
  39. useful data structures.
  40. %description devel -l ja
  41. GIMP の X ライブラリをサポートする静的関数およびヘッダファイルです。
  42. GLIB には使いやすいデータストラクチャーも含まれています。
  43. ## to build compat32 for x86_64 architecture support
  44. %package -n compat32-%{name}
  45. Summary: A library of handy utility functions.
  46. Group: System Environment/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. %description -n compat32-%{name}
  49. Glib is a handy library of utility functions. This C
  50. library is designed to solve some portability problems
  51. and provide other useful functionality which most
  52. programs require.
  53. %package -n compat32-%{name}-devel
  54. Summary: Libraries and header files for glib development
  55. Group: Development/Libraries
  56. Requires: compat32-%{name} = %{version}-%{release}
  57. %description -n compat32-%{name}-devel
  58. Static libraries and header files for the support library for the GIMP's X
  59. libraries, which are available as public libraries. GLIB includes generally
  60. useful data structures.
  61. %prep
  62. %setup -q
  63. %patch1 -p1 -b .isowarning
  64. %patch2 -p1 -b .gcc34
  65. %patch3 -p1 -b .config.sub
  66. %build
  67. %configure
  68. make %{?_smp_mflags}
  69. %install
  70. rm -rf ${RPM_BUILD_ROOT}
  71. make install DESTDIR=${RPM_BUILD_ROOT}
  72. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
  74. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  75. # libgmodule-1.2.so.0* missing eXecute bit
  76. chmod -c a+x %{buildroot}%{_libdir}/lib*.so*
  77. #%find_lang %{name}
  78. %clean
  79. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  80. %post -p /sbin/ldconfig
  81. %postun -p /sbin/ldconfig
  82. %post devel
  83. /sbin/install-info %{_infodir}/glib.info* %{_infodir}/dir
  84. %preun devel
  85. if [ "$1" = 0 ]; then
  86. /sbin/install-info --delete %{_infodir}/glib.info* %{_infodir}/dir
  87. fi
  88. %post -n compat32-%{name} -p /sbin/ldconfig
  89. %postun -n compat32-%{name} -p /sbin/ldconfig
  90. %files
  91. %defattr(-, root, root)
  92. %doc AUTHORS COPYING ChangeLog NEWS README
  93. %{_libdir}/libglib-1.2.so.*
  94. %{_libdir}/libgthread-1.2.so.*
  95. %{_libdir}/libgmodule-1.2.so.*
  96. %files devel
  97. %defattr(-, root, root)
  98. %{_bindir}/*
  99. %{_libdir}/lib*.so
  100. %{_libdir}/glib
  101. %{_libdir}/pkgconfig/*
  102. %{_includedir}/*
  103. %{_datadir}/aclocal/*
  104. %{_infodir}/*
  105. %{_mandir}/man1/*
  106. ## to build compat32 for x86_64 architecture support
  107. %if %{build_compat32}
  108. %files -n compat32-%{name}
  109. %defattr(-, root, root)
  110. %{_libdir}/libglib-1.2.so.*
  111. %{_libdir}/libgthread-1.2.so.*
  112. %{_libdir}/libgmodule-1.2.so.*
  113. %files -n compat32-%{name}-devel
  114. %defattr(-, root, root)
  115. %{_libdir}/lib*.so
  116. %{_libdir}/glib
  117. %endif
  118. %changelog
  119. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-5
  120. - rebuild with VineSeed environment
  121. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-4
  122. - rebuild with rpm-4.8.1 for pkg-config file
  123. * Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-3
  124. - spec in UTF-8
  125. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-2
  126. - updated %%if %%{build_compat32} case related statements
  127. * Tue May 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-1
  128. - applied new versioning policy
  129. - moved Requires(post,preun): /sbin/install-info to devel package
  130. * Fri Feb 10 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.10-0vl7
  131. - added compat32-* packages for x86_64 architecture support
  132. - added glib-1.2.10-config.sub-x86_64.patch
  133. * Tue Feb 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl6
  134. - rebuild
  135. - disable %%find_lang macro
  136. - refine %%configure macro
  137. - add PreReq: ldconfig, install-info instead of /sbin/install-info
  138. * Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.10-0vl5
  139. - rebuilt
  140. - change from Copyright to License
  141. - add patch2
  142. - remove info/dir
  143. * Wed Dec 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl4
  144. - rebuilt with new toolchain
  145. - TODO: we better remove info files when glib2 be ready to ship...
  146. * Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl3
  147. - Applied RH patch (glib-1.2.10-isowarning.patch)
  148. * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
  149. - Add #pragma GCC system_header to supress warnings when in -pedantic
  150. mode. (41271)
  151. - Added %%{_libdir}/pkgconfig to devel file list.
  152. * Sat Jul 14 2001 <sagami@vinelinux.org>
  153. - 1.2.10-0vl2: put %%patch0 at %%setup, not %%build. But already applied:-)
  154. * Tue Apr 3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl1
  155. - New upstream release.
  156. * Wed Mar 7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.9-0vl1
  157. - New upstream release.
  158. * Mon Feb 05 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  159. - 1.2.8-0vl2
  160. - fixed files section so as not to own mandir itself
  161. - use better macros
  162. * Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  163. - updated to 1.2.8
  164. * Thu Feb 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  165. - [glib-1.2.7-0vl1]
  166. * Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
  167. - [glib-1.2.6-1]
  168. * Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
  169. - [glib-1.2.5-1]
  170. * Tue Sep 7 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  171. [glib-1.2.4-2.1]
  172. - added debug option to CFLAG.
  173. * Mon Sep 6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  174. [glib-1.2.4-2]
  175. - gzip info.
  176. * Fri Sep 3 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  177. [glib-1.2.4-1]
  178. - version 1.2.4.
  179. - bzip2 source.
  180. - info is installed in glib-devel.
  181. * Sat Aug 21 1999 Jun Nishii <jun@flatout.org>
  182. - added Japanese summary and description
  183. - build for Vine-1.9
  184. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  185. - version 1.2.3
  186. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  187. - version 1.2.1
  188. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  189. - Version 1.2
  190. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  191. - version 1.2.0pre1
  192. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  193. - new description tags
  194. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  195. - removed libtoolize from %build
  196. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  197. - added libgthread to file list
  198. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  199. - version 1.1.15
  200. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  201. - version 1.1.14
  202. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  203. - version 1.1.13
  204. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  205. - version 1.1.12
  206. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  207. - updated in preparation for the GNOME freeze
  208. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  209. - Split out glib package