jsoncpp-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159
  1. Name: jsoncpp
  2. Version: 1.9.5
  3. Release: 1%{?_dist_release}
  4. Summary: JSON library implemented in C++
  5. Summary(ja): C++ で実装された JSON ライブラリ
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: Public Domain or MIT
  10. URL: https://github.com/open-source-parsers/jsoncpp
  11. Source0: https://github.com/open-source-parsers/jsoncpp/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: cmake > 3.15.0
  14. BuildRequires: python3-devel
  15. BuildRequires: python3-rpm-macros
  16. %description
  17. %{name} is an implementation of a JSON (http://json.org) reader and writer in
  18. C++. JSON (JavaScript Object Notation) is a lightweight data-interchange format.
  19. It is easy for humans to read and write. It is easy for machines to parse and
  20. generate.
  21. %package devel
  22. Summary: Development headers and library for %{name}
  23. Summary(ja): %{name} の開発用ヘッダファイルとライブラリ
  24. Group: programming
  25. Requires: %{name} = %{version}-%{release}
  26. Obsoletes: %{name}-doc < 1.0.0
  27. %description devel
  28. This package contains the development headers and library for %{name}.
  29. %debug_package
  30. %prep
  31. %autosetup -p1
  32. %build
  33. %cmake -DBUILD_STATIC_LIBS=OFF \
  34. -DBUILD_OBJECT_LIBS=OFF \
  35. -DJSONCPP_WITH_WARNING_AS_ERROR=OFF \
  36. -DJSONCPP_WITH_PKGCONFIG_SUPPORT=ON \
  37. -DJSONCPP_WITH_CMAKE_PACKAGE=ON \
  38. -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF \
  39. -DJSONCPP_WITH_EXAMPLE:BOOL=OFF \
  40. -DJSONCPP_WITH_STRICT_ISO:BOOL=ON \
  41. -DPYTHON_EXECUTABLE="%{__python3}"
  42. %cmake_build
  43. %check
  44. # Run tests single threaded.
  45. %global _smp_mflags -j1
  46. %ctest
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. %cmake_install
  50. %clean
  51. rm -rf $RPM_BUILD_ROOT
  52. %files
  53. %license LICENSE
  54. %doc AUTHORS README*
  55. %{_libdir}/lib%{name}.so.*
  56. %files devel
  57. %doc doc/*.html
  58. %{_libdir}/lib%{name}.so
  59. %{_includedir}/json
  60. %{_libdir}/cmake/*
  61. %{_libdir}/pkgconfig/%{name}.pc
  62. %changelog
  63. * Fri Nov 18 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.5-1
  64. - new upstream release.
  65. - dropped ldconfig scriptlets.
  66. * Thu Jul 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.3-1
  67. - new upstream release.
  68. - dropped Patch0000: fixed in upstream.
  69. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.1-1
  70. - new upstream release.
  71. - dropped Source1.
  72. - dropped Patch0.
  73. - imported Patch0000 from rawhide.
  74. - dropped a sub-package "doc".
  75. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.7.1-2
  76. - rebuild with gcc-5.4.0
  77. * Tue Jan 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.7.1-1
  78. - Initial build for Vine Linux
  79. * Sun Sep 21 2014 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.14.rc2
  80. - Allow int values to be converted to string (#1143774)
  81. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.13.rc2
  82. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  83. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.12.rc2
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  85. * Tue Sep 10 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.11.rc2
  86. - https://bugzilla.redhat.com/show_bug.cgi?id=998149 : applied Michael Schwendt's
  87. patch to fix duplicated documentation
  88. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-0.10.rc2
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  90. * Fri Mar 15 2013 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.9.rc2
  91. - Changed Summary
  92. - Added %%doc files to the doc package
  93. - Added python as an explicit BuildRequires
  94. * Fri Feb 15 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.8.rc2
  95. - Added documentation sub-package
  96. * Sun Jan 20 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.7.rc2
  97. - Added graphviz as a BuildRequire
  98. * Sat Jan 19 2013 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.6.rc2
  99. - Install the corrected library
  100. * Sat Dec 22 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.5.rc2
  101. - Added libjsoncpp.so.0
  102. - Moved the shared lib build to the correct section
  103. * Fri Dec 21 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.4.rc2
  104. - Removed doc subpackage
  105. - Added .pc file
  106. - Fixed shared lib
  107. * Wed Dec 12 2012 Sebastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.3.rc2
  108. - Removed static package
  109. - Preserving timestamp on installed files
  110. - Added guard grep to the sed expression
  111. - Removed duplicated doc files
  112. - Removed dependency on pkgconfig
  113. - Changed base package group
  114. * Sun Dec 02 2012 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.6.0-0.2.rc2
  115. - Changed license field to Public Domain or MIT
  116. * Tue Nov 27 2012 Sébastien Willmann <sebastien.willmann@gmail.com> 0.6.0-0.1.rc2
  117. - Creation of the spec file