nss-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. %define nspr_version 4.11
  4. %define unsupported_tools_directory %{_libdir}/nss/unsupported-tools
  5. # Produce .chk files for the final stripped binaries
  6. #
  7. # NOTE: The LD_LIBRARY_PATH line guarantees shlibsign links
  8. # against the freebl that we just built. This is necessary
  9. # because the signing algorithm changed on 3.14 to DSA2 with SHA256
  10. # whereas we previously signed with DSA and SHA1. We must Keep this line
  11. # until all mock platforms have been updated.
  12. # After %%{__os_install_post} we would add
  13. # export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%%{_libdir}
  14. %define __spec_install_post \
  15. %{?__debug_package:%{__debug_install_post}} \
  16. %{__arch_install_post} \
  17. %{__os_install_post} \
  18. $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libsoftokn3.so \
  19. $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libfreebl3.so \
  20. $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libnssdbm3.so \
  21. %{nil}
  22. Summary: Network Security Services
  23. Name: nss
  24. Version: 3.21.1
  25. Release: 2%{?_dist_release}
  26. License: MPLv1.1 or GPLv2+ or LGPLv2+
  27. URL: http://www.mozilla.org/projects/security/pki/nss/
  28. Group: System Environment/Libraries
  29. Source0: %{name}-%{version}.tar.gz
  30. Source1: nss.pc.in
  31. Source2: nss-config.in
  32. Source3: blank-cert8.db
  33. Source4: blank-key3.db
  34. Source5: blank-secmod.db
  35. Source6: blank-cert9.db
  36. Source7: blank-key4.db
  37. Source8: system-pkcs11.txt
  38. Source12: %{name}-pem-20140125.tar.bz2
  39. Source101: nss-util.pc.in
  40. Source102: nss-util-config.in
  41. Source103: nss-softokn.pc.in
  42. Source104: nss-softokn-config.in
  43. Patch2: add-relro-linker-option.patch
  44. Patch3: renegotiate-transitional.patch
  45. Patch6: nss-enable-pem.patch
  46. Patch16: nss-539183.patch
  47. Patch18: nss-646045.patch
  48. # TODO: Remove this patch when the ocsp test are fixed
  49. Patch40: nss-3.14.0.0-disble-ocsp-test.patch
  50. Patch50: iquote.patch
  51. # As of nss-3.21 we compile NSS with -Werror.
  52. # see https://bugzilla.mozilla.org/show_bug.cgi?id=1182667
  53. # This requires a cleanup of the PEM module as we have it here.
  54. # TODO: submit a patch to the interim nss-pem upstream project
  55. # The submission will be very different from this patch as
  56. # cleanup there is already in progress there.
  57. Patch51: pem-compile-with-Werror.patch
  58. Patch52: Bug-1001841-disable-sslv2-libssl.patch
  59. Patch53: Bug-1001841-disable-sslv2-tests.patch
  60. Patch54: sslauth-no-v2.patch
  61. Patch55: enable-fips-when-system-is-in-fips-mode.patch
  62. # rhbz: https://bugzilla.redhat.com/show_bug.cgi?id=1026677
  63. Patch56: p-ignore-setpolicy.patch
  64. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=943144
  65. Patch62: nss-fix-deadlock-squash.patch
  66. # Two patches from from rhel6.8 that are also needed for rhel-7
  67. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1054373
  68. Patch74: race.patch
  69. Patch94: nss-3.16-token-init-race.patch
  70. Patch99: ssl-server-min-key-sizes.patch
  71. Patch100: fix-min-library-version-in-SSLVersionRange.patch
  72. # Add support for sha384 tls cipher suites, dss cipher suites, and
  73. # server-side dhe key exchange
  74. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=102794
  75. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
  76. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
  77. Patch101: dhe-sha384-dss-support.patch
  78. # TODO: From upstream review: For the client authentication case, should
  79. # probably drop our hack of swapping between sha256 and sha384 and plan
  80. # on implementing the fix we already have a patch for. What is that fix?
  81. Patch102: client_auth_for_sha384_prf_support.patch
  82. Patch103: nss-fix-client-auth-init-hashes.patch
  83. Patch104: nss-map-oid-to-hashalg.patch
  84. Patch105: nss-remove-bogus-assert.patch
  85. Patch106: nss-old-pkcs11-num.patch
  86. Patch107: nss-enable-384-cipher-tests.patch
  87. Patch108: nss-sni-c-v-fix.patch
  88. Patch109: nss-fix-signature-and-hash.patch
  89. Patch110: nss-sslstress-txt-ssl3-lower-value-in-range.patch
  90. # Enable by default two additional ciphers and fix order of two tables
  91. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
  92. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
  93. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1211403
  94. Patch112: rh1238290.patch
  95. # Local: keep as long nss-softokn lacks support
  96. Patch113: disable-extended-master-secret-with-old-softoken.patch
  97. # extra tests needed
  98. Patch114: tests-extra.patch
  99. Patch115: nss-prevent-abi-issue.patch
  100. Patch116: nss-tests-prevent-abi-issue.patch
  101. Patch117: fix-nss-test-filtering.patch
  102. Patch118: fix-allowed-sig-alg.patch
  103. Patch119: nss-ssl-ssl3con-delete-duplicates.patch
  104. # Local patches
  105. Patch1002: hasht-dont-include-prtypes.patch
  106. Patch1007: pkcs1sig-include-prtypes.patch
  107. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
  108. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
  109. Patch1008: nss-util-3.19.1-tls12-mechanisms.patch
  110. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  111. BuildRequires: nspr-devel >= %{nspr_version}
  112. BuildRequires: sqlite3-devel
  113. BuildRequires: zlib-devel
  114. BuildRequires: pkgconfig
  115. BuildRequires: gawk
  116. BuildRequires: psmisc
  117. BuildRequires: perl
  118. Provides: mozilla-nss
  119. Obsoletes: mozilla-nss
  120. Requires: nspr >= %{nspr_version}
  121. %description
  122. Network Security Services (NSS) is a set of libraries designed to
  123. support cross-platform development of security-enabled client and
  124. server applications. Applications built with NSS can support SSL v2
  125. and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
  126. v3 certificates, and other security standards.
  127. %package tools
  128. Summary: Tools for the Network Security Services
  129. Group: System Environment/Base
  130. Requires: nss = %{version}-%{release}
  131. %description tools
  132. Network Security Services (NSS) is a set of libraries designed to
  133. support cross-platform development of security-enabled client and
  134. server applications. Applications built with NSS can support SSL v2
  135. and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
  136. v3 certificates, and other security standards.
  137. Install the nss-tools package if you need command-line tools to
  138. manipulate the NSS certificate and key database.
  139. %package devel
  140. Summary: Development libraries for Network Security Services
  141. Group: Development/Libraries
  142. Requires: nss = %{version}-%{release}
  143. Requires: nspr-devel >= %{nspr_version}
  144. Provides: mozilla-nss-devel
  145. Obsoletes: mozilla-nss-devel
  146. %description devel
  147. Header and Library files for doing development with Network Security Services.
  148. %package pkcs11-devel
  149. Summary: Development libraries for PKCS #11 (Cryptoki) using NSS
  150. Group: Development/Libraries
  151. Requires: nss-devel = %{version}-%{release}
  152. %description pkcs11-devel
  153. Library files for developing PKCS #11 modules using basic NSS
  154. low level services.
  155. ## to build compat32 for x86_64 architecture support
  156. %package -n compat32-%{name}
  157. Summary: Network Security Services
  158. Group: System Environment/Libraries
  159. %description -n compat32-%{name}
  160. Network Security Services (NSS) is a set of libraries designed to
  161. support cross-platform development of security-enabled client and
  162. server applications. Applications built with NSS can support SSL v2
  163. and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
  164. v3 certificates, and other security standards.
  165. %prep
  166. %setup -q
  167. %setup -q -T -D -n %{name}-%{version} -a 12
  168. %patch2 -p0 -b .relro
  169. %patch3 -p0 -b .transitional
  170. %patch6 -p0 -b .libpem
  171. %patch16 -p0 -b .539183
  172. pushd nss
  173. %patch18 -p1 -b .646045
  174. popd
  175. %patch40 -p0 -b .noocsptest
  176. %patch50 -p0 -b .iquote
  177. %patch51 -p1 -b -Werror
  178. pushd nss
  179. %patch52 -p1 -b .disableSSL2libssl
  180. %patch53 -p1 -b .disableSSL2tests
  181. %patch54 -p1 -b .sslauth-no-v2
  182. %patch55 -p1 -b .852023_enable_fips_when_in_fips_mode
  183. %patch56 -p1 -b .1026677_ignore_set_policy
  184. %patch62 -p1 -b .fix_deadlock
  185. %patch99 -p1 -b .min_key_sizes
  186. %patch100 -p0 -b .1171318
  187. %patch101 -p1 -b .dhe_and_sha384
  188. %patch102 -p1 -b .client_auth_prf
  189. %patch112 -p1 -b .1238290
  190. %patch113 -p1 -b .disable-ems
  191. %patch114 -p1 -b .extra
  192. %patch115 -p1 -b .abi_lib
  193. %patch116 -p1 -b .abi_tests
  194. %patch117 -p1 -b .test-filtering
  195. %patch74 -p1 -b .race
  196. popd
  197. %patch94 -p0 -b .init-token-race
  198. %patch103 -p0 -b .fix_client_auth_crash
  199. %patch104 -p0 -b .use_oids
  200. %patch105 -p0 -b .remove_bogus_assert
  201. %patch106 -p0 -b .old_pkcs11_num
  202. %patch107 -p0 -b .enable_384_cipher_tests
  203. %patch108 -p0 -b .sni_c_v_fix
  204. %patch109 -p0 -b .fix_signature_and_hash
  205. %patch110 -p0 -b .no_ssl2
  206. pushd nss
  207. %patch118 -p1 -b .allowed-sig-alg
  208. popd
  209. %patch119 -p0 -b .delete_duplicates
  210. %patch1002 -p0 -b .prtypes
  211. %patch1007 -p0 -b .include_prtypes
  212. %patch1008 -p1 -b .tls12_mechs
  213. pemNeedsFromSoftoken="lowkeyi lowkeyti softoken softoknt"
  214. for file in ${pemNeedsFromSoftoken}; do
  215. %{__cp} ./nss/lib/softoken/${file}.h ./nss/lib/ckfw/pem/
  216. done
  217. %{__cp} ./nss/lib/softoken/lowkeyi.h ./nss/cmd/rsaperf
  218. %{__cp} ./nss/lib/softoken/lowkeyti.h ./nss/cmd/rsaperf
  219. pushd nss/tests/ssl
  220. # Create versions of sslcov.txt and sslstress.txt that disable tests
  221. # for SSL2 and EXPORT ciphers.
  222. cat sslcov.txt| sed -r "s/^([^#].*EXPORT|^[^#].*SSL2)/#disabled \1/" > sslcov.noSSL2orExport.txt
  223. cat sslstress.txt| sed -r "s/^([^#].*EXPORT|^[^#].*SSL2)/#disabled \1/" > sslstress.noSSL2orExport.txt
  224. popd
  225. %build
  226. export NSS_NO_SSL2=1
  227. NSS_NO_PKCS11_BYPASS=1
  228. export NSS_NO_PKCS11_BYPASS
  229. # partial RELRO support as a security enhancement
  230. LDFLAGS+=-Wl,-z,relro
  231. export LDFLAGS
  232. FREEBL_NO_DEPEND=1
  233. export FREEBL_NO_DEPEND
  234. # Must export FREEBL_LOWHASH=1 for nsslowhash.h so that it gets
  235. # copied to dist and the rpm install phase can find it
  236. # This due of the upstream changes to fix
  237. # https://bugzilla.mozilla.org/show_bug.cgi?id=717906
  238. FREEBL_LOWHASH=1
  239. export FREEBL_LOWHASH
  240. # Enable compiler optimizations and disable debugging code
  241. BUILD_OPT=1
  242. export BUILD_OPT
  243. # Generate symbolic info for debuggers
  244. XCFLAGS=$RPM_OPT_FLAGS
  245. export XCFLAGS
  246. PKG_CONFIG_ALLOW_SYSTEM_LIBS=1
  247. PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1
  248. export PKG_CONFIG_ALLOW_SYSTEM_LIBS
  249. export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS
  250. NSPR_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nspr | sed 's/-I//'`
  251. NSPR_LIB_DIR=`/usr/bin/pkg-config --libs-only-L nspr | sed 's/-L//'`
  252. export NSPR_INCLUDE_DIR
  253. export NSPR_LIB_DIR
  254. #export FREEBL_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-softokn | sed 's/-I//'`
  255. #export FREEBL_LIB_DIR=%{_libdir}
  256. export USE_SYSTEM_FREEBL=0
  257. NSS_USE_SYSTEM_SQLITE=1
  258. export NSS_USE_SYSTEM_SQLITE
  259. export USE_SYSTEM_ZLIB=1
  260. export ZLIB_LIBS=%{_libdir}
  261. %ifarch x86_64 ppc64 ia64 s390x
  262. USE_64=1
  263. export USE_64
  264. %endif
  265. # uncomment if the iquote patch is activated
  266. export IN_TREE_FREEBL_HEADERS_FIRST=1
  267. #export NSS_BLTEST_NOT_AVAILABLE=1
  268. #
  269. #%{__make} -C ./nss/coreconf
  270. #%{__make} -C ./nss/lib/dbm
  271. %{__make} -C ./nss
  272. %install
  273. # There is no make install target so we'll do it ourselves.
  274. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3
  275. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3/templates
  276. %{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
  277. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}
  278. %{__mkdir_p} $RPM_BUILD_ROOT/%{unsupported_tools_directory}
  279. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  280. # Copy the binary libraries we want
  281. for file in libsoftokn3.so libfreebl3.so libnss3.so libnssutil3.so \
  282. libssl3.so libsmime3.so libnssckbi.so libnsspem.so libnssdbm3.so
  283. do
  284. %{__install} -m 755 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
  285. done
  286. # Install the empty NSS db files
  287. # Legacy db
  288. %{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb
  289. %{__install} -m 644 %{SOURCE3} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/cert8.db
  290. %{__install} -m 644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/key3.db
  291. %{__install} -m 644 %{SOURCE5} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/secmod.db
  292. # Shared db
  293. %{__install} -p -m 644 %{SOURCE6} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/cert9.db
  294. %{__install} -p -m 644 %{SOURCE7} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/key4.db
  295. %{__install} -p -m 644 %{SOURCE8} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/pkcs11.txt
  296. # Copy the development libraries we want
  297. for file in libcrmf.a libnssb.a libnssckfw.a
  298. do
  299. %{__install} -m 644 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
  300. done
  301. # Copy the binaries we want
  302. for file in certutil cmsutil crlutil modutil pk12util signtool signver ssltap
  303. do
  304. %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{_bindir}
  305. done
  306. # Copy the binaries we ship as unsupported
  307. for file in atob btoa derdump ocspclnt pp selfserv shlibsign strsclnt symkeyutil tstclnt vfyserv vfychain
  308. do
  309. %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{unsupported_tools_directory}
  310. done
  311. # Copy the include files
  312. for file in dist/public/nss/*.h
  313. do
  314. %{__install} -m 644 $file $RPM_BUILD_ROOT/%{_includedir}/nss3
  315. done
  316. # Copy some freebl include files we also want
  317. for file in blapi.h alghmac.h
  318. do
  319. %{__install} -p -m 644 dist/private/nss/$file $RPM_BUILD_ROOT/%{_includedir}/nss3
  320. done
  321. # Set up our package file
  322. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  323. %{__cat} %{SOURCE1} | sed -e "s,%%libdir%%,%{_libdir},g" \
  324. -e "s,%%prefix%%,%{_prefix},g" \
  325. -e "s,%%exec_prefix%%,%{_prefix},g" \
  326. -e "s,%%includedir%%,%{_includedir}/nss3,g" \
  327. -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
  328. -e "s,%%NSS_VERSION%%,%{version},g" \
  329. -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
  330. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss.pc
  331. NSS_VMAJOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
  332. NSS_VMINOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMINOR" | awk '{print $3}'`
  333. NSS_VPATCH=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VPATCH" | awk '{print $3}'`
  334. export NSS_VMAJOR
  335. export NSS_VMINOR
  336. export NSS_VPATCH
  337. %{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
  338. %{__cat} %{SOURCE2} | sed -e "s,@libdir@,%{_libdir},g" \
  339. -e "s,@prefix@,%{_prefix},g" \
  340. -e "s,@exec_prefix@,%{_prefix},g" \
  341. -e "s,@includedir@,%{_includedir}/nss3,g" \
  342. -e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \
  343. -e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \
  344. -e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \
  345. > $RPM_BUILD_ROOT/%{_bindir}/nss-config
  346. chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-config
  347. %{__cat} %{SOURCE101} | sed -e "s,%%libdir%%,%{_libdir},g" \
  348. -e "s,%%prefix%%,%{_prefix},g" \
  349. -e "s,%%exec_prefix%%,%{_prefix},g" \
  350. -e "s,%%includedir%%,%{_includedir}/nss3,g" \
  351. -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
  352. -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
  353. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss-util.pc
  354. NSSUTIL_VMAJOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMAJOR" | awk '{print $3}'`
  355. NSSUTIL_VMINOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMINOR" | awk '{print $3}'`
  356. NSSUTIL_VPATCH=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VPATCH" | awk '{print $3}'`
  357. export NSSUTIL_VMAJOR
  358. export NSSUTIL_VMINOR
  359. export NSSUTIL_VPATCH
  360. %{__cat} %{SOURCE102} | sed -e "s,@libdir@,%{_libdir},g" \
  361. -e "s,@prefix@,%{_prefix},g" \
  362. -e "s,@exec_prefix@,%{_prefix},g" \
  363. -e "s,@includedir@,%{_includedir}/nss3,g" \
  364. -e "s,@MOD_MAJOR_VERSION@,$NSSUTIL_VMAJOR,g" \
  365. -e "s,@MOD_MINOR_VERSION@,$NSSUTIL_VMINOR,g" \
  366. -e "s,@MOD_PATCH_VERSION@,$NSSUTIL_VPATCH,g" \
  367. > $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
  368. chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
  369. %{__cat} %{SOURCE103} | sed -e "s,%%libdir%%,%{_libdir},g" \
  370. -e "s,%%prefix%%,%{_prefix},g" \
  371. -e "s,%%exec_prefix%%,%{_prefix},g" \
  372. -e "s,%%includedir%%,%{_includedir}/nss3,g" \
  373. -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
  374. -e "s,%%NSSUTIL_VERSION%%,%{version},g" \
  375. -e "s,%%SOFTOKEN_VERSION%%,%{version},g" > \
  376. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss-softokn.pc
  377. SOFTOKEN_VMAJOR=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VMAJOR" | awk '{print $3}'`
  378. SOFTOKEN_VMINOR=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VMINOR" | awk '{print $3}'`
  379. SOFTOKEN_VPATCH=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VPATCH" | awk '{print $3}'`
  380. export SOFTOKEN_VMAJOR
  381. export SOFTOKEN_VMINOR
  382. export SOFTOKEN_VPATCH
  383. %{__cat} %{SOURCE104} | sed -e "s,@libdir@,%{_libdir},g" \
  384. -e "s,@prefix@,%{_prefix},g" \
  385. -e "s,@exec_prefix@,%{_prefix},g" \
  386. -e "s,@includedir@,%{_includedir}/nss3,g" \
  387. -e "s,@MOD_MAJOR_VERSION@,$SOFTOKEN_VMAJOR,g" \
  388. -e "s,@MOD_MINOR_VERSION@,$SOFTOKEN_VMINOR,g" \
  389. -e "s,@MOD_PATCH_VERSION@,$SOFTOKEN_VPATCH,g" \
  390. > $RPM_BUILD_ROOT/%{_bindir}/nss-softokn-config
  391. chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-softokn-config
  392. %clean
  393. %{__rm} -rf $RPM_BUILD_ROOT
  394. %post
  395. /sbin/ldconfig >/dev/null 2>/dev/null
  396. %postun
  397. /sbin/ldconfig >/dev/null 2>/dev/null
  398. %files
  399. %defattr(-,root,root)
  400. %{_libdir}/libnss3.so
  401. %{_libdir}/libnssutil3.so
  402. %{_libdir}/libnssdbm3.so
  403. %{_libdir}/libssl3.so
  404. %{_libdir}/libsmime3.so
  405. %{_libdir}/libsoftokn3.so
  406. %{_libdir}/libnssckbi.so
  407. %{_libdir}/libnsspem.so
  408. %{_libdir}/libfreebl3.so
  409. %{unsupported_tools_directory}/shlibsign
  410. %{_libdir}/libfreebl3.chk
  411. %{_libdir}/libnssdbm3.chk
  412. %{_libdir}/libsoftokn3.chk
  413. %dir %{_sysconfdir}/pki/nssdb
  414. %config(noreplace) %{_sysconfdir}/pki/nssdb/cert8.db
  415. %config(noreplace) %{_sysconfdir}/pki/nssdb/key3.db
  416. %config(noreplace) %{_sysconfdir}/pki/nssdb/secmod.db
  417. %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/cert9.db
  418. %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/key4.db
  419. %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/pkcs11.txt
  420. %files tools
  421. %defattr(-,root,root)
  422. %{_bindir}/certutil
  423. %{_bindir}/cmsutil
  424. %{_bindir}/crlutil
  425. %{_bindir}/modutil
  426. %{_bindir}/pk12util
  427. %{_bindir}/signtool
  428. %{_bindir}/signver
  429. %{_bindir}/ssltap
  430. %{unsupported_tools_directory}/atob
  431. %{unsupported_tools_directory}/btoa
  432. %{unsupported_tools_directory}/derdump
  433. %{unsupported_tools_directory}/ocspclnt
  434. %{unsupported_tools_directory}/pp
  435. %{unsupported_tools_directory}/selfserv
  436. %{unsupported_tools_directory}/strsclnt
  437. %{unsupported_tools_directory}/symkeyutil
  438. %{unsupported_tools_directory}/tstclnt
  439. %{unsupported_tools_directory}/vfyserv
  440. %{unsupported_tools_directory}/vfychain
  441. %files devel
  442. %defattr(-,root,root)
  443. %{_libdir}/libcrmf.a
  444. %{_libdir}/pkgconfig/nss.pc
  445. %{_libdir}/pkgconfig/nss-softokn.pc
  446. %{_libdir}/pkgconfig/nss-util.pc
  447. %{_bindir}/nss-config
  448. %{_bindir}/nss-softokn-config
  449. %{_bindir}/nss-util-config
  450. %dir %{_includedir}/nss3
  451. %{_includedir}/nss3/alghmac.h
  452. %{_includedir}/nss3/base64.h
  453. %{_includedir}/nss3/blapi.h
  454. %{_includedir}/nss3/blapit.h
  455. %{_includedir}/nss3/cert.h
  456. %{_includedir}/nss3/certdb.h
  457. %{_includedir}/nss3/certt.h
  458. %{_includedir}/nss3/ciferfam.h
  459. %{_includedir}/nss3/cmmf.h
  460. %{_includedir}/nss3/cmmft.h
  461. %{_includedir}/nss3/cms.h
  462. %{_includedir}/nss3/cmsreclist.h
  463. %{_includedir}/nss3/cmst.h
  464. %{_includedir}/nss3/crmf.h
  465. %{_includedir}/nss3/crmft.h
  466. %{_includedir}/nss3/cryptohi.h
  467. %{_includedir}/nss3/cryptoht.h
  468. %{_includedir}/nss3/ecl-exp.h
  469. %{_includedir}/nss3/hasht.h
  470. %{_includedir}/nss3/jar-ds.h
  471. %{_includedir}/nss3/jar.h
  472. %{_includedir}/nss3/jarfile.h
  473. %{_includedir}/nss3/key.h
  474. %{_includedir}/nss3/keyhi.h
  475. %{_includedir}/nss3/keyt.h
  476. %{_includedir}/nss3/keythi.h
  477. %{_includedir}/nss3/nss.h
  478. %{_includedir}/nss3/nssb64.h
  479. %{_includedir}/nss3/nssb64t.h
  480. %{_includedir}/nss3/nssckbi.h
  481. %{_includedir}/nss3/nssilckt.h
  482. %{_includedir}/nss3/nssilock.h
  483. %{_includedir}/nss3/nsslocks.h
  484. %{_includedir}/nss3/nsslowhash.h
  485. %{_includedir}/nss3/nsspem.h
  486. %{_includedir}/nss3/nssrwlk.h
  487. %{_includedir}/nss3/nssrwlkt.h
  488. %{_includedir}/nss3/nssutil.h
  489. %{_includedir}/nss3/ocsp.h
  490. %{_includedir}/nss3/ocspt.h
  491. %{_includedir}/nss3/p12.h
  492. %{_includedir}/nss3/p12plcy.h
  493. %{_includedir}/nss3/p12t.h
  494. %{_includedir}/nss3/pk11func.h
  495. %{_includedir}/nss3/pk11pqg.h
  496. %{_includedir}/nss3/pk11priv.h
  497. %{_includedir}/nss3/pk11pub.h
  498. %{_includedir}/nss3/pk11sdr.h
  499. %{_includedir}/nss3/pkcs11.h
  500. %{_includedir}/nss3/pkcs11f.h
  501. %{_includedir}/nss3/pkcs11n.h
  502. %{_includedir}/nss3/pkcs11p.h
  503. %{_includedir}/nss3/pkcs11t.h
  504. %{_includedir}/nss3/pkcs11u.h
  505. %{_includedir}/nss3/pkcs12.h
  506. %{_includedir}/nss3/pkcs12t.h
  507. %{_includedir}/nss3/pkcs7t.h
  508. %{_includedir}/nss3/pkcs1sig.h
  509. %{_includedir}/nss3/portreg.h
  510. %{_includedir}/nss3/preenc.h
  511. %{_includedir}/nss3/secasn1.h
  512. %{_includedir}/nss3/secasn1t.h
  513. %{_includedir}/nss3/seccomon.h
  514. %{_includedir}/nss3/secder.h
  515. %{_includedir}/nss3/secdert.h
  516. %{_includedir}/nss3/secdig.h
  517. %{_includedir}/nss3/secdigt.h
  518. %{_includedir}/nss3/secerr.h
  519. %{_includedir}/nss3/sechash.h
  520. %{_includedir}/nss3/secitem.h
  521. %{_includedir}/nss3/secmime.h
  522. %{_includedir}/nss3/secmod.h
  523. %{_includedir}/nss3/secmodt.h
  524. %{_includedir}/nss3/secoid.h
  525. %{_includedir}/nss3/secoidt.h
  526. %{_includedir}/nss3/secpkcs5.h
  527. %{_includedir}/nss3/secpkcs7.h
  528. %{_includedir}/nss3/secport.h
  529. %{_includedir}/nss3/shsign.h
  530. %{_includedir}/nss3/smime.h
  531. %{_includedir}/nss3/ssl.h
  532. %{_includedir}/nss3/sslerr.h
  533. %{_includedir}/nss3/sslproto.h
  534. %{_includedir}/nss3/sslt.h
  535. %{_includedir}/nss3/utilrename.h
  536. %{_includedir}/nss3/utilmodt.h
  537. %{_includedir}/nss3/utilpars.h
  538. %{_includedir}/nss3/utilparst.h
  539. %files pkcs11-devel
  540. %defattr(-, root, root)
  541. %{_includedir}/nss3/nssbase.h
  542. %{_includedir}/nss3/nssbaset.h
  543. %{_includedir}/nss3/nssckepv.h
  544. %{_includedir}/nss3/nssckft.h
  545. %{_includedir}/nss3/nssckfw.h
  546. %{_includedir}/nss3/nssckfwc.h
  547. %{_includedir}/nss3/nssckfwt.h
  548. %{_includedir}/nss3/nssckg.h
  549. %{_includedir}/nss3/nssckmdt.h
  550. %{_includedir}/nss3/nssckt.h
  551. %{_libdir}/libnssb.a
  552. %{_libdir}/libnssckfw.a
  553. ## to build compat32 for x86_64 architecture support
  554. %if %{build_compat32}
  555. %files -n compat32-%{name}
  556. %defattr(-,root,root)
  557. %{_libdir}/*.so
  558. %ghost %{_libdir}/libsoftokn3.chk
  559. %ghost %{_libdir}/libfreebl3.chk
  560. %{unsupported_tools_directory}/shlibsign
  561. %endif
  562. %changelog
  563. * Mon Jun 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.21.1-2
  564. - enabled softokn and freebl.
  565. - dropped Patch47 and Patch49.
  566. * Tue May 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.21.1-1
  567. - update to 3.21.1
  568. - import patches from centos package
  569. * Thu Jun 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.16.1-1
  570. - update to 3.16.1
  571. * Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.3-1
  572. - update to 3.14.3
  573. - import patches from fedora package
  574. * Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.1-1
  575. - update to 3.14.1
  576. * Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.6-2
  577. - add Source101 (nss-util.pc.in)
  578. - add Source102 (nss-util-config.in)
  579. * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.6-1
  580. - new upstream release
  581. * Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.3-1
  582. - new upstream release
  583. * Thu Dec 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-2
  584. - fix nss.pc
  585. * Wed Dec 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-1
  586. - new upstream release
  587. * Fri Sep 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.11-1
  588. - new upstram release
  589. * Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.10-1
  590. - update to 3.12.10
  591. * Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.9-1
  592. - update to 3.12.9.with.ckbi.1.82
  593. - update nss-pem source
  594. - define NSS_USE_SYSTEM_SQLITE, remove unneeded Patch2
  595. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-2
  596. - rebuild with rpm-4.8.1 for pkg-config file
  597. * Wed Apr 7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12.6-1
  598. - new upstream release
  599. - update nss-pem Source12 to 20091210 (from 3.12.6-2.fc14)
  600. * Sat Jan 23 2010 NAKAMURA Kenta <kenta@vinelinux.org> 3.12.5-2
  601. - built with FREEBL_NO_DEPEND environmental variable to include nsslowhash.h
  602. * Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.5-1
  603. - new upstream release
  604. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-4
  605. - rebuild to fix the package built with broken environment.
  606. * Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-3
  607. - fixed %%files for compat32
  608. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-2
  609. - added compat32 subpackages
  610. * Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-1
  611. - new upstream release
  612. * Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-1
  613. - new upstream release
  614. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.11.4-0vl1
  615. - initial build for Vine Linux
  616. * Fri Mar 02 2007 Kai Engert <kengert@redhat.com> - 3.11.5-2
  617. - Fix rhbz#230545, failure to enable FIPS mode
  618. - Fix rhbz#220542, make NSS more tolerant of resets when in the
  619. middle of prompting for a user password.
  620. * Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 3.11.5-1
  621. - Update to 3.11.5
  622. - This update fixes two security vulnerabilities with SSL 2
  623. - Do not use -rpath link option
  624. - Added several unsupported tools to tools package
  625. * Tue Jan 9 2007 Bob Relyea <rrelyea@redhat.com> - 3.11.4-4
  626. - disable ECC, cleanout dead code
  627. * Tue Nov 28 2006 Kai Engert <kengert@redhat.com> - 3.11.4-1
  628. - Update to 3.11.4
  629. * Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-2
  630. - Revert the attempt to require latest NSPR, as it is not yet available
  631. in the build infrastructure.
  632. * Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-1
  633. - Update to 3.11.3
  634. * Thu Aug 03 2006 Kai Engert <kengert@redhat.com> - 3.11.2-2
  635. - Add /etc/pki/nssdb
  636. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.11.2-1.1
  637. - rebuild
  638. * Fri Jun 30 2006 Kai Engert <kengert@redhat.com> - 3.11.2-1
  639. - Update to 3.11.2
  640. - Enable executable bit on shared libs, also fixes debug info.
  641. * Wed Jun 14 2006 Kai Engert <kengert@redhat.com> - 3.11.1-2
  642. - Enable Elliptic Curve Cryptography (ECC)
  643. * Fri May 26 2006 Kai Engert <kengert@redhat.com> - 3.11.1-1
  644. - Update to 3.11.1
  645. - Include upstream patch to limit curves
  646. * Wed Feb 15 2006 Kai Engert <kengert@redhat.com> - 3.11-4
  647. - add --noexecstack when compiling assembler on x86_64
  648. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.2
  649. - bump again for double-long bug on ppc(64)
  650. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.1
  651. - rebuilt for new gcc4.1 snapshot and glibc changes
  652. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 3.11-3
  653. - rebuild
  654. * Fri Dec 16 2005 Christopher Aillon <caillon@redhat.com> 3.11-2
  655. - Update file list for the devel packages
  656. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-1
  657. - Update to 3.11
  658. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs.2
  659. - Add patch to allow building on ppc*
  660. - Update the pkgconfig file to Require nspr
  661. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs
  662. - Initial import into Fedora Core, based on a CVS snapshot of
  663. the NSS_3_11_RTM tag
  664. - Fix up the pkcs11-devel subpackage to contain the proper headers
  665. - Build with RPM_OPT_FLAGS
  666. - No need to have rpath of /usr/lib in the pc file
  667. * Thu Dec 15 2005 Kai Engert <kengert@redhat.com>
  668. - Adressed review comments by Wan-Teh Chang, Bob Relyea,
  669. Christopher Aillon.
  670. * Sat Jul 9 2005 Rob Crittenden <rcritten@redhat.com> 3.10-1
  671. - Initial build