shotwell-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188
  1. Name: shotwell
  2. Version: 0.8.1
  3. Release: 3%{?_dist_release}
  4. Summary: A photo organizer for the GNOME desktop
  5. Summary(ja): GNOME デスクトップ向けの画像整理ソフト
  6. Group: Applications/Graphics
  7. # LGPLv2+ for the code
  8. # CC-BY-SA for some of the icons
  9. License: LGPLv2+ and CC-BY-SA
  10. URL: http://www.yorba.org/shotwell/
  11. Source0: http://www.yorba.org/download/shotwell/0.8/shotwell-%{version}.tar.bz2
  12. # svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
  13. #Patch0: workaround_desktop.patch
  14. Patch1: shotwell-0.8.1-vala.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: GConf2-devel
  17. BuildRequires: LibRaw-devel
  18. BuildRequires: LibRaw-static
  19. BuildRequires: WebKit-gtk-devel
  20. BuildRequires: dbus-glib-devel
  21. BuildRequires: desktop-file-utils
  22. BuildRequires: gettext
  23. BuildRequires: gtk2-devel
  24. BuildRequires: gstreamer-devel
  25. BuildRequires: hal-devel
  26. BuildRequires: json-glib-devel
  27. BuildRequires: libexif-devel
  28. BuildRequires: libgee-devel
  29. BuildRequires: libgphoto2-devel
  30. BuildRequires: libgudev1-devel
  31. BuildRequires: libgexiv2-devel >= 0.2.0
  32. BuildRequires: libsoup-devel
  33. BuildRequires: libxml2-devel
  34. BuildRequires: sqlite3-devel
  35. BuildRequires: unique-devel
  36. BuildRequires: vala-devel >= 0.9.5
  37. %description
  38. Shotwell is a new open source photo organizer designed for the GNOME desktop
  39. environment. It allows you to import photos from your camera, view and edit
  40. them, and share them with others.
  41. %description -l ja
  42. Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
  43. 画像整理ソフトです。
  44. あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
  45. 他の人々と共有するなどができます。
  46. %prep
  47. %setup -q -n %{name}-%{version}
  48. #%patch0 -p1
  49. %patch1 -p1
  50. %build
  51. ./configure --prefix=/usr --disable-schemas-install --assume-pkgs
  52. sed -i -e 's/\\n/\n/g' configure.mk
  53. sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
  54. sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
  55. make %{?_smp_mflags}
  56. %install
  57. rm -rf $RPM_BUILD_ROOT
  58. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  59. export XDG_DISABLE_MAKEFILE_UPDATES=1
  60. make install DESTDIR=$RPM_BUILD_ROOT
  61. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
  62. desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
  63. %find_lang %{name}
  64. %clean
  65. rm -rf $RPM_BUILD_ROOT
  66. %post
  67. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  68. update-desktop-database &> /dev/null || :
  69. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  70. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  71. %pre
  72. if [ "$1" -gt 1 ]; then
  73. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  74. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  75. fi
  76. %preun
  77. if [ "$1" -eq 0 ]; then
  78. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  79. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
  80. fi
  81. %postun
  82. if [ $1 -eq 0 ] ; then
  83. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  84. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  85. fi
  86. update-desktop-database &> /dev/null || :
  87. %posttrans
  88. gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
  89. %files -f %{name}.lang
  90. %defattr(-,root,root,-)
  91. %doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
  92. %{_sysconfdir}/gconf/schemas/shotwell.schemas
  93. %{_bindir}/shotwell
  94. %{_datadir}/gnome/help/
  95. %{_datadir}/shotwell
  96. %{_datadir}/applications/shotwell.desktop
  97. %{_datadir}/applications/shotwell-viewer.desktop
  98. %{_datadir}/icons/hicolor/*
  99. %exclude %{_datadir}/icons/hicolor/icon-theme.cache
  100. %changelog
  101. * Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
  102. - dropt Patch0
  103. - added BuildRequires: LibRaw-static
  104. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
  105. - add Patch1 (shotwell-0.8.1-vala.patch)
  106. * Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
  107. - new upstream release
  108. - added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
  109. * Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
  110. - rebuilt with rpm-4.8.1 for pkg-config
  111. - fixed %%changelog in Tue Sep 14 2010
  112. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
  113. - new upstream release
  114. - changed source URL
  115. - added Patch0 to work around desktop file incorrect comment
  116. - changed BuildRequires: vala-devel >= 0.9.5
  117. * Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
  118. - new upstream release
  119. * Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
  120. - new upstream release
  121. - changed BuildRequires: libgexiv2-devel >= 0.2.0
  122. * Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
  123. - fixed LIB_DIRS in libraw-config (for lib64)
  124. * Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
  125. - new upstream release
  126. - added BuildRequires: LibRaw-devel, libgexiv2-devel
  127. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
  128. - new upstream release
  129. * Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  130. - new upstream release
  131. - added BuildRequires: libgudev1-devel
  132. - applied new naming policy to spec
  133. * Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
  134. - new upstream release
  135. - proved Japanese description
  136. * Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
  137. - new upstrema release
  138. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
  139. - intial build for VineSeed
  140. * Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
  141. * Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  142. - Update to 0.3.2
  143. * Tue Nov 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
  144. - Version 0.3.0
  145. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
  146. - Rebuild against new libgee
  147. * Sun Aug 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
  148. - Bring icon cache handling in sync with current guidelines
  149. * Sun Aug 9 2009 Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
  150. - Initial packaging