clutter-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409
  1. %define clutter_version 1.26.2
  2. %define clutter_release 2%{?_dist_release}
  3. Name: clutter
  4. Version: %{clutter_version}
  5. Release: %{clutter_release}
  6. Summary: Open Source software library for creating rich graphical user interfaces
  7. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.clutter-project.org/
  11. Source0: http://www.clutter-project.org/sources/%{name}/1.26/%{name}-%{version}.tar.xz
  12. Patch0: clutter-fixdso.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: gobject-introspection
  15. # FIXME to remove when all the bits have been merged into their
  16. # libraries
  17. BuildRequires: glib2-devel
  18. BuildRequires: mesa-libGL-devel
  19. BuildRequires: mesa-libEGL-devel
  20. BuildRequires: gdk-pixbuf2-devel
  21. BuildRequires: atk-devel
  22. BuildRequires: gtk3-devel
  23. BuildRequires: pkgconfig
  24. BuildRequires: pango-devel
  25. BuildRequires: libXdamage-devel
  26. BuildRequires: libXcomposite-devel
  27. BuildRequires: libXi-devel
  28. BuildRequires: gettext
  29. BuildRequires: gtk-doc
  30. BuildRequires: gobject-introspection-devel >= 0.9.5
  31. BuildRequires: json-glib-devel
  32. BuildRequires: cogl-devel >= 1.20.0
  33. BuildRequires: libinput-devel
  34. BuildRequires: libxkbcommon-devel
  35. BuildRequires: eudev-libudev-devel
  36. BuildRequires: libgudev-devel
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. %description
  40. Clutter is an open source software library for creating fast,
  41. visually rich graphical user interfaces. The most obvious example
  42. of potential usage is in media center type applications.
  43. We hope however it can be used for a lot more.
  44. %description -l ja
  45. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  46. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  47. しかしながら、我々はいろいろな分野で使用されることを願っています。
  48. %package devel
  49. Summary: Clutter development environment
  50. Summary(ja): Clutterの開発環境
  51. Group: Development/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  54. Requires: mesa-libGL-devel
  55. Requires: mesa-libEGL-devel
  56. Requires: gobject-introspection-devel
  57. Requires: json-glib-devel
  58. Requires: libXcomposite-devel
  59. Requires: libXi-devel
  60. %description devel
  61. Header files and libraries for building a extension library for the
  62. clutter
  63. %package docs
  64. Summary: Documentation for %{name}
  65. Summary(ja): %{name}用のドキュメント
  66. Group: Documentation
  67. Provides: %{name}-doc = %{version}-%{release}
  68. BuildArch: noarch
  69. %description docs
  70. Clutter is an open source software library for creating fast,
  71. visually rich graphical user interfaces. The most obvious example
  72. of potential usage is in media center type applications.
  73. We hope however it can be used for a lot more.
  74. This package contains documentation for clutter.
  75. %prep
  76. %setup -q
  77. %patch0 -p1 -b .dso
  78. %build
  79. #%configure --enable-gtk-doc \
  80. # --enable-introspection=yes \
  81. # --disable-silent-rules \
  82. # --enable-xinput \
  83. # --disable-static
  84. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  85. %configure $CONFIGFLAGS \
  86. --disable-static \
  87. --disable-silent-rules \
  88. --enable-introspection=yes \
  89. --enable-xinput \
  90. --enable-x11-backend=yes \
  91. --enable-gdk-backend=no \
  92. --enable-egl-backend=yes \
  93. --enable-evdev-input=yes
  94. # clutter git ships with some magic to put the git log in shipped tarballs
  95. # which gets listed in files; don't blow up if it's missing
  96. if ! test -f ChangeLog; then
  97. echo "Created from snapshot" > ChangeLog
  98. fi
  99. )
  100. make V=0
  101. %install
  102. rm -rf $RPM_BUILD_ROOT
  103. #make DESTDIR=$RPM_BUILD_ROOT install
  104. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  105. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  106. %find_lang %{name}-1.0
  107. %clean
  108. rm -rf $RPM_BUILD_ROOT
  109. %post -p /sbin/ldconfig
  110. %postun -p /sbin/ldconfig
  111. %files -f %{name}-1.0.lang
  112. %defattr(-,root,root,-)
  113. %doc AUTHORS COPYING NEWS README
  114. %{_libdir}/*.so.*
  115. %{_libdir}/girepository-1.0/*.typelib
  116. %files devel
  117. %defattr(-, root, root)
  118. %doc ChangeLog
  119. %{_includedir}/clutter-1.0
  120. %{_libdir}/*.so
  121. %{_libdir}/pkgconfig/*.pc
  122. %{_datadir}/gir-1.0/*.gir
  123. %files docs
  124. %defattr(-, root, root)
  125. %{_datadir}/gtk-doc/html/clutter
  126. %changelog
  127. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.2-2
  128. - disabled gdk backend.
  129. * Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.2-1
  130. - new upstream release.
  131. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.0-1
  132. - new upstream release
  133. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.24.2-1
  134. - new upstream release
  135. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.4-1
  136. - new upstream release
  137. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.2-1
  138. - new upstream release
  139. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
  140. - new upstream release
  141. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
  142. - new upstream release
  143. - add BuildRequires: mesa-libEGL-devel
  144. * Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
  145. - new upstream release
  146. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
  147. - new upstream release
  148. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
  149. - new upstream release
  150. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
  151. - new upstream release
  152. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
  153. - new upstream release
  154. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
  155. - new upstream release
  156. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
  157. - new upstream release
  158. * Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  159. - new upstream release
  160. * Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
  161. - new upstream release
  162. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  163. - new upstream release
  164. * Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
  165. - new upstream release
  166. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
  167. - new upstream release
  168. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
  169. - new upstream release
  170. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  171. - new upstream release
  172. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
  173. - new upstream release
  174. * Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
  175. - new upstream release
  176. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  177. - new upstream release
  178. - add Requires: libXcomposite-devel, libXi-devel (-devel package)
  179. * Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
  180. - new upstream release
  181. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
  182. - new upstream release
  183. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
  184. - new upstream release
  185. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
  186. - new upstream release
  187. - add BuildRequires: cogl-devel
  188. - add "BuildArch: noarch" to doc sub package
  189. - add Patch0 (clutter-fixdso.patch)
  190. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  191. - new upstream release
  192. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  193. - new upstream release
  194. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  195. - new upstream release
  196. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  197. - new upstream release
  198. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  199. - new upstream release
  200. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  201. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  202. - drop Patch0
  203. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  204. - new upstream release
  205. - drop Patch1
  206. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  207. - new upstream release
  208. - add BuildRequires: json-glib-devel
  209. - delete Requires: gir-repository
  210. - delete BuildRequires: gir-repository-devel
  211. - add Requires: json-glib-devel (devel package)
  212. - add Patch0, Patch1
  213. - fix %build
  214. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  215. - rebuild with rpm-4.8.1 for pkg-config file
  216. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  217. - new upstream release
  218. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  219. - new upstream release
  220. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  221. - new upstream release
  222. - add configure option (--enable-xinput)
  223. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  224. - new upstream release
  225. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  226. - new upstream release
  227. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  228. - new upstream release
  229. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  230. - new upstream release
  231. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  232. - new upstream release
  233. - build for Vine Linux
  234. - add Summary(ja)
  235. - fix BuildRoot
  236. - remove Obsolete and Provides
  237. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  238. - Update to 1.0.6
  239. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  240. - Update to 1.0.4, update gobject-introspection requirement
  241. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  242. - Update to 1.0.2
  243. * Sat Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  244. - Move ChangeLog to -devel to save some space
  245. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  246. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  247. onto the live cd
  248. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  249. - Update to 1.0.0
  250. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  251. - fix bz #507389
  252. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  253. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  254. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  255. - Update to 0.9.8
  256. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  257. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  258. introspection support to clutter (#512260)
  259. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  260. - Update to 0.9.6
  261. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  262. - Update to 0.9.4
  263. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  264. - Update to 0.9.2
  265. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  266. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  267. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  268. - Remove noarch from doc subpackage
  269. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  270. - Added gtk-doc for cogl
  271. - Created doc subpackage
  272. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  273. - Update to 0.8.6
  274. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  275. - Update to 0.8.2
  276. - Removed clutter-0.8.0-clutter-fixed.patch
  277. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  278. - Update to 0.8.0
  279. - Added clutter-0.8.0-clutter-fixed.patch
  280. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  281. - Update to 0.6.4
  282. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  283. - Update to 0.6.2
  284. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  285. - Update to 0.6.0
  286. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  287. - Autorebuild for GCC 4.3
  288. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  289. - Update to 0.4.2
  290. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  291. - Update to 0.4.1
  292. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  293. - Update to 0.3.1
  294. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  295. - Update to 0.2.3
  296. * Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  297. - Changed buildrequires and requires
  298. * Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  299. - Fix .spec
  300. * Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  301. - Fix .spec
  302. * Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  303. - Initial RPM release