cryptsetup-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418
  1. %define _root_sbindir /sbin
  2. %define upstream_version %{version}
  3. Summary: A utility for setting up encrypted disks
  4. Summary(ja): 暗号化ファイルシステム設定用ユーティリティ
  5. Name: cryptsetup
  6. Version: 2.5.0
  7. Release: 1%{?_dist_release}
  8. Group: system,security
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv2 and LGPLv2+
  12. URL: https://gitlab.com/cryptsetup/cryptsetup
  13. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  14. Source0: https://www.kernel.org/pub/linux/utils/cryptsetup/v%{shortver}/cryptsetup-%{upstream_version}.tar.xz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: popt-devel
  17. BuildRequires: device-mapper-devel
  18. BuildRequires: json-c-devel
  19. BuildRequires: libblkid-devel
  20. BuildRequires: libgcrypt-devel
  21. BuildRequires: libgpg-error-devel
  22. BuildRequires: libssh-devel
  23. BuildRequires: libuuid-devel
  24. BuildRequires: openssl-devel
  25. Provides: cryptsetup-luks = %{version}-%{release}
  26. Obsoletes: cryptsetup-luks < 1.4.0
  27. Requires: cryptsetup-libs = %{version}-%{release}
  28. Obsoletes: %{name}-python < 2.0.0
  29. %description
  30. The cryptsetup package contains a utility for setting up
  31. disk encryption using dm-crypt kernel module.
  32. %description -l ja
  33. cryptsetup パッケージには、dm-crypt カーネルモジュールを使って
  34. ディスクの暗号化を設定するユーティリティが収録されています。
  35. %package devel
  36. Summary: Headers and libraries for using encrypted file systems
  37. Summary(ja): 暗号化ファイルシステムを使うためのヘッダとライブラリ
  38. Group: programming
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: libgcrypt-devel > 1.1.42
  41. Requires: device-mapper-devel
  42. Requires: libuuid-devel
  43. Requires: pkgconfig
  44. Provides: cryptsetup-luks-devel = %{version}-%{release}
  45. Obsoletes: cryptsetup-luks-devel < 1.4.0
  46. %description devel
  47. The cryptsetup-devel package contains libraries and header files
  48. used for writing code that makes use of disk encryption.
  49. %description devel -l ja
  50. cryptsetup-devel パッケージには、ディスクの暗号化を使うコードを
  51. 書くのに使われるライブラリとヘッダファイルが収録されています。
  52. %package libs
  53. Summary: Cryptsetup shared library
  54. Summary(ja): Cryptsetup 共有ライブラリ
  55. Group: system
  56. Provides: cryptsetup-luks-libs = %{version}-%{release}
  57. Obsoletes: cryptsetup-luks-libs < 1.4.0
  58. %description libs
  59. This package contains the cryptsetup shared library, libcryptsetup.
  60. %description libs -l ja
  61. このパッケージには、cryptsetup の共有ライブラリ、libcryptsetup が
  62. 収録されています。
  63. %debug_package
  64. %prep
  65. %setup -q -n cryptsetup-%{upstream_version}
  66. %build
  67. export PYTHON=%{__python3}
  68. %configure \
  69. --sbindir=%{_root_sbindir} \
  70. --libdir=/%{_lib} \
  71. --disable-selinux \
  72. --disable-asciidoc
  73. # remove rpath
  74. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  75. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  76. make %{?_smp_mflags}
  77. %install
  78. rm -rf %{buildroot}
  79. make install DESTDIR=%{buildroot}
  80. rm -rf %{buildroot}/%{_lib}/*.la %{buildroot}/%{_lib}/cryptsetup
  81. # move libcryptsetup.so to %%{_libdir}
  82. pushd %{buildroot}/%{_lib}
  83. rm libcryptsetup.so
  84. mkdir -p %{buildroot}/%{_libdir}
  85. ln -s ../../%{_lib}/$(ls libcryptsetup.so.??.?.?) %{buildroot}/%{_libdir}/libcryptsetup.so
  86. mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}
  87. popd
  88. %find_lang cryptsetup
  89. %clean
  90. rm -rf %{buildroot}
  91. %files -f cryptsetup.lang
  92. %license COPYING
  93. %doc ChangeLog AUTHORS TODO FAQ
  94. %{_mandir}/man8/*.8.gz
  95. %{_root_sbindir}/*
  96. %files devel
  97. %doc docs/examples/*
  98. %{_includedir}/libcryptsetup.h
  99. %{_libdir}/libcryptsetup.so
  100. %{_libdir}/pkgconfig/libcryptsetup.pc
  101. %files libs
  102. %license COPYING
  103. /%{_lib}/libcryptsetup.so.*
  104. %changelog
  105. * Tue Aug 30 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5.0-1
  106. - new upstream release.
  107. * Sun Oct 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.1-1
  108. - new upstream release.
  109. - built with openssl-3.0.0.
  110. - dropped ldconfig scriptlets.
  111. * Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.2-1
  112. - new upstream release.
  113. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3.1-1
  114. - new upstream release.
  115. * Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.5-1
  116. - updated to 1.7.5.
  117. * Sat Dec 6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.4.1-4
  118. - rebuilt with libgcrypt 1.6.0
  119. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.1-3
  120. - updated to 1.4.1; spec revamp; Japanese summary & description
  121. - Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
  122. - applied new versioning policy
  123. - Sun Dec 9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
  124. - initial build for VineSeed
  125. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.1-2
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  127. * Wed Nov 09 2011 Milan Broz <mbroz@redhat.com> - 1.4.1-1
  128. - Update to cryptsetup 1.4.1.
  129. - Add Python cryptsetup bindings.
  130. - Obsolete separate python-cryptsetup package.
  131. * Wed Oct 26 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-1
  132. - Update to cryptsetup 1.4.0.
  133. * Mon Oct 10 2011 Milan Broz <mbroz@redhat.com> - 1.4.0-0.1
  134. - Update to cryptsetup 1.4.0-rc1.
  135. - Rename package back from cryptsetup-luks to cryptsetup.
  136. * Wed Jun 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-2
  137. - Fix return code for status command when device doesn't exist.
  138. * Tue May 24 2011 Milan Broz <mbroz@redhat.com> - 1.3.1-1
  139. - Update to cryptsetup 1.3.1.
  140. * Tue Apr 05 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-1
  141. - Update to cryptsetup 1.3.0.
  142. * Tue Mar 22 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.2
  143. - Update to cryptsetup 1.3.0-rc2
  144. * Mon Mar 14 2011 Milan Broz <mbroz@redhat.com> - 1.3.0-0.1
  145. - Update to cryptsetup 1.3.0-rc1
  146. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  148. * Mon Dec 20 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-1
  149. - Update to cryptsetup 1.2.0
  150. * Thu Nov 25 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.2
  151. - Fix crypt_activate_by_keyfile() to work with PLAIN devices.
  152. * Tue Nov 16 2010 Milan Broz <mbroz@redhat.com> - 1.2.0-0.1
  153. - Add FAQ to documentation.
  154. - Update to cryptsetup 1.2.0-rc1
  155. * Sat Jul 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.3-1
  156. - Update to cryptsetup 1.1.3
  157. * Mon Jun 07 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-2
  158. - Fix alignment ioctl use.
  159. - Fix API activation calls to handle NULL device name.
  160. * Sun May 30 2010 Milan Broz <mbroz@redhat.com> - 1.1.2-1
  161. - Update to cryptsetup 1.1.2
  162. - Fix luksOpen handling of new line char on stdin.
  163. * Sun May 23 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-1
  164. - Update to cryptsetup 1.1.1
  165. - Fix luksClose for stacked LUKS/LVM devices.
  166. * Mon May 03 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.2
  167. - Update to cryptsetup 1.1.1-rc2.
  168. * Sat May 01 2010 Milan Broz <mbroz@redhat.com> - 1.1.1-0.1
  169. - Update to cryptsetup 1.1.1-rc1.
  170. * Sun Jan 17 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-1
  171. - Update to cryptsetup 1.1.0.
  172. * Fri Jan 15 2010 Milan Broz <mbroz@redhat.com> - 1.1.0-0.6
  173. - Fix gcrypt initialisation.
  174. - Fix backward compatibility for hash algorithm (uppercase).
  175. * Wed Dec 30 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.5
  176. - Update to cryptsetup 1.1.0-rc4
  177. * Mon Nov 16 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.4
  178. - Update to cryptsetup 1.1.0-rc3
  179. * Thu Oct 01 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.3
  180. - Update to cryptsetup 1.1.0-rc2
  181. - Fix libcryptsetup to properly export only versioned symbols.
  182. * Tue Sep 29 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.2
  183. - Update to cryptsetup 1.1.0-rc1
  184. - Add luksHeaderBackup and luksHeaderRestore commands.
  185. * Fri Sep 11 2009 Milan Broz <mbroz@redhat.com> - 1.1.0-0.1
  186. - Update to new upstream testing version with new API interface.
  187. - Add luksSuspend and luksResume commands.
  188. - Introduce pkgconfig.
  189. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-2
  190. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  191. * Wed Jul 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-1
  192. - Update to upstream final release.
  193. - Split libs subpackage.
  194. - Remove rpath setting from cryptsetup binary.
  195. * Wed Jul 15 2009 Till Maas <opensource@till.name> - 1.0.7-0.2
  196. - update BR because of libuuid splitout from e2fsprogs
  197. * Mon Jun 22 2009 Milan Broz <mbroz@redhat.com> - 1.0.7-0.1
  198. - Update to new upstream 1.0.7-rc1.
  199. - Wipe old fs headers to not confuse blkid (#468062)
  200. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-7
  201. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  202. * Thu Oct 30 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-6
  203. - Wipe old fs headers to not confuse blkid (#468062)
  204. * Tue Sep 23 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-5
  205. - Change new project home page.
  206. - Print more descriptive messages for initialization errors.
  207. - Refresh patches to versions commited upstream.
  208. * Sat Sep 06 2008 Milan Broz <mbroz@redhat.com> - 1.0.6-4
  209. - Fix close of zero decriptor.
  210. - Fix udevsettle delays - use temporary crypt device remapping.
  211. * Wed May 28 2008 Till Maas <opensource till name> - 1.0.6-3
  212. - remove a duplicate sentence from the manpage (RH #448705)
  213. - add patch metadata about upstream status
  214. * Tue Apr 15 2008 Bill Nottinghm <notting@redhat.com> - 1.0.6-2
  215. - Add the device to the luksOpen prompt (#433406)
  216. - Use iconv, not recode (#442574)
  217. * Thu Mar 13 2008 Till Maas <opensource till name> - 1.0.6-1
  218. - Update to latest version
  219. - remove patches that have been merged upstream
  220. * Mon Mar 03 2008 Till Maas <opensource till name> - 1.0.6-0.1.pre2
  221. - Update to new version with several bugfixes
  222. - remove patches that have been merged upstream
  223. - add patch from cryptsetup newsgroup
  224. - fix typo / missing luksRemoveKey in manpage (patch)
  225. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.5-9
  226. - Autorebuild for GCC 4.3
  227. * Sat Jan 19 2008 Peter Jones <pjones@redhat.com> - 1.0.5-8
  228. - Rebuild for broken deps.
  229. * Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
  230. - update URL
  231. - update license tag
  232. - recode ChangeLog from latin1 to uf8
  233. - add smp_mflags to make
  234. * Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
  235. - cleanup BuildRequires:
  236. - removed versions, packages in Fedora are new enough
  237. - changed popt to popt-devel
  238. * Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
  239. - fix devel subpackage requires
  240. - remove empty NEWS README
  241. - remove uneeded INSTALL
  242. - remove uneeded ldconfig requires
  243. - add readonly detection patch
  244. * Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
  245. - disable patch2, libsepol is now detected by configure
  246. - move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
  247. * Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
  248. - Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
  249. * Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
  250. - Use /lib as libdir (#243228)
  251. - sync header and library (#215349)
  252. - do not use %%makeinstall (recommended by PackageGuidelines)
  253. - select sbindir with %%configure instead with make
  254. - add TODO
  255. * Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
  256. - update to 1.0.5
  257. * Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
  258. - Don't build static any more.
  259. * Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
  260. - Add build dependency on new device-mapper-devel package.
  261. - Add preun and post ldconfig requirements.
  262. - Update BuildRoot.
  263. * Wed Nov 1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
  264. - Require newer libselinux (#213414)
  265. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
  266. - rebuild
  267. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
  268. - put shared libs in the right subpackages
  269. * Fri Apr 7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
  270. - update to final 1.0.3
  271. * Mon Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
  272. - update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
  273. * Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
  274. - update to 1.0.3rc1, reverts changes to default encryption type
  275. * Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
  276. - update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
  277. * Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
  278. - BuildRequires: libselinux-devel
  279. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
  280. - bump again for double-long bug on ppc(64)
  281. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
  282. - rebuilt for new gcc4.1 snapshot and glibc changes
  283. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  284. - rebuilt
  285. * Mon Dec 5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
  286. - rebuild against new libdevmapper
  287. * Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
  288. - add -lsepol to rebuild on current fc5
  289. * Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
  290. - fix cryptsetup help for isLuks action
  291. * Fri Jul 1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
  292. - update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
  293. piped passwords
  294. * Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
  295. - add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
  296. * Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
  297. - update to 1.0
  298. * Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
  299. - switch to cryptsetup-luks, for LUKS support
  300. * Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
  301. - oops, make that *everything* static (#129926)
  302. * Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
  303. - link some things static, move to /sbin (#129926)
  304. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  305. - rebuilt
  306. * Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
  307. - initial packaging