viewnior-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. # We don't build with Gnome support by default to avoid a GConf dependency.
  2. # If you would like to set the Gnome background image with Viewnior, rebuild
  3. # the srpm with:
  4. # rpmbuild --rebuild viewnior-*-src.rpm --with gnome
  5. # or use bcond_without to change the default
  6. %bcond_with gnome
  7. Name: viewnior
  8. Version: 1.2
  9. Release: 1%{?_dist_release}
  10. Summary: Elegant image viewer
  11. Summary(ja): エレガントな画像ビューア
  12. Group: Applications/Graphics
  13. License: GPLv3+
  14. URL: http://xsisqox.github.com/Viewnior
  15. Source0: http://cloud.github.com/downloads/xsisqox/Viewnior/%{name}-%{version}.tar.gz
  16. Patch0: viewnior-0.7-dsofix.patch
  17. Patch1: viewnior-1.2-fix_typo.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: gdk-pixbuf2-devel >= 2.4.0
  20. BuildRequires: glib2-devel >= 2.24
  21. BuildRequires: gtk2-devel >= 2.20
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: gettext
  24. BuildRequires: intltool >= 0.35.0
  25. BuildRequires: perl-XML-Parser
  26. BuildRequires: shared-mime-info >= 0.20
  27. %if %{with gnome}
  28. BuildRequires: GConf2-devel
  29. %endif
  30. %description
  31. Viewnior is an image viewer program. Created to be simple, fast and elegant.
  32. It's minimalistic interface provides more screen space for your images. Among
  33. its features are:
  34. * Fullscreen & Slideshow
  35. * Rotate, flip, save, delete images
  36. * Animation support
  37. * Browse only selected images
  38. * Navigation window
  39. * Simple interface
  40. * Configurable mouse actions
  41. %prep
  42. %setup -q
  43. %patch0 -p1 -b .dsofix
  44. %patch1 -p1 -b .orig
  45. # fix spurious executable perms
  46. chmod 0644 AUTHORS ChangeLog COPYING NEWS README TODO src/*
  47. %build
  48. %configure --enable-static=no \
  49. %if %{with gnome}
  50. --enable-wallpaper
  51. %endif
  52. make %{?_smp_mflags} V=1
  53. %install
  54. rm -rf %{buildroot}
  55. make install DESTDIR=%{buildroot} INSTALL='install -p'
  56. %find_lang %{name}
  57. desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
  58. %clean
  59. rm -rf %{buildroot}
  60. %post
  61. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  62. update-desktop-database &> /dev/null || :
  63. %postun
  64. if [ $1 -eq 0 ] ; then
  65. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  66. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  67. fi
  68. update-desktop-database &> /dev/null || :
  69. %posttrans
  70. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  71. %files -f %{name}.lang
  72. %defattr(-,root,root,-)
  73. %doc AUTHORS ChangeLog COPYING NEWS README TODO
  74. %{_bindir}/%{name}
  75. %{_datadir}/applications/%{name}.desktop
  76. %{_datadir}/icons/hicolor/*/apps/%{name}.*
  77. %{_datadir}/%{name}/
  78. %{_mandir}/man?/
  79. %changelog
  80. * Sat Feb 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2-1
  81. - new upstream release
  82. - added patch1 to fix typo
  83. - added configure option: --enable-static=no
  84. * Thu Dec 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1-1
  85. - initial build for VineSeed
  86. * Wed Mar 31 2010 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-1
  87. - Update to 1.0
  88. * Tue Feb 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-2
  89. - Add patch to fix DSO linking (#565018)
  90. - Switch to %%bcond macro
  91. * Mon Sep 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7-1
  92. - Update to 0.7
  93. * Sat Sep 05 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-2
  94. - Spec file cleanups from review.
  95. * Mon Aug 01 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6-1
  96. - Initial package