sox-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230
  1. ##
  2. ## disable gsm for Vine Linux
  3. %define nogsm 1
  4. ## disable libmad
  5. %define nomad 1
  6. Summary: A general purpose sound file conversion tool.
  7. Summary(ja): 汎用サウンドファイル変換ツール
  8. Name: sox
  9. Version: 14.4.1
  10. Release: 1%{?_dist_release}
  11. License: LGPL
  12. Group: Applications/Multimedia
  13. Source: http://prdownloads.sourceforge.net/sox/sox-%{version}.tar.bz2
  14. URL: http://sox.sourceforge.net/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: alsa-lib-devel
  17. BuildRequires: pulseaudio-lib-devel
  18. Build%{?nomad:Conflicts}%{!?nomad:Requires}: libmad-devel
  19. Build%{?nogsm:Conflicts}%{!?nogsm:Requires}: gsm-devel
  20. %description
  21. SoX (Sound eXchange) is a sound file format converter for Linux, UNIX
  22. and DOS PCs. The 'Swiss Army knife of sound tools,' SoX can convert
  23. between many different digitized sound formats and perform simple
  24. sound manipulation functions, including sound effects.
  25. %description -l ja
  26. SoX (Sound eXchange) は Linux, UNIX, DOS PC 用サウンドファイルフォーマット
  27. 変換ツールです.SoX は「サウンドツール界のスイスアーミーナイフ」で,
  28. 様々なデジタルサウンドフォーマットを相互に変換したり,
  29. 簡単なサウンドエフェクト等の処理も行うことが出来ます.
  30. %package -n sox-devel
  31. Summary: The SoX sound file format converter libraries.
  32. Summary(ja): SoX サウンドファイル変換ライブラリ
  33. Group: Development/Libraries
  34. %description -n sox-devel
  35. This package contains the library needed for compiling applications
  36. which will use the SoX sound file format converter.
  37. Install sox-devel if you want to develop applications which will use
  38. SoX.
  39. %description -n sox-devel -l ja
  40. このパッケージには SoX サウンドファイルフォーマット変換ツールを
  41. 利用するアプリケーションをコンパイルするのに必要なライブラリが
  42. 収められています.
  43. SoX を利用するプログラムを開発する場合は sox-devel パッケージを
  44. インストールして下さい.
  45. %prep
  46. %setup -q
  47. %build
  48. %configure \
  49. --disable-static \
  50. --includedir=%{_includedir}/sox \
  51. %{!?nogsm: --with-gsm}
  52. make
  53. %install
  54. rm -rf $RPM_BUILD_ROOT
  55. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  56. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  57. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
  58. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
  59. make install DESTDIR=$RPM_BUILD_ROOT
  60. echo "#!/bin/sh" > $RPM_BUILD_ROOT%{_bindir}/soxplay
  61. echo "" >> $RPM_BUILD_ROOT%{_bindir}/soxplay
  62. echo '%{_bindir}/sox $1 -t .au - > /dev/audio' >> $RPM_BUILD_ROOT%{_bindir}/soxplay
  63. chmod 755 $RPM_BUILD_ROOT%{_bindir}/soxplay
  64. strip $RPM_BUILD_ROOT%{_bindir}/sox
  65. ln -snf play $RPM_BUILD_ROOT%{_bindir}/rec
  66. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
  67. ln -snf play.1 $RPM_BUILD_ROOT%{_mandir}/man1/rec.1
  68. ln -snf sox.1 $RPM_BUILD_ROOT%{_mandir}/man1/soxmix.1
  69. mkdir -p $RPM_BUILD_ROOT%{_includedir}/sox
  70. install -m 644 src/*.h $RPM_BUILD_ROOT%{_includedir}/sox
  71. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %post -p /sbin/ldconfig
  75. %postun -p /sbin/ldconfig
  76. %files
  77. %defattr(-,root,root)
  78. %doc Changelog README TODO INSTALL
  79. %{_bindir}/*
  80. %{_libdir}/libsox.so.*
  81. %{_mandir}/man1/*
  82. %files -n sox-devel
  83. %defattr(-,root,root)
  84. %{_includedir}/*
  85. %{_libdir}/libsox.so
  86. %{_libdir}/pkgconfig/sox.pc
  87. %{_mandir}/man3/*
  88. %{_mandir}/man7/*
  89. %changelog
  90. * Sun Aug 03 2014 Yoji TOYODA <owa@bg.wakwak.com> 14.4.1-1
  91. - update to 14.4.1
  92. * Sat Nov 05 2011 Yoji TOYODA <owa@bg.wakwak.com> 14.3.2-1
  93. - new upstream release
  94. - add BuildRequires: pulseaudio-lib-devel
  95. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 12.18.1-2
  96. - rebuilt with rpm-4.8.1-3
  97. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 12.18.1-1vl5
  98. - applied new versioning policy, spec in utf-8
  99. * Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 12.18.1-0vl3
  100. - fix installing play.1 man page (<BTS:510>)
  101. - add BuildRequires: alsa-lib-devel (alsa stuffs are now in main repo)
  102. * Mon Sep 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 12.18.1-0vl2
  103. - add "%%define nomad 1" to disable libmad dependency
  104. * Fri Aug 25 2006 NAKAMURA Kenta <kenta@vinelinux.org> 12.18.1-0vl1
  105. - new upstream release
  106. - dropped sox-vorberr.patch and sox-CAN-2004-0557.patch
  107. * Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl2
  108. - add patch for buffer overflow in wav code (CAN-2004-0557, #128158)
  109. - fixed %files section
  110. * Thu Jul 3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 12.17.3-12vl1
  111. - based on 12.17.3-12 from Rawhide
  112. - rebuild with new toolchains
  113. - to use License tag instead of Copyright
  114. - fix License (from distributable to LGPL)
  115. * Fri Jan 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  116. - 12.17.1-1vl1
  117. - based on 12.17.1-1 from Rawhide
  118. - use better macros (%%{_bindir}, %%{_libdir}, %%{_includedir})
  119. - added Japanese summary and description
  120. - disable gsm stuff for Vine Linux
  121. * Tue Jan 2 2001 Bill Nottingham <notting@redhat.com>
  122. - re-enable gsm stuff
  123. - update to 12.17.1
  124. * Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
  125. - rebuild because of broken fileutils
  126. * Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
  127. - update to 12.17
  128. - yank out gsm stuff
  129. * Mon Aug 7 2000 Bill Nottingham <notting@redhat.com>
  130. - fix playing of sounds on cards that don't support mono
  131. * Sat Aug 5 2000 Bill Nottingham <notting@redhat.com>
  132. - fix playing of sounds on cards that don't support 8-bit
  133. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  134. - automatic rebuild
  135. * Thu Feb 03 2000 Bill Nottingham <notting@redhat.com>
  136. - fix manpage link the Right Way(tm)
  137. * Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  138. - Fix rec manpage link - now that man pages are compressed, it should point to
  139. play.1.gz, not play.1
  140. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  141. - fix description
  142. * Tue Sep 28 1999 Bill Nottingham <notting@redhat.com>
  143. - Grrr. Arrrrgh. Fix link.
  144. * Fri Sep 24 1999 Bill Nottingham <notting@redhat.com>
  145. - add some more files to devel
  146. * Fri Sep 17 1999 Bill Nottingham <notting@redhat.com>
  147. - fix link
  148. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  149. - update to 12.16
  150. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  151. - auto rebuild in the new build environment (release 4)
  152. * Wed Jan 20 1999 Bill Nottingham <notting@redhat.com>
  153. - allow spaces in filenames for play/rec
  154. * Wed Dec 9 1998 Bill Nottingham <notting@redhat.com>
  155. - fix docs
  156. * Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
  157. - update to 12.15
  158. * Sat Oct 10 1998 Michael Maher <mike@redhat.com>
  159. - fixed broken spec file
  160. * Mon Jul 13 1998 Michael Maher <mike@redhat.com>
  161. - updated source from Chris Bagwell.
  162. * Tue Jun 23 1998 Michael Maher <mike@redhat.com>
  163. - made patch to fix the '-e' option. BUG 580
  164. - added buildroot
  165. * Fri May 08 1998 Prospector System <bugs@redhat.com>
  166. - translations modified for de, fr, tr
  167. * Thu Nov 06 1997 Erik Troan <ewt@redhat.com>
  168. - built against glibc