pcre2-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Perl-compatible regular expression library
  3. Summary(ja): Perl 互換の正規表現ライブラリ
  4. Name: pcre2
  5. Version: 10.37
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: inagaki
  11. License: BSD
  12. URL: https://www.pcre.org/
  13. Source0: https://ftp.pcre.org/pub/pcre/%{name}-%{version}.tar.bz2
  14. # Upstream thinks RPATH is good idea.
  15. Patch0: pcre2-10.31-multilib.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: zlib-devel
  18. BuildRequires: bzip2-devel
  19. BuildRequires: libedit-devel
  20. # New libtool to get rid of rpath
  21. BuildRequires: autoconf, automake, libtool
  22. %description
  23. Perl-compatible regular expression library.
  24. PCRE has its own native API, but a set of "wrapper" functions that are based on
  25. the POSIX API are also supplied in the library libpcreposix. Note that this
  26. just provides a POSIX calling interface to PCRE: the regular expressions
  27. themselves still follow Perl syntax and semantics. The header file
  28. for the POSIX-style functions is called pcreposix.h.
  29. %package devel
  30. Summary: Development files for %{name}
  31. Summary(ja): %{name} の開発用ファイル
  32. Group: programming
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. Development files (Headers, libraries for static linking, etc) for %{name}.
  36. %package -n compat32-%{name}
  37. Summary: Perl-compatible regular expression library
  38. Summary(ja): Perl 互換の正規表現ライブラリ
  39. Group: system
  40. %description -n compat32-%{name}
  41. Perl-compatible regular expression library.
  42. PCRE has its own native API, but a set of "wrapper" functions that are based on
  43. the POSIX API are also supplied in the library libpcreposix. Note that this
  44. just provides a POSIX calling interface to PCRE: the regular expressions
  45. themselves still follow Perl syntax and semantics. The header file
  46. for the POSIX-style functions is called pcreposix.h.
  47. %package -n compat32-%{name}-devel
  48. Summary: Development files for %{name}
  49. Summary(ja): %{name} の開発用ファイル
  50. Group: programming,legacy
  51. Requires: compat32-%{name} = %{version}-%{release}
  52. %description -n compat32-%{name}-devel
  53. Development files (Headers, libraries for static linking, etc) for %{name}.
  54. %debug_package
  55. %prep
  56. %setup -q
  57. # Get rid of rpath
  58. %patch0 -p1 -b .multilib
  59. # Because of rpath patch
  60. libtoolize --copy --force && autoreconf -vif
  61. # One contributor's name is non-UTF-8
  62. for F in ChangeLog; do
  63. iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
  64. touch --reference "$F" "${F}.utf8"
  65. mv "${F}.utf8" "$F"
  66. done
  67. %build
  68. %configure \
  69. --enable-jit \
  70. --disable-static \
  71. --enable-utf8 \
  72. --enable-unicode-properties \
  73. --enable-pcregrep-libz \
  74. --enable-pcregrep-libbz2 \
  75. --enable-pcretest-libedit \
  76. --enable-pcre2-8 \
  77. --enable-pcre2-16 \
  78. --enable-pcre2-32
  79. make %{?_smp_mflags}
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. make install DESTDIR=$RPM_BUILD_ROOT
  83. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  85. %check
  86. %ifarch s390 s390x ppc
  87. # larger stack is needed on s390, ppc
  88. ulimit -s 10240
  89. %endif
  90. make %{?_smp_mflags} check VERBOSE=yes
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %files
  94. %defattr(-,root,root)
  95. %license COPYING LICENCE
  96. %doc AUTHORS ChangeLog NEWS README
  97. %{_bindir}/pcre2grep
  98. %{_libdir}/*.so.*
  99. %{_mandir}/man1/pcre2grep.*
  100. %files devel
  101. %defattr(-,root,root)
  102. %doc doc/html/*
  103. %{_bindir}/pcre2-config
  104. %{_bindir}/pcre2test
  105. %{_includedir}/*
  106. %{_libdir}/*.so
  107. %{_libdir}/pkgconfig/*.pc
  108. %{_mandir}/man1/pcre2-config.*
  109. %{_mandir}/man1/pcre2test.*
  110. %{_mandir}/man3/*
  111. %if %{build_compat32}
  112. %files -n compat32-%{name}
  113. %defattr(-, root, root)
  114. %{_libdir}/*.so.*
  115. %files -n compat32-%{name}-devel
  116. %defattr(-, root, root)
  117. %{_libdir}/*.so
  118. %endif
  119. %changelog
  120. * Mon Jul 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.37-1
  121. - new upstream release.
  122. - dropped ldconfig scriptletes.
  123. * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.36-1
  124. - new upstream release.
  125. * Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.35-1
  126. - new upstream release.
  127. * Sun Mar 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.34-1
  128. - new upstream release.
  129. * Sun May 20 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 10.31-1
  130. - new: pcre2 package
  131. - update multilib patch (Patch0)
  132. - drop unnecessary patch (Patch1)
  133. * Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
  134. - create comapt32 packages
  135. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
  136. - new upstream release.
  137. - dropped Patch1000,1001: fixed in upstream.
  138. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
  139. - new upstream release.
  140. - removed Patch2,Patch3 (no longer needed).
  141. - added Patch1000 to fix CVE-2016-1283.
  142. * Sun Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
  143. - new upstream release
  144. - added patches including security fix from Fedora (CVE-2014-8964)
  145. * Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
  146. - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
  147. (bug #1165626)
  148. * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
  149. - Reset non-matched groups within capturing group up to forced match
  150. (bug #1161587)
  151. * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
  152. - Fix typos in manual pages (bugs #675476, #675477)
  153. * Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
  154. - new upstream release
  155. - add --enable-pcre32 and --enable-pcretest-libedit
  156. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
  157. - new upstream release
  158. - add --enable-pcre16 --enable-pcre8 --enable-jit
  159. - API change
  160. - change includedir to /usr/include
  161. * Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
  162. - new upstream release
  163. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
  164. - new upstream release
  165. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
  166. - rebuilt with rpm-4.8.1 for pkg-config
  167. * Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
  168. - new upstream release
  169. * Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
  170. - new upstream release with security fix
  171. * Sat Feb 6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
  172. - new upstream release
  173. * Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
  174. - new upstream release
  175. * Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
  176. - add --enable-unicode-properties to configure option
  177. * Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
  178. - new upstream release
  179. - added BR: zlib-devel, bzip2-devel
  180. - removed static libraries from devel package
  181. - added Packager tag
  182. * Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
  183. - new upstream release
  184. - spec in UTF-8
  185. * Sun Jul 6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
  186. - new upstream release
  187. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  188. - use macro for Release
  189. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  190. - apply new virsioning policy.
  191. - remove *.la
  192. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
  193. - new upstream release
  194. * Wed Nov 7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
  195. - new upstream release
  196. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
  197. - new upstream release
  198. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
  199. - rebuild with new environment/toolchain
  200. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
  201. - new upstream release
  202. * Mon Sep 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
  203. - added --enable-utf8 option
  204. * Sun Sep 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
  205. - new upstream release
  206. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
  207. - new upstream release
  208. - added Japanese summary
  209. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
  210. - new upstream release
  211. * Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
  212. - new upstream release
  213. * Mon May 5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
  214. - skip 'make check' on alpha
  215. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
  216. - change install section
  217. - change files section
  218. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
  219. - update to 4.1
  220. - add %{_bindir}/pcretest
  221. - add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
  222. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
  223. - rebuild with new toolchains
  224. * Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
  225. - Update to 3.9
  226. * Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
  227. - Update to 3.7
  228. * Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
  229. - Update to 3.5
  230. * Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
  231. - Build for VineSeed
  232. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
  233. - Move libpcre to /lib, grep uses it these days (#41104)
  234. * Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  235. - Move this to a separate package, used to be in kdesupport, but it's
  236. generally useful...