compiler-rt-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: LLVM "compiler-rt" runtime libraries
  6. Summary(ja): LLVM "compiler-rt" ランタイムライブラリ
  7. Name: compiler-rt
  8. Version: 15.0.2
  9. Release: 1%{?_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: NCSA
  14. URL: https://llvm.org/
  15. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
  16. # patches
  17. Patch0: add-llvm-cmake-package.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: python3
  22. BuildRequires: python3-devel
  23. BuildRequires: llvm-devel = %{version}
  24. BuildRequires: llvm-static = %{version}
  25. Requires: clang = %{version}-%{release}
  26. # LLVM is not supported on PPC64
  27. # http://llvm.org/bugs/show_bug.cgi?id=3729
  28. ExcludeArch: ppc64
  29. %description
  30. The compiler-rt project is a part of the LLVM project. It provides
  31. implementation of the low-level target-specific hooks required by
  32. code generation, sanitizer runtimes and profiling library for code
  33. instrumentation, and Blocks C language extension.
  34. %debug_package
  35. %prep
  36. %autosetup -n compiler-rt-%{version}.src -p2
  37. pathfix%{python3_version}.py -i %{__python3} -pn lib/hwasan/scripts/hwasan_symbolize
  38. %build
  39. %cmake \
  40. -GNinja \
  41. -DCMAKE_BUILD_TYPE=Release \
  42. -DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config-%{__isa_bits} \
  43. -DCMAKE_INSTALL_RPATH=";" \
  44. -DCMAKE_SKIP_RPATH:BOOL=ON \
  45. %if 0%{?__isa_bits} == 64
  46. -DLLVM_LIBDIR_SUFFIX=64 \
  47. %else
  48. -DLLVM_LIBDIR_SUFFIX= \
  49. %endif
  50. -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
  51. %cmake_build
  52. %install
  53. rm -rf %{buildroot}
  54. %cmake_install
  55. # compiler-rt
  56. # move sanitizer lists to better place
  57. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/share
  58. mv -v %{buildroot}%{_datadir}/*list.txt %{buildroot}%{_libdir}/clang/%{version}/share/
  59. # move sanitizer libs to better place
  60. %global libclang_rt_installdir lib/linux
  61. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
  62. mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/*clang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
  63. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
  64. pushd %{buildroot}%{_libdir}/clang/%{version}/lib
  65. for i in *.a *.so
  66. do
  67. ln -s ../$i linux/$i
  68. done
  69. %if %{with test}
  70. %check
  71. #cmake_build --target check-compiler-rt
  72. %endif
  73. %clean
  74. rm -rf %{buildroot}
  75. %files
  76. %license LICENSE.TXT
  77. %{_includedir}/*
  78. %{_libdir}/clang/%{version}/lib/*
  79. %{_libdir}/clang/%{version}/share/*
  80. %ifarch x86_64 aarch64
  81. %{_bindir}/hwasan_symbolize
  82. %endif
  83. %changelog
  84. * Thu Oct 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  85. - new upstream release.
  86. * Wed Sep 07 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  87. - new upstream release.
  88. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  89. - new upstream release.
  90. - dropped Patch0.
  91. - imported Patch0 from rawhide.
  92. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  93. - new upstream release.
  94. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  95. - new upstream release.
  96. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  97. - new upstream release.
  98. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  99. - devided compiler-rt from llvm.
  100. - new upstream release.
  101. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  102. - enabled to build utils.
  103. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  104. - new upstream release.
  105. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  106. - new upstream release.
  107. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  108. - rebuilt with libffi-3.3.
  109. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  110. - new upstream release.
  111. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  112. - new upstream release.
  113. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  114. - dropped all patches.
  115. - switched build-system to ninja.
  116. - switched python to python3.
  117. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  118. - new upstream release.
  119. - added OpenMP.
  120. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  121. - fixed %%files.
  122. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  123. - new upstream release.
  124. - dropped Patch0, 4, 5, 100 and 200.
  125. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  126. - renamed a subpackage "llvm-libs".
  127. - added a subpackage "lld".
  128. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  129. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  130. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  131. - new upstream release.
  132. - dropped Patch1 and 2: fixed in upstream.
  133. - imported Patch0, 3-5, 100 and 200 from rawhide.
  134. - disabled Patch1002: no longer needed?
  135. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  136. - new upstream release.
  137. - switched to cmake.
  138. - disable ocaml binding as default.
  139. - updated Patch1000 and 1002.
  140. - disabled Patch1000 as default.
  141. - cleanup patches.
  142. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  143. - rebuild with gcc-5.4.0
  144. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  145. - new upstream release
  146. - added BR: ocaml-ctypes
  147. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  148. - new upstream release
  149. - dropt Patch 1, 201 and 1001
  150. - updated Patch 1000
  151. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  152. - updated to 3.5.1
  153. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  154. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  155. - obsoleted clang-doc
  156. - built with ocaml 4.02.1
  157. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  158. - fix <BTS:2832>
  159. - fix configure option "--with-c-include-dirs"
  160. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  161. - update Patch1001: clang-3.5.0-driver-lib64.patch
  162. - update Patch1002: clang-3.5.0-driver-vine.patch
  163. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  164. - update to 3.5.0
  165. - remove Patch11 (clang-hardfloat-hack.patch)
  166. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  167. - rebuild with libffi-3.0.13
  168. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  169. - update to 3.3
  170. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  171. - ld.gold (patch1000,1001)
  172. - add /%{_lib} to ld search path
  173. - add support *-vine-linux gcc (patch1002)
  174. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  175. - update to 3.1
  176. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  177. - updated to 3.0 release
  178. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  179. - added patch 2-4 to support -O4 link-time optimization
  180. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  181. - disable -fno-var-tracking-assignments on ppc
  182. (seems like gcc-4.4.5 still doesn't support this)
  183. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  184. - new upstream release
  185. - add BR: libffi-devel
  186. - add R: libffi-devel to -devel
  187. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  188. - initial build for Vine Linux
  189. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  190. - Update to final 2.7 release
  191. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  192. - Update to first 2.7 pre-release
  193. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  194. - Update to 2.6 pre-release2
  195. - -devel subpackage now virtually provides -static
  196. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  197. - Disable var tracking assignments on PPC
  198. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  199. - Don't adjust clang include dir; files there are noarch (bz#521893)
  200. - Enable clang unit tests
  201. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  202. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  203. - Package Clang's static analyzer tools
  204. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  205. - PIC is now enabled by default; explicitly disable on %%{ix86}
  206. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  207. - First 2.6 prerelease
  208. - Enable Clang front-end
  209. - Enable debuginfo generation
  210. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  211. - Disable assertions (needed by OpenGTL, bz#521261)
  212. - Align spec file with upstream build instructions
  213. - Enable unit tests
  214. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  215. - Only disable PIC on %%ix86; ppc actually needs it
  216. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  217. - Disable use of position-independent code on 32-bit platforms
  218. (buggy in LLVM <= 2.5)
  219. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  220. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  221. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  222. - Remove build scripts; they require the build directory to work
  223. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  224. - Update to 2.5
  225. - Package build scripts (bug #457881)
  226. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  227. - Patched build process for the OCaml binding
  228. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  229. - Update to 2.4
  230. - Package Ocaml binding
  231. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  232. - Add dependency on groff
  233. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  234. - LLVM 2.3
  235. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  236. - fix license tags
  237. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  238. - Fix compilation problems with gcc 4.3
  239. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  240. - Autorebuild for GCC 4.3
  241. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  242. - Fix review comments
  243. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  244. - Initial version