gauche-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149
  1. %define pkg_name gauche
  2. %define pkg_version 0.9.5
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: An R7RS Scheme implementation developed to be a handy script interpreter
  5. Summary(ja): R7RS準拠のScheme処理系
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: BSD-style
  10. Group: Applications/Languages
  11. URL: http://practical-scheme.net/gauche/index-j.html
  12. Source: Gauche-%{version}.tgz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: zlib-devel
  15. BuildRequires: gdbm-devel
  16. BuildRequires: texi2html
  17. # BuildRequires: texinfo
  18. # BuildRequires: texlive-common
  19. # BuildRequires: texlive-collection-basic
  20. # BuildRequires: texlive-collection-latexextra
  21. # BuildRequires: texlive-collection-fontsextra
  22. # %if %{?_dist_release} == "vl6"
  23. # BuildRequires: texlive-collection-texinfo
  24. # %endif
  25. # %if %{?_dist_release} == "vl7"
  26. # BuildRequires: texlive-collection-plainextra
  27. # BuildRequires: texlive-collection-fontsrecommended
  28. # # rpm -qa --qf "BuildRequires: %{name}\n" | grep -v -e "doc$" | \
  29. # # grep texlive-collection-lang
  30. # BuildRequires: texlive-collection-langenglish
  31. # BuildRequires: texlive-collection-langkorean
  32. # BuildRequires: texlive-collection-langitalian
  33. # BuildRequires: texlive-collection-langpolish
  34. # BuildRequires: texlive-collection-langgerman
  35. # BuildRequires: texlive-collection-langjapanese
  36. # BuildRequires: texlive-collection-langgreek
  37. # BuildRequires: texlive-collection-langcyrillic
  38. # BuildRequires: texlive-collection-langeuropean
  39. # BuildRequires: texlive-collection-langspanish
  40. # BuildRequires: texlive-collection-langcjk
  41. # BuildRequires: texlive-collection-langczechslovak
  42. # BuildRequires: texlive-collection-langfrench
  43. # BuildRequires: texlive-collection-langarabic
  44. # BuildRequires: texlive-collection-langother
  45. # BuildRequires: texlive-collection-langportuguese
  46. # BuildRequires: texlive-collection-langindic
  47. # BuildRequires: texlive-collection-langafrican
  48. # BuildRequires: texlive-collection-langchinese
  49. # %endif
  50. Requires: gdbm
  51. Vendor: Project Vine
  52. Distribution: Vine Linux
  53. Packager: ara_t
  54. %description
  55. Gauche is an R7RS Scheme implementation developed to be a handy
  56. script interpreter, which allows programmers and system administrators
  57. to write small to large scripts for their daily chores. Quick startup,
  58. built-in system interface, native multilingual support are some of my goals.
  59. %descriptionl -l ja
  60. Gauche(ゴーシュ)は、スクリプトインタプリタとしての使い易さに重点を置いて
  61. 開発を行っているR7RS準拠のScheme処理系です。日常業務の中でのちょっとした
  62. 処理を行うスクリプトを気軽にSchemeで書きたいなあ、という願望のもとに、
  63. 起動が速いこと、システムへのアクセスが組み込まれていること、 最初から
  64. 多国語対応を考慮していること、リスト処理ライブラリとして他のC/C++プログラム
  65. から簡単にリンク可能であること、などを目標としています。
  66. %prep
  67. %{__rm} -rf ${RPM_BUILD_ROOT}
  68. %setup -q -n Gauche-%{version}
  69. %build
  70. %{configure} --enable-multibyte=utf-8
  71. %{__perl} -pi -e "s|DESTDIR\ +\=|DESTDIR = ${RPM_BUILD_ROOT}|" src/Makefile
  72. %{__make} %{?_smp_mflags}
  73. # (cd doc; %{__make} pdf html)
  74. (cd doc; %{__make} html)
  75. %install
  76. export LD_LIBRARY_PATH=${RPM_BUILD_ROOT}%{_libdir}:${LD_LIBRARY_PATH}
  77. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  78. %{__make} install-doc DESTDIR=${RPM_BUILD_ROOT}
  79. %check
  80. export LD_LIBRARY_PATH=${RPM_BUILD_ROOT}%{_libdir}:${LD_LIBRARY_PATH}
  81. %{__make} check
  82. %clean
  83. %{__rm} -rf ${RPM_BUILD_ROOT}
  84. %post
  85. for doc in gauche-refe gauche-refj; do
  86. file=%{_infodir}/${doc}.info.gz
  87. if [ -e ${file} ]; then
  88. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  89. fi
  90. done
  91. %{_syssbindir}/ldconfig
  92. %preun
  93. if [ $1 = 0 ]; then
  94. for doc in gauche-refe gauche-refj; do
  95. file=%{_infodir}/${doc}.info.gz
  96. if [ -e ${file} ]; then
  97. /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
  98. fi
  99. done
  100. fi
  101. %postun -p %{_syssbindir}/ldconfig
  102. %files
  103. %defattr(-, root, root)
  104. %doc AUTHORS COPYING ChangeLog HACKING NEWS README
  105. %doc doc/gauche-ref*.html
  106. # %doc doc/gauche-ref*.pdf
  107. %{_bindir}/
  108. %{_libdir}/gauche-*
  109. %{_libdir}/libgauche-*.so*
  110. %{_datadir}/aclocal/
  111. %{_datadir}/gauche-*
  112. %{_infodir}/
  113. %{_mandir}/man1/
  114. %changelog
  115. * Sat Oct 08 2016 Toshiaki Ara <ara_t@384.jp> 0.9.5-1
  116. - update to 0.9.5
  117. - drop PDF manual
  118. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 0.9.4-2
  119. - make pdf manuals
  120. - add BuildRequires
  121. * Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 0.9.4-1
  122. - new package