yatex-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369
  1. %define _noVersionedDependencies 1
  2. #% define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. Name: yatex
  4. Version: 1.78.4
  5. Release: 1%{?_dist_release}
  6. License: Distributable
  7. Source0: http://www.yatex.org/yatex%{version}.tar.gz
  8. #Source0: http://www.gentei.org/~yuuji/tmp/yatex11205111805.tar.gz
  9. Source1: %{name}-install.sh
  10. Source2: %{name}-remove.sh
  11. Source3: %{name}-init.el
  12. Source4: vine-default-%{name}.el
  13. Source5: vine-default-yahtml.el
  14. ## Vine Patch(es)
  15. Patch1: yatexhlp-emacs.diff
  16. Patch2: yatex-make.diff
  17. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  18. # and modified to suit 1.70 release
  19. Patch3: yahtml-1.70-timestamp.patch
  20. Patch10: yatex-1.78-vine-vl7.patch
  21. URL: http://www.yatex.org/
  22. Group: Applications/Editors/Emacs
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. Summary: YaTeX - Yet Another TeX mode for Emacs
  25. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  26. BuildArch: noarch
  27. Requires(post): emacsen
  28. Requires(post): emacsen-common
  29. Requires(post): make
  30. BuildRequires: emacsen-common
  31. BuildRequires: nkf perl
  32. Obsoletes: yatex-xemacs
  33. Distribution: Vine Linux
  34. Vendor: Project Vine
  35. Packager: munepi
  36. %description
  37. YaTeX is an intelligent, acquisitive and integrated package which reduces
  38. your efforts of composing LaTeX source on GNU Emacs.
  39. If you are YaTeX user and you install both yatex and auctex on your system,
  40. you may add the following configure in your emacs init file
  41. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs major version):
  42. ;; I am a YaTeX user!!!
  43. (setq vine-default-auctex nil
  44. vine-default-preview-latex nil)
  45. %description -l ja
  46. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  47. してくれる、LaTeX 入力支援環境です。
  48. yatex と auctex パッケージの両方をインストールする場合、
  49. ~/.emacs.d/emacsXX-vine-default.el (XX: emacs のメジャーバージョン)
  50. に以下の設定を追加するとよいでしょう。
  51. ;; YaTeX ユーザです!!!
  52. (setq vine-default-auctex nil
  53. vine-default-preview-latex nil)
  54. %prep
  55. %setup -n yatex%{version}
  56. %patch1 -p1
  57. %patch2 -p1
  58. %patch3 -p1
  59. %patch10 -p1 -b .vine
  60. (cd docs
  61. # change permissions
  62. chmod 644 *
  63. # encode as utf-8 (LF)
  64. # NOTE: This changes needs to entry info files to Info DIR
  65. for i in yatexj yatexe yahtmlj yahtmle; do nkf --unix -w --overwrite $i; done
  66. )
  67. %build
  68. %install
  69. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  70. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  71. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  72. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  73. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  74. #
  75. # install el files
  76. #
  77. %__cp -a *.el makefile help \
  78. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  79. %__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  80. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  81. #
  82. # install info files
  83. #
  84. %__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  85. ${RPM_BUILD_ROOT}%{_infodir}
  86. #
  87. # install script (bytecompile el and install elc, remove)
  88. #
  89. %_installemacsenscript %{name} %{SOURCE1}
  90. %_removeemacsenscript %{name} %{SOURCE2}
  91. %clean
  92. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  93. %post
  94. #
  95. # bytecompile and install
  96. #
  97. if [ "$1" = 2 ] ; then
  98. %_emacsenPackageRemove %{name}
  99. fi
  100. %_addemacsenlist %{name}
  101. %_emacsenPackageInstall %{name}
  102. for i in yatexe yatexj yahtmle yahtmlj; do
  103. /sbin/install-info --dir-file %{_infodir}/dir --section="Emacs" \
  104. %{_infodir}/${i}.gz
  105. done
  106. %preun
  107. if [ "$1" = 0 ]; then
  108. %_emacsenPackageRemove %{name}
  109. %_removeemacsenlist %{name}
  110. for i in yatexe yatexj yahtmle yahtmlj; do
  111. /sbin/install-info --delete --dir-file %{_infodir}/dir --section="Emacs" \
  112. %{_infodir}/${i}.gz
  113. done
  114. fi
  115. %files
  116. %defattr(-,root,root)
  117. %doc 00readme install manifest yatex.new
  118. %doc docs
  119. %{_datadir}/emacs/site-lisp/yatex/
  120. %{_infodir}/yahtmle*
  121. %{_infodir}/yahtmlj*
  122. %{_infodir}/yatexe*
  123. %{_infodir}/yatexj*
  124. %{emacsen_pkgdir}/install/%{name}
  125. %{emacsen_pkgdir}/remove/%{name}
  126. %changelog
  127. * Mon Jan 11 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.78.4-1
  128. - new upstream release
  129. - TeX Live 2015
  130. * Mon May 13 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.77-1
  131. - new upstream release
  132. - applied yatex-1.77-vine-vl{6,7}.patch instead
  133. * Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-2
  134. - new upstream release
  135. - updated yatex-1.76-vine-vl{6,7}.patch
  136. * Sat May 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.76-1.20120511
  137. - source snapshot 20120511: testing version 1.76 development
  138. - dropped obsoleted/upstreamed patches
  139. - applied yatex-1.76-vine-vl{6,7}.patch
  140. * Fri May 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-3
  141. - added BuildRequires: nkf perl
  142. - updated yatex-1.74-vine.patch as yatex-1.75-vine-vl{6,7}.patch
  143. - dropped pre-formatted info files
  144. - use original info files
  145. - encode info files as utf-8
  146. - add INFO-DIR-ENTRY
  147. * Thu May 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-2
  148. - fixed vine-default-yatex.el
  149. - applied yatex-1.74-vine.patch for vl6
  150. - updated yatex-1.74-vine.patch: support some extensions for \includegraphics
  151. * Thu Feb 9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.75-1
  152. - new upstream release
  153. - updated vine-default-yatex.el
  154. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-9
  155. - support TeX Live 2011
  156. - applied yatex-1.74-vine-vl7.patch
  157. - updated vine-default-yatex.el
  158. * Thu Aug 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-8
  159. - added Requires(post): make
  160. * Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-7
  161. - updated vine-default-yatex.el
  162. - check 'YaTeX-inhibit-prefix-letter
  163. - used "pbibtex -kanji=utf8" as default bibtex-command
  164. - used "mendex -U" as default makeindex-command
  165. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-6
  166. - updated vine-default-{yatex,yahtml}.el
  167. - revived auto-fill-mode on {yatex,yahtml}-mode
  168. * Tue Feb 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-5
  169. - updated yatex-init.el
  170. - dropped all pathes of auctex and preview-latex from load-path
  171. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
  172. - updated vine-default-yatex.el
  173. - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
  174. - supported TeX Live
  175. - used "eplatex", "pxdvi", "pdvips" as default commands
  176. - updated yatex-init.el
  177. - output "Loading vine-default-yatex ..." to the buffer *Messages*
  178. - defined vine-default-yahtml
  179. - added vine-default-yahtml.el
  180. * Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
  181. - updated vine-default-yatex.el
  182. - added bbl extension in auto-mode-alist to run yatex-mode
  183. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
  184. - updated vine-default-yatex.el
  185. - supported new vine-default
  186. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  187. - new upstream release
  188. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  189. - updated vine-default-yatex.el
  190. - dropped (setq YaTeX-no-begend-shortcut t)
  191. - use %{emacsen_pkgdir}
  192. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  193. - updated vine-default-yatex.el
  194. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  195. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  196. - updated yatex-install.sh
  197. - *-init.el: changed from hard copy to symbolic link
  198. on /etc/emacs-XX.YY/site-start.d
  199. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  200. - fixed yatex-init.el
  201. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  202. - added yatex-init.el, vine-default-yatex.el
  203. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  204. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  205. - spec in utf8
  206. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  207. - applied new versioning policy
  208. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  209. - new upstream release
  210. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  211. - s/Copyright/License/
  212. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  213. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  214. - update yatex-1.72
  215. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  216. - update yatex-1.71
  217. * Wed Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  218. - added Patch3 to add hhmts timestamp feature
  219. * Mon May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  220. - update yatex-1.70
  221. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  222. - update yatex10203151806
  223. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  224. - fixed: bytecompile yatex19
  225. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  226. - now emacsen-common aware
  227. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  228. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  229. - 1.68-0vl2
  230. - no kanji code conversion of documents
  231. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  232. - 1.68-0vl1
  233. - update to 1.68
  234. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  235. - 1.67-6vl5
  236. - YATEXHLP.{jp,eng} moved to appropriate dir
  237. * Fri Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  238. - 1.67-6vl3
  239. - rebuilt for emacs-20.7
  240. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  241. - 1.67-6vl2
  242. - oops ... fixed target dir for help files
  243. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  244. - 1.67-6vl1
  245. - rebuilt for emacs-20.6
  246. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  247. - 1.67-6
  248. - included forgotten info file for YaHTML
  249. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  250. - 1.67-5
  251. - updated for emacs-20.5a release
  252. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  253. - 1.67-4
  254. - change Group to Applications/Editors/EmacsLisp
  255. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  256. - 1.67-3
  257. - %post and %preun section modified
  258. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  259. - 1.67-2
  260. - fixed minor problem in the %files section
  261. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  262. - 1.67-1
  263. - updated to 1.67 release
  264. - rebuilt for emacs-20.4 on Vine Linux 1.9
  265. - updated URL for the new web site of YaTeX
  266. - some typo fix
  267. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  268. - Initial Release