libtiff-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library of functions for manipulating TIFF format image files.
  3. Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
  4. Name: libtiff
  5. Version: 4.0.7
  6. Release: 1%{_dist_release}
  7. License: distributable
  8. Group: System Environment/Libraries
  9. Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
  10. URL: http://www.remotesensing.org/libtiff/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: zlib-devel libjpeg-devel
  13. %define LIBVER %(echo %{version} | cut -f-2 -d.)
  14. %ifarch x86_64
  15. Provides: libtiff.so.4()(64bit)
  16. %else
  17. Provides: libtiff.so.4
  18. %endif
  19. Obsoletes: libtiff4
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: daisuke, iwamoto
  23. %description
  24. The libtiff package contains a library of functions for manipulating
  25. TIFF (Tagged Image File Format) image format files. TIFF is a widely
  26. used file format for bitmapped images. TIFF files usually end in the
  27. .tif extension and they are often quite large.
  28. The libtiff package should be installed if you need to manipulate TIFF
  29. format image files.
  30. %description -l ja
  31. libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
  32. 扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
  33. 広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
  34. 拡張子が使われ,サイズは概して大きめです.
  35. TIFF 形式の画像ファイルを扱う必要があるならば,
  36. libtiff パッケージを是非インストールして下さい.
  37. %package devel
  38. Summary: Development tools for programs which will use the libtiff library.
  39. Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
  40. Group: Development/Libraries
  41. Requires: libtiff = %{version}
  42. %description devel
  43. This package contains the header files and static libraries for
  44. developing programs which will manipulate TIFF format image files
  45. using the libtiff library.
  46. If you need to develop programs which will manipulate TIFF format
  47. image files, you should install this package. You'll also need to
  48. install the libtiff package.
  49. #'
  50. %description devel -l ja
  51. このパッケージには,libtiff ライブラリを使って TIFF 形式の
  52. 画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
  53. スタティックライブラリが収められています.
  54. TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
  55. このパッケージをインストールして下さい.libtiff パッケージも同時に
  56. インストールする必要があります.
  57. ## to build compat32 for x86_64 architecture support
  58. %package -n compat32-%{name}
  59. Summary: A library of functions for manipulating TIFF format image files.
  60. Group: System Environment/Libraries
  61. Requires: %{name} = %{version}
  62. Provides: libtiff.so.4
  63. Obsoletes: compat32-libtiff4
  64. %description -n compat32-%{name}
  65. The libtiff package contains a library of functions for manipulating
  66. TIFF (Tagged Image File Format) image format files. TIFF is a widely
  67. used file format for bitmapped images. TIFF files usually end in the
  68. .tif extension and they are often quite large.
  69. The libtiff package should be installed if you need to manipulate TIFF
  70. format image files.
  71. %package -n compat32-%{name}-devel
  72. Summary: Development tools for programs which will use the libtiff library.
  73. Group: Development/Libraries
  74. Requires: compat32-%{name} = %{version}
  75. Requires: %{name}-devel = %{version}
  76. %description -n compat32-%{name}-devel
  77. This package contains the header files and static libraries for
  78. developing programs which will manipulate TIFF format image files
  79. using the libtiff library.
  80. If you need to develop programs which will manipulate TIFF format
  81. image files, you should install this package. You'll also need to
  82. install the libtiff package.
  83. #'
  84. %prep
  85. %setup -q -n tiff-%{version}
  86. %build
  87. %configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
  88. %__make %{?_smp_mflags}
  89. %__make clean
  90. %install
  91. rm -fr $RPM_BUILD_ROOT
  92. %makeinstall
  93. rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
  94. ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
  95. rm $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
  96. %post -p /sbin/ldconfig
  97. %postun -p /sbin/ldconfig
  98. %if %{build_compat32}
  99. %post -n compat32-%{name} -p /sbin/ldconfig
  100. %postun -n compat32-%{name} -p /sbin/ldconfig
  101. %endif
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %files
  105. %defattr(-,root,root)
  106. %doc COPYRIGHT README RELEASE-DATE VERSION
  107. %{_bindir}/*
  108. %{_libdir}/libtiff*.so.*
  109. %{_mandir}/man1/*
  110. %files devel
  111. %defattr(-,root,root)
  112. %doc TODO html ChangeLog
  113. %{_includedir}/*
  114. %{_libdir}/libtiff*.so
  115. %{_libdir}/pkgconfig/*.pc
  116. %{_mandir}/man3/*
  117. ## to build compat32 for x86_64 architecture support
  118. %if %{build_compat32}
  119. %files -n compat32-%{name}
  120. %defattr(-,root,root)
  121. %{_libdir}/libtiff.so.*
  122. %files -n compat32-%{name}-devel
  123. %defattr(-,root,root)
  124. %{_libdir}/libtiff.so
  125. %endif
  126. %changelog
  127. * Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  128. - new upstream release.
  129. - drooped patch1-11: fixed in upstream.
  130. * Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
  131. - add patch1-11 from fc21 to fix security issues
  132. * Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
  133. - new upstream release with security fix (CVE-2012-4447)
  134. - drop *.a files from -devel packages
  135. * Thu Aug 2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
  136. - new upstream release with security fixes (CVE-2012-2088, 2113)
  137. - drop patch1 (is included in new release)
  138. * Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
  139. - Obosletes: libtiff4 and compat32-libtiff4 (vl6)
  140. * Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
  141. - fix R: for compat32 package
  142. * Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
  143. - add libtiff.so.4 for compatibility
  144. - add pkgconfig file
  145. * Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  146. - new upstream release
  147. - add patch1 to fix CVE-2012-1173
  148. * Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
  149. - new upstream release
  150. - drop all patches (are included in new release)
  151. - remove if-endif for Vine 4.x
  152. - add Vendor/Distri tags
  153. * Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
  154. - add some patches from RHEL6 3.9.4-1.el6_0.3
  155. - fix for CVE-2011-0192 (Patch11)
  156. - fix for CVE-2011-1167 (Patch12)
  157. - fix for CVE-2009-5022 (Patch13)
  158. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
  159. - rebuilt with rpm-4.8.1-3
  160. * Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
  161. - new upstream release
  162. - add patch4-10 from fedora
  163. * Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
  164. - new upstream release
  165. - remove BC: freeglut-devel
  166. - add patch1,2,4,5 from fedora
  167. - drop obsolete patches
  168. * Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
  169. - change if-endif to make both i386 and compat32 packages
  170. * Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
  171. - add patch5 for fix CVE-2009-2347 (Integer Overflow)
  172. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
  173. - add patch4 for fix lzw underflow security issue
  174. - add if branch Vine4/5 in devel files section (*.la are included or not)
  175. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
  176. - removed *.la
  177. - spec in utf-8
  178. * Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
  179. - fix changelog typo (3.8.4 -> 3.8.2)
  180. - new versioning policy
  181. - add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
  182. * Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
  183. - fix libdir in libtiff.la
  184. - add BuildConflicts: freeglut-devel
  185. * Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
  186. - rebuilt without glut-devel
  187. * Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
  188. - add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
  189. * Fri Jun 9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
  190. - new upstream release
  191. - remove obsolete patches
  192. - add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
  193. - delete duped docs
  194. - add --disable-cxx to configure option
  195. - add *.la to devel package
  196. * Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
  197. - added compat32-* packages for x86_64 architecture support
  198. - added --with-jpeg-lib-dir=%{_libdir} to configure
  199. * Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
  200. - new upstream release
  201. - remove obsolete patches
  202. - cleanup specs
  203. * Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
  204. - rebuild for Vine3.1
  205. * Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
  206. - add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
  207. - update URL
  208. * Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
  209. - build for Vine2.6
  210. * Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
  211. - fix changelog: proper name
  212. * Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
  213. - add symlink to shared lib by running ldconfig at compile time
  214. * Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
  215. - add patch8-13 from Fedora Core
  216. --* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
  217. --- fix some integer and buffer overflows (#134853, #134848)
  218. - add patch14 from SUSE LINUX
  219. --* Wed Oct 20 2004 - meissner@suse.de
  220. --- Do not crash if we are using unsupported codecs (like OJPEG).
  221. * Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
  222. - rebuild with new toolchains
  223. - to use License instead of Copyright
  224. * Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  225. - 3.5.7-6vl1
  226. - based on 3.5.7-6 from Rawhide
  227. * Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  228. - 3.5.5-8vl1
  229. - based on 3.5.5-8 from Rawhide
  230. - added Japanese summary and description
  231. * Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
  232. - rebuild
  233. * Mon Aug 7 2000 Crutcher Dunnavant <crutcher@redhat.com>
  234. - added a tiff-to-ps.fpi filter for printing
  235. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  236. - automatic rebuild
  237. * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  238. - apply Peter Skarpetis's fix for the 32-bit conversion
  239. * Mon Jul 3 2000 Nalin Dahyabhai <nalin@redhat.com>
  240. - make man pages non-executable (#12811)
  241. * Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
  242. - remove CVS repo info from data directories
  243. * Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  244. - fix build rooting
  245. - fix syntax error in configure script
  246. - move man pages to %{_mandir}
  247. * Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  248. - rebuild for an errata release
  249. * Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  250. - update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
  251. * Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  252. - fix fax2ps swapping height and width in the bounding box
  253. * Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
  254. - move man pages from devel package to the regular one
  255. - integrate Frank Warmerdam's fixed .fax handling code (keep until next release
  256. of libtiff)
  257. - fix fax2ps breakage (bug #8345)
  258. * Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
  259. - set MANDIR=man3 to make multifunction man pages friendlier
  260. * Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  261. - fix URLs
  262. * Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  263. - link shared library against libjpeg and libz
  264. * Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  265. - enable zip and jpeg codecs
  266. - change defattr in normal package to 0755
  267. - add defattr to -devel package
  268. * Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
  269. - update to 3.5.4
  270. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  271. - auto rebuild in the new build environment (release 6)
  272. * Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
  273. - build for glibc 2.1
  274. * Wed Jun 10 1998 Prospector System <bugs@redhat.com>
  275. - translations modified for de
  276. * Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
  277. - rebuilt against fixed jpeg libs (libjpeg-6b)
  278. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  279. - translations modified for de, fr, tr
  280. * Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
  281. - new version to replace the one from libgr
  282. - patched for glibc
  283. - added shlib support