gd-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362
  1. %bcond_with libvpx
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: A graphics library for drawing .png files.
  4. Summary(ja): PNGイメージファイルを描写するためのグラフィックライブラリ
  5. Name: gd
  6. Version: 2.2.4
  7. Release: 1%{_dist_release}
  8. Source0: https://bitbucket.org/libgd/gd-libgd/downloads/libgd-%{version}.tar.xz
  9. Patch0: gd-2.1.0-multilib.patch
  10. Patch1: issue357.patch
  11. Patch2: issue364.patch
  12. License: BSD-style
  13. URL: http://www.libgd.org/
  14. Group: System Environment/Libraries
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: freetype2-devel
  17. BuildRequires: fontconfig-devel
  18. BuildRequires: gettext-devel
  19. BuildRequires: libjpeg-turbo-devel
  20. BuildRequires: libpng-devel
  21. BuildRequires: libtiff-devel
  22. %if %{with libvpx}
  23. BuildRequires: libvpx-devel
  24. %endif
  25. BuildRequires: libX11-devel
  26. BuildRequires: libXpm-devel
  27. BuildRequires: zlib-devel
  28. BuildRequires: pkgconfig
  29. # for test
  30. BuildRequires: TrueType-vlgothic
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: daisuke
  34. %description
  35. Gd is a graphics library for drawing .png files. Gd allows your code to
  36. quickly draw images (lines, arcs, text, multiple colors, cutting and
  37. pasting from other images, flood fills) and write out the result as a
  38. .png file. Gd is particularly useful in web applications, where .pngs
  39. are commonly used as inline images. Note, however, that gd is not a
  40. paint program.
  41. Install gd if you are developing applications which need to draw .png
  42. files. If you install gd, you'll also need to install the gd-devel
  43. package.
  44. %description -l ja
  45. GdはPNGファイルを描写するためのグラフックライブラリです。 Gdを使って、
  46. 画像(線や弧, テキスト, カラー, 他の画像からのカット&ペースト等々)を
  47. 簡単に描写して、PNGファイルへ結果を出力することができます。
  48. Gdは特に、一般にPNG画像を埋め込む必要のあるウェブアプリケーションで
  49. 便利です。ただし、注意して欲しいのは, Gdはペイントツールではありませ
  50. ん。
  51. PNGファイルを描写する必要のあるアプリケーションを開発する場合、
  52. Gdをインストールしてください。gdをインストールした場合、gd-devel
  53. パッケージも必要になります。
  54. %package progs
  55. Summary: Utility programs that use libgd.
  56. Summary(ja): libgd を用いたユーティリティプログラム
  57. Group: Applications/Graphics
  58. Requires: gd = %{version}
  59. Requires: perl
  60. %description progs
  61. These are utility programs supplied with gd, the .png graphics library.
  62. If you install these, you must install gd.
  63. %description progs -l ja
  64. これは PNG グラフィックライブラリ gd によって提供されるユーティリティ
  65. プログラムです。これをインストールするには, gdをインストールする必要
  66. があります。
  67. %package devel
  68. Summary: The development libraries and header files for gd.
  69. Summary(ja): Gd用の開発ライブラリとヘッダファイル
  70. Group: Development/Libraries
  71. Requires: gd = %{version}
  72. Requires: freetype2-devel
  73. Requires: fontconfig-devel
  74. Requires: libjpeg-turbo-devel
  75. Requires: libpng-devel
  76. Requires: libtiff-devel
  77. %if %{with libvpx}
  78. Requires: libvpx-devel
  79. %endif
  80. Requires: libX11-devel
  81. Requires: libXpm-devel
  82. Requires: zlib-devel
  83. %description devel
  84. These are the development libraries and header files for gd, the .png
  85. graphics library.
  86. If you're installing the gd graphics library, you must install gd-devel.
  87. %description devel -l ja
  88. これらは開発ライブラリです。
  89. PNGグラフィックライブラリ gd 用の開発ライブラリおよびヘッダファイル
  90. です。
  91. gdをインストールした場合、gd-develパッケージも必要になります。
  92. ## to build compat32 for x86_64 architecture support
  93. %package -n compat32-%{name}
  94. Summary: A graphics library for drawing .png files.
  95. Group: System Environment/Libraries
  96. %description -n compat32-%{name}
  97. Gd is a graphics library for drawing .png files. Gd allows your code to
  98. quickly draw images (lines, arcs, text, multiple colors, cutting and
  99. pasting from other images, flood fills) and write out the result as a
  100. .png file. Gd is particularly useful in web applications, where .pngs
  101. are commonly used as inline images. Note, however, that gd is not a
  102. paint program.
  103. Install gd if you are developing applications which need to draw .png
  104. files. If you install gd, you'll also need to install the gd-devel
  105. package.
  106. %package -n compat32-%{name}-devel
  107. Summary: The development libraries and header files for gd.
  108. Group: Development/Libraries
  109. Requires: compat32-freetype2-devel
  110. Requires: compat32-fontconfig-devel
  111. Requires: compat32-libjpeg-turbo-devel
  112. Requires: compat32-libpng-devel
  113. Requires: compat32-libtiff-devel
  114. %if %{with libvpx}
  115. Requires: compat32-libvpx-devel
  116. %endif
  117. Requires: compat32-libX11-devel
  118. Requires: compat32-libXpm-devel
  119. Requires: compat32-zlib-devel
  120. %description -n compat32-%{name}-devel
  121. These are the development libraries and header files for gd, the .png
  122. graphics library.
  123. If you're installing the gd graphics library, you must install gd-devel.
  124. %prep
  125. %setup -q -n libgd-%{version}
  126. %patch0 -p1 -b .mlib
  127. %patch1 -p1 -b .issue357
  128. %patch2 -p1 -b .issue364
  129. : regenerate autotool stuff
  130. if [ -f configure ]; then
  131. libtoolize --copy --force
  132. autoreconf -vif
  133. else
  134. ./bootstrap.sh
  135. fi
  136. %build
  137. # Provide a correct default font search path
  138. CFLAGS="$RPM_OPT_FLAGS -DDEFAULT_FONTPATH='\"\
  139. /usr/share/fonts/alias/TrueType/:\
  140. /usr/share/fonts/TrueType-vlgothic/:\
  141. /usr/share/fonts/bitstream-vera/:\
  142. /usr/share/fonts/TrueType-dejavu/:\
  143. /usr/share/fonts/TrueType-ipafont/:\
  144. /usr/share/fonts/TrueType-ipaexfont/:\
  145. /usr/share/fonts/default/Type1/:\
  146. /usr/share/X11/fonts/Type1/:\
  147. /usr/share/fonts/TrueType-linux-liberation/\
  148. \"'"
  149. %configure CPPFLAGS="-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H" \
  150. --with-freetype \
  151. --with-tiff=%{_prefix} \
  152. %if %{with libvpx}
  153. --with-vpx=%{_prefix} \
  154. %endif
  155. --disable-rpath
  156. make %{?_smp_mflags}
  157. %install
  158. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  159. make DESTDIR=$RPM_BUILD_ROOT install
  160. ## remove unuse files
  161. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  162. %check
  163. %ifarch x86_64
  164. make %{?_smp_mflags} check
  165. %endif
  166. %clean
  167. [ "$RPM_BUILD_ROOT" != "/" ] && rm -fr $RPM_BUILD_ROOT
  168. %post -p /sbin/ldconfig
  169. %postun -p /sbin/ldconfig
  170. %if %{build_compat32}
  171. %post -n compat32-%{name} -p /sbin/ldconfig
  172. %postun -n compat32-%{name} -p /sbin/ldconfig
  173. %endif
  174. %files
  175. %defattr(-,root,root)
  176. %doc ChangeLog COPYING NEWS docs/*
  177. %{_libdir}/*.so.*
  178. %files progs
  179. %defattr(-,root,root)
  180. %{_bindir}/*
  181. %exclude %{_bindir}/gdlib-config
  182. %files devel
  183. %defattr(-,root,root)
  184. %{_bindir}/gdlib-config
  185. %{_includedir}/*
  186. %{_libdir}/*.so
  187. %{_libdir}/pkgconfig/*.pc
  188. %if %{build_compat32}
  189. %files -n compat32-%{name}
  190. %defattr(-,root,root)
  191. %{_libdir}/*.so.*
  192. %files -n compat32-%{name}-devel
  193. %defattr(-,root,root)
  194. %{_libdir}/*.so
  195. %endif
  196. %changelog
  197. * Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
  198. - new upstream release.
  199. - made to skip %%check on i686.
  200. * Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
  201. - new upstream release.
  202. - removed Patch1000 (fixed in upstream).
  203. * Wed May 4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-2
  204. - added Patch1000 to fix CVE-2016-3074.
  205. * Wed Mar 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  206. - new upstream release.
  207. * Wed Oct 29 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.1.0-3
  208. - BR: freetype2-devel instead of freetype-devel on devel package
  209. * Mon Jun 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-2
  210. - fixed version in gd.h.
  211. - added fontconfig and tiff support.
  212. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.0-1
  213. - new upstream release.
  214. - dropped unnecessary patches.
  215. * Tue Feb 19 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.35-8
  216. - import patches from fedora package
  217. - modified font path patch for Vine Linux
  218. - drop static library
  219. - remove "-DJISX0208"
  220. - add "-DHAVE_ICONV -DHAVE_STDARG_H -DHAVE_ERRNO_H""
  221. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.35-7
  222. - move gdlib-config from gd-progs subpackage to gd-devel subpackage
  223. * Thu Apr 14 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.35-6
  224. - build on current VineSeed
  225. * Tue Nov 3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-5
  226. - fix build_compat32 if-endif sections
  227. * Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-4
  228. - add patch2 for fix CVE-2009-3546 (_gdGetColors())
  229. * Wed Apr 8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.35-3
  230. - updated URL
  231. - changed progs Group to Applications/Graphics
  232. - added %%postun section
  233. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.35-2
  234. - removed *.la
  235. - spec in utf-8
  236. * Sat Apr 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-1
  237. - add patch1 from centos5
  238. - new versioning policy
  239. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.35-0vl1
  240. - new upstream release with security fix (CVE-2007-2756)
  241. * Wed Feb 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.34-0vl1
  242. - new upstream release with security fix
  243. - change source tarball format gz -> bz2
  244. * Fri Mar 17 2006 Shu KONNO <owa@bg.wakwak.com> 2.0.33-0vl2
  245. - added compat32-* packages for x86_64 architecture support
  246. * Sat Nov 6 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.33-0vl1
  247. - source upgrade
  248. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.27-0vl1
  249. - source update
  250. - added -DJISX0208 flag
  251. * Thu Jun 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.26-0vl1
  252. - source upgrade
  253. - BuildPrereq: XOrg-devel instead of XFree86-devel
  254. * Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.22-0vl1
  255. - source upgrade
  256. - remove patch0 (no need for freetype2-2.1.7)
  257. * Wed Nov 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl2
  258. - add patch0 to build against freetype2-2.1.7
  259. * Sat Jun 7 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.15-0vl1
  260. - source upgrade
  261. - add URL
  262. - remove all patches
  263. - use %%configure script
  264. - add BuildPrereq: freetype2-devel XFree86-devel
  265. - remove BuildPrereq: VFlib-devel
  266. - update %%files
  267. - update Requires:
  268. - use License tag instead of Copyright
  269. * Fri Apr 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.8.3-0vl4
  270. - rebuild with libpng-devel-1.2.5-0vl1
  271. * Sun Apr 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl3
  272. - rebuild with new toolchain
  273. * Sat Sep 02 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  274. - 1.8.3-0vl2
  275. - symlink to libgd.so.1 (for backward compatibility)
  276. * Tue Jun 6 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  277. - first gd 1.8.x release for Vine from rawhide.
  278. - enable freetype support and defined JISX208 macro.
  279. * Mon May 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  280. - break out a -progs subpackage
  281. - disable freetype support
  282. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  283. - update to latest version (1.8.2)
  284. - disable xpm support
  285. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  286. - auto rebuild in the new build environment (release 6)
  287. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  288. - auto rebuild in the new build environment (release 5)
  289. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  290. - buiuld for glibc 2.1
  291. * Fri Sep 11 1998 Cristian Gafton <gafton@redhat.com>
  292. - built for 5.2