gtk+-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657
  1. # Note that this is NOT a relocatable package
  2. %define ver 1.2.10
  3. %define rel 4%{?_dist_release}
  4. %define debug off
  5. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  6. Name: gtk+
  7. Version: %{ver}
  8. Release: %{rel}
  9. License: LGPL
  10. Group: System Environment/Libraries
  11. URL: http://www.gtk.org
  12. Obsoletes: gtk
  13. BuildRequires: glib-devel >= 1.2.10
  14. BuildRequires: libX11-devel libXext-devel libXi-devel
  15. BuildRequires: linuxdoc-tools automake14 autoconf213
  16. BuildRequires: libXt-devel
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Source: ftp://ftp.gimp.org/pub/gtk/v1.2/%{name}-%{ver}.tar.gz
  19. Source1: gtkrc-default
  20. Source2: gtkrc.ja-vine
  21. #
  22. # merged RH patches.
  23. #
  24. Patch1: gtk+-1.2.6-ahiguti.patch
  25. Patch5: gtk+-1.2.8-wrap-alnum.patch
  26. ## Supress alignment warnings on ia64
  27. Patch10: gtk+-1.2.10-alignment.patch
  28. ## Improve exposure compression
  29. Patch11: gtk+-1.2.10-expose.patch
  30. ## Handle focus tracking for embedded window properly
  31. Patch12: gtk+-1.2.10-focus.patch
  32. ## Find gtkrc files for the current encoding better
  33. Patch13: gtk+-1.2.10-encoding.patch
  34. ## Don't screw up CTEXT encoding for UTF-8
  35. Patch14: gtk+-1.2.10-ctext.patch
  36. ## Don't warn about missing fonts for UTF-8
  37. Patch15: gtk+-1.2.10-utf8fontset.patch
  38. ## Accept KP_Enter as a synonym for Return everywhere
  39. Patch16: gtk+-1.2.10-kpenter.patch
  40. ## Allow theme switching to work properly when no windows are realized
  41. Patch17: gtk+-1.2.10-themeswitch.patch
  42. ## Fix crash when switching themes
  43. Patch18: gtk+-1.2.10-pixmapref.patch
  44. ## Fix computation of width of missing characters
  45. Patch19: gtk+-1.2.10-missingchar.patch
  46. # Fix sizes of Ukrainian fontsets
  47. Patch20: gtk+-1.2.10-ukfont.patch
  48. # Fix file selection delete-dir when changing directory problem
  49. # also, fix memory corruption problem when changing directories.
  50. Patch21: gtk+-1.2.10-deletedir.patch
  51. # Improve warning for missing fonts
  52. Patch22: gtk+-1.2.10-fontwarning.patch
  53. # Allow themes to make scrollbar trough always repaint
  54. Patch23: gtk+-1.2.10-troughpaint.patch
  55. # Fix a crash that can happen in some apps when the current
  56. # locale is not supported by XLib.
  57. Patch24: gtk+-1.2.10-localecrash.patch
  58. # Use lib64 in X11R6 path if it exists.
  59. Patch25: gtk+-1.2.10-xlibs.patch
  60. # Patch from CVS to fix b.g.o #56349
  61. Patch26: gtk+-1.2.10-dndorder.patch
  62. # Patch from CVS to fix b.g.o #94812
  63. Patch27: gtk+-1.2.10-clistfocusrow.patch
  64. # Fix GTK+ to obey X server's default bell volume
  65. Patch28: gtk+-1.2.10-bellvolume.patch
  66. # Hack up the configure scripts to deal with some obscure
  67. # breakage with ancient libtool
  68. Patch29: gtk+-1.2.10-libtool.patch
  69. # Add a dependency on libgdk to libgtk
  70. Patch30: gtk+-1.2.10-gtkgdkdep.patch
  71. # Add x86_64
  72. Patch31: gtk+-1.2.10-config.sub-x86_64.patch
  73. #
  74. # Vine-specific patches.
  75. #
  76. # This is still necessary.
  77. Patch101: gtk+-1.2.3-eventmask.patch
  78. Patch102: gtk+-1.2.8-fontselector.patch
  79. Patch103: gtk+-1.2.6-event_send.patch
  80. # Security Patch
  81. Patch110: gtk+-1.2.8-gtkmod.patch
  82. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  83. Summary(ja): X 上の GUI を作成ライブラリ: GIMP ツールキット(GTK+)
  84. %description
  85. The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating
  86. graphical user interfaces for the X Window System. GTK+ was originally
  87. written for the GIMP (GNU Image Manipulation Program) image processing
  88. program, but is now used by several other programs as well.
  89. If you are planning on using the GIMP or another program that uses GTK+,
  90. you'll need to have the gtk+ package installed.
  91. %description -l ja
  92. gtk+ パッケージは, X ウィンドウ・システム上で GUI を作成するための GIMP
  93. ツールキット (GTK+) を含んでいます。GTK+ は、画像処理プログラム GIMP
  94. (GNU Image Manipulation Program) のために作られましたが、現在は他の様々な
  95. プログラムで用いられています。
  96. もし、GTK+ を使う GIMP や他のプログラムを用いる予定ならば、この gtk+
  97. パッケージをインストールしてください。
  98. %package -n compat32-%{name}
  99. Summary: The GIMP ToolKit (GTK+), a library for creating GUIs for X.
  100. Summary(ja): X 上の GUI を作成ライブラリ: GIMP ツールキット(GTK+)
  101. Group: System Environment/Libraries
  102. Requires: %{name} = %{version}
  103. %description -n compat32-%{name}
  104. The gtk+ package contains the GIMP ToolKit (GTK+), a library for creating
  105. graphical user interfaces for the X Window System. GTK+ was originally
  106. written for the GIMP (GNU Image Manipulation Program) image processing
  107. program, but is now used by several other programs as well.
  108. If you are planning on using the GIMP or another program that uses GTK+,
  109. you'll need to have the gtk+ package installed.
  110. %description -n compat32-%{name} -l ja
  111. gtk+ パッケージは, X ウィンドウ・システム上で GUI を作成するための GIMP
  112. ツールキット (GTK+) を含んでいます。GTK+ は、画像処理プログラム GIMP
  113. (GNU Image Manipulation Program) のために作られましたが、現在は他の様々な
  114. プログラムで用いられています。
  115. もし、GTK+ を使う GIMP や他のプログラムを用いる予定ならば、この gtk+
  116. パッケージをインストールしてください。
  117. %package devel
  118. Summary: Development tools for GTK+ (GIMP ToolKit) applications.
  119. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  120. Group: Development/Libraries
  121. Requires: %{name} = %{version}
  122. Requires: glib-devel
  123. Requires: libX11-devel
  124. Requires: libXext-devel
  125. Requires: libXi-devel
  126. Obsoletes: gtk-devel
  127. Requires(post): /sbin/install-info
  128. Requires(preun): /sbin/install-info
  129. %description devel
  130. The gtk+-devel package contains the static libraries and header files
  131. needed for developing GTK+ (GIMP ToolKit) applications. The gtk+-devel
  132. package contains glib (a collection of routines for simplifying the
  133. development of GTK+ applications), GDK (the General Drawing Kit, which
  134. simplifies the interface for writing GTK+ widgets and using GTK+ widgets
  135. in applications), and GTK+ (the widget set).
  136. Install gtk+-devel if you need to develop GTK+ applications. You'll also
  137. need to install the gtk+ package.
  138. %description devel -l ja
  139. gtk+-devel には、GTK+ (GIMP ToolKit) アプリケーションを開発するのに必要
  140. な静的ライブラリやヘッダファイルを含んでいます。gtk+-devel パッケージには
  141. glib (GTK+ アプリケーション開発を簡単にするルーチン集), GDK (アプリケーシ
  142. ョン中でGTK+ ウィジッドを書いたり用いたりするのを簡単にするドローキット)
  143. そして、GTK+ (ウィジッド・セット) を含んでいます。
  144. もし、GTK+ アプリケーションを開発するなら、gtk+-devel パッケージをインスト
  145. ールしてください。gtk+ パッケージもインストールしておく必要があります。
  146. %package -n compat32-%{name}-devel
  147. Summary: Development tools for GTK+ (GIMP ToolKit) applications.
  148. Summary(ja): GTK+ (GIMP ツールキット) アプリケーション開発ツール
  149. Group: Development/Libraries
  150. Requires: %{name}-devel = %{version}
  151. Requires: compat32-%{name} = %{version}
  152. %description -n compat32-%{name}-devel
  153. The gtk+-devel package contains the static libraries and header files
  154. needed for developing GTK+ (GIMP ToolKit) applications. The gtk+-devel
  155. package contains glib (a collection of routines for simplifying the
  156. development of GTK+ applications), GDK (the General Drawing Kit, which
  157. simplifies the interface for writing GTK+ widgets and using GTK+ widgets
  158. in applications), and GTK+ (the widget set).
  159. Install gtk+-devel if you need to develop GTK+ applications. You'll also
  160. need to install the gtk+ package.
  161. %description -n compat32-%{name}-devel -l ja
  162. gtk+-devel には、GTK+ (GIMP ToolKit) アプリケーションを開発するのに必要
  163. な静的ライブラリやヘッダファイルを含んでいます。gtk+-devel パッケージには
  164. glib (GTK+ アプリケーション開発を簡単にするルーチン集), GDK (アプリケーシ
  165. ョン中でGTK+ ウィジッドを書いたり用いたりするのを簡単にするドローキット)
  166. そして、GTK+ (ウィジッド・セット) を含んでいます。
  167. もし、GTK+ アプリケーションを開発するなら、gtk+-devel パッケージをインスト
  168. ールしてください。gtk+ パッケージもインストールしておく必要があります。
  169. %prep
  170. %setup -q
  171. %patch1 -p1 -b .ahiguti
  172. %patch5 -p1 -b .alnum
  173. %patch10 -p1 -b .alignment
  174. %patch11 -p1 -b .expose
  175. %patch12 -p1 -b .focus
  176. %patch13 -p1 -b .encoding
  177. %patch14 -p1 -b .ctext
  178. %patch15 -p1 -b .utf8fontset
  179. %patch16 -p1 -b .kpenter
  180. %patch17 -p1 -b .themeswitch
  181. %patch18 -p1 -b .pixmapref
  182. %patch19 -p1 -b .missingchar
  183. %patch20 -p1 -b .ukfont
  184. %patch21 -p1 -b .deletedir
  185. %patch22 -p1 -b .fontwarning
  186. %patch23 -p0 -b .troughpaint
  187. %patch24 -p1 -b .localecrash
  188. %patch25 -p1 -b .xlibs
  189. %patch26 -p0 -b .dndorder
  190. %patch27 -p0 -b .clistfocusrow
  191. %patch28 -p1 -b .bellvolume
  192. %patch29 -p1 -b .libtool
  193. %patch31 -p1 -b .x86_64
  194. %patch101 -p1 -b .nocore
  195. %patch102 -p1 -b .fontsel
  196. %patch103 -p1 -b .event_send
  197. %patch110 -p1 -b .gtkmod
  198. #libtoolize --force
  199. #aclocal-1.4
  200. automake-1.4
  201. autoconf-2.13
  202. autoheader-2.13
  203. %build
  204. if [ %{debug} = "on" ] ; then
  205. export CFLAGS="$RPM_OPT_FLAGS -g"
  206. else
  207. export CFLAGS="$RPM_OPT_FLAGS"
  208. fi
  209. # gcc-2.95.3 with '-O2' option causes problems on Alpha
  210. %ifarch alpha
  211. export CFLAGS="-O -mieee"
  212. %endif
  213. AUTOMAKE=automake-1.4 %configure --with-xinput=xfree --with-native-locale
  214. if [ "$SMP" != "" ]; then
  215. (make "MAKE=make -k -j $SMP"; exit 0)
  216. make AUTOMAKE=automake-1.4
  217. else
  218. make AUTOMAKE=automake-1.4
  219. fi
  220. %install
  221. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  222. %makeinstall
  223. # rename gtk-config to gtk-config-32 if build_compat32 option is enabled
  224. %if %{build_compat32}
  225. #mv $RPM_BUILD_ROOT%{_bindir}/gtk-config $RPM_BUILD_ROOT%{_bindir}/gtk-config-32
  226. cp -p $RPM_BUILD_ROOT%{_bindir}/gtk-config $RPM_BUILD_ROOT%{_bindir}/gtk-config-32
  227. %endif
  228. #
  229. # Make cleaned-up versions of examples and tutorial for installation
  230. #
  231. ./mkinstalldirs tmpdocs/tutorial
  232. install -m 0644 docs/html/gtk_tut.html docs/html/gtk_tut-[0-9]*.html docs/html/*.gif tmpdocs/tutorial
  233. for dir in examples/*; do
  234. if [ -d $dir ]; then
  235. ./mkinstalldirs tmpdocs/$dir
  236. for file in $dir/*; do
  237. case $file in
  238. *pre1.2.7)
  239. ;;
  240. *)
  241. install -m 0644 $file tmpdocs/$dir
  242. ;;
  243. esac
  244. done
  245. fi
  246. done
  247. install -m 444 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/gtk/gtkrc
  248. install -m 444 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/gtk/gtkrc.ja
  249. %find_lang %{name}
  250. # remove unneeded files
  251. %__rm -f %{buildroot}%{_libdir}/lib{gdk,gtk}.la
  252. %clean
  253. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  254. %post -p /sbin/ldconfig
  255. %postun -p /sbin/ldconfig
  256. %post -n compat32-%{name} -p /sbin/ldconfig
  257. %postun -n compat32-%{name} -p /sbin/ldconfig
  258. %post devel
  259. /sbin/install-info %{_infodir}/gdk.info.gz %{_infodir}/dir
  260. /sbin/install-info %{_infodir}/gtk.info.gz %{_infodir}/dir
  261. %preun devel
  262. if [ $1 = 0 ]; then
  263. /sbin/install-info --delete %{_infodir}/gdk.info.gz %{_infodir}/dir
  264. /sbin/install-info --delete %{_infodir}/gtk.info.gz %{_infodir}/dir
  265. fi
  266. %files -f %{name}.lang
  267. %defattr(-, root, root)
  268. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  269. %{_libdir}/libgtk-1.2.so.*
  270. %{_libdir}/libgdk-1.2.so.*
  271. %{_datadir}/themes/Default
  272. %config %{_sysconfdir}/gtk/*
  273. %files devel
  274. %defattr(-, root, root)
  275. %{_libdir}/lib*.so
  276. %{_libdir}/*.a
  277. %{_libdir}/pkgconfig
  278. %{_mandir}/man1/*
  279. %{_includedir}/*
  280. %{_infodir}/*info*
  281. %{_datadir}/aclocal/*
  282. #%{_bindir}/*
  283. %{_bindir}/gtk-config
  284. %doc tmpdocs/tutorial
  285. %doc tmpdocs/examples
  286. %if %{build_compat32}
  287. %files -n compat32-%{name}
  288. %defattr(-, root, root)
  289. %{_libdir}/libgtk-1.2.so.*
  290. %{_libdir}/libgdk-1.2.so.*
  291. %files -n compat32-%{name}-devel
  292. %defattr(-, root, root)
  293. %{_libdir}/lib*.so
  294. %{_libdir}/*.a
  295. %{_libdir}/pkgconfig
  296. %{_bindir}/gtk-config-32
  297. %endif
  298. %changelog
  299. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.10-4
  300. - fixed missing of gtk-config (on i686)
  301. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-3
  302. - rebuild with rpm-4.8.1 for pkg-config file
  303. - add BuildRequires: libXt-devel
  304. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.10-2
  305. - spec in utf-8
  306. * Mon Jun 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.10-1
  307. - applied new versioning policy
  308. - rebuilt with xorg-x11 7.3 (updated denepdancies)
  309. * Wed May 24 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl10
  310. - rename gtk-config to gtk-config-32 if build_compat32 option is enabled
  311. * Mon Mar 06 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.10-0vl9
  312. - added compat32-* packages for x86_64 architecture support
  313. * Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.10-0vl8
  314. - added gtk+-1.2.10-config.sub-x86_64.patch
  315. * Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.10-0vl7
  316. - rebuild
  317. - not run libtoolize --force, aclocal-1.4
  318. - remove %%{_libdir}/lib{gdk,gtk}.la
  319. - compress info files by brp-compress
  320. * Wed Jul 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.10-0vl6
  321. - merge more RH patches (Patch26-Patch29)
  322. * Mon Oct 27 2003 Owen Taylor <otaylor@redhat.com> 1:1.2.10-28.1
  323. - Cave like a cheap house of cards and add gdk-pixbuf dependency (#105613)
  324. - Add gtkrc.*.utf8 RC files for CJK (#84593)
  325. - Add a dependency on libgdk to libgtk (#106677)
  326. * Thu Feb 13 2003 Elliot Lee <sopwith@redhat.com> 1.2.10-26
  327. - Run libtoolize/auto* to get an updated libtool that recognizes ppc64
  328. * Wed Jan 15 2003 Owen Taylor <otaylor@redhat.com> 1.2.10-24
  329. - Add a couple of patches from GNOME CVS, fixing a crash
  330. with CList focus row tracking, and a place where DND
  331. would get confused.
  332. - Obey the system bell volume (#74802)
  333. - Ship the pkg-config files
  334. * Mon Nov 4 2002 Tim Waugh <twaugh@redhat.com> 1.2.10-23
  335. - Don't install files not shipped.
  336. - Fix gtk-config output for multilib archs.
  337. * Wed Dec 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.10-0vl5
  338. - merge more RH patches (Patch20-Patch25)
  339. - rawhide's changelog since last merge (except "automated rebuild") are:
  340. - Thu Aug 22 2002 Owen Taylor <otaylor@redhat.com>
  341. - Fix a crash that can happen in some apps when the current
  342. locale is not supported by XLib. (#72157)
  343. - Fri Jul 26 2002 Owen Taylor <otaylor@redhat.com>
  344. - Fix a small memory leak in the .encoding patch (Kjartan Maraas)
  345. - Fri Jul 19 2002 Alexander Larsson <alexl@redhat.com>
  346. - Add troughpaint patch
  347. - Thu Jun 27 2002 Owen Taylor <otaylor@redhat.com>
  348. - Fix UTF-8 font specification not to pick up *-c-* fonts
  349. - Thu May 16 2002 Alex Larsson <alexl@redhat.com>
  350. - Require automake 1.4
  351. - Wed Apr 17 2002 Owen Taylor <otaylor@redhat.com>
  352. - Fix problem with incorrect directory contents when changing directories (#63726)
  353. - Fri Apr 12 2002 Owen Taylor <otaylor@redhat.com>
  354. - Fix filesel delete-filename-on-dir-change problem
  355. - Improve warning for missing fontset elements
  356. - Thu Apr 11 2002 Owen Taylor <otaylor@redhat.com>
  357. - Fix ukrainian font sizes, minor tweak to russian fonts (#63135)
  358. - Own /etc/gtk/ as well as the files in it (#63139)
  359. * Thu Mar 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl4
  360. - changed default theme to BeCool.
  361. * Mon Oct 15 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl3
  362. - Merged several RH patches.
  363. * Mon Aug 13 2001 Owen Taylor <otaylor@redhat.com>
  364. - Fix problem with width computation for missing characters
  365. * Sun Aug 12 2001 Owen Taylor <otaylor@redhat.com>
  366. - Fix refcounting problem in gtk_style_copy() that might affect
  367. theme switching. (#51580)
  368. * Wed Aug 8 2001 Owen Taylor <otaylor@redhat.com>
  369. - Add fix for theme switching in nautilus sidebar tabs
  370. (and other similar situations)
  371. * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
  372. - Accept KP_Enter as well as Return (#21111)
  373. * Wed Jul 11 2001 Owen Taylor <otaylor@redhat.com>
  374. - Further improve exposure compression code
  375. * Tue Jul 10 2001 Owen Taylor <otaylor@redhat.com>
  376. - Omit warnings about character sets not found in fontset,
  377. if current locale is UTF-8 based. (Hack!)
  378. * Tue Jul 3 2001 Owen Taylor <otaylor@redhat.com>
  379. - Add patch for alignment warnings on ia64
  380. - Add from Alex to vastly improve expose compression
  381. - Add patch to fix focus tracking for embedded windows
  382. - Add patch by Pablo Saratxaga to improve encoding handling
  383. - Add patch to not screw up CTEXT for UTF-8 locales
  384. * Tue Jul 17 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
  385. - 1.2.10-0vl2
  386. - change CFLAGS on alpha (gcc-2.95.3 with -O2 causes problems)
  387. * Tue Apr 3 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.10-0vl1
  388. - New upstream release.
  389. * Wed Mar 7 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2.9-0vl1
  390. - New upstream release.
  391. * Wed Feb 14 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl6
  392. - correct configure for stablity
  393. * Tue Feb 13 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl5
  394. - correct configure (for --enable-xinput)
  395. - add DESTDIR patch for po/Makefile.in.in
  396. * Wed Feb 7 2001 Shoji Matsumoto <shom@vinelinux.org> 1.2.8-0vl4
  397. - add gtk+-1.2.8-gtktextwcfix.patch
  398. * Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  399. - 1.2.8-0vl2
  400. - applied security patch (http://www.securityfocus.com/bid/2165)
  401. * Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  402. - updated to 1.2.8
  403. * Fri Feb 18 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  404. - added fontselector based on kondara's patch
  405. * Thu Feb 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  406. - updated to 1.2.7
  407. - remove morioka marged to the original gtk source tree.
  408. Tue Dec 28 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
  409. - added event_send patch to be more stable when switching themes.
  410. * Sat Dec 11 1999 Jun Nishii <jun@flatout.org>
  411. - smaller fontset in gtkrc.ja
  412. * Thu Nov 25 1999 Jun NISHII <jun@flatout.org>
  413. - use morioka patch instead of fontsel patches
  414. * Sat Oct 23 1999 Jun Nishii <jun@flatout.org>
  415. - gtk+-1.2.6-1vl2
  416. - added fontsel patches from gtk/gnome-ML
  417. * Tue Oct 12 1999 Jun Nishii <jun@flatout.org>
  418. - gtk+-1.2.6-1vl1
  419. * Thu Sep 30 1999 Jun Nishii <jun@flatout.org>
  420. - gtk+-1.2.5-1vl2
  421. - with wordwrap patch
  422. * Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
  423. - gtk+-1.2.5-1vl1
  424. * Fri Sep 11 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  425. [gtk+-1.2.4-1vl2]
  426. - removed fontsel patch.
  427. * Fri Sep 6 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  428. [gtk+-1.2.4-1vl1]
  429. - install gzipped info.
  430. - changed release tag with 'vl.'
  431. * Fri Sep 3 1999 Yasuhide OOMORI <dasen@typhoon.co.jp>
  432. [gtk+-1.2.4-1]
  433. - Update for GTK+-1.2.4.
  434. - bzip2 source.
  435. - use %{sysconfdir} as /etc.
  436. * Sun Aug 22 1999 Jun Nishii <jun@flatout.org>
  437. - bzip2 source
  438. * Sat Aug 21 1999 Jun Nishii <jun@flatout.org>
  439. - build for Vine-1.9
  440. - merge fontset patch
  441. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  442. - Update for GTK+-1.2.3
  443. - Patches that will be in GTK+-1.2.4
  444. - Patch to keep GTK+ from coredumping on X IO errors
  445. - Patch to improve compatilibity with GTK-1.2.1 (allow
  446. event mask to be set on realized widgets)
  447. * Mon Apr 19 1999 Michael Fulbright <drmike@redhat.com>
  448. - fixes memory leak
  449. * Mon Apr 12 1999 Owen Taylor <otaylor@redhat.com>
  450. - The important bug fixes that will be in GTK+-1.2.2
  451. * Thu Apr 01 1999 Michael Fulbright <drmike@redhat.com>
  452. - patches from owen to handle various gdk bugs
  453. * Sun Mar 28 1999 Michael Fulbright <drmike@redhat.com>
  454. - added XFree86-devel requirement for gtk+-devel
  455. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  456. - version 1.2.1
  457. * Wed Mar 17 1999 Michael Fulbright <drmike@redhat.com>
  458. - removed /usr/info/dir.gz file from package
  459. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  460. - Version 1.2.0
  461. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  462. - version 1.2.0pre2, patched to use --sysconfdir=/etc
  463. * Mon Feb 15 1999 Michael Fulbright <drmike@redhat.com>
  464. - patched in Owen's patch to fix Metal theme
  465. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  466. - bumped up to 1.1.15
  467. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  468. - bumped up to 1.1.14
  469. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  470. - bumped up to 1.1.13
  471. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  472. - bumped up to 1.1.12
  473. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  474. - added Theme directory to file list
  475. - up to 1.1.7 for GNOME freeze
  476. * Sun Oct 25 1998 Shawn T. Amundson <amundson@gtk.org>
  477. - Fixed Source: to point to v1.1
  478. * Tue Aug 04 1998 Michael Fulbright <msf@redhat.com>
  479. - change %postun to %preun
  480. * Mon Jun 27 1998 Shawn T. Amundson
  481. - Changed version to 1.1.0
  482. * Thu Jun 11 1998 Dick Porter <dick@cymru.net>
  483. - Removed glib, since it is its own module now
  484. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  485. - Split out glib package
  486. * Tue Apr 8 1998 Shawn T. Amundson <amundson@gtk.org>
  487. - Changed version to 1.0.0
  488. * Tue Apr 7 1998 Owen Taylor <otaylor@gtk.org>
  489. - Changed version to 0.99.10
  490. * Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
  491. - Changed version to 0.99.9
  492. - Changed gtk home page to www.gtk.org
  493. * Thu Mar 19 1998 Shawn T. Amundson <amundson@gimp.org>
  494. - Changed version to 0.99.8
  495. * Sun Mar 15 1998 Marc Ewing <marc@redhat.com>
  496. - Added aclocal and bin stuff to file list.
  497. - Added -k to the SMP make line.
  498. - Added lib/glib to file list.
  499. * Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
  500. - Changed version to 0.99.7
  501. * Fri Mar 14 1998 Shawn T. Amundson <amundson@gimp.org>
  502. - Updated ftp url and changed version to 0.99.6
  503. * Thu Mar 12 1998 Marc Ewing <marc@redhat.com>
  504. - Reworked to integrate into gtk+ source tree
  505. - Truncated ChangeLog. Previous Authors:
  506. Trond Eivind Glomsrod <teg@pvv.ntnu.no>
  507. Michael K. Johnson <johnsonm@redhat.com>
  508. Otto Hammersmith <otto@redhat.com>