123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268 |
- %global debug_package %{nil}
- %global _binaries_in_noarch_packages_terminate_build 0
- %global __requires_exclude_from ^(%{_datadir}|%{_libdir})/%{name}/(doc|src)/.*$
- %global __strip /bin/true
- %define _use_internal_dependency_generator 0
- %define __find_requires %{nil}
- %global debug_package %{nil}
- %global __spec_install_post /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot \
- /usr/lib/rpm/brp-compress
- Name: golang
- Version: 1.2
- Release: 1%{?_dist_release}
- Summary: The Go Programming Language
- License: BSD
- URL: http://golang.org/
- Source0: https://go.googlecode.com/files/go%{version}.src.tar.gz
- BuildRequires: net-tools
- Requires: glibc
- Patch0: golang-1.2-verbose-build.patch
- Patch2: golang-1.2-remove-ECC-p224.patch
- Patch3: ./golang-1.2-skipCpuProfileTest.patch
- ExclusiveArch: %{ix86} x86_64
- Source100: golang-gdbinit
- Source101: golang-prelink.conf
- %description
- %{summary}.
- %pretrans -p <lua>
- for _,d in pairs({"api", "doc", "include", "lib", "src"}) do
- path = "%{_libdir}/%{name}/" .. d
- if posix.stat(path, "type") == "link" then
- os.remove(path)
- posix.mkdir(path)
- end
- end
- %prep
- %setup -q -n go
- %patch0 -p1
- %patch2 -p1
- %patch3 -p1
- mkdir -p zz
- echo -e "#!/bin/sh\n/usr/bin/gcc $RPM_OPT_FLAGS $RPM_LD_FLAGS \"\$@\"" > ./zz/gcc
- chmod +x ./zz/gcc
- %build
- export GOROOT_FINAL=%{_libdir}/%{name}
- cd src
- PATH="$(pwd -P)/../zz:$PATH" CC="gcc" ./make.bash
- cd ..
- %check
- export GOROOT=$(pwd -P)
- export PATH="$PATH":"$GOROOT"/bin
- cd src
- ./run.bash --no-rebuild
- cd ..
- %install
- rm -rf $RPM_BUILD_ROOT
- mkdir -p $RPM_BUILD_ROOT%{_bindir}
- mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{name}
- cp -av api bin doc favicon.ico include lib pkg robots.txt src \
- $RPM_BUILD_ROOT%{_libdir}/%{name}
- rm -rfv $RPM_BUILD_ROOT%{_libdir}/%{name}/lib/time
- rm -rfv $RPM_BUILD_ROOT%{_libdir}/%{name}/doc/Makefile
- pushd $RPM_BUILD_ROOT%{_bindir}
- for z in $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/*
- do mv $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/$(basename $z) .
- done
- popd
- mkdir -p $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions
- cp -av misc/bash/go $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions
- for z in 8l 6l 5l 8g 6g 5g gofmt gccgo
- do ln -s go $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/$z
- done
- mkdir -p $RPM_BUILD_ROOT%{_datadir}/zsh/site-functions
- cp -av misc/zsh/go $RPM_BUILD_ROOT%{_datadir}/zsh/site-functions
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gdbinit.d
- cp -av %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/gdbinit.d/golang
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/prelink.conf.d
- cp -av %{SOURCE101} $RPM_BUILD_ROOT%{_sysconfdir}/prelink.conf.d/golang.conf
- %files
- %doc AUTHORS CONTRIBUTORS LICENSE PATENTS VERSION
- %{_libdir}/%{name}
- %{_bindir}/go
- %{_bindir}/gofmt
- %{_datadir}/bash-completion
- %{_datadir}/zsh
- %{_sysconfdir}/gdbinit.d
- %{_sysconfdir}/prelink.conf.d
- %changelog
- * Sat Feb 1 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.2
- - initial build for Vine Linux
- - drop emacs and vim package
- * Thu Jan 24 2014 Vincent Batts <vbatts@redhat.com> 1.2-4
- - skip a flaky test that is sporadically failing on the build server
- * Thu Jan 16 2014 Vincent Batts <vbatts@redhat.com> 1.2-3
- - remove golang-godoc dependency. cyclic dependency on compiling godoc
- * Wed Dec 18 2013 Vincent Batts <vbatts@redhat.com> - 1.2-2
- - removing P224 ECC curve
- * Mon Dec 2 2013 Vincent Batts <vbatts@fedoraproject.org> - 1.2-1
- - Update to upstream 1.2 release
- - remove the pax tar patches
- * Tue Nov 26 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-8
- - fix the rpmspec conditional for rhel and fedora
- * Thu Nov 21 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-7
- - patch tests for testing on rawhide
- - let the same spec work for rhel and fedora
- * Wed Nov 20 2013 Vincent Batts <vbatts@redhat.com> - 1.1.2-6
- - don't symlink /usr/bin out to ../lib..., move the file
- - seperate out godoc, to accomodate the go.tools godoc
- * Fri Sep 20 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-5
- - Pull upstream patches for BZ#1010271
- - Add glibc requirement that got dropped because of meta dep fix
- * Fri Aug 30 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-4
- - fix the libc meta dependency (thanks to vbatts [at] redhat.com for the fix)
- * Tue Aug 27 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-3
- - Revert incorrect merged changelog
- * Tue Aug 27 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-2
- - This was reverted, just a placeholder changelog entry for bad merge
- * Tue Aug 20 2013 Adam Miller <maxamillion@fedoraproject.org> - 1.1.2-1
- - Update to latest upstream
- * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-7
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 1.1.1-6
- - Perl 5.18 rebuild
- * Wed Jul 10 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-5
- - Blacklist testdata files from prelink
- - Again try to fix
- * Fri Jul 5 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-4
- - Move src to libdir for now (#973842) (upstream issue https://code.google.com/p/go/issues/detail?id=5830)
- - Eliminate noarch data package to work around RPM bug (#975909)
- - Try to add runtime-gdb.py to the gdb safe-path (#981356)
- * Wed Jun 19 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-3
- - Use lua for pretrans (http://fedoraproject.org/wiki/Packaging:Guidelines#The_.25pretrans_scriptlet)
- * Mon Jun 17 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-2
- - Hopefully really fix
- - Fix update from pre-1.1.1 (#974840)
- * Thu Jun 13 2013 Adam Goode <adam@spicenitz.org> - 1.1.1-1
- - Update to 1.1.1
- - Fix basically useless package (#973842)
- * Sat May 25 2013 Dan Horák <dan[at]danny.cz> - 1.1-3
- - set ExclusiveArch
- * Fri May 24 2013 Adam Goode <adam@spicenitz.org> - 1.1-2
- - Fix noarch package discrepancies
- * Fri May 24 2013 Adam Goode <adam@spicenitz.org> - 1.1-1
- - Initial Fedora release.
- - Update to 1.1
- * Thu May 9 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.3.rc3
- - Update to rc3
- * Thu Apr 11 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.2.beta2
- - Update to beta2
- * Tue Apr 9 2013 Adam Goode <adam@spicenitz.org> - 1.1-0.1.beta1
- - Initial packaging.
|