123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772 |
- %{!?with_sqlite: %global with_sqlite 1}
- %{!?with_docs: %global with_docs 0}
- # crash is not available
- %ifarch ppc ppc64 %{sparc}
- %{!?with_crash: %global with_crash 0}
- %else
- %{!?with_crash: %global with_crash 1}
- %endif
- %{!?with_rpm: %global with_rpm 1}
- %{!?with_bundled_elfutils: %global with_bundled_elfutils 0}
- %{!?elfutils_version: %global elfutils_version 0.142}
- %{!?pie_supported: %global pie_supported 1}
- %{!?with_boost: %global with_boost 0}
- %{!?with_publican: %global with_publican 0}
- %{!?publican_brand: %global publican_brand fedora}
- Name: systemtap
- Version: 2.0
- Release: 1%{?_dist_release}
- # for version, see also configure.ac
- # Packaging abstract:
- #
- # systemtap empty req:-client req:-devel
- # systemtap-server /usr/bin/stap-server*, req:-devel
- # systemtap-devel /usr/bin/stap, runtime, tapset, req:kernel-devel
- # systemtap-runtime /usr/bin/staprun, /usr/bin/stapsh
- # systemtap-client /usr/bin/stap, samples, docs, tapset(bonus), req:-runtime
- # systemtap-initscript /etc/init.d/systemtap, req:systemtap
- # systemtap-sdt-devel /usr/include/sys/sdt.h /usr/bin/dtrace
- # systemtap-testsuite /usr/share/systemtap/testsuite*, req:systemtap, req:sdt-devel
- #
- # Typical scenarios:
- #
- # stap-client: systemtap-client
- # stap-server: systemtap-server
- # local user: systemtap
- #
- # Unusual scenarios:
- #
- # intermediary stap-client for --remote: systemtap-client (-runtime unused)
- # intermediary stap-server for --use-server: systemtap-server (-devel unused)
- Summary: Programmable system-wide instrumentation system
- Group: Development/System
- License: GPLv2+
- URL: http://sourceware.org/systemtap/
- Source: ftp://sourceware.org/pub/%{name}/releases/%{name}-%{version}.tar.gz
- # Build*
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
- BuildRequires: gcc-c++
- BuildRequires: gettext-devel
- BuildRequires: nss-devel avahi-devel pkgconfig
- %if %{with_sqlite}
- BuildRequires: sqlite-devel
- %endif
- # Needed for libstd++ < 4.0, without <tr1/memory>
- %if %{with_boost}
- BuildRequires: boost-devel
- %endif
- %if %{with_crash}
- BuildRequires: crash-devel zlib-devel
- %endif
- %if %{with_rpm}
- BuildRequires: rpm-devel glibc-headers
- %endif
- %if %{with_bundled_elfutils}
- Source1: elfutils-%{elfutils_version}.tar.gz
- Patch1: elfutils-portability.patch
- BuildRequires: m4
- %global setup_elfutils -a1
- %else
- BuildRequires: elfutils-devel >= %{elfutils_version}
- %endif
- %if %{with_docs}
- BuildRequires: texlive-common
- BuildRequires: latex2html
- %if %{with_publican}
- BuildRequires: publican
- BuildRequires: /usr/share/publican/Common_Content/%{publican_brand}/defaults.cfg
- %endif
- %endif
- # Install requirements
- Requires: systemtap-client = %{version}-%{release}
- Requires: systemtap-devel = %{version}-%{release}
- %description
- SystemTap is an instrumentation system for systems running Linux.
- Developers can write instrumentation scripts to collect data on
- the operation of the system. The base systemtap package contains/requires
- the components needed to locally develop and execute systemtap scripts.
- # ------------------------------------------------------------------------
- %package server
- Summary: Instrumentation System Server
- Group: Development/System
- License: GPLv2+
- URL: http://sourceware.org/systemtap/
- Requires: systemtap-devel = %{version}-%{release}
- # On RHEL[45], /bin/mktemp comes from the 'mktemp' package. On newer
- # distributions, /bin/mktemp comes from the 'coreutils' package. To
- # avoid a specific RHEL[45] Requires, we'll do a file-based require.
- Requires: nss /bin/mktemp
- Requires: zip unzip
- Requires(pre): shadow-utils
- Requires(post): chkconfig
- Requires(preun): chkconfig
- Requires(preun): initscripts
- Requires(postun): initscripts
- Requires(post): %{name}-runtime
- BuildRequires: nss-devel avahi-devel
- %description server
- This is the remote script compilation server component of systemtap.
- It announces itself to nearby clients with avahi (if available), and
- compiles systemtap scripts to kernel objects on their demand.
- %package devel
- Summary: Programmable system-wide instrumentation system - development headers, tools
- Group: Development/System
- License: GPLv2+
- URL: http://sourceware.org/systemtap/
- Requires: kernel >= 2.6.9-11
- # Alternate kernel packages kernel-PAE-devel et al. have a virtual
- # provide for kernel-devel, so this requirement does the right thing,
- # at least past RHEL4.
- Requires: kernel-devel
- Requires: gcc make
- # Suggest: kernel-debuginfo
- %description devel
- This package contains the components needed to compile a systemtap
- script from source form into executable (.ko) forms. It may be
- installed on a self-contained developer workstation (along with the
- systemtap-client and systemtap-runtime packages), or on a dedicated
- remote server (alongside the systemtap-server package). It includes
- a copy of the standard tapset library and the runtime library C files.
- %package runtime
- Summary: Programmable system-wide instrumentation system - runtime
- Group: Development/System
- License: GPLv2+
- URL: http://sourceware.org/systemtap/
- Requires: kernel >= 2.6.9-11
- Requires(pre): shadow-utils
- %description runtime
- SystemTap runtime contains the components needed to execute
- a systemtap script that was already compiled into a module
- using a local or remote systemtap-devel installation.
- %package client
- Summary: Programmable system-wide instrumentation system - client
- Group: Development/System
- License: GPLv2+
- URL: http://sourceware.org/systemtap/
- Requires: zip unzip
- Requires: systemtap-runtime = %{version}-%{release}
- Requires: coreutils grep sed unzip zip
- Requires: openssh-clients
- %description client
- This package contains/requires the components needed to develop
- systemtap scripts, and compile them using a local systemtap-devel
- or a remote systemtap-server installation, then run them using a
- local or remote systemtap-runtime. It includes script samples and
- documentation, and a copy of the tapset library for reference.
- %package initscript
- Summary: Systemtap Initscripts
- Group: Development/System
- License: GPLv2+
- URL: http://sourceware.org/systemtap/
- Requires: systemtap = %{version}-%{release}
- Requires(post): chkconfig
- Requires(preun): chkconfig
- Requires(preun): initscripts
- Requires(postun): initscripts
- %description initscript
- Sysvinit scripts to launch selected systemtap scripts at system startup.
- %package sdt-devel
- Summary: Static probe support tools
- Group: Development/System
- License: GPLv2+ and Public Domain
- URL: http://sourceware.org/systemtap/
- %description sdt-devel
- This package includes the <sys/sdt.h> header file used for static
- instrumentation compiled into userspace programs and libraries, along
- with the optional dtrace-compatibility preprocessor to process related
- .d files into tracing-macro-laden .h headers.
- %package testsuite
- Summary: Instrumentation System Testsuite
- Group: Development/System
- License: GPLv2+
- URL: http://sourceware.org/systemtap/
- Requires: systemtap = %{version}-%{release}
- Requires: systemtap-sdt-devel = %{version}-%{release}
- Requires: systemtap-server = %{version}-%{release}
- Requires: dejagnu which prelink elfutils grep
- Requires: gcc gcc-c++ make glibc-devel
- # testsuite/systemtap.server/client.exp needs avahi
- Requires: avahi
- %if %{with_crash}
- # testsuite/systemtap.base/crash.exp needs crash
- Requires: crash
- %endif
- %ifarch x86_64
- Requires: compat32-glibc-devel
- %endif
- %description testsuite
- This package includes the dejagnu-based systemtap stress self-testing
- suite. This may be used by system administrators to thoroughly check
- systemtap on the current system.
- # ------------------------------------------------------------------------
- %prep
- %setup -q %{?setup_elfutils}
- %if %{with_bundled_elfutils}
- cd elfutils-%{elfutils_version}
- %patch1 -p1
- sleep 1
- find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
- sleep 1
- find . \( -name configure -o -name config.h.in \) -print | xargs touch
- cd ..
- %endif
- %build
- %if %{with_bundled_elfutils}
- # Build our own copy of elfutils.
- %global elfutils_config --with-elfutils=elfutils-%{elfutils_version}
- # We have to prevent the standard dependency generation from identifying
- # our private elfutils libraries in our provides and requires.
- %global _use_internal_dependency_generator 0
- %global filter_eulibs() /bin/sh -c "%{1} | sed '/libelf/d;/libdw/d;/libebl/d'"
- %global __find_provides %{filter_eulibs /usr/lib/rpm/find-provides}
- %global __find_requires %{filter_eulibs /usr/lib/rpm/find-requires}
- # This will be needed for running stap when not installed, for the test suite.
- %global elfutils_mflags LD_LIBRARY_PATH=`pwd`/lib-elfutils
- %endif
- # Enable/disable the sqlite coverage testing support
- %if %{with_sqlite}
- %global sqlite_config --enable-sqlite
- %else
- %global sqlite_config --disable-sqlite
- %endif
- # Enable/disable the crash extension
- %if %{with_crash}
- %global crash_config --enable-crash
- %else
- %global crash_config --disable-crash
- %endif
- # Enable/disable the code to find and suggest needed rpms
- %if %{with_rpm}
- %global rpm_config --with-rpm
- %else
- %global rpm_config --without-rpm
- %endif
- %if %{with_docs}
- %global docs_config --enable-docs
- %else
- %global docs_config --disable-docs
- %endif
- # Enable pie as configure defaults to disabling it
- %if %{pie_supported}
- %global pie_config --enable-pie
- %else
- %global pie_config --disable-pie
- %endif
- %if %{with_publican}
- %global publican_config --enable-publican --with-publican-brand=%{publican_brand}
- %else
- %global publican_config --disable-publican
- %endif
- %configure %{?elfutils_config} %{sqlite_config} %{crash_config} %{docs_config} %{pie_config} %{publican_config} %{rpm_config} --disable-silent-rules
- make %{?_smp_mflags}
- %install
- rm -rf ${RPM_BUILD_ROOT}
- make DESTDIR=$RPM_BUILD_ROOT install
- %find_lang %{name}
- # We want the examples in the special doc dir, not the build install dir.
- # We build it in place and then move it away so it doesn't get installed
- # twice. rpm can specify itself where the (versioned) docs go with the
- # %doc directive.
- mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/examples examples
- # Fix paths in the example & testsuite scripts
- find examples testsuite -type f -name '*.stp' -print0 | xargs -0 sed -i -r -e '1s@^#!.+stap@#!%{_bindir}/stap@'
- # To make rpmlint happy, remove any .gitignore files in the testsuite.
- find testsuite -type f -name '.gitignore' -print0 | xargs -0 rm -f
- # Because "make install" may install staprun with whatever mode, the
- # post-processing programs rpmbuild runs won't be able to read it.
- # So, we change permissions so that they can read it. We'll set the
- # permissions back to 04110 in the %files section below.
- chmod 755 $RPM_BUILD_ROOT%{_bindir}/staprun
- #install the useful stap-prep script
- install -c -m 755 stap-prep $RPM_BUILD_ROOT%{_bindir}/stap-prep
- # Copy over the testsuite
- cp -rp testsuite $RPM_BUILD_ROOT%{_datadir}/systemtap
- %if %{with_docs}
- # We want the manuals in the special doc dir, not the generic doc install dir.
- # We build it in place and then move it away so it doesn't get installed
- # twice. rpm can specify itself where the (versioned) docs go with the
- # %doc directive.
- mkdir docs.installed
- mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/*.pdf docs.installed/
- mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/tapsets docs.installed/
- %if %{with_publican}
- mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/SystemTap_Beginners_Guide docs.installed/
- %endif
- %endif
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
- install -m 755 initscript/systemtap $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/conf.d
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/script.d
- install -m 644 initscript/config.systemtap $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/config
- mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/systemtap
- mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/systemtap
- install -m 755 initscript/stap-server $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server/conf.d
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
- install -m 644 initscript/config.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/stap-server
- mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server
- touch $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server/log
- mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
- install -m 644 initscript/logrotate.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/stap-server
- %clean
- rm -rf ${RPM_BUILD_ROOT}
- %pre runtime
- getent group stapusr >/dev/null || groupadd -g 156 -r stapusr || groupadd -r stapusr
- getent group stapsys >/dev/null || groupadd -g 157 -r stapsys || groupadd -r stapsys
- getent group stapdev >/dev/null || groupadd -g 158 -r stapdev || groupadd -r stapdev
- exit 0
- %pre server
- getent group stap-server >/dev/null || groupadd -g 155 -r stap-server || groupadd -r stap-server
- getent passwd stap-server >/dev/null || \
- useradd -c "Systemtap Compile Server" -u 155 -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server || \
- useradd -c "Systemtap Compile Server" -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server
- test -e ~stap-server && chmod 755 ~stap-server
- if [ ! -f ~stap-server/.systemtap/rc ]; then
- mkdir -p ~stap-server/.systemtap
- chown stap-server:stap-server ~stap-server/.systemtap
- echo "--rlimit-as=614400000 --rlimit-cpu=60 --rlimit-nproc=20 --rlimit-stack=1024000 --rlimit-fsize=51200000" > ~stap-server/.systemtap/rc
- chown stap-server:stap-server ~stap-server/.systemtap/rc
- fi
- exit 0
- %post server
- test -e %{_localstatedir}/log/stap-server/log || {
- touch %{_localstatedir}/log/stap-server/log
- chmod 664 %{_localstatedir}/log/stap-server/log
- chown stap-server:stap-server %{_localstatedir}/log/stap-server/log
- }
- # If it does not already exist, as stap-server, generate the certificate
- # used for signing and for ssl.
- if test ! -e ~stap-server/.systemtap/ssl/server/stap.cert; then
- runuser -s /bin/sh - stap-server -c %{_libexecdir}/%{name}/stap-gen-cert >/dev/null
- # Authorize the certificate as a trusted ssl peer and as a trusted signer
- # on the local host.
- %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/ssl/client >/dev/null
- %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/staprun >/dev/null
- fi
- # Activate the service
- /sbin/chkconfig --add stap-server
- exit 0
- %preun server
- # Check that this is the actual deinstallation of the package, as opposed to
- # just removing the old package on upgrade.
- if [ $1 = 0 ] ; then
- /sbin/service stap-server stop >/dev/null 2>&1
- /sbin/chkconfig --del stap-server
- fi
- exit 0
- %postun server
- # Check whether this is an upgrade of the package.
- # If so, restart the service if it's running
- if [ "$1" -ge "1" ] ; then
- /sbin/service stap-server condrestart >/dev/null 2>&1 || :
- fi
- exit 0
- %post initscript
- /sbin/chkconfig --add systemtap
- exit 0
- %preun initscript
- # Check that this is the actual deinstallation of the package, as opposed to
- # just removing the old package on upgrade.
- if [ $1 = 0 ] ; then
- /sbin/service systemtap stop >/dev/null 2>&1
- /sbin/chkconfig --del systemtap
- fi
- exit 0
- %postun initscript
- # Check whether this is an upgrade of the package.
- # If so, restart the service if it's running
- if [ "$1" -ge "1" ] ; then
- /sbin/service systemtap condrestart >/dev/null 2>&1 || :
- fi
- exit 0
- %post
- # Remove any previously-built uprobes.ko materials
- (make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
- (/sbin/rmmod uprobes) >/dev/null 2>&1 || true
- %preun
- # Ditto
- (make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
- (/sbin/rmmod uprobes) >/dev/null 2>&1 || true
- # ------------------------------------------------------------------------
- %files -f %{name}.lang
- # The master "systemtap" rpm doesn't include any files.
- %files server -f %{name}.lang
- %defattr(-,root,root)
- %{_bindir}/stap-server
- %dir %{_libexecdir}/%{name}
- %{_libexecdir}/%{name}/stap-serverd
- %{_libexecdir}/%{name}/stap-start-server
- %{_libexecdir}/%{name}/stap-stop-server
- %{_libexecdir}/%{name}/stap-gen-cert
- %{_libexecdir}/%{name}/stap-sign-module
- %{_mandir}/man7/stappaths.7*
- %{_mandir}/man8/stap-server.8*
- %{_sysconfdir}/rc.d/init.d/stap-server
- %config(noreplace) %{_sysconfdir}/logrotate.d/stap-server
- %dir %{_sysconfdir}/stap-server
- %dir %{_sysconfdir}/stap-server/conf.d
- %config(noreplace) %{_sysconfdir}/sysconfig/stap-server
- %dir %attr(0755,stap-server,stap-server) %{_localstatedir}/log/stap-server
- %ghost %config(noreplace) %attr(0644,stap-server,stap-server) %{_localstatedir}/log/stap-server/log
- %ghost %attr(0755,stap-server,stap-server) %{_localstatedir}/run/stap-server
- %doc initscript/README.stap-server
- %doc README README.unprivileged AUTHORS NEWS COPYING
- %files devel -f %{name}.lang
- %{_bindir}/stap
- %{_bindir}/stap-prep
- %{_bindir}/stap-report
- %dir %{_datadir}/%{name}/runtime
- %{_datadir}/%{name}/runtime
- %dir %{_datadir}/%{name}/tapset
- %{_datadir}/%{name}/tapset
- %{_mandir}/man1/stap.1*
- %{_mandir}/man7/stappaths.7*
- %doc README README.unprivileged AUTHORS NEWS COPYING
- %if %{with_bundled_elfutils}
- %dir %{_libdir}/%{name}
- %{_libdir}/%{name}/lib*.so*
- %endif
- %files runtime -f %{name}.lang
- %defattr(-,root,root)
- %attr(4110,root,stapusr) %{_bindir}/staprun
- %{_bindir}/stapsh
- %{_bindir}/stap-merge
- %{_bindir}/stap-report
- %dir %{_libexecdir}/%{name}
- %{_libexecdir}/%{name}/stapio
- %{_libexecdir}/%{name}/stap-env
- %{_libexecdir}/%{name}/stap-authorize-cert
- %if %{with_crash}
- %dir %{_libdir}/%{name}
- %{_libdir}/%{name}/staplog.so*
- %endif
- %{_mandir}/man7/stappaths.7*
- %{_mandir}/man8/staprun.8*
- %doc README README.security AUTHORS NEWS COPYING
- %files client -f %{name}.lang
- %defattr(-,root,root)
- %doc README README.unprivileged AUTHORS NEWS COPYING examples
- %if %{with_docs}
- %doc docs.installed/*.pdf
- %doc docs.installed/tapsets/*.html
- %if %{with_publican}
- %doc docs.installed/SystemTap_Beginners_Guide
- %endif
- %endif
- %{_bindir}/stap
- %{_bindir}/stap-prep
- %{_bindir}/stap-report
- %{_mandir}/man1/stap.1*
- %{_mandir}/man1/stap-merge.1*
- %{_mandir}/man3/*
- %{_mandir}/man7/stappaths.7*
- %dir %{_datadir}/%{name}
- %{_datadir}/%{name}/tapset
- %files initscript
- %defattr(-,root,root)
- %{_sysconfdir}/rc.d/init.d/systemtap
- %dir %{_sysconfdir}/systemtap
- %dir %{_sysconfdir}/systemtap/conf.d
- %dir %{_sysconfdir}/systemtap/script.d
- %config(noreplace) %{_sysconfdir}/systemtap/config
- %dir %{_localstatedir}/cache/systemtap
- %ghost %{_localstatedir}/run/systemtap
- %doc initscript/README.systemtap
- %files sdt-devel -f %{name}.lang
- %defattr(-,root,root)
- %{_bindir}/dtrace
- %{_includedir}/sys/sdt.h
- %{_includedir}/sys/sdt-config.h
- %{_mandir}/man1/dtrace.1*
- %doc README AUTHORS NEWS COPYING
- %files testsuite
- %defattr(-,root,root)
- %dir %{_datadir}/%{name}
- %{_datadir}/%{name}/testsuite
- # ------------------------------------------------------------------------
- %changelog
- * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0-1
- - initial build for Vine Linux
- * Wed Jul 18 2012 Josh Stone <jistone@redhat.com> - 1.8-5
- - bz840902 ppc build fix (related to bz837641)
- * Fri Jul 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.8-4
- - Fix ifarch statement
- - use file based requires for glibc-devel on x86_64 so that we work in koji
- * Wed Jul 11 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-3
- - PR14348 task_work_add race condition fix
- * Mon Jul 09 2012 Josh Stone <jistone@redhat.com>
- - bz837641 build fix
- * Sun Jun 17 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-1
- - Upstream release.
- * Mon Apr 30 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.7-7
- - Enable crash support on ARM, cleanup spec
- * Thu Apr 19 2012 Karsten Hopp <karsten@redhat.com> - 1.7-6.1
- - rebuild on PPC(64) without crash, publican
- * Thu Mar 29 2012 Richard W.M. Jones <rjones@redhat.com> - 1.7-6
- - Rebuild for rpm soname bump.
- * Fri Mar 16 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-5
- - dbhole advises ARM publican/fop/java is a go for launch.
- * Thu Mar 01 2012 Mark Wielaard <mjw@redhat.com> - 1.7-4
- - ARM currently doesn't have publican/fop/java and no prelink.
- * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-3
- - Rebuilt for c++ ABI breakage
- * Wed Feb 22 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-2
- - CVE-2012-0875 (kernel panic when processing malformed DWARF unwind data)
- * Wed Feb 01 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-1
- - Upstream release.
- * Fri Jan 13 2012 David Smith <dsmith@redhat.com> - 1.6-2
- - Fixed /bin/mktemp require.
- * Mon Jul 25 2011 Stan Cox <scox@redhat.com> - 1.6-1
- - Upstream release.
- * Tue May 23 2011 Stan Cox <scox@redhat.com> - 1.5-1
- - Upstream release.
- * Mon Jan 17 2011 Frank Ch. Eigler <fche@redhat.com> - 1.4-1
- - Upstream release.
- * Wed Jul 21 2010 Josh Stone <jistone@redhat.com> - 1.3-1
- - Upstream release.
- * Mon Mar 22 2010 Frank Ch. Eigler <fche@redhat.com> - 1.2-1
- - Upstream release.
- * Mon Dec 21 2009 David Smith <dsmith@redhat.com> - 1.1-1
- - Upstream release.
- * Tue Sep 22 2009 Josh Stone <jistone@redhat.com> - 1.0-1
- - Upstream release.
- * Tue Aug 4 2009 Josh Stone <jistone@redhat.com> - 0.9.9-1
- - Upstream release.
- * Thu Jun 11 2009 Josh Stone <jistone@redhat.com> - 0.9.8-1
- - Upstream release.
- * Thu Apr 23 2009 Josh Stone <jistone@redhat.com> - 0.9.7-1
- - Upstream release.
- * Fri Mar 27 2009 Josh Stone <jistone@redhat.com> - 0.9.5-1
- - Upstream release.
- * Wed Mar 18 2009 Will Cohen <wcohen@redhat.com> - 0.9-2
- - Add location of man pages.
- * Tue Feb 17 2009 Frank Ch. Eigler <fche@redhat.com> - 0.9-1
- - Upstream release.
- * Thu Nov 13 2008 Frank Ch. Eigler <fche@redhat.com> - 0.8-1
- - Upstream release.
- * Tue Jul 15 2008 Frank Ch. Eigler <fche@redhat.com> - 0.7-1
- - Upstream release.
- * Fri Feb 1 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-3
- - Add zlib-devel to buildreq; missing from crash-devel
- - Process testsuite .stp files for #!stap->#!/usr/bin/stap
- * Fri Jan 18 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-1
- - Add crash-devel buildreq to build staplog.so crash(8) module.
- - Many robustness & functionality improvements:
- * Wed Dec 5 2007 Will Cohen <wcohen@redhat.com> - 0.6-2
- - Correct Source to point to location contain code.
- * Thu Aug 9 2007 David Smith <dsmith@redhat.com> - 0.6-1
- - Bumped version, added libcap-devel BuildRequires.
- * Wed Jul 11 2007 Will Cohen <wcohen@redhat.com> - 0.5.14-2
- - Fix Requires and BuildRequires for sqlite.
- * Tue Jul 2 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.14-1
- - Many robustness improvements: 1117, 1134, 1305, 1307, 1570, 1806,
- 2033, 2116, 2224, 2339, 2341, 2406, 2426, 2438, 2583, 3037,
- 3261, 3282, 3331, 3428 3519, 3545, 3625, 3648, 3880, 3888, 3911,
- 3952, 3965, 4066, 4071, 4075, 4078, 4081, 4096, 4119, 4122, 4127,
- 4146, 4171, 4179, 4183, 4221, 4224, 4254, 4281, 4319, 4323, 4326,
- 4329, 4332, 4337, 4415, 4432, 4444, 4445, 4458, 4467, 4470, 4471,
- 4518, 4567, 4570, 4579, 4589, 4609, 4664
- * Mon Mar 26 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.13-1
- - An emergency / preliminary refresh, mainly for compatibility
- with 2.6.21-pre kernels.
- * Mon Jan 1 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.12-1
- - Many changes, see NEWS file.
- * Tue Sep 26 2006 David Smith <dsmith@redhat.com> - 0.5.10-1
- - Added 'systemtap-runtime' subpackage.
- * Wed Jul 19 2006 Roland McGrath <roland@redhat.com> - 0.5.9-1
- - PRs 2669, 2913
- * Fri Jun 16 2006 Roland McGrath <roland@redhat.com> - 0.5.8-1
- - PRs 2627, 2520, 2228, 2645
- * Fri May 5 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.7-1
- - PRs 2511 2453 2307 1813 1944 2497 2538 2476 2568 1341 2058 2220 2437
- 1326 2014 2599 2427 2438 2465 1930 2149 2610 2293 2634 2506 2433
- * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.5.5-1
- - Many changes, affected PRs include: 2068, 2293, 1989, 2334,
- 1304, 2390, 2425, 953.
- * Wed Feb 1 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.4-1
- - PRs 1916, 2205, 2142, 2060, 1379
- * Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 0.5.3-1
- - Many changes, affected PRs include: 2056, 1144, 1379, 2057,
- 2060, 1972, 2140, 2148
- * Mon Dec 19 2005 Roland McGrath <roland@redhat.com> - 0.5.2-1
- - Fixed build with gcc 4.1, various tapset changes.
- * Wed Dec 7 2005 Roland McGrath <roland@redhat.com> - 0.5.1-1
- - elfutils update, build changes
- * Fri Dec 02 2005 Frank Ch. Eigler <fche@redhat.com> - 0.5-1
- - Many fixes and improvements: 1425, 1536, 1505, 1380, 1329, 1828, 1271,
- 1339, 1340, 1345, 1837, 1917, 1903, 1336, 1868, 1594, 1564, 1276, 1295
- * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.4.2-1
- - Many fixes and improvements: PRs 1344, 1260, 1330, 1295, 1311, 1368,
- 1182, 1131, 1332, 1366, 1456, 1271, 1338, 1482, 1477, 1194.
- * Wed Sep 14 2005 Roland McGrath <roland@redhat.com> - 0.4.1-1
- - Many fixes and improvements since 0.2.2; relevant PRs include:
- 1122, 1134, 1155, 1172, 1174, 1175, 1180, 1186, 1187, 1191, 1193, 1195,
- 1197, 1205, 1206, 1209, 1213, 1244, 1257, 1258, 1260, 1265, 1268, 1270,
- 1289, 1292, 1306, 1335, 1257
- * Wed Sep 7 2005 Frank Ch. Eigler <fche@redhat.com>
- - Bump version.
- * Wed Aug 16 2005 Frank Ch. Eigler <fche@redhat.com>
- - Bump version.
- * Wed Aug 3 2005 Martin Hunt <hunt@redhat.com> - 0.2.2-1
- - Add directory /var/cache/systemtap
- - Add stp_check to /usr/libexec/systemtap
- * Wed Aug 3 2005 Roland McGrath <roland@redhat.com> - 0.2.1-1
- - New version 0.2.1, various fixes.
- * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.2-1
- - New version 0.2, requires elfutils 0.111
- * Mon Jul 25 2005 Roland McGrath <roland@redhat.com>
- - Clean up spec file, build bundled elfutils.
- * Thu Jul 21 2005 Martin Hunt <hunt@redhat.com>
- - Set Version to use version from autoconf.
- - Fix up some of the path names.
- - Add Requires and BuildRequires.
- * Wed Jul 19 2005 Will Cohen <wcohen@redhat.com>
- - Initial creation of RPM.
|