123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184 |
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- Name: libtevent
- Summary: The tevent library
- Summary(ja): Tevent ライブラリ
- Version: 0.9.28
- Release: 1%{?_dist_release}
- Group: System Environment/Libraries
- License: LGPLv3+
- URL: http://tevent.samba.org/
- Source: http://samba.org/ftp/tevent/tevent-%{version}.tar.gz
- BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
- Patch1: tevent-098-add_abi_scripts_and_fix_exports.patch
- BuildRequires: libtalloc-devel >= 2.0.0
- BuildRequires: python-devel
- BuildRequires: pytalloc-devel
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: tomop
- %description
- Tevent is an event system based on the talloc memory management library.
- Tevent has support for many event types, including timers, signals, and
- the classic file descriptor events.
- Tevent also provide helpers to deal with asynchronous code providing the
- tevent_req (Tevent Request) functions.
- %package devel
- Summary: Developer tools for the Tevent library
- Summary(ja): Tevent ライブラリの開発用ファイル
- Group: Development/Libraries
- Requires: libtevent = %{version}-%{release}
- Requires: libtalloc-devel >= 2.0.0
- Requires: pkgconfig
- %description devel
- Header files needed to develop programs that link against the Tevent library.
- %package -n python-tevent
- Summary: Python bindings for the Tevent library
- Summary(ja): Tevent ライブラリの python バインディング
- Group: System Environment/Libraries
- Requires: libtevent = %{version}-%{release}
- Requires: pytalloc >= 2.0.0
- Requires: pkgconfig
- %description -n python-tevent
- Python bindings for libtevent
- %if %build_compat32
- %package -n compat32-%{name}
- Summary: The tevent library
- Summary(ja): Tevent ライブラリ
- Group: System Environment/Libraries
- %description -n compat32-%{name}
- Tevent is an event system based on the talloc memory management library.
- Tevent has support for many event types, including timers, signals, and
- the classic file descriptor events.
- Tevent also provide helpers to deal with asynchronous code providing the
- tevent_req (Tevent Request) functions.
- %endif
- %prep
- %setup -q -n tevent-%{version}
- %patch1 -p1 -b .abi_checks
- %build
- %configure
- make %{?_smp_mflags}
- %check
- make %{?_smp_mflags} check
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- #ln -s libtevent.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libtevent.so.0
- #ln -s libtevent.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libtevent.so
- rm -f $RPM_BUILD_ROOT%{_libdir}/libtevent.a
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root,-)
- %{_libdir}/libtevent.so.*
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/tevent.h
- %{_libdir}/libtevent.so
- %{_libdir}/pkgconfig/tevent.pc
- %files -n python-tevent
- %{python_sitearch}/_tevent.so
- %{python_sitearch}/tevent.py
- %if %build_compat32
- %files -n compat32-%{name}
- %defattr(-,root,root,-)
- %{_libdir}/libtevent.so.*
- %endif
- %post
- /sbin/ldconfig
- %postun
- /sbin/ldconfig
- %if %build_compat32
- %post -n compat32-%{name}
- /sbin/ldconfig
- %postun -n compat32-%{name}
- /sbin/ldconfig
- %endif
- %changelog
- * Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.28-1
- - new upstream release.
- * Wed Dec 2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.26-1
- - new upstream release.
- * Sat Jun 13 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.25-1
- - new upstream release.
- * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.24-2
- - added compat32 package.
- * Fri Mar 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.24-1
- - new upstream release.
- * Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.22-1
- - new upstream release.
- * Mon Oct 6 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.9.21-2
- - moved libtevent to System Environment/Libraries Group
- * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.21-1
- - new upstream release.
- * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.20-1
- - new upstream release.
- * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.19-1
- - new upstream release.
- * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.9.17-1
- - new upstream release.
- - initial build for Vine Linux.
- * Fri May 21 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-8
- - Run make check during RPM build
- - Fix abi_check patch to guarantee script executability
- * Wed Feb 24 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-7.1
- - Remove all references to ABI compatibility patch
- * Wed Feb 24 2010 Stephen Gallagher <sgallagh@redhat.com> - 0.9.8-7
- - Drop ABI compatibility patch (no longer needed)
- * Wed Sep 23 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-5
- - Add patch to fix a segfault case
- * Wed Sep 16 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-2
- - Fix abi compatibility with 0.9.3
- * Tue Sep 8 2009 Simo Sorce <ssorce@redhat.com> - 0.9.8-1
- - First independent release for tevent 0.9.8
|