123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154 |
- %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
- Name: libbsd
- Version: 0.7.0
- Release: 1%{?_dist_release}
- Summary: Library providing BSD-compatible functions for portability
- License: BSD and ISC and Copyright only and Public Domain
- Group: System Environment/Libraries
- URL: http://libbsd.freedesktop.org/
- Source0: http://libbsd.freedesktop.org/releases/libbsd-%{version}.tar.xz
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: tomop
- %description
- libbsd provides useful functions commonly found on BSD systems, and
- lacking on others like GNU systems, thus making it easier to port
- projects with strong BSD origins, without needing to embed the same
- code over and over again on each project.
- %package devel
- Summary: Development files for libbsd
- Group: Development/Libraries
- Requires: libbsd = %{version}-%{release}
- Requires: pkgconfig
- %description devel
- Development files for the libbsd library.
- # compat32
- %package -n compat32-%{name}
- Summary: Library providing BSD-compatible functions for portability
- Group: System Environment/Libraries
- Requires: libbsd = %{version}-%{release}
- %description -n compat32-%{name}
- libbsd provides useful functions commonly found on BSD systems, and
- lacking on others like GNU systems, thus making it easier to port
- projects with strong BSD origins, without needing to embed the same
- code over and over again on each project.
- %package -n compat32-%{name}-devel
- Summary: Development files for libbsd
- Group: Development/Libraries
- Requires: compat32-%{name} = %{version}-%{release}
- Requires: compat32-pkgconfig
- Requires: %{name}-devel = %{version}-%{release}
- %description -n compat32-%{name}-devel
- Development files for the libbsd library.
- %prep
- %setup -q
- # fix encoding of flopen.3 man page
- for f in man/flopen.3; do
- iconv -f iso8859-1 -t utf-8 $f >$f.conv
- touch -r $f $f.conv
- mv $f.conv $f
- done
- %build
- %configure
- make CFLAGS="%{optflags}" %{?_smp_mflags} \
- libdir=%{_libdir} \
- usrlibdir=%{_libdir} \
- exec_prefix=%{_prefix}
- %install
- rm -rf %{buildroot}
- make libdir=%{_libdir} \
- usrlibdir=%{_libdir} \
- exec_prefix=%{_prefix} \
- DESTDIR=%{buildroot} \
- install
- # don't want static library
- rm -f %{buildroot}%{_libdir}/lib*.a
- rm -f %{buildroot}%{_libdir}/lib*.la
- %clean
- rm -rf %{buildroot}
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %if %{build_compat32}
- %post -n compat32-%{name} -p /sbin/ldconfig
- %postun -n compat32-%{name} -p /sbin/ldconfig
- %endif
- %files
- %doc COPYING README TODO ChangeLog
- %{_libdir}/%{name}.so.*
- %files devel
- %{_mandir}/man3/*.3.gz
- %{_mandir}/man3/*.3bsd.gz
- %{_includedir}/bsd
- %{_libdir}/%{name}.so
- %{_libdir}/pkgconfig/%{name}.pc
- %{_libdir}/pkgconfig/%{name}-ctor.pc
- %{_libdir}/pkgconfig/%{name}-overlay.pc
- # compat32
- %if %{build_compat32}
- %files -n compat32-%{name}
- %defattr(-,root,root)
- %{_libdir}/%{name}.so.*
- %files -n compat32-%{name}-devel
- %defattr(-,root,root)
- %{_libdir}/%{name}.so
- %{_libdir}/pkgconfig/%{name}.pc
- %{_libdir}/pkgconfig/%{name}-ctor.pc
- %{_libdir}/pkgconfig/%{name}-overlay.pc
- %endif
- %changelog
- * Sun Feb 1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.7.0-1
- - new upstream release.
- - added compat32 subpackages
- * Sun Jan 12 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.6.0-1
- - new upstream release.
- * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.2-1
- - new upstream release.
- - initial build for Vine Linux.
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Sat Oct 08 2011 Eric Smith <eric@brouhaha.com> - 0.3.0-1
- - Update to latest upstream release.
- - Removed Patch0, fixed upstream.
- - Removed BuildRoot, clean, defattr.
- * Fri Jan 29 2010 Eric Smith <eric@brouhaha.com> - 0.2.0-3
- - changes based on review by Sebastian Dziallas
- * Fri Jan 29 2010 Eric Smith <eric@brouhaha.com> - 0.2.0-2
- - changes based on review comments by Jussi Lehtola and Ralf Corsepious
- * Thu Jan 28 2010 Eric Smith <eric@brouhaha.com> - 0.2.0-1
- - initial version
|