python-pillow-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605
  1. %global with_python3 1
  2. %global py3_incdir %(python3 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
  3. %global py3_libbuilddir %(python3 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
  4. %global srcname pillow
  5. # bootstrap building docs (pillow is required by docutils, docutils are
  6. # required by sphinx; pillow build-requires sphinx)
  7. %global with_docs 0
  8. Name: python-%{srcname}
  9. Version: 9.0.0
  10. Release: 1%{?_dist_release}
  11. Summary: Python image processing library
  12. Group: programming
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. # License: see http://www.pythonware.com/products/pil/license.htm
  16. License: MIT
  17. URL: http://python-pillow.github.io/
  18. Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
  19. BuildRequires: freetype2-devel
  20. BuildRequires: gcc
  21. BuildRequires: ghostscript
  22. BuildRequires: lcms2-devel
  23. #BuildRequires: libimagequant-devel
  24. BuildRequires: libjpeg-devel
  25. #BuildRequires: libraqm-devel
  26. BuildRequires: libtiff-devel
  27. BuildRequires: libwebp-devel
  28. BuildRequires: openjpeg2-devel
  29. BuildRequires: tk-devel
  30. BuildRequires: zlib-devel
  31. %if 0%{?with_python3}
  32. BuildRequires: python3-rpm-macros
  33. BuildRequires: python3-cffi
  34. BuildRequires: python3-devel
  35. BuildRequires: python3-numpy
  36. #BuildRequires: python3-olefile
  37. BuildRequires: python3-qt5
  38. BuildRequires: python3-setuptools
  39. %if 0%{?with_docs}
  40. BuildRequires: python3-sphinx
  41. BuildRequires: python3-sphinx_rtd_theme
  42. %endif
  43. BuildRequires: python3-tkinter
  44. %endif
  45. %global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
  46. %description
  47. Python image processing library, fork of the Python Imaging Library (PIL)
  48. This library provides extensive file format support, an efficient
  49. internal representation, and powerful image processing capabilities.
  50. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  51. devel (development) and doc (documentation).
  52. %if 0%{?with_python3}
  53. %package -n python3-%{srcname}
  54. Summary: Python 3 image processing library
  55. Group: programming
  56. Requires: ghostscript
  57. %{?python_provide:%python_provide python3-%{srcname}}
  58. Provides: python3-imaging = %{version}-%{release}
  59. %description -n python3-%{srcname}
  60. Python image processing library, fork of the Python Imaging Library (PIL)
  61. This library provides extensive file format support, an efficient
  62. internal representation, and powerful image processing capabilities.
  63. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  64. devel (development) and doc (documentation).
  65. %package -n python3-%{srcname}-devel
  66. Summary: Development files for %{srcname}
  67. Group: programming
  68. Requires: python3-devel, libjpeg-devel, zlib-devel
  69. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  70. %{?python_provide:%python_provide python3-%{srcname}-devel}
  71. Provides: python3-imaging-devel = %{version}-%{release}
  72. %description -n python3-%{srcname}-devel
  73. Development files for %{srcname}.
  74. %package -n python3-%{srcname}-doc
  75. Summary: Documentation for %{srcname}
  76. Group: documentation
  77. BuildArch: noarch
  78. Requires: python3-%{srcname} = %{version}-%{release}
  79. %{?python_provide:%python_provide python3-%{srcname}-doc}
  80. Provides: python3-imaging-doc = %{version}-%{release}
  81. Obsoletes: python-%{srcname}-doc < 5.4.1-4
  82. %description -n python3-%{srcname}-doc
  83. Documentation for %{srcname}.
  84. %package -n python3-%{srcname}-tk
  85. Summary: Tk interface for %{srcname}
  86. Group: programming
  87. Requires: python3-tkinter
  88. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  89. %{?python_provide:%python_provide python3-%{srcname}-tk}
  90. Provides: python3-imaging-tk = %{version}-%{release}
  91. %description -n python3-%{srcname}-tk
  92. Tk interface for %{name}.
  93. %package -n python3-%{srcname}-qt
  94. Summary: Qt %{srcname} image wrapper
  95. Group: programming
  96. Requires: python3-qt5
  97. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  98. %{?python_provide:%python_provide python3-%{srcname}-qt}
  99. Provides: python3-imaging-qt = %{version}-%{release}
  100. %description -n python3-%{srcname}-qt
  101. Qt %{srcname} image wrapper.
  102. %endif
  103. %debug_package
  104. %prep
  105. %autosetup -p1 -n Pillow-%{version}
  106. %build
  107. %if 0%{?with_python3}
  108. # Build Python 3 modules
  109. %py3_build
  110. %ifarch x86_64
  111. %if 0%{?with_docs}
  112. PYTHONPATH=$PWD/build/%py3_libbuilddir make -C docs html BUILDDIR=_build_py3 SPHINXBUILD=sphinx-build-%python3_version
  113. rm -f docs/_build_py3/html/.buildinfo
  114. %endif
  115. %endif
  116. %endif
  117. %install
  118. %if 0%{?with_python3}
  119. # Install Python 3 modules
  120. install -d %{buildroot}/%{py3_incdir}/Imaging
  121. install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
  122. %py3_install
  123. %endif
  124. %check
  125. %if 0%{?with_python3}
  126. # Check Python 3 modules
  127. ln -s $PWD/Images $PWD/build/%py3_libbuilddir/Images
  128. cp -R $PWD/Tests $PWD/build/%py3_libbuilddir/Tests
  129. cp -R $PWD/selftest.py $PWD/build/%py3_libbuilddir/selftest.py
  130. pushd build/%py3_libbuilddir
  131. PYTHONPATH=$PWD %{__python3} selftest.py
  132. popd
  133. %endif
  134. %if 0%{?with_python3}
  135. %files -n python3-%{srcname}
  136. %doc README.rst CHANGES.rst
  137. %license docs/COPYING
  138. %{python3_sitearch}/*
  139. # These are in subpackages
  140. %exclude %{python3_sitearch}/PIL/_imagingtk*
  141. %exclude %{python3_sitearch}/PIL/ImageTk*
  142. %exclude %{python3_sitearch}/PIL/SpiderImagePlugin*
  143. %exclude %{python3_sitearch}/PIL/ImageQt*
  144. %exclude %{python3_sitearch}/PIL/__pycache__/ImageTk*
  145. %exclude %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  146. %exclude %{python3_sitearch}/PIL/__pycache__/ImageQt*
  147. %files -n python3-%{srcname}-devel
  148. %{py3_incdir}/Imaging/
  149. %ifarch x86_64
  150. %files -n python3-%{srcname}-doc
  151. %if 0%{?with_docs}
  152. %doc docs/_build_py3/html
  153. %endif
  154. %endif
  155. %files -n python3-%{srcname}-tk
  156. %{python3_sitearch}/PIL/_imagingtk*
  157. %{python3_sitearch}/PIL/ImageTk*
  158. %{python3_sitearch}/PIL/SpiderImagePlugin*
  159. %{python3_sitearch}/PIL/__pycache__/ImageTk*
  160. %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  161. %files -n python3-%{srcname}-qt
  162. %{python3_sitearch}/PIL/ImageQt*
  163. %{python3_sitearch}/PIL/__pycache__/ImageQt*
  164. %endif
  165. %changelog
  166. * Tue Jan 25 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 9.0.0-1
  167. - new upstream release.
  168. * Sat Sep 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.3.2-1
  169. - new upstream release.
  170. * Sat Jul 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.3.1-1
  171. - new upstream release.
  172. * Wed Jun 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.2.0-1
  173. - new upstream release.
  174. * Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.1.2-1
  175. - new upstream release.
  176. * Tue Jan 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.1.0-1
  177. - new upstream release.
  178. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-2
  179. - built with python-3.8.
  180. * Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-1
  181. - new upstream release.
  182. - dropped python2 support.
  183. * Wed Jan 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.2-1
  184. - new upstream release.
  185. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
  186. - initial build for Vine Linux.
  187. * Mon Oct 07 2019 Petr Viktorin <pviktori@redhat.com> - 6.2.0-2
  188. - Remove optional build dependency on python2-cffi
  189. * Tue Oct 01 2019 Sandro Mani <manisandro@gmail.com> - 6.2.0-1
  190. - Update to 6.2.0
  191. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 6.1.0-4
  192. - Rebuilt for Python 3.8
  193. * Mon Aug 12 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-3
  194. - Drop python2-pillow-qt, python2-pillow-tk
  195. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
  196. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  197. * Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-1
  198. - Update to 6.1.0
  199. * Fri May 31 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 6.0.0-2
  200. - Fix broken Python/C interop on s390x
  201. * Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
  202. - Update to 6.0.0
  203. * Sun Mar 10 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
  204. - Drop python2-pillow-doc
  205. * Mon Mar 04 2019 Yatin Karel <ykarel@redhat.com> - 5.4.1-3
  206. - Fix python3 conditional
  207. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.1-2
  208. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  209. * Mon Jan 07 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-1
  210. - Update to 5.4.1
  211. * Mon Oct 01 2018 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
  212. - Update to 5.3.0
  213. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
  214. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  215. * Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 5.2.0-2
  216. - Rebuilt for Python 3.7
  217. * Mon Jul 02 2018 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
  218. - Update to 5.2.0
  219. * Wed Jun 27 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-3
  220. - Fix the tkinter dependency
  221. * Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-2
  222. - Rebuilt for Python 3.7
  223. * Wed Apr 25 2018 Sandro Mani <manisandro@gmail.com> - 5.1.1-1
  224. - Update to 5.1.1
  225. * Thu Apr 05 2018 Sandro Mani <manisandro@gmail.com> - 5.1.0-1
  226. - Update to 5.1.0
  227. * Wed Mar 07 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-3
  228. - Add missing BR: gcc
  229. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
  230. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  231. * Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
  232. - Update to 5.0.0
  233. * Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
  234. - Update to 4.3.0
  235. * Tue Sep 05 2017 Troy Dawson <tdawson@redhat.com> - 4.2.1-5
  236. - Cleanup spec file conditionals
  237. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
  238. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  239. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-3
  240. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  241. * Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.2.1-2
  242. - Rebuild due to bug in RPM (RHBZ #1468476)
  243. * Thu Jul 06 2017 Sandro Mani <manisandro@gmail.com> - 4.2.1-1
  244. - Update to 4.2.1
  245. * Sat Jul 01 2017 Sandro Mani <manisandro@gmail.com> - 4.2.0-1
  246. - Update to 4.2.0
  247. * Fri Apr 28 2017 Sandro Mani <manisandro@gmail.com> - 4.1.1-1
  248. - Update to 4.1.1
  249. * Wed Apr 05 2017 Sandro Mani <manisandro@gmail.com> - 4.1.0-1
  250. - Update to 4.1.0
  251. * Wed Feb 15 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-3
  252. - Fix some __pycache__ files in wrong subpackage (#1422606)
  253. * Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-2
  254. - Rebuild (libwebp)
  255. * Tue Jan 03 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-1
  256. - Update to 4.0.0
  257. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-3
  258. - Enable docs build
  259. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-2
  260. - Rebuild for Python 3.6
  261. * Wed Oct 19 2016 Sandro Mani <manisandro@gmail.com> - 3.4.2-1
  262. - Update to 3.4.2
  263. * Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.4.1-1
  264. - Update to 3.4.1
  265. * Mon Oct 03 2016 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
  266. - Update to 3.4.0
  267. * Thu Aug 18 2016 Sandro Mani <manisandro@gmail.com> - 3.3.1-1
  268. - Update to 3.3.1
  269. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-2
  270. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  271. * Sat Jul 02 2016 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
  272. - Update to 3.3.0
  273. - Modernize spec
  274. * Fri Apr 01 2016 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
  275. - Update to 3.2.0
  276. * Wed Feb 10 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-3
  277. - Fix broken python3-pillow package description
  278. * Sun Feb 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.1.1-2
  279. - Fix provides
  280. * Thu Feb 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-1
  281. - Update to 3.1.1
  282. - Fixes CVE-2016-0740, CVE-2016-0775
  283. * Mon Jan 11 2016 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.0-2
  284. - Fix executable files in doc package bringing in python 2 for the python3 doc
  285. packages
  286. * Mon Jan 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
  287. - Update to 3.1.0
  288. * Tue Dec 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-5
  289. - Build with docs
  290. * Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-4
  291. - Rebuilt for libwebp soname bump
  292. * Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-3
  293. - Rebuilt for Python3.5 rebuild with docs
  294. * Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-2
  295. - Rebuilt for Python3.5 rebuild without docs
  296. * Fri Oct 02 2015 Sandro Mani <manisandro@gmail.com> - 3.0.0-1
  297. - Update to 3.0.0
  298. * Wed Jul 29 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-2
  299. - Fix python3-pillow-tk Requires: tkinter -> python3-tkinter (#1248085)
  300. * Thu Jul 02 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-1
  301. - Update to 2.9.0
  302. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
  303. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  304. * Mon Jun 08 2015 Sandro Mani <manisandro@gmail.com> - 2.8.2-1
  305. - Update to 2.8.2
  306. * Thu Apr 02 2015 Sandro Mani <manisandro@gmail.com> - 2.8.1-1
  307. - Update to 2.8.1
  308. * Wed Apr 01 2015 Sandro Mani <manisandro@gmail.com> - 2.8.0-1
  309. - Update to 2.8.0
  310. * Mon Jan 12 2015 Sandro Mani <manisandro@gmail.com> - 2.7.0-1
  311. - Update to 2.7.0
  312. - Drop sane subpackage, is in python-sane now
  313. - Fix python3 headers directory
  314. - Drop Obsoletes: python3-pillow on python3-pillow-qt
  315. * Mon Oct 13 2014 Sandro Mani <manisandro@gmail.com> - 2.6.1-1
  316. - Update to 2.6.1
  317. * Thu Oct 02 2014 Sandro Mani <manisandro@gmail.com> - 2.6.0-1
  318. - Update to 2.6.0
  319. * Wed Aug 20 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-3
  320. - Rebuilding again to resolve transient build error that caused BZ#1131723
  321. * Tue Aug 19 2014 Stephen Gallagher <sgallagh@redhat.com> - 2.5.3-2
  322. - Rebuilding to resolve transient build error that caused BZ#1131723
  323. * Tue Aug 19 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
  324. - Update to 2.5.3 (Fix CVE-2014-3598, a DOS in the Jpeg2KImagePlugin)
  325. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
  326. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  327. * Wed Aug 13 2014 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
  328. - Update to 2.5.2 (Fix CVE-2014-3589, a DOS in the IcnsImagePlugin)
  329. * Sat Jul 26 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-2
  330. - Reenable jpeg2k tests on big endian arches
  331. * Tue Jul 15 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-1
  332. - Update to 2.5.1
  333. * Wed Jul 02 2014 Sandro Mani <manisandro@gmail.com> - 2.5.0-1
  334. - Update to 2.5.0
  335. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-11
  336. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  337. * Wed May 28 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-10
  338. - Rebuild with docs enabled
  339. - Update python-pillow_openjpeg-2.1.0.patch
  340. * Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-9
  341. - Rebuild against openjpeg-2.1.0
  342. * Fri May 23 2014 Dan Horák <dan[at]danny.cz> - 2.4.0-8
  343. - skip jpeg2k tests on big endian arches (#1100762)
  344. * Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.0-7
  345. - Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
  346. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-6
  347. - Set with_docs to 1 to build docs.
  348. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-5
  349. - Bootstrap building sphinx docs because of circular dependency with sphinx.
  350. * Fri May 9 2014 Orion Poplawski <orion@cora.nwra.com> - 2.4.0-4
  351. - Rebuild for Python 3.4
  352. * Tue Apr 22 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-3
  353. - Add patch: Have the tempfile use a suffix with a dot
  354. * Thu Apr 17 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-2
  355. - Enable Jpeg2000 support
  356. - Enable webp support also on s390* archs, bug #962091 is now fixed
  357. - Add upstream patch for ghostscript detection
  358. * Wed Apr 02 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-1
  359. - Update to 2.4.0
  360. * Wed Mar 19 2014 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
  361. - Update to 2.3.1 (Fix insecure use of tempfile.mktemp (CVE-2014-1932 CVE-2014-1933))
  362. * Thu Mar 13 2014 Jakub Dorňák <jdornak@redhat.com> - 2.3.0-5
  363. - python-pillow does not provide python3-imaging
  364. (python3-pillow does)
  365. * Tue Jan 07 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-4
  366. - Add missing ghostscript Requires and BuildRequires
  367. * Mon Jan 06 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
  368. - Remove python-pillow_help-theme.patch, add python-sphinx-theme-better BR
  369. * Sun Jan 05 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
  370. - Rebuild with docs enabled
  371. - Change lcms BR to lcms2
  372. * Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
  373. - Update to 2.3.0
  374. - Build with doc disabled to break circular python-pillow -> python-sphinx -> python pillow dependency
  375. * Wed Oct 23 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-2
  376. - Backport fix for decoding tiffs with correct byteorder, fixes rhbz#1019656
  377. * Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
  378. - Update to 2.2.1
  379. - Really enable webp on ppc, but leave disabled on s390
  380. * Thu Aug 29 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-4
  381. - Add patch to fix incorrect PyArg_ParseTuple tuple signature, fixes rhbz#962091 and rhbz#988767.
  382. - Renable webp support on bigendian arches
  383. * Wed Aug 28 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-3
  384. - Add patch to fix memory corruption caused by invalid palette size, see rhbz#1001122
  385. * Tue Jul 30 2013 Karsten Hopp <karsten@redhat.com> 2.1.0-2
  386. - Build without webp support on ppc* archs (#988767)
  387. * Wed Jul 03 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
  388. - Update to 2.1.0
  389. - Run tests in builddir, not installroot
  390. - Build python3-pillow docs with python3
  391. - python-pillow_endian.patch upstreamed
  392. * Mon May 13 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-10
  393. - Build without webp support on s390* archs
  394. Resolves: rhbz#962059
  395. * Sat May 11 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-9.gitd1c6db8
  396. - Conditionaly disable build of python3 parts on RHEL system
  397. * Wed May 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-8.gitd1c6db8
  398. - Add patch to fix test failure on big-endian
  399. * Thu Apr 25 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.0-7.gitd1c6db8
  400. - Remove Obsoletes in the python-pillow-qt subpackage. Obsoletes isn't
  401. appropriate since qt support didn't exist in the previous python-pillow
  402. package so there's no reason to drag in python-pillow-qt when updating
  403. python-pillow.
  404. * Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-6.gitd1c6db8
  405. - Update to latest git
  406. - python-pillow_quantization.patch now upstream
  407. - python-pillow_endianness.patch now upstream
  408. - Add subpackage for ImageQt module, with correct dependencies
  409. - Add PyQt4 and numpy BR (for generating docs / running tests)
  410. * Mon Apr 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-5.git93a488e
  411. - Reenable tests on bigendian, add patches for #928927
  412. * Sun Apr 07 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.git93a488e
  413. - Update to latest git
  414. - disable tests on bigendian (PPC*, S390*) until rhbz#928927 is fixed
  415. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.gitde210a2
  416. - python-pillow_tempfile.patch now upstream
  417. - Add python3-imaging provides (bug #924867)
  418. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.git2e88848
  419. - Update to latest git
  420. - Remove python-pillow-disable-test.patch, gcc is now fixed
  421. - Add python-pillow_tempfile.patch to prevent a temporary file from getting packaged
  422. * Tue Mar 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.git2f4207c
  423. - Update to 2.0.0 git snapshot
  424. - Enable python3 packages
  425. - Add libwebp-devel BR for Pillow 2.0.0
  426. * Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
  427. - Add ARM support
  428. * Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
  429. - add s390* and ppc* to arch detection
  430. * Tue Mar 05 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-4.20130305git7866759
  431. - Update to latest git snapshot
  432. - 0001-Cast-hash-table-values-to-unsigned-long.patch now upstream
  433. - Pillow-1.7.8-selftest.patch now upstream
  434. * Mon Feb 25 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-3.20130210gite09ff61
  435. - Really remove -fno-strict-aliasing
  436. - Place comment on how to retreive source just above the Source0 line
  437. * Mon Feb 18 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-2.20130210gite09ff61
  438. - Rebuild without -fno-strict-aliasing
  439. - Add patch for upstream issue #52
  440. * Sun Feb 10 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-1.20130210gite09ff61
  441. - Initial RPM package