perl-Thread-Serialize-vl.spec 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. %define real_name Thread-Serialize
  2. Summary: serialize data-structures between threads
  3. Name: perl-Thread-Serialize
  4. Version: 0.11
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL+
  7. Group: Development/Libraries
  8. Source: http://search.cpan.org/CPAN/authors/id/E/EL/ELIZABETH/Thread-Serialize-%{version}.tar.gz
  9. URL: http://search.cpan.org/dist/Thread-Serialize/
  10. BuildArch: noarch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: perl(ExtUtils::MakeMaker)
  13. BuildRequires: perl(Storable)
  14. BuildRequires: perl(load) >= 0.10
  15. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  16. Requires: perl(Storable)
  17. Requires: perl(load) >= 0.10
  18. %description
  19. The Thread::Serialize module is a library for centralizing the
  20. routines used to serialize data-structures between threads.
  21. Because of this central location, other modules such as
  22. Thread::Conveyor, Thread::Pool or Thread::Tie can benefit from
  23. the same optimizations that may take place here in the future.
  24. This module only functions on Perl versions 5.8.0 and later.
  25. And then only when threads are enabled with -Dusethreads. It
  26. is of no use with any version of Perl before 5.8.0 or without
  27. threads enabled.
  28. %prep
  29. %setup -q -n %{real_name}-%{version}
  30. %build
  31. %{expand: %%define optflags %{optflags} -fPIC}
  32. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  33. make %{?_smp_mflags}
  34. %install
  35. rm -rf %{buildroot}
  36. make pure_install DESTDIR=%{buildroot}
  37. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  38. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  39. %{_fixperms} %{buildroot}
  40. %clean
  41. %{__rm} -rf %{buildroot}
  42. %files
  43. %defattr(-, root, root, 0755)
  44. %doc MANIFEST README CHANGELOG TODO
  45. %doc %{_mandir}/man3/Thread::Serialize.3pm*
  46. %dir %{perl_vendorlib}/Thread/
  47. %{perl_vendorlib}/Thread/Serialize.pm
  48. %changelog
  49. * Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
  50. - initial build for Vine Linux